source: projects/specs/trunk/c/chromium/chromium-vl.spec @ 1019

Revision 1019, 20.1 KB checked in by munepi, 14 years ago (diff)

updated chromium

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5# norootforbuild
6
7%if %{?_dist_release} == "vl6"
8#% define with_system_icu 1
9%endif
10
11%define svn_rev 47263
12
13Name:           chromium
14Summary:        Google's opens source browser project
15Summary(ja):    Googleのオープンソースウェブブラウザ
16#'
17Version:        6.0.405.0
18Release:        1%{?_dist_release}
19License:        BSD
20Group:          Applications/Internet
21Source0:        %{name}.%{version}.svn%{svn_rev}.tar.lzma
22## The following are included for source reasons only
23# Custom build tools for chromium, hammer is a fancy front-end for scons
24Source1:        http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
25%{?nosrc:NoSource: 0}
26%{?nosrc:NoSource: 1}
27# Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
28Source2:        repack_chromium_archive.sh
29# Script used to create the tar.lzma archive from a checked out source
30#Source3:        pack_chromium_source.sh
31Source3:        pack_chromium_source-vine.sh
32#Source10:       chromium.desktop
33Source10:       chromium-vine.desktop
34# Patch template which adds vendor to user agent
35##!!Source20:       chromium-vendor.patch.in
36Source20:       chromium-vendor-vine.patch.in
37##!!Source30:       master_preferences
38Source30:       master_preferences.vine
39#Source31:       default_bookmarks.html
40#Source31:       default_bookmarks.html.vine
41# icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
42Source100:      icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
43Provides:       chromium-browser = %{version}
44#Obsoletes:      chromium-browser < %{version}
45
46## Start Patches
47# Many changes to the gyp system so we can use system libraries
48# My first ever patch set.  I hope I did well.
49Patch3:         chromium-gyp-system-02-icu.patch
50Patch4:         chromium-no-sqlite-debug.patch
51Patch5:         chromium-gyp-system-04-nss-nspr.patch
52Patch7:         chromium-codechanges-nss-nspr.patch
53Patch8:         chromium-codechanges-zlib.patch
54#Patch9:         chromium-drop-sse.patch
55Patch10:        chromium-fix-wrapper.patch
56Patch12:        chromium-no-test-sources.patch
57Patch13:        chromium-no-courgette.patch
58Patch14:        chromium-master-prefs-path.patch
59#Patch15:        chromium-media-probe.patch
60Patch16:        chromium-icu-code-changes.patch
61Patch17:        chromium-system-glew.patch
62Patch18:        chromium-system-expat.patch
63Patch19:        chromium-system-zlib.patch
64Patch20:        chromium-noffmpeg.patch
65Patch21:        chromium-system-old-ffmpeg-way.patch
66Patch23:        chromium-disable-mmx.patch
67Patch24:        chromium-fix-yuv_row_posix-shared.patch
68Patch25:        tcmalloc-factory.patch
69
70# Vine
71#Patch40:       chromium-5.0.353-no-ffmpeg-vine.patch
72
73## Gentoo patches
74# Allow use of MP3/MPEG-4 audio/video tags with our system ffmpeg
75#Patch50: http://sources.gentoo.org/viewcvs.py/*checkout*/gentoo-x86/www-client/chromium/files/chromium-20100122-ubuntu-html5-video-mimetypes.patch
76
77BuildRequires:  gcc gcc-c++
78%if %{?_dist_release} == "vl5"
79BuildRequires:  libstdc++34 libstdc++34-devel
80%elseif %{?_dist_release} == "vl6"
81BuildRequires:  libstdc++ libstdc++-devel
82%endif
83BuildRequires:  libevent
84##!!BuildRequires:  pkg-config
85BuildRequires:  python
86##!!BuildRequires:  python-xml
87BuildRequires:  python-pyxml
88BuildRequires:  perl bison flex gperf
89##!!BuildRequires:  wdiff
90##!!BuildRequires:  update-desktop-files
91BuildRequires:  desktop-file-utils
92BuildRequires:  lzma
93##!!BuildRequires:  mozilla-nss-devel
94BuildRequires:  nss-devel
95##!!BuildRequires:  alsa-devel
96BuildRequires:  alsa-lib-devel
97BuildRequires:  gtk2-devel
98BuildRequires:  glib2-devel
99BuildRequires:  cairo-devel >= 1.6
100##!!BuildRequires:  mozilla-nspr-devel
101BuildRequires:  nspr-devel
102##!!BuildRequires:  gconf2-devel
103BuildRequires:  GConf2-devel
104BuildRequires:  freetype2-devel
105##!!BuildRequires:  dbus-1-devel
106BuildRequires:  dbus-devel
107BuildRequires:  libxslt-devel
108BuildRequires:  libxml2-devel
109BuildRequires:  libjpeg-devel
110BuildRequires:  zlib-devel
111BuildRequires:  libpng-devel
112##!!BuildRequires:  libbz2-devel
113BuildRequires:  bzip2-devel
114%if %{?_dist_release} == "vl6"
115BuildRequires:  fdupes
116%endif
117##!!BuildRequires:  libexpat-devel
118BuildRequires:  expat-devel
119BuildRequires:  glew-devel
120##!!BuildRequires:  Mesa-devel
121BuildRequires:  mesa-libGLU-devel
122
123%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
124BuildRequires:  libevent-devel
125
126##Vine Linux
127BuildRequires:  libXScrnSaver-devel
128#BuildRequires:  gle-devel
129#BuildRequires:  webkit-gtk-devel
130#BuildRequires:  scons
131%ifarch x86_64
132Requires:  nspluginwrapper
133%endif
134
135##!!Requires:       alsa
136Requires:       alsa-lib
137# shouldn't be required to name all dependencies
138# Requires:       mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
139## Recommends the ffmpeg libraries (available from packman)
140#Recommends:     libavcodec52 libavformat52 libavutil50
141
142BuildRoot:      %{_tmppath}/%{name}-%{version}-root
143
144%description
145Chromium is the open-source project behind Google Chrome.
146We invite you to join us in our effort to help build a safer, faster,
147and more stable way for all Internet users to experience the web,
148and to create a powerful platform for developing a new generation of
149web applications.
150
151%description -l ja
152Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
153私たちは、ウェブを体験しているすべてのインターネットユーザに対して
154より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
155ウェブアプリケーションの新しい世代を発展させるように
156強力なプラットホームを作成するために、
157私たちの取り組みで私たちに加わるようにあなたを誘います。
158
159
160%prep
161[ -d %{name} ] && %__rm -rf %{name}
162lzma -cd %{SOURCE0} | tar xf -
163%setup -D -T -n %{name}
164
165# use static libicu
166#%if %{?_dist_release} == "vl5"
167cd src/third_party || exit 1
168    %__rm -rf icu || exit 1
169    tar jxvf %{SOURCE100} || exit 1
170    %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
171cd - || exit 1
172#%endif
173
174# use system libicu only if >= 4.0
175%{?with_system_icu:%patch3 -p1}
176
177%patch4 -p1
178%patch5 -p1
179%patch7 -p1
180%patch8 -p1
181#%patch9 -p1
182%patch10 -p1
183#%patch11 -p1
184%patch12 -p1
185%patch13 -p1
186%patch14 -p1
187#%patch15 -p0
188%{?with_system_icu:%patch16 -p1}
189%patch17 -p1
190%patch18 -p1
191%patch19 -p1
192%patch20 -p1
193%patch21 -p1
194#%patch22 -p1
195%patch25 -p1
196%ifarch %ix86
197%patch23 -p1
198%endif
199%patch24 -p1
200
201
202# apply vendor patch after substitution
203%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
204
205%build
206## create make files
207
208PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
209for i in src/build/common.gypi; do
210        %__sed -i "s|'-march=pentium4',||g" $i
211        %__sed -i "s|'-msse2',||g" $i
212        %__sed -i "s|'-mfpmath=sse',||g" $i
213        %__sed -i "s|'-O<(debug_optimize)',||g" $i
214        %__sed -i "s|'-m32',||g" $i
215        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
216        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
217done
218# '
219
220pushd src
221
222./build/gyp_chromium -f make build/all.gyp \
223    -Duse_system_ffmpeg=1 \
224    -Duse_system_zlib=1 \
225    -Duse_system_libpng=1 \
226    -Duse_system_bzip2=1 \
227    -Duse_system_libjpeg=1 \
228    -Duse_system_libxml=1 \
229    -Duse_system_libxslt=1 \
230    -Duse_system_libevent=1 \
231    -Dproprietary_codes=1 \
232    -Dlinux_fpic=1 \
233    %{?with_system_icu:-Duse_system_icu=1} \
234    %{!?with_system_icu:-Duse_system_icu=0} \
235    %ifarch %{ix86}
236        -Dtarget_arch=ia32 \
237         -Ddisable_sse2=1 \
238    %endif
239    %ifarch x86_64
240        -Dtarget_arch=x64 \
241    %endif
242    %if %{?_dist_release} == "vl6"
243        -Dno_strict_aliasing=1 -Dgcc_version=44 \
244    %endif
245    -Drelease_extra_cflags=-fPIC \
246    ;
247
248#make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
249#%__make -r -j5 chrome BUILDTYPE=Release
250%__make %{?_smp_mflags} chrome BUILDTYPE=Release
251
252popd
253
254%install
255%{__rm} -rf %{buildroot}
256
257## Create install directories
258%{__mkdir_p} %{buildroot}%{_libdir}/%{name}
259%{__mkdir_p} %{buildroot}%{_bindir}
260%{__mkdir_p} %{buildroot}%{_datadir}/applications
261%{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
262%{__mkdir_p} %{buildroot}%{_mandir}/man1
263%{__mkdir_p} %{buildroot}%{_sysconfdir}/%{name}
264
265# chromium 'make' deposits us back at the top level build directory
266pushd src/out/Release
267ls -l
268
269# clean somechromium-codechanges-zlib.patch
270# clean debug junk
271%{__rm} -rf obj/ mksnapshot obj.target obj.host
272find ./ -type f -name '*.d' | while read i; do %__rm -f $i; done
273# clean NaCl stuff...  maybe NaCl will be in its own package in the future.
274%{__rm} -f ncdecode_table ncdecode_tablegen
275# clean other temporary binaries used in the compilation of chromium
276%{__rm} -f protoc xdg-settings
277
278%{__cp} -rf * %{buildroot}%{_libdir}/%{name}/
279
280# Man page
281[ ! -f %{name}.1 ] && %{__mv} chrome.1 %{name}.1
282%__install -m 0644 %{name}.1 %{buildroot}%{_mandir}/man1
283
284# Add startup file with plugins enabled
285%{__cat} > %{buildroot}%{_bindir}/%{name} <<EOF
286#!/bin/bash
287%{_libdir}/%{name}/chrome-wrapper --enable-plugins --enable-user-scripts --enable-extensions --enable-sync --enable-geolocation --enable-webgl "\$@"
288EOF
289
290# # link to browser plugin path.  Plugin patch doesn't work. Why?
291# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
292# pushd %{buildroot}%{_libdir}/%{name}
293# %{__ln_s} %{_libdir}/browser-plugins plugins
294# popd
295pushd %{buildroot}%{_libdir}/%{name}
296%ifarch x86_64
297%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
298%else
299%{__ln_s} %{_libdir}/mozilla/plugins plugins
300%endif
301
302#touch %{buildroot}%{_libdir}/libavcodec.so.52
303#%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
304#touch %{buildroot}%{_libdir}/libavformat.so.52
305#%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
306#touch %{buildroot}%{_libdir}/libavutil.so.50
307#%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
308popd
309
310# Install desktop-related files
311%__install -m 0644 %{SOURCE10} %{buildroot}%{_datadir}/applications/%{name}.desktop
312%__install -m 0644 product_logo_48.png %{buildroot}%{_datadir}/pixmaps/%{name}.png
313desktop-file-install --vendor Vine                      \
314        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
315        --delete-original                               \
316        --mode 644                                      \
317        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
318
319# Install the master_preferences file
320#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
321%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
322
323## install o3d plugin
324#pushd src/o3d/build/out/Release
325#%{__cp} -rf * %{buildroot}%{_libdir}/browser-plugins
326
327%clean
328%{__rm} -rf %{buildroot}
329
330
331%files
332%defattr(-,root,root)
333%doc src/AUTHORS src/LICENSE
334%dir %{_libdir}/%{name}
335%attr(0755,root,root) %{_bindir}/%{name}
336%{_mandir}/man1/*
337%{_datadir}/applications/*%{name}.desktop
338%{_datadir}/pixmaps/%{name}.png
339%{_libdir}/%{name}/*
340%config %{_sysconfdir}/%{name}
341#%{_libdir}/browser-plugins/*
342#%exclude %{_libdir}/libavcodec.so.52
343#%exclude %{_libdir}/libavutil.so.50
344#%exclude %{_libdir}/libavformat.so.52
345
346%changelog
347* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
348- updated to snapshot 6.0.405.0 r47263
349
350* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
351- unused with_system_icu (for vl6)
352  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
353
354* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
355- updated to snapshot 5.0.378.0 r44472
356  - used with_system_icu (for vl6)
357  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
358
359* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
360- updated to snapshot 5.0.372.0 r43947
361- added BuildRequires: glew-devel
362- changed Group tag to Applications/Internet
363- added Summary(ja) and %%description -l ja
364
365* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
366- updated to snapshot 5.0.365.0 r42966
367- merged 5.0.353.0-4vl5
368 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
369 - build on Vine Linux 5.1
370   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
371
372* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
373- updated to snapshot 5.0.364.0 r42779
374
375* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
376- updated to snapshot 5.0.359.0 r42116
377- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
378
379* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
380- fixed master_preferences.vine, little
381
382* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
383- fixed to install master_preferences
384- dropped chromium-5.0.353-no-ffmpeg-vine.patch
385
386* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
387- applied chromium-5.0.353-no-ffmpeg-vine.patch
388
389* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
390- updated to snapshot 5.0.353.0 r41449
391  * Wed Mar 10 2010 bgmerrell@novell.com
392  - Add master_preferences source file and install it to /etc/chromium.
393  - Create a new patch (chromium-master-prefs-path.patch) which tells
394    chromium to look in /etc/chromium for the master_preferences file
395    (instead of looking in the default directory, which is the same
396    directory as the 'chrome' binary).
397
398* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
399- updated to snapshot 5.0.335.0 r39556
400
401* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
402- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
403
404* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
405- updated to snapshot 5.0.330.0 r39074
406
407* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
408- use_system_ffmpeg
409
410* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
411- added Requires:  nspluginwrapper
412- fixed a symbolic link of plugins directory with nspluginwrapper
413
414* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
415- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
416
417* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
418- added BuildRequires: mesa-libGLU-devel
419- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
420
421* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
422- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
423
424  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
425  - Update to 4.0.260
426  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
427  - Update to 4.0.259
428  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
429  - Update to 4.0.258
430  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
431  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
432    changed to having an built-in v8
433  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
434  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
435  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
436  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
437  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
438  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
439  - update to newer svn snapshot
440    + Obsoletes fwrite patch (included upstream)
441  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
442  - update to newer svn snapshot
443    + Requires newer version of v8
444  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
445  - do not force SSE on x86 (drop-sse.patch)
446  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
447  - Update to newer svn snapshot
448  - Fixed spec file in order to build
449  - Included patch to build with system zlib
450  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
451  - package renamed to chromium
452  - cleaned up spec file
453  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
454  - v8 is now built as a separate package, and is required
455  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
456  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
457  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
458  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
459  - initial build
460
461#% changelog
462* Sun Jan 24 2010 prusnak@suse.cz
463- added vendor to user agent (chromium-vendor.patch.in)
464* Sun Nov 29 2009 prusnak@suse.cz
465- added --enable-sync to wrapper to enable bookmark sync
466* Fri Nov 13 2009 tittiatcoke@gmail.com
467- update to 247.0 svn 31928
468* Fri Oct 30 2009 tittiatcoke@gmail.com
469- update to 229.0 svn 30454
470  + Fix regression where popups and app frames lost their titlebars.
471  + Makes it so that when a folder is open on the bookmark bar
472    and the mouse moves over another folder, the menu for that
473    folder is shown.
474  + Lazily create the find bar.
475  + Polish to the gmail checker sample.
476  * New, crisper icons that are exactly 19x19
477  * Add a loading animation at the beginning before Gmail
478    responds.
479  * Fix a bug where we sometimes don't update the UI after a
480    logout/login cycle.
481  + Refactor widget methods to support desktop notifications,
482    including GTK stubs.
483  + Find-in-page should not ding while deleting characters.
484  + Add SSL wrapper for linux and mac.  This allows notifier to
485    use chrome's SSL layer instead of OpenSSL.
486  + Add three of the six extensions to PAC that Internet Explorer supports.
487  + WebSocket support in chromium. (Run with --enable-web-sockets
488    enables WebSocket features.)
489  + Do not allow GTK File Chooser dialogs to return directories.
490  + Fix the notifier SSL layer to make notifications work for
491    Linux Bookmark sync.
492  + linux: don't override mouse selection behavior in omnibox
493* Sun Oct 25 2009 tittiatcoke@gmail.com
494- Update to 224.4 svn 30027
495  + First cut at new page and browser action docs based
496    on new API. Deleted old stuff.
497  + Add suppression for new memory leak caused by WebKit merge 49830:49844
498  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
499  + Minimize dependency of user scripts
500  + Fixup the flip_framer eof-handling semantics now that we have
501    the FIN bit in place
502  + app depends on x11 because of active_window_watcher_x
503  + Adding two images for the new Extension managment UI
504  + Removing hard-coded Chrome Frame output path
505  + Rearrange clipboard code
506  + Fix crash bug when attempting to download a url with unsupported scheme,
507    e.g. 'data:', by 'Alt + Click'
508  + GTK: Change text for extension download UI
509  + Ignore invalid urls on command line
510  + Make dropped tabs animate from where they were dropped.
511  + Make room for the full width of the tab placeholder.
512  + Make tab dragging as smooth as glass.
513  + Remove an annoying NOTIMPLEMNETED
514  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
515  + If we're in the middle of a drag, don't allow the user to middle
516    click to close or right click for the context menu
517  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
518  + Remove +x bit from files that shouldn't have it
519  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
520  + Adding new image needed for the managment UI
521  + Fix a race bug where content scripts would not apply to the first page load
522  + Make escape remove a bookmark if it's just been added (but not if it already existed)
523  + Fix bubbles deactivating the opaque frame
524  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
525  + ake all pepper plugins default to windowless and transparent
526  + Add styles for printing
527  + Implement the new extension management UI
528  + Add support for to automation interface load install and load extensions
529  + GTK: theme the info bar border
530  + Update V8 to version 1.3.16.1
531  + Introduce WebSecurityPolicy for security related methods
532  + New button scheme...borders are separate from the inner contents so
533    that they can be highlighted / depressed independently
534  + When opening Chrome maximized with an application window already
535    running, the Chrome window was not activated
536  + Fix compatibility problems with FileZilla FTP Server
537  + Remove the extension shelf on Linux
538  + Fix the proxy host and port string to start with http:// if it does not already
539  + Enable HTML5 databases for all extension renderer processes
Note: See TracBrowser for help on using the repository browser.