source: projects/specs/trunk/c/chicken/chicken-vl.spec @ 10284

Revision 10284, 1.4 KB checked in by ara_t, 8 years ago (diff)

first commit

Line 
1%define pkg_name    chicken
2%define pkg_version 4.10.0
3%define pkg_release 1%{?_dist_release}
4
5Summary: Practical and portable Scheme system - compiler
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: BSD-style
11Group:   Applications/Languages
12URL:     https://www.call-cc.org/
13Source:  http://code.call-cc.org/releases/%{version}/%{name}-%{version}.tar.gz
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16# Patch0: 1269.patch
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: ara_t
21
22%description
23CHICKEN is a compiler for the Scheme programming language.
24It produces portable and efficient C and supports the R5RS
25and R7RS (work in progress) standards, and many extensions.
26
27
28%prep
29%{__rm} -rf ${RPM_BUILD_ROOT}
30%setup -q
31# %patch0
32
33%build
34%{__make} \
35 PLATFORM=linux \
36 PREFIX=%{_prefix} \
37 IDOCDIR=%{_docdir}/%{name}-%{version}
38
39%install
40%{__make} install \
41 PLATFORM=linux \
42 PREFIX=%{_prefix} \
43 IDOCDIR=%{_docdir}/%{name}-%{version} \
44 DESTDIR=${RPM_BUILD_ROOT}
45
46# %check
47# %{__make} check PLATFORM=linux
48
49%clean
50%{__rm} -rf ${RPM_BUILD_ROOT}
51
52%post -p %{_syssbindir}/ldconfig
53%postun -p %{_syssbindir}/ldconfig
54
55
56%files
57%defattr(-, root, root)
58%{_bindir}/
59%{_includedir}/
60/usr/lib/libchicken.so*
61/usr/lib//libchicken.a
62/usr/lib/chicken
63%{_datadir}/chicken
64%{_mandir}/man1/
65%{_docdir}/%{name}-%{version}
66
67
68%changelog
69* Fri May 13 2016 Toshiaki Ara <ara_t@384.jp> 4.10.0-1
70- new package
Note: See TracBrowser for help on using the repository browser.