source: projects/specs/trunk/c/check/check-vl.spec @ 521

Revision 521, 2.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        A unit test framework for C
2Summary(ja):    C 言語用単体テストフレームワーク
3Name:           check
4Version:        0.9.5
5Release:        2%{?_dist_release}
6Vendor:         Project Vine
7Distribution:   Vine Linux
8Packager:       USAMI Kosuke <usami-k@yc5.so-net.ne.jp>
9License:        LGPL
10Group:          Development/Tools
11URL:            http://check.sourceforge.net/
12Source0:        http://prdownloads.sourceforge.net/check/%{name}-%{version}.tar.gz
13Patch0:         %{name}-examples-bootstrap.patch
14Patch1:         check-0.9.5-fPIC.patch
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  docbook-utils
17Requires(post,preun): /sbin/install-info
18
19
20%description
21Check is a unit test framework for C. It features a simple interface
22for defining unit tests, putting little in the way of the developer.
23Tests are run in a separate address space, so Check can catch both
24assertion failures and code errors that cause segmentation faults or
25other signals. The output from unit tests can be used within source
26code editors and IDEs.
27
28
29%package devel
30Summary:        Libraries and headers for developing programs with check
31Summary(ja):    Check を使ったプログラム開発用ライブラリとヘッダファイル
32Group:          Development/Libraries
33Requires:       pkgconfig
34Requires:       %{name} = %{version}-%{release}
35
36%description devel
37Libraries and headers for developing programs with check
38
39
40%prep
41%setup -q
42%patch0 -p1
43%patch1 -p1 -b .fPIC
44
45
46%build
47%configure
48make
49
50
51%install
52rm -rf $RPM_BUILD_ROOT
53%makeinstall
54rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
55rm -rf $RPM_BUILD_ROOT%{_infodir}/dir
56
57rm -rf example
58cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/check/example .
59rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/check
60
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65
66%post
67/sbin/ldconfig
68/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
69
70
71%postun -p /sbin/ldconfig
72
73%preun
74if [ $1 = 0 ]; then
75    /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
76fi
77
78
79%files
80%defattr(-,root,root)
81%doc AUTHORS COPYING.LESSER ChangeLog ChangeLogOld NEWS README SVNChangeLog
82%{_libdir}/libcheck.so.*
83%{_infodir}/check.info*
84
85
86%files devel
87%defattr(-,root,root)
88%doc example
89%{_includedir}/check.h
90%{_libdir}/libcheck.so
91%{_libdir}/pkgconfig/check.pc
92%{_datadir}/aclocal/check.m4
93
94
95%changelog
96* Mon May 26 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.5-2
97- spec in UTF-8
98- split devel subpackage
99
100* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-1vl5
101- new upstream release
102- updated Patch1
103
104* Mon Sep 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.3-0vl2
105- enable -fPIC to build gstreamer on x86_64
106
107* Mon Jan 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.3-0vl1
108- upstream release
109- add BuildRequires: docbook-utils instead of lyx
110
111* Fri Aug  1 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.8.4-0vl2
112- Rebuild for new Vine.
113
114* Wed Jun 18 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 0.8.4-0vl1
115- Initial build.
116
Note: See TracBrowser for help on using the repository browser.