source: projects/specs/trunk/c/cegui06/cegui06-vl.spec @ 9767

Revision 9767, 6.6 KB checked in by Takemikaduchi, 9 years ago (diff)

blender,glew,mesa-demos: new upstream release
others: rebuild with glew-1.13.0

Line 
1Name:           cegui06
2Version:        0.6.2
3Release:        2%{?_dist_release}
4Summary:        CEGUI library 0.6 for apps which need this specific version
5Group:          System Environment/Libraries
6License:        MIT and LGPLv2+
7URL:            http://www.cegui.org.uk
8# This is
9# http://downloads.sourceforge.net/crayzedsgui/CEGUI-0.6.2b.tar.gz
10# with the bundled GLEW: RendererModules/OpenGLGUIRenderer/GLEW
11# removed as its an older GLEW version which contains
12# parts under then non Free SGI OpenGL and GLX licenses
13# To regenerate do:
14# wget http://downloads.sourceforge.net/crayzedsgui/CEGUI-0.6.2b.tar.gz
15# tar xvfz CEGUI-0.6.2b.tar.gz'
16# rm -r CEGUI-0.6.2/RendererModules/OpenGLGUIRenderer/GLEW
17# tar cvfz CEGUI-0.6.2b-clean.tar.gz
18Source0:        CEGUI-0.6.2b-clean.tar.gz
19Source1:        http://downloads.sourceforge.net/crayzedsgui/CEGUI-%{version}-DOCS.tar.gz
20# Both submitted upstream: http://www.cegui.org.uk/mantis/view.php?id=197
21Patch1:         cegui-0.6.0-release-as-so-ver.patch
22Patch2:         cegui-0.6.0-userverso.patch
23# TODO: submit upstream
24Patch3:         cegui-0.6.2-new-DevIL.patch
25Patch4:         cegui-0.6.2-new-tinyxml.patch
26Patch5:         cegui-0.6.2-gcc46.patch
27BuildRequires:  expat-devel
28BuildRequires:  freetype2-devel > 2.0.0
29BuildRequires:  libICE-devel
30BuildRequires:  libGLU-devel
31BuildRequires:  libSM-devel
32BuildRequires:  pcre-devel
33BuildRequires:  glew-devel
34
35%description
36Crazy Eddie's GUI System is a free library providing windowing and widgets for
37graphics APIs / engines. This package contains the older version 0.6 for
38apps which cannot be easily ported to 0.7. As such this version has been build
39without additional image codecs or xml parsers.
40
41
42%package devel
43Summary:        Development files for cegui06
44Group:          Development/Libraries
45Requires:       %{name} = %{version}-%{release}
46Requires:       libGLU-devel
47
48%description devel
49Development files for cegui06
50
51
52%package devel-doc
53Summary:        API documentation for cegui06
54Group:          Documentation
55Requires:       %{name}-devel = %{version}-%{release}
56
57%description devel-doc
58API and Falagard skinning documentation for cegui06
59
60
61%prep
62%setup -qb1 -qn CEGUI-%{version}
63%patch1 -p1
64%patch2 -p1
65%patch3 -p1
66%patch4 -p1
67%patch5 -p1
68
69# Permission fixes for debuginfo RPM
70chmod -x include/falagard/*.h
71
72# Delete zero length file
73rm -f documentation/api_reference/keepme
74
75# Encoding fixes
76iconv -f iso8859-1 AUTHORS -t utf8 > AUTHORS.conv && mv -f AUTHORS.conv AUTHORS
77iconv -f iso8859-1 TODO -t utf8 > TODO.conv && mv -f TODO.conv TODO
78iconv -f iso8859-1 README -t utf8 > README.conv && mv -f README.conv README
79
80# Make makefile happy even though we've removed the (unused) included copy of
81# GLEW due to license reasons
82mkdir -p RendererModules/OpenGLGUIRenderer/GLEW/GL
83touch RendererModules/OpenGLGUIRenderer/GLEW/GL/glew.h
84touch RendererModules/OpenGLGUIRenderer/GLEW/GL/glxew.h
85touch RendererModules/OpenGLGUIRenderer/GLEW/GL/wglew.h
86touch RendererModules/OpenGLGUIRenderer/GLEW/GLEW-LICENSE
87
88
89%build
90%configure --disable-static --disable-samples --disable-lua-module \
91    --disable-corona --disable-devil --disable-silly --disable-freeimage \
92    --disable-irrlicht-renderer --disable-directfb-renderer \
93    --disable-xerces-c --disable-libxml --disable-tinyxml \
94    --with-default-xml-parser=ExpatParser \
95    --with-default-image-codec=TgaImageCodec \
96    --with-pic
97# We do not want to get linked against a system copy of ourselves!
98sed -i 's|-L%{_libdir}||g' RendererModules/OpenGLGUIRenderer/Makefile
99# Don't use rpath!
100sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
101sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
102make %{?_smp_mflags}
103
104
105%install
106make install DESTDIR=%{buildroot}
107find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
108
109# Move some things around to make cegui06-devel co-exist peacefully with
110# cegui-devel
111mkdir -p %{buildroot}/%{_libdir}/CEGUI-0.6
112for i in libCEGUIBase libCEGUIExpatParser libCEGUIFalagardWRBase \
113         libCEGUIOpenGLRenderer libCEGUITGAImageCodec; do
114    rm %{buildroot}/%{_libdir}/$i.so
115    ln -s ../$i-%{version}.so %{buildroot}/%{_libdir}/CEGUI-0.6/$i.so
116done
117mv %{buildroot}/%{_includedir}/CEGUI %{buildroot}/%{_includedir}/CEGUI-0.6
118mv %{buildroot}/%{_datadir}/CEGUI %{buildroot}/%{_datadir}/CEGUI-0.6
119sed -e 's|/CEGUI|/CEGUI-0.6|g' \
120    -e 's|libdir=%{_libdir}|libdir=%{_libdir}/CEGUI-0.6|g' \
121    -i %{buildroot}/%{_libdir}/pkgconfig/*.pc
122for i in %{buildroot}/%{_libdir}/pkgconfig/*.pc; do
123    mv $i `echo $i | sed 's|\.pc\$|-0.6.pc|'`
124done
125
126
127%post -p /sbin/ldconfig
128%postun -p /sbin/ldconfig
129
130
131%files
132%doc AUTHORS ChangeLog COPYING README TODO
133%{_libdir}/libCEGUI*-%{version}.so
134
135%files devel
136%{_libdir}/CEGUI-0.6
137%{_libdir}/pkgconfig/CEGUI-OPENGL-0.6.pc
138%{_libdir}/pkgconfig/CEGUI-0.6.pc
139%{_includedir}/CEGUI-0.6
140%{_datadir}/CEGUI-0.6
141
142%files devel-doc
143%doc documentation/FalagardSkinning.pdf documentation/api_reference
144
145
146%changelog
147* Thu Oct 15 2015 Yoji TOYODA <bsymaato@sea.plala.or.jp> 0.6.2-2
148- rebuild with glew-1.13.0
149
150* Sun Nov 11 2012 Yoji TOYODA <bsymaato@sea.plala.or.jp> 0.6.2-1
151- initial build for Vine Linux
152
153
154
155* Thu Jul 26 2012 Hans de Goede <hdegoede@redhat.com> - 0.6.2-12
156- Rebuilt for new GLEW
157
158* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.2-11
159- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
160
161* Fri Feb 10 2012 Petr Pisar <ppisar@redhat.com> - 0.6.2-10
162- Rebuild against PCRE 8.30
163
164* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.2-9
165- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
166
167* Mon Jun 20 2011 ajax@redhat.com - 0.6.2-8
168- Rebuild for new glew soname
169
170* Sun Feb 13 2011 Hans de Goede <hdegoede@redhat.com> - 0.6.2-7
171- Fix building with gcc-4.6
172
173* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.2-6
174- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
175
176* Fri Jan 07 2011 Bruno Wolff III <bruno@wolff.to> - 0.6.2-5
177- Rebuild against ogre that uses boost instead of poco.
178
179* Tue Jan 04 2011 Bruno Wolff III <bruno@wolff.to> - 0.6.2-4
180- Fix requires to be cegui06-devel rather than cegui-devel
181
182* Mon Jan  3 2011 Hans de Goede <hdegoede@redhat.com> 0.6.2-3
183- Update License tag to "MIT and LGPLv2+" and some files did not have
184  their copyright header updated when upstream moved from LGPLv2+ to MIT.
185  This is fixed in the 0.7.x (and later) versions of cegui.
186
187* Tue Nov  9 2010 Hans de Goede <hdegoede@redhat.com> 0.6.2-2
188- Switch to new upstream 0.6.2b tarbal (#650643)
189
190* Sun Nov  7 2010 Hans de Goede <hdegoede@redhat.com> 0.6.2-1
191- First release of CEGUI-0.6.2 as cegui06
Note: See TracBrowser for help on using the repository browser.