source: projects/specs/trunk/c/cdrtools/cdrtools-vl.spec @ 521

Revision 521, 34.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Upstream auther:      Joerg Schilling <schilling@fokus.gmd.de>
2
3%define alphav  a04
4
5Summary:        A set command line tools for CD/DVD-Recorders
6Summary(ja):    CD/DVD レコーダーのためのコマンドラインツール
7Name:           cdrtools
8Version:        2.01.01
9#Release:       0vl0%{?alphav:.%{alphav}}.1
10Release:        1%{?alphav:.%{alphav}}%{?_dist_release}
11License:        CDDL
12Group:          Applications/Multimedia
13URL:            http://cdrecord.berlios.de/old/private/cdrecord.html
14Source:         %{name}-%{version}%{?alphav:%{alphav}}.tar.bz2
15
16# security fix
17Patch0:         cdrecord-2.01-CAN-2004-0806.patch.bz2
18
19# patches from http://people.mandriva.com/~warly/files/cdrtools/
20Patch10:        cdrtools-2.01.01a04-dvd.patch.bz2
21Patch13:        cdrtools-2.01.01a04-rawio.patch.bz2
22Patch14:        cdrtools-2.01.01a03-warnings.patch
23Patch15:        cdrtools-2.01.01a01-scanbus.patch.bz2
24Patch16:        cdrtools-2.01.01a03-rezero.patch
25
26# debian
27Patch30:        cdrtools-2.01.01-mkisofs-iconv.patch
28
29BuildRoot:      %{_tmppath}/%{name}-%{version}-root
30BuildRequires:  libcap-devel, perl
31
32%description
33A set command line tools for CD/DVD-Recorders including cdrecord,
34mkisofs, readcd, isoinfo and others.
35
36%description -l ja
37CD/DVD レコーダーのためのコマンドラインツール群。
38cdrecord, mkisofs, readcd, isoinfo などのコマンドが含まれています。
39
40%package        cdrecord
41Summary:        A command line CD/DVD-Recorder
42Summary(ja):    コマンドラインの CD/DVD 書き込みツール
43Group:          Applications/Multimedia
44Obsoletes:      cdrecord
45Provides:       cdrecord
46
47%description    cdrecord
48Cdrecord allows you to create CD's on a CD-Recorder (SCSI/ATAPI).
49Supports data, audio, mixed, multi-session and CD+ discs etc.
50
51%package        devel
52Summary:        Libraries and Headers needed for development.
53Group:          Development/Libraries
54Obsoletes:      cdrecord-devel, cdrtools-libscg, cdrtools-utils
55
56%description    devel
57Libraries and Headers for development.
58
59%package        cdda2wav
60Summary:        Get WAV files from digital audio cd's
61Group:          Applications/Multimedia
62Obsoletes:      cdda2wav, cdrecord-cdda2wav
63Provides:       cdda2wav
64
65%description    cdda2wav
66A sampling utility for cdrom drives that are capable of sending audio
67cd data in digital form to your host. Data can be dumped into wav or
68sun format sound files. Options control the recording format (stereo/mono;
698,12,16 bits; different rates).
70
71%package        mkisofs
72Summary:        Creates a ISO9660 filesystem image
73Group:          Applications/System
74Obsoletes:      mkisofs, mkhybrid, cdrecord-mkhybrid, cdrecord-mkisofs
75Provides:       mkisofs
76
77%description    mkisofs
78This is the mkisofs package.  It is used to create ISO 9660
79file system images for creating CD-ROMs. Now includes support
80for making bootable "El Torito" CD-ROMs.
81
82%prep
83%setup -q
84%patch0 -p1 -b .CAN-2004-0806
85%patch10 -p1 -b .dvd
86%patch13 -p1 -b .rawio
87%patch14 -p1 -b .warnings
88%patch15 -p1 -b .scanbus
89%patch16 -p1 -b .rezero
90
91%patch30 -p1 -b .iconv
92
93%__perl -pi -e "s/^COPTOPT=.*/COPTOPT=$RPM_OPT_FLAGS/g" RULES/*-linux-cc.rul
94find . -name \*.mk|xargs %__perl -pi -e 's/INSDIR=\s*lib\s*$/INSDIR=%{_lib}\n/g'
95
96%build
97./Gmake.linux
98
99%install
100[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
101mandir=%{_mandir}
102./Gmake.linux "MANDIR=${mandir#/usr}" \
103"INS_BASE=${RPM_BUILD_ROOT}%{_prefix}" install
104
105# Installing Header files for use with devel package
106rm include/scg
107install -d ${RPM_BUILD_ROOT}%{_prefix}/include/schily/scg
108install -m 644 include/* ${RPM_BUILD_ROOT}%{_prefix}/include/schily
109install -m 644 incs/*/xconfig.h ${RPM_BUILD_ROOT}%{_prefix}/include/schily
110install -m 644 libscg/scg/* ${RPM_BUILD_ROOT}%{_prefix}/include/schily/scg
111
112# Installing default config.
113mkdir -p ${RPM_BUILD_ROOT}/etc/default
114install -m 644 cdrecord/cdrecord.dfl ${RPM_BUILD_ROOT}/etc/default/cdrecord
115install -m 644 rscsi/rscsi.dfl ${RPM_BUILD_ROOT}/etc/default/rscsi
116
117## Preparing doc files for RPM
118# cdrecord
119{
120  pushd doc
121  groff -Tps -man cdrecord.man > cdrecord.ps
122  popd
123}
124
125# cdrecord
126mkdir cdrecord-rpmdocs
127cp AN-%{version}* doc/cdrecord.ps Changelog README.* \
128   cdrecord/cdrecord.dfl cdrecord-rpmdocs
129chmod 644 -R cdrecord-rpmdocs/*
130cp -a READMEs cdrecord-rpmdocs/
131
132# cdda2wav
133mkdir cdda2wav-rpmdocs
134cp AN-%{version}* cdda2wav/Frontends cdda2wav/GPL cdda2wav/HOWTOUSE \
135   cdda2wav/OtherProgs cdda2wav/README cdda2wav/THANKS cdda2wav/TODO \
136   cdda2wav/cdda2mp3 cdda2wav/cdda2mp3.new cdda2wav/cdda_links \
137   cdda2wav/pitchplay cdda2wav/readmult cdda2wav/tracknames.pl \
138   cdda2wav/tracknames.txt cdda2wav/FAQ cdda2wav/cdda2ogg \
139   cdda2wav-rpmdocs
140chmod 644 cdda2wav-rpmdocs/*
141
142install -m 755 cdda2wav/cdda2{mp3,ogg} $RPM_BUILD_ROOT%{_bindir}/
143
144# mkisofs
145mkdir mkisofs-rpmdocs
146cp AN-%{version}* mkisofs/COPYING mkisofs/ChangeLog mkisofs/README* \
147   mkisofs-rpmdocs
148chmod 644 mkisofs-rpmdocs/*
149
150# remove unpackaged files
151rm -f $RPM_BUILD_ROOT%{_mandir}/man5/make{files,rules}.5*
152
153%clean
154[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
155
156%files  cdrecord
157%defattr(-,root,root)
158%doc cdrecord-rpmdocs/*
159%config(noreplace) /etc/default/cdrecord
160%config(noreplace) /etc/default/rscsi
161%{_bindir}/cdrecord
162%{_bindir}/readcd
163%{_bindir}/devdump
164%{_bindir}/isoinfo
165%{_bindir}/isodump
166%{_bindir}/isodebug
167%{_bindir}/isovfy
168%{_bindir}/skel
169%{_mandir}/man1/cdrecord.1*
170%{_mandir}/man1/readcd.1*
171%{_mandir}/man8/isoinfo.8*
172%{_sbindir}/rscsi
173
174%files  devel
175%defattr(-,root,root)
176%{_bindir}/scgcheck
177%{_libdir}/*.a
178%{_mandir}/man1/scgcheck.1*
179%{_includedir}/*.h
180%{_includedir}/schily
181
182%files  cdda2wav
183%defattr(-,root,root)
184%doc cdda2wav-rpmdocs/*
185%{_prefix}/bin/cdda2wav
186%{_prefix}/bin/cdda2ogg
187%{_prefix}/bin/cdda2mp3
188%{_mandir}/man1/cdda2wav.1*
189%{_mandir}/man1/cdda2ogg.1*
190
191%files  mkisofs
192%defattr(-,root,root)
193%doc mkisofs-rpmdocs/*
194%{_bindir}/mkisofs
195%{_bindir}/mkhybrid
196%{_mandir}/man8/mkisofs.8*
197%{_mandir}/man8/mkhybrid.8*
198
199%changelog
200* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 2.01.01-1.a04vl5
201- applied new versioning policy, spec in utf-8
202
203* Fri Nov 03 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.01.01-0vl0.a04.1
204- added perl script to support lib64 architecture
205
206* Fri Oct 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.01.01-0vl0.a04
207- update to cdrtools-2.01.01a04
208- update dvd patch
209- remove unneeded patches
210- add iconv patch instead of NLS patch.
211
212* Fri Oct 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.01.01-0vl0.a01
213- update to cdrtools-2.01.01a01
214  - FIXME: 2.01.01a03 and newer is not compatible with NLS patch
215- update dvd patch
216- add Patch15 to allow scanbus as user
217
218* Fri Sep 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.01-0vl1
219- new upstream release
220- [SECURITY] import CAN-2004-0806.patch (patch20) from MDV
221  - fix RSH environment variable privilege escalation vulnerability
222- update URL
223- drop stupid macros
224- overwrite COPTOPT with $RPM_OPT_FLAGS
225- add BuildRequires: libcap-devel, perl
226- unofficial patches
227  - update dvd.patch (patch10)
228  - add rawio.patch (patch13) to burn as user with kernel 2.6.8
229  - add warnings.patch (patch14) to remove warnings
230
231    cf. http://people.mandriva.com/~warly/files/cdrtools/
232
233* Sat Jun 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.01-0.a31vl2
234- apply unofficial DVD support patch (Patch10,11,12)
235  http://people.mandrakesoft.com/~warly/files/cdrtools/
236
237* Tue Jun 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.01-0.a31vl1
238- new upstream release
239
240* Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.01-0.a24vl2
241- rebuild for VineSeedPlus
242
243* Wed Jan 14 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.01-0.a24vl1
244- source upgrade to 2.01_alpha24
245
246* Tue Sep 23 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.01-0.a15vl2
247- rebuild with new toolchains
248
249* Tue Jun  3 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.01-0.a15vl1
250- source upgrade to 2.01_alpha15
251
252* Sat May 24 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.01-0.a14vl1
253- source upgrade to 2.01_alpha14
254- use Gmake instead of make
255- add patch0 from Momonga Linux CVS repository
256
257* Mon May 12 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.11a40-0vl2
258- change man dir from /usr/man to /usr/share/man
259- revised %files section
260
261* Mon Dec  2 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11a40-0vl1
262- new upstream release 1.11a40 for newer xcdroast.
263- build for Vine Linux based on cdrtools-1.11a24-1
264
265* Tue Jun 04 2002 tn@xcdroast.org
266  [cdrtools-1.11a24-1]
267
268- see changelog
269* Wed May 15 2002 Ryan Weaver <ryanw@falsehope.com>
270  [cdrtools-1.11a23-1]
271- Cdrecord:
272- Try to make cdrecord behave more polite for platforms (like Cygwin)
273  that don't support large files when the DVD data to be written
274  is read from stdin.
275  mkisofs ... | cdrecord ... -
276  will now work for DVDs on non large file OS
277- Call flush buffer in silent mode to avoid error messages with
278  cdrecord -toc called on a CD-ROM drive.
279
280- Cdda2wav (By Heiko Ei?eldt heiko@hexco.de):
281- Fix some bugs with option parsing introduced with the new option
282  parsing using getargs()
283- New option -version to make cdrtools behave similar
284- New option paraopts=opts for paranoia options.
285- Print Paranoia statistics result at end of every track.
286
287- Mkisofs (By J?g Schilling and James Pearson j.pearson@ge.ucl.ac.uk):
288- Try to fix (very old) rotten code in various files that did cause
289  integer overflows for files > 2 GB - 2kB.
290  Inconsistent use of (always diferent) hand crufted code using
291  2048, 2047, ... instead of SECTOR_SIZE, ISO_ROUND_UP(), ...
292  Note that this is not only of interest for DVDs as mkisofs could
293  believe that > 2 GB of data would fit on a CD.
294- New code to print file type names.
295
296* Tue May  7 2002 Ryan Weaver <ryanw@falsehope.com>
297- Renamed cdrtools-libscg to cdrtools-devel because the package
298  contains much more than just libscg.a and associated headers now.
299  [cdrtools-1.11a22-1]
300- All:
301- Autoconf code now check for alloca() and dynamic sized array support
302  (needed by libparanoia).
303- Added links for ia64-linux to the Make RULES to allow users of GNUmake
304  to compile cdrtools on IA64. Note that "smake" includes automake
305  features and will auto-create the missing links.
306
307- Libparanoia:
308- The paranoia code from cdparanoia (written by Monty xiphmont@mit.edu)
309  has been converted into a portable library.
310
311- Libscg:
312- Enhanced list of SCSI Error texts from SCSI standard from 29.5.2001
313- New callback function to allow execption handling to be done after
314  the current SCSI command did finish.
315
316- Cdrecord:
317- Corrected printf() formats for verbose printing to hold enough
318  space for media > 1 GB (DVD)
319- Corrected printf() formats to make the write speed non-jumping.
320- If called from a GUI, cdrecord now reads from "stderr" if
321  the CD-input-data is from "stdin".
322  If it turns out that stderr is not open for reading, cdrecord
323  waits to receive a SIGUSR1
324- Better printouts for the DISC-ids covered by the orange forum embargo.
325- DVD structure structure definition enhanced to reflect
326  current standard.
327- new option gracetime=
328- Try to abort DAO recording with a flush_buffer() if ^C is hit.
329
330- Cdda2wav (By Heiko Ei?eldt heiko@hexco.de):
331- new script cddda2ogg
332- bugfix deemphasizing (thanks to Klaus Wolterec)
333- bugfix rounding error (creation of info files)
334- added AlbumPerformer entry in info files
335- integration of Monty's libparanoia
336- switch to J?gs getargs option handling
337
338- Mkisofs (By J?g Schilling and James Pearson j.pearson@ge.ucl.ac.uk):
339- Allow the -sort option to work with the Eltorito Boot Catalogue
340- Corrected the man page that still incorrectly stated that at least one
341  pathspec on the command line is needed.
342- Correct the new short usage function so there will be no more
343  core dumps on intel processors.
344- Allow '-' to be part of the ISO-9660 filename if -no-iso-translate
345  has been specified.
346  Thanks for this hint from Georgy Salnikov (sge@nmr.nioch.nsc.ru)
347  from Novosibirsk, Russia.
348- Try to avoid an integer overflow with the -C option and DVDs
349
350* Sun Apr 21 2002 Ryan Weaver <ryanw@falsehope.com>
351  [cdrtools-1.11a21-1]
352- Cdda2wav (By Heiko Ei?eldt heiko@hexco.de):
353- new script cddda2ogg
354
355- Mkisofs (By J?g Schilling and James Pearson j.pearson@ge.ucl.ac.uk):
356- Man page part for UTF-converting corrected
357- Canonicalize graft points so commands like:
358  mkisofs -graft-points /a/b/././//=some_dir
359  and
360  mkisofs -graft-points /a/b/../c/=some_dir
361  will not cause broken ISO images anymore.
362- Avoid unwanted information in debug information on disk.
363
364* Fri Apr  5 2002 Ryan Weaver <ryanw@falsehope.com>
365  [cdrtools-1.11a20-1]
366- Mkisofs (By J?g Schilling and James Pearson j.pearson@ge.ucl.ac.uk):
367- Only print a short Usage if mkisofs detected a usage error.
368- -z option now working to create CDs in a format with Linux proprietary
369  Rock Ridge extensions for transparent compression.
370  This is a patch from H.P. Anvin. It makes only sense with Linux-2.4.14
371  or later.
372- New option -debug
373- Correctly use stat()/lstat() with graft points
374- Fixed a bug with escape character handling in graft point handling.
375- Make the graft point a directory if the file it should point to
376  is a directory.
377- Correctly handle non-canonical filenames with graft points.
378  .////././///test=OBJ/sparc-sunos5-cc/ will now work correctly
379  and not result in a corrupted ISO-Filesystem.
380
381* Tue Mar 26 2002 Ryan Weaver <ryanw@falsehope.com>
382  [cdrtools-1.11a19-1]
383- All:
384- Add hints that compiling on unknown platforms wil only work if
385  "smake" is used.
386- Autoconf code for Large file support now handles Linux system include
387  file bugs that prevented correct behavior on 64 Bit Linux systems.
388
389- Cdrecord:
390- DVD-R code (undisclosed) now supports:
391  Vendor_info    : 'MATSHITA'
392  Identifikation : 'DVD-RAM LF-D310 '
393  Revision       : 'A116'
394- Support for SCMS from *.inf files
395  Note that you need to use cdda2wav/cdrecord that have fitting versions
396  because of this change. Otherwise cdrecord may add SCMS copy
397  protection.
398- RAW mode now honors COPY bit and SCMS coding.
399- Avoid coredump with "cdrecord textfile= non/existant ..."
400- New CD-text *inf file Tag Albumperformer=
401  NOTE later versions of cdrecord will ignore
402  Albumtitle= and Albumperformer= if the value is not identical
403  for all tracks.
404
405- Cdda2wav (By Heiko Ei?eldt heiko@hexco.de):
406- Better TOC ADDR/CRTL (red book) handling
407- Better method to scan for indices.
408- Support for SCMS in *.inf files
409- Better SUID/SGID handling
410
411- Readcd:
412- Better behavior with extreme badly readable media.
413- List number of completely unreadable sectors in addition to
414  the C2 error count.
415
416* Fri Mar 15 2002 Ryan Weaver <ryanw@falsehope.com>
417  [cdrtools-1.11a18-1]
418- Libscg:
419- Make the packet code compile on Linux  > 2.2.12 && < 2.4.3
420
421- Readcd:
422- Now use /etc/default/cdrecord as documented in the man page.
423
424- Mkisofs (By J?g Schilling and James Pearson j.pearson@ge.ucl.ac.uk):
425- Fixed a minor bug with HFS labels & multi-session
426  Thanks to James Pearson
427
428* Mon Mar 11 2002 Ryan Weaver <ryanw@falsehope.com>
429- Removed patch to change location of config files.
430  Default config location /etc/default.
431  ALL OLD CONFIG FILES -WILL NOT- UPGRADED.
432  NO PATCHING OF CONFIG FILES WILL TAKE PLACE.
433  PLEASE EDIT ANY UNWORKABLE DEFAULTS AFTER INSTALLATION.
434
435  [cdrtools-1.11a17-1]
436- All:
437- This release contains a clean up and many new important features...
438- VMS script build_all.com now includes astoll.c so compilation
439  on VMS should work again.
440- Many README's cleaned up.
441- New macros for max/min values of int*_t in utypes.h
442- Limit the different handling of packed bitfields for AIX to AIX CC.
443- Unfortunately fragementation of cdrecord has begun.
444  I noticed this fact recently when people started to ask me
445  senseless things which turned out to be a result of
446  a modified cdrtools source that I have not ben aware of.
447
448  One main goal of cdrtools is to provide a platform indepenant
449  user interface which cannot be achieved if people change important
450  parts os the user interface.
451  For this reason, I changed the license in hope that this will
452  help at least to keep the user interface the same on all
453  platforms and on all distributions.
454
455  Please keep in mind that fragmentation in many cases increases
456  my workload. There is no real reason for a modification,
457  and (even worse) the people who create modifications do not help
458  to keep my workload low in order to help me (and Heiko and James)
459  with the cdrtools project. People should rather contribute to
460  the project. Cdrtools should be free and actively mantained
461  in future. With increasing workload, I don't know how to do this.
462
463- Libscg:
464- Version -> 0.6
465- Adding support for the CDROM_SEND_PACKET ioctl() from cdrom.c
466
467- Cdrecord:
468- Default usage code is now only 6 lines so the error message
469  does no longer scroll out the screen. If yu like to get the old
470  long usage information, call cdrecord -help
471- move 'dd' like number conversion stuff into getnum.c
472- Allow the /etc/default/cdrecord parsing code to be used by
473  readcd too (as documented in the man page)
474- First support for Plextor's VariRec feature in the PX-W4012
475  I am not sure about the final user interface.
476  For now, call e.g. cdrecord speed=4 driveropts=varirec=-1
477  for all audio CDs. Allowed varirec parameters are -2, -1, 0, 1, 2
478  VariRec only works at write speed 4.
479- Print the actual current write speed in verbose mode.
480
481- Readcd:
482- Now use /etc/default/cdrecord as documented in the man page.
483
484- Mkisofs (By J?g Schilling and James Pearson j.pearson@ge.ucl.ac.uk):
485- Fixed a minor bug with HFS labels & multi-session
486  Thanks to James Pearson
487
488* Sun Mar  3 2002 Ryan Weaver <ryanw@falsehope.com>
489  [cdrtools-1.11a16-1]
490- Cdrecord:
491- Allow ' to appear inside CD-Text strings
492- better messages for CD manufacturer codes that are not in the
493  latest free Orange forum table.
494
495- Cdda2wav (By Heiko Ei?eldt heiko@hexco.de):
496- new option -L changed. Now a numerical parameter (0 or 1)
497  defines the handling of multiple cddbp entries.
498  0 enters user interactive mode.
499  1 take the first entry unconditionally.
500  I still need a reasonable way for gui interaction in this case!
501  Proposals are welcome.
502- made cddbp handling for mixed mode cds more robust.
503  It is unclear yet, if data tracks have to be included in the
504  query. Anybody knows the definitive answer?
505
506- Mkisofs (By J?g Schilling and James Pearson j.pearson@ge.ucl.ac.uk):
507- Support generic boot code if session does not start at sector 0.
508
509* Sun Feb 24 2002 Ryan Weaver <ryanw@falsehope.com>
510  [cdrtools-1.11a15-1]
511- All:
512- Support for NT-5.1 (WIN XP) added os-cygwin_nt-5.1.id
513
514- Cdrecord:
515- CD-Text Code now also accepts Text File without 4 byte Size header
516- CD-Text file read code now is able to do CRC error correction
517  Note that only songle bit errors per 18 byte pack.
518- First CD-text Authoring support:
519
520- Cdda2wav (By Heiko Ei?eldt heiko@hexco.de):
521- Fixed a bug that caused cdda2wav to dump core with certain
522  CD-Text data.
523
524- Mkisofs (By J?g Schilling and James Pearson j.pearson@ge.ucl.ac.uk):
525- Fixed a check in the Apple HFS code that used strcmp for
526  data that could contain null bytes.
527- Introduced many casts to enhance portability.
528  This was needed for GNU fnmatch.c and the HFS support lib libhfs_iso
529- Use Protoyped function definitions for hash.c to allow old UNIX variants
530  where sizeof(dev_t) is < sizeof(int)
531
532* Mon Feb 11 2002 Ryan Weaver <ryanw@falsehope.com>
533  [cdrtools-1.11a14-1]
534- All:
535- New rule allows automatic fallback to GCC if the configured
536  default compiler could not be found.
537- statdefs.h enhanced
538- Many corrections to give less warnings on SCO Openserver
539
540- Libscg:
541- Massive modicifation of the support code for SCO OpenServer 5.x
542
543- Cdda2wav (By Heiko Ei?eldt heiko@hexco.de):
544- New option -L to ask freedb.freedb.org for CDDB information.
545  This alllows to automatically create CD-Text CDs.
546- correct TOC endianess for FreeBSD ioctl interface.
547
548- Readcd:
549- Enhanced output for C2 error scan.
550
551- Mkisofs (By J?g Schilling and James Pearson j.pearson@ge.ucl.ac.uk):
552- Fixed a check in the Apple HFS code that used strcmp for
553  data that could contain null bytes.
554- Introduced many casts to enhance portability.
555  This was needed for GNU fnmatch.c and the HFS support lib libhfs_iso
556- Use Protoyped function definitions for hash.c to allow old UNIX variants
557  where sizeof(dev_t) is < sizeof(int)
558
559* Fri Jan 18 2002 Ryan Weaver <ryanw@falsehope.com>
560  [cdrtools-1.11a13-1]
561- All:
562- New supported architctures:
563  s390-linux-cc.rul parisc-linux-cc.rul parisc64-linux-cc.rul
564- Large File support for IRIX-6.2 (added autoconf test for -n32 cc option)
565- Large File support for IRIX-6.5 now everything works correctly if the
566  OS supports Large Files by default in 32 bit mode (uses fseeko()/ftello()
567  if present. This could only be done by massively changing the autoconf code
568  stolen from GNUtar.
569- Support for SGI IRIX platform ip17-irix
570- Support for SGI IRIX-6.5
571- Try to support recent BeOS (again)
572  Workaround in libschily/comerr.c for the nonstandard
573  big negative errno values on BeOS
574- libschily now includes floating point printf() for BeOS
575- fileluopen.c from libschily now compiles on BeOS (without O_NDELAY)
576- workaround for the nonstandard negative errno values on BeOS
577- Schily makefile RULES for AmigaOS added
578- getpagesize() emulation for BeOS to make cdda2wav compile on BeOS
579
580- Libscg:
581- Try to make scsi-beos.c compile on new BeOS version 5
582- First attempt to integrate the AmigaOS SCSI transport interface code
583  from Thomas Langer <Langer.Thomas@gmx.net>
584
585- Rscsi:
586- Make it compile on BeOS
587
588- Cdrecord:
589- correctly use the buffer capacity code from the driver instead
590  of the MMC-2 read buffer cap code directly
591- Support for the unusual not ready error code of the CyberDrive CW038D
592
593- Cdda2wav:
594- fixed ioctl handling of toc entries
595- checked ISRC retrieval (MMC + Plextor)
596- more checking for weird CDs with wrong track types
597- bugfix in setuid.c
598- read full toc method extended to a data track in the second
599  session for cd-extra/enhanced cd recognition
600- if the tracks in the TOC are labelled as data, this is checked
601  and corrected if untrue
602- show cd text disc identification, if one exist
603- a new perl script to generate a binary cdtext file for use with
604  cdrecord. This is currently very simple, but it enables you to
605  create cd-text enriched copies from non cd-text originals.
606  For a hint how to use the new perl script see the CD-text usage
607  notes above.
608
609- Readcd:
610- use comerrno() instead of comerr() if the drive is not ready
611  as errno is not valid after that test.
612
613- Scgcheck:
614- Corrected some typos
615
616- Mkisofs:
617- Fixed a bug in the man page (typo .R instead of .B made text invisible)
618- Write messages with more correct size names for the floppy eltorito
619  boot images
620- rearranged the man page by removing the unreadable short listing
621  of options on the synopsys line.
622- Added UDF to the man page
623- Added a missing prototype in getopt.c
624- isodump.c isoinfo.c isovfy.c:
625  Correctly handle symlinks use offsetof(struct iso_directory_record, name[0])
626  instead of sizeof(struct iso_directory_record) - sizeof(idr->name)
627
628* Mon Nov 26 2001 Ryan Weaver <ryanw@falsehope.com>
629  [cdrtools-1.11a12-1]
630- All:
631- fixed fexec.c to make it compile ion QNX
632- Now the complete libschily is included although it it not needed
633  for cdrtools.
634
635- Cdda2wav:
636- Changed handling of Table of contents. Now the more informative
637  methods of Read full toc are being used in favor to the old SCSI readtoc
638  command. For Sony methods, the fallback is the old method.
639  The new methods are available on MMC drives and modern drives with
640  Sony command sets. It should enhance access to very weird multi session
641  cds.
642
643- Mkisofs:
644- Fixed a problem from an uninitialized variable in desktop.c
645  that caused random effects in Apple CD's
646- better documentation for README.sort/README.hide from James Pearson
647- Fixed a bug in sort code that caused the compare function to behave
648  symmetric when called c(a,b) vs. c(b,a)
649- First UDF support via -udf option - thanks to Ben Rudiak-Gould.
650  Note that the UDF support is not what you might indend. It is currently
651  wired to the Joliet tree which is a bad idea. It also does not yet
652  support Symbolic Links, user ID's and similar.
653
654* Mon Nov 19 2001 Ryan Weaver <ryanw@falsehope.com>
655  [cdrtools-1.11a11-1]
656- All:
657- fixed a bug in the new floatingpoint code that caused the emulation
658  code to be activated on Linux too.
659- added more parts from libschily to allow the cdrtools package to
660  be used as a plugin base for the new 'Slottable Source Plugin Module'
661  system (SSPM).
662
663- Cdrecord:
664- Better messages when trying to write more than the amount of data
665  that fits on a DVD.
666- The DVD driver now reports a DVD media back to the high level code.
667
668* Mon Nov 12 2001 Ryan Weaver <ryanw@falsehope.com>
669  [cdrtools-1.11a10-1]
670- All:
671- timedefs.h modified. Now the last schily portability support include
672  file hast been reworked to make portability even much easier.
673- schily.h & standard.h havebeen modified to hopefully finally solve
674  all type clash problems with size_t & spawn*()
675- Compile support for QNX Neutrino
676- Now we hopefully have floating point support for _all_ platforms
677  even those without *cvt() and without __dtoa(). Thanks to a hint
678  from Thomas Langer <Langer.Thomas@gmx.net> we now use strtod.c
679  to gert a fallback __dtoa()
680- Added an autoconf test for rcmd() so cdrtools now should compile
681  again on BeOS and AmigaOS where no rcmd() is present.
682
683- Cdrecord:
684- Fixed a bug introduced with cdrtools-1.11a07 for better DVD+CD
685  recognition support that prevented cdrecord to work with non MMC
686  writers.
687
688- Mkisofs:
689- libhfs_iso reworked to use timedefs.h from schily portability support.
690- man page enhanced
691- Better error messages for ISO and Rock Ridge directory sort problems
692- Preserves HFS file dates for AppleDouble, AppleSingle and NetaTalk files
693
694* Tue Oct 30 2001 Ryan Weaver <ryanw@falsehope.com>
695  [cdrtools-1.11a09-1]
696- All:
697- Better support for Darwin-1.3 and 1.4
698- Schily support includefiles rearranged to make portability even
699  easier.
700- mconfig.h now defines IS_SCHILY to signal users of the
701  Schily makefilesystem, that the Schily portability environment
702  is being used.
703- now includes the forgotten mkdep-sco.sh that helps to better
704  work around the SCO C-compiler.
705
706- Libscg:
707- First attempt for support for the new IOKit SCSI interface on MaxOS X
708  Darwin-1.4 and newer with much much help from
709  Constantine Sapuntzakis  <csapuntz@Stanford.EDU>
710  Unfortunately there is not yet support for SCSI devices nor
711  is there support for standard Bus,Target,Lun device namings.
712  I hope that bot may be added in the future.
713  Volunteers who like to help with the libscg interface stuff
714  for Darwin-1.4 are welcome.
715
716- Rscsi:
717- Code now checks for HAVE_NETDB_H (added by request of
718  "Thomas" <Langer.Thomas@gmx.de> to help with AmigaOS port)
719  This should indicate whether there is support for rcmd()
720  in the OS.
721
722- Cdrecord:
723- Behaviour of the function that reads fs= tsize= and similar
724  corrected.
725- Modified driver interface for better DVD support
726- FIFO Code now checks for HAVE_FORK (added by request of
727  "Thomas" <Langer.Thomas@gmx.de> to help with AmigaOS port)
728
729- Cdda2wav:
730- Restructured to better use the schily makefile portability structures.
731- Many other changes from Heiko - ask Heiko heiko@hexco.de for
732  the list.
733
734- Mkisofs:
735- Try to avoid the C-compiler warnings for getopt.c that are caused
736  by the non-confirming way of hacking used by FSF people
737- isoinfo now corectly displays file with filesize > 1 GB
738- isoinfo now implements a new option -s that displays the size
739  of the files in multiples of the sector size (2048 Bytes)
740
741* Tue Oct  8 2001 Ryan Weaver <ryanw@falsehope.com>
742  [cdrtools-1.11a08-1]
743- Libscg:
744- Better scg_open() error messages when trying to do scanbus on Linux
745  and no /dev/sg* or /dev/pg* could be opened.
746- Output Request Sense buffer with -debug when the USCSI interface is
747  used on Solaris.
748
749- Cdrecord:
750- Reading CD-Text on DOS/Win32 now works correclty. The O_BINARY
751  flag is used for open().
752- modify -version output if Clone writing support is present
753- A new driver has been added that first checks the media if the drive
754  supports to write CD & DVD.
755
756- Cdda2wav:
757- Changes to make cdda2wav compile better on Alpha/True64
758
759* Tue Sep 11 2001 Ryan Weaver <ryanw@falsehope.com>
760  [cdrtools-1.11a07-1]
761- All:
762- Better and extended description in README.macosX
763- Support for SCO (Caldera) OpenUNIX (aka. UnixWare 8)
764
765- Libscg:
766- Trying to add a workaround for just another bug in the
767  sg driver in the Linux kernel. If a TIMEOUT occurs,
768  the error code does not indicate a TIMEOUT.
769
770- Rscsi:
771- Now using signal safe read/write functions.
772
773- Cdrecord:
774- rscsi client code now uses buffered read to speed up on Cygwin
775- rscsi client code now uses signal safe read/write functions
776- Cdrecod now does not open/close the tray anymore if the disk
777  is going to be erased.
778
779- Mkisofs:
780- Man page updated and corrected.
781
782* Mon Jul 16 2001 Ryan Weaver <ryanw@falsehope.com>
783  [cdrtools-1.11a06-1]
784- All:
785- forgot to add the new printf.c with 1.11a05 now cdrtools really
786  compiles with GCC-3.0 on Linux
787
788- Cdrecord:
789- better FIFO debug messages
790- New driver config table for Taiyo Yuden EW-50.
791  This dive is like a Philips CDD-521 but has been reported to
792  swab audio data.
793
794- Readcd:
795- Better handling of C2 scans on unreadable data disks.
796
797- Scgcheck:
798- Fixed Makefile so scgcheck now compiles on FreeBSD
799
800* Fri Jun 28 2001 Ryan Weaver <ryanw@falsehope.com>
801  [cdrtools-1.11a05-1]
802- NOTE: There are 3000 new lines of code and aprox. 1500 lines
803        of code did change within the last few weeks.
804        Although I thoroughly tested every line of my code,
805        there may be bugs...
806
807        Please report if you have any problem that is not present
808        with cdrtools-1.11a01.
809
810- All:
811- Circumvent some problems with GCC-3.0 on Linux
812- Removed printf() definitions from schily.h to avoid type clashes
813
814- Cdrecord:
815- Circumvent a bug in the system include files from Linux that
816  makes printf() a macro and prevented compilation with GCC-3.0
817
818- Added some #include <stdio.h> to substitute missing printf() definitions
819- SAO/R16 mode removed from tests, it may never occur.
820- Changed some .min defines in structs to .pmin to avoid K&R complier
821  problems
822
823- Readcd:
824- Better handling of C2 scans on unreadable data disks.
825
826- Scgcheck:
827- Fixed Makefile so scgcheck now compiles on FreeBSD
828
829* Tue Jun 19 2001 Ryan Weaver <ryanw@falsehope.com>
830  [cdrtools-1.11a04-1]
831- NOTE: There are 3000 new lines of code and aprox. 1500 lines
832        of code did change within the last few weeks.
833        Although I thoroughly tested every line of my code,
834        there may be bugs...
835
836        Please report if you have any problem that is not present
837        with cdrtools-1.11a01.
838
839- Cdrecord:
840- add a forgotten if (xdebug) in drv_mmc.c.
841  This caused a superfluous write mode debug message to be printed
842- do installation of exit handlers (to reset SCSI state) earlier
843- Cdrecord now does not exit with 0 anymore when interrupted with ^C
844  during the waittime before starting to write.
845- First CD-Text support (can only copy CD-Text information from master
846  disk) (See AN-1.11a04 for more details)
847
848- Readcd:
849- Handle signals and other aborts by restoring old drive state
850- Set PF bit with mode select.
851- New option -quiet to suppress primary SCSI error messages
852  in read CD error handling
853  This are the messages that are printed before entering the
854  retry mode.
855- Secondary SCSI error messages are now suppressed by default,
856  they may be turned on again with -verbose
857  This are the messages that are printed in -noerror
858  retry mode.
859
860  [cdrtools-1.11a03-1]
861- Cdrecord:
862- Fixed a bug in the option checking that prevented to write
863  data CD's at all.
864  Now only "RAW data" CD's are flagged as expected.
865- Fixed a bug in the Firmware bug recognition system.
866  This bug did prevent cdrecord to work with Philips drives
867  when writing in RAW mode.
868- Added the -raw* options to the man page
869- New options -copy & -nocopy to allow to modify the 'copy' bit
870  in audio subchannel data.
871- -scms option added to the man page and online help.
872- New model to compute SCSI transfersizes
873- -xa1 -xa2 sector typedefinitions changed.
874- Debug messages while checking possible write modes of MMC
875  compliant made optional.
876- RAW writing scatter sector function made more general
877- New functions to convert between 2448 and 2368 byte sectors
878
879- Readcd:
880- error handling increased
881
882* Tue Jun  5 2001 Ryan Weaver <ryanw@falsehope.com>
883  [cdrtools-1.11a02-1]
884- There are 2000 new lines of code and aprox. 1000 lines
885  of code did change within the last two weeks.
886  Although I thoroughly tested every line of my code,
887  there may be bugs...
888  Please report if you have any problem that is not present
889  with cdrtools-1.11a01.
890
891- Cdrecord:
892- I hope that the 90 minute CD capacity warning now will finally
893  disappear for DVD writers.
894- Old test code removed that prevented cdrecord from being able
895  to write manually configured indices. Note that the index lists
896  from the *.inf files with using the -useinfo option alway worked.
897- -force will force cdrecord to ingnore any failed forced OPC.
898  currently this is only done if the drive does not support
899  forced OPC.
900- Do forced OPC before blanking a CD-RW
901- Driveropts "burnproof" renamed to "burnfree".
902  This has been done as this technology now appears in the MMC standard.
903- Cdrecord now shows whether BURN-Free is active. This makes
904  sense as Ricoh's "Just-Link" is enabled by default.
905  Unfortunately, the way "Just-link" is implemented is not compliant
906  with the MMC standard. We will have to wait until I get the needed
907  information from Ricoh.
908- Support for MMC RAW mode writing.
909  This allows to do disk at once recording on Philips drives that
910  do not support SAO.
911- Cdrecord now checks the properties of the writer. If a specific write
912  mode is not supported by the writer, cdrecord warns you and makes
913  a suggestion for a similar alternate write mode.
914  With the curent structure of cdrecord, it is not possible to silently
915  e.g. change the write mode from -dao to -raw96r
916- MMC compliant drives are automatically scanned for supported write modes.
917  This should help to make cdrecord work without manual static configuration.
918  My hope is still to have no need to know all drive properties in
919  advance, so new drives will continue to work as long as they
920  are standard comliant enough for cdrecord.
921
922* Sat May 19 2001 Ryan Weaver <ryanw@falsehope.com>
923  [cdrtools-1.11a01-1]
924- All:
925- Now using the "Slottable Source" feature of the makefile system.
926  This is the fist modular reusable portable makefile standard
927  in the open source world.
928- README.multi fixed
929- README.sony fixed
930- config.sub now recognises "parisc-unknown-linux-gnu"
931
932- Rscsi:
933- RSCSI now works if the target is a Win32 system.
934  This is not done by changing rscsi.c but by fixing a bug
935  in Cygwin!
936- Now prints user ID & user Name into DEBUG file
937
938- Cdrecord:
939- New option -overburn
940  This option has been added as many people seem to be unabe to understand
941  that they are going to write more than the official disk capacity from
942  reading cdrecord's output. Oveburnung now is no more done by default!
943- Do not print a warning for writing more than 90 minutes if the media is
944  a DVD
945- Fix for a problem with setting high priority on Win32 systems.
946  Thanks to  egor duda <deo@logos-m.ru>
947- Sony MMC drives now work in -multi session mode.
948  There was a bug in cdrecord that was accepted by all other drives.
949  The bug did cause a temporary bad setup to the drive.
950
951- Readcd:
952- better error recovery with -noerror
953
954
Note: See TracBrowser for help on using the repository browser.