source: projects/specs/trunk/c/cdrkit/cdrkit-vl.spec @ 8915

Revision 8915, 12.8 KB checked in by Takemikaduchi, 10 years ago (diff)

dash,liboil,libutempter,virtuoso-opensource,wavpack: new upstream release
others: rebuild

Line 
1Summary: A collection of CD/DVD utilities
2Summary(ja): CD/DVD ユーティリティ集
3Name: cdrkit
4Version: 1.1.11
5Release: 2%{?_dist_release}
6License: GPLv2
7Group: Applications/System
8URL: http://cdrkit.org/
9Source: http://cdrkit.org/releases/cdrkit-%{version}.tar.gz
10
11Patch1: cdrkit-1.1.8-werror.patch
12Patch2: cdrkit-1.1.9-efi-boot.patch
13Patch4: cdrkit-1.1.9-no_mp3.patch
14Patch5: cdrkit-1.1.9-buffer_overflow.patch
15#Patch6: cdrkit-1.1.9-rr_joliet.patch
16Patch6: cdrkit-1.1.10-build-fix.patch
17Patch7: cdrkit-1.1.11-manpagefix.patch
18Patch8: cdrkit-1.1.11-rootstat.patch
19Patch9: cdrkit-1.1.11-usalinst.patch
20Patch10: cdrkit-1.1.11-readsegfault.patch
21
22BuildRequires: cmake libcap-devel zlib-devel perl file-devel bzip2-devel
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25
26%description
27cdrkit is a collection of CD/DVD utilities.
28
29%package -n wodim
30Summary: A command line CD/DVD recording program
31Summary(ja): コマンドラインの CD/DVD 書き込みプログラム
32Group: Applications/Archiving
33Obsoletes: dvdrecord < 0.1.5.1
34Provides: dvdrecord = 0.1.5.1
35Obsoletes: cdrecord < 2.01.01.1
36Provides: cdrecord = 2.01.01.1
37Obsoletes: cdrtools-cdrecord < 2.01.01.1
38Provides: cdrtools-cdrecord = 2.01.01.1
39Requires(preun): alternatives chkconfig coreutils
40Requires(post): alternatives chkconfig coreutils
41
42%description -n wodim
43Wodim is an application for creating audio and data CDs. Wodim
44works with many different brands of CD recorders, fully supports
45multi-sessions and provides human-readable error messages.
46
47%package -n genisoimage
48Summary: Creates an image of an ISO9660 file system
49Summary(ja): ISO9660 ファイルシステムのイメージを作成するツール
50Group: Applications/System
51Obsoletes: mkisofs < 2.01.01.1
52Provides: mkisofs = 2.01.01.1
53Obsoletes: cdrtools-mkisofs < 2.01.01.1
54Provides: cdrtools-mkisofs = 2.01.01.1
55Obsoletes: mkhybrid, cdrecord-mkhybrid, cdrecord-mkisofs
56Requires(preun): alternatives chkconfig coreutils
57Requires(post): alternatives chkconfig coreutils
58
59%description -n genisoimage
60The genisoimage program is used as a pre-mastering program; i.e., it
61generates the ISO9660 file system. Genisoimage takes a snapshot of
62a given directory tree and generates a binary image of the tree
63which will correspond to an ISO9660 filesystem when written to
64a block device. Genisoimage is used for writing CD-ROMs, and includes
65support for creating bootable El Torito CD-ROMs.
66
67Install the genisoimage package if you need a program for writing
68CD-ROMs.
69
70%package -n dirsplit
71Summary: Utility to split directories
72Summary(ja): ディレクトリを分割するユーティリティ
73Group: Applications/System
74Requires: perl
75Requires: genisoimage = %{version}-%{release}
76
77%description -n dirsplit
78This utility is used to split directories into chunks before burning.
79Chunk size is usually set to fit to a CD/DVD.
80
81%package -n icedax
82Group: Applications/Multimedia
83Summary: A utility for sampling/copying .wav files from digital audio CDs
84Summary(ja): デジタルオーディオCDから.wavファイルをサンプリング/コピーするためのユーティリティ
85Obsoletes: cdda2wav < 2.01.01.1
86Provides: cdda2wav = 2.01.01.1
87Obsoletes: cdrtools-cdda2wav < 2.01.01.1
88Provides: cdrtools-cdda2wav = 2.01.01.1
89Requires(preun): alternatives chkconfig coreutils
90Requires(post): alternatives chkconfig coreutils
91Requires: vorbis-tools
92
93%description -n icedax
94Icedax is a sampling utility for CD-ROM drives that are capable of
95providing a CD's audio data in digital form to your host. Audio data
96read from the CD can be saved as .wav or .sun format sound files.
97Recording formats include stereo/mono, 8/12/16 bits and different
98rates. Icedax can also be used as a CD player.
99
100%package -n libusal-devel
101Summary: Development files for libusal
102Summary(ja): libusal の開発ファイル
103Group: Development/Libraries
104Provides: libusal-static = %{version}-%{release}
105
106%description -n libusal-devel
107The libusal-devel package contains libraries and header files
108for developing applications that use libusal.
109
110%prep
111%setup -q
112%patch1 -p1 -b .werror
113%patch2 -p1 -b .efi
114%patch4 -p1 -b .no_mp3
115%patch5 -p1 -b .buffer_overflow
116#%patch6 -p1 -b .rr_joliet
117%patch6 -p1 -b .build-fix
118%patch7 -p1 -b .manpagefix
119%patch8 -p1 -b .rootstat
120%patch9 -p1 -b .usalinst
121%patch10 -p1 -b .readsegfault
122
123find . -type f -print0 | xargs -0 perl -pi -e 's#/usr/local/bin/perl#/usr/bin/perl#g'
124find doc -type f -print0 | xargs -0 chmod a-x
125
126
127%build
128mkdir fedora
129cd fedora
130export CFLAGS="$RPM_OPT_FLAGS -Wall -Werror -Wno-unused-function -Wno-unused-variable -Wno-unused-but-set-variable -Wno-array-bounds -fno-strict-aliasing -Wno-sizeof-pointer-memaccess"
131export CXXFLAGS="$CFLAGS"
132export FFLAGS="$CFLAGS"
133%cmake CMAKE_VERBOSE=1 \
134        -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
135        -DBUILD_SHARED_LIBS:BOOL=ON \
136..
137
138make VERBOSE=1 %{?_smp_mflags}
139
140%install
141rm -rf $RPM_BUILD_ROOT
142cd fedora
143make install DESTDIR=$RPM_BUILD_ROOT
144perl -pi -e 's#^require v5.8.1;##g' $RPM_BUILD_ROOT%{_bindir}/dirsplit
145ln -s genisoimage $RPM_BUILD_ROOT%{_bindir}/mkisofs
146ln -s genisoimage $RPM_BUILD_ROOT%{_bindir}/mkhybrid
147ln -s icedax $RPM_BUILD_ROOT%{_bindir}/cdda2wav
148ln -s wodim $RPM_BUILD_ROOT%{_bindir}/cdrecord
149ln -s wodim $RPM_BUILD_ROOT%{_bindir}/dvdrecord
150
151# missing man page. Do symlink like in debian
152ln -sf wodim.1.gz $RPM_BUILD_ROOT/%{_mandir}/man1/netscsid.1.gz
153
154# we don't need cdda2mp3 since we don't have any mp3 {en,de}coder
155rm $RPM_BUILD_ROOT%{_bindir}/cdda2mp3
156
157%clean
158rm -rf $RPM_BUILD_ROOT
159
160%post -n wodim
161link=`readlink %{_bindir}/cdrecord`
162if [ "$link" == "%{_bindir}/wodim" ] || [ "$link" == "" ]; then
163        rm -f %{_bindir}/cdrecord
164fi
165link=`readlink %{_bindir}/dvdrecord`
166if [ "$link" == "wodim" ] || [ "$link" == "" ]; then
167        rm -f %{_bindir}/dvdrecord
168fi
169
170/sbin/update-alternatives --install %{_bindir}/cdrecord cdrecord \
171                %{_bindir}/wodim 50 \
172        --slave %{_mandir}/man1/cdrecord.1.gz cdrecord-cdrecordman \
173                %{_mandir}/man1/wodim.1.gz \
174        --slave %{_bindir}/dvdrecord cdrecord-dvdrecord %{_bindir}/wodim \
175        --slave %{_mandir}/man1/dvdrecord.1.gz cdrecord-dvdrecordman \
176                %{_mandir}/man1/wodim.1.gz \
177        --slave %{_bindir}/readcd cdrecord-readcd %{_bindir}/readom \
178        --slave %{_mandir}/man1/readcd.1.gz cdrecord-readcdman \
179                %{_mandir}/man1/readom.1.gz
180
181%preun -n wodim
182if [ $1 = 0 ]; then
183        %{_sbindir}/alternatives --remove cdrecord %{_bindir}/wodim
184fi
185
186%post -n genisoimage
187link=`readlink %{_bindir}/mkisofs`
188if [ "$link" == "genisoimage" ] || [ "$link" == "" ]; then
189        rm -f %{_bindir}/mkisofs
190fi
191
192/sbin/update-alternatives --install %{_bindir}/mkisofs mkisofs \
193                %{_bindir}/genisoimage 50 \
194        --slave %{_mandir}/man1/mkisofs.1.gz mkisofs-mkisofsman \
195                %{_mandir}/man1/genisoimage.1.gz \
196        --slave %{_bindir}/mkhybrid mkisofs-mkhybrid %{_bindir}/genisoimage
197
198%preun -n genisoimage
199if [ $1 = 0 ]; then
200        /sbin/update-alternatives --remove mkisofs %{_bindir}/genisoimage
201fi
202
203%post -n icedax
204link=`readlink %{_bindir}/cdda2wav`
205if [ "$link" == "icedax" ] || [ "$link" == "" ]; then
206        rm -f %{_bindir}/cdda2wav
207fi
208/sbin/update-alternatives --install %{_bindir}/cdda2wav cdda2wav \
209                %{_bindir}/icedax 50 \
210        --slave %{_mandir}/man1/cdda2wav.1.gz cdda2wav-cdda2wavman \
211                %{_mandir}/man1/icedax.1.gz
212
213%preun -n icedax
214if [ $1 = 0 ]; then
215        /sbin/update-alternatives --remove cdda2wav %{_bindir}/icedax
216fi
217
218%files -n wodim
219%defattr(-,root,root)
220%doc Changelog COPYING FAQ FORK START
221%doc doc/READMEs doc/wodim
222%{_bindir}/devdump
223%{_bindir}/wodim
224%ghost %{_bindir}/cdrecord
225%ghost %{_bindir}/dvdrecord
226%{_bindir}/readom
227%{_sbindir}/netscsid
228%{_mandir}/man1/devdump.*
229%{_mandir}/man1/wodim.*
230%{_mandir}/man1/netscsid.*
231%{_mandir}/man1/readom.*
232
233%files -n icedax
234%defattr(-,root,root)
235%doc doc/icedax COPYING
236%{_bindir}/icedax
237%ghost %{_bindir}/cdda2wav
238%{_bindir}/cdda2ogg
239%{_mandir}/man1/icedax.*
240%{_mandir}/man1/cdda2ogg.*
241%{_mandir}/man1/list_audio_tracks.*
242
243%files -n genisoimage
244%defattr(-,root,root)
245%doc doc/genisoimage COPYING
246%{_bindir}/genisoimage
247%ghost %{_bindir}/mkisofs
248%ghost %{_bindir}/mkhybrid
249%{_bindir}/isodebug
250%{_bindir}/isodump
251%{_bindir}/isoinfo
252%{_bindir}/isovfy
253%{_bindir}/pitchplay
254%{_bindir}/readmult
255%{_mandir}/man5/genisoimagerc.*
256%{_mandir}/man1/genisoimage.*
257%{_mandir}/man1/isodebug.*
258%{_mandir}/man1/isodump.*
259%{_mandir}/man1/isoinfo.*
260%{_mandir}/man1/isovfy.*
261%{_mandir}/man1/pitchplay.*
262%{_mandir}/man1/readmult.*
263
264%files -n dirsplit
265%defattr(-,root,root)
266%{_bindir}/dirsplit
267%{_mandir}/man1/dirsplit.*
268
269%files -n libusal-devel
270%defattr(-,root,root)
271%doc Changelog COPYING FAQ FORK START
272%{_libdir}/libusal.a
273%{_libdir}/librols.a
274%{_includedir}/usal
275
276%changelog
277* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.11-2
278- rebuild with VineSeed environment
279
280* Fri Apr 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.11-1
281- initial build for Vine Linux
282
283* Thu Mar 17 2011 Honza Horak <hhorak@redhat.com> - 1.1.11-6
284- Added Provides: libusal-static for libusal-devel subpackage
285  (Resolves: #688347)
286
287* Mon Mar 07 2011 Honza Horak <hhorak@redhat.com> - 1.1.11-5
288- Fix segmentation fault in readom
289  (Resolves: #682591)
290
291* Thu Feb 17 2011 Honza Horak <hhorak@redhat.com> - 1.1.11-4
292- Library libusal is installed in order to be used by other apps
293  (Resolves: #588508)
294  https://bugzilla.redhat.com/show_bug.cgi?id=588508
295
296* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.11-3
297- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
298
299* Mon Jan 31 2011 Honza Horak <hhorak@redhat.com> 1.1.11-2
300- fixed man page missing arguments (Resolves: #647024)
301  https://bugzilla.redhat.com/show_bug.cgi?id=647024
302- fixed erroneous "Unknown file type (unallocated)" warning
303  (Resolves: #174667)
304  https://bugzilla.redhat.com/show_bug.cgi?id=174667
305
306* Mon Oct 18 2010 Nikola Pajkovsky <npajkovs@redhat.com> 1.1.11-1
307- new upstream version 1.1.11
308
309* Mon Jun 21 2010 Roman Rakus <rrakus@redhat.com> - 1.1.10-2
310- Added missing manpage for netscsid (symlink to wodim manpage)
311
312* Wed Jan 20 2010 Nikola Pajkovsky <npajkovs@redhat.com> - 1.1.10-1
313- new upstream version 1.1.10
314
315* Tue Aug 11 2009 Nikola Pajkovsky <npajkovs@redhat.com> 1.1.9-10
316- fix #508449. fix string overflow breakage when using the -root
317
318* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-9
319- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
320
321* Thu Jul 16 2009 Nikola Pajkovsky <npajkovs@redhat.com> 1.1.9-8
322- fix buffer overflow
323
324* Fri Jul 10 2009 Adam Jackson <ajax@redhat.com> 1.1.9-7
325- Move dirsplit to a subpackage to isolate the perl dependency.
326
327* Mon Jun 15 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-6
328- rename functions as they conflict with glibc
329- Don't push cdda2mp3 because we don't have any mp3 coder
330  Resolves: #505918
331
332* Tue Jun 02 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-5
333- Added Requires vorbis-tools in icedax (rhbz #503699)
334
335* Wed Feb 25 2009 Peter Jones <pjones@redhat.com> - 1.1.9-4
336- Add support for EFI boot images.
337
338* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-3
339- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
340
341* Thu Feb 12 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-2
342- Use -fno-strict-aliasing to prevent strict_aliasing warnings/errors
343
344* Mon Oct 27 2008 Roman Rakus <rrakus@redhat.com> - 1.1.9-1
345- Bump to version 1.1.9
346
347* Tue May 27 2008 Roman Rakus <rrakus@redhat.com> - 1.1.8-1
348- Version 1.1.8 - old patches included
349                - added bzip2-devel to build requirements
350- fixed #171510 - preserve directory permissions
351
352* Wed Feb 27 2008 Harald Hoyer <harald@redhat.com> 1.1.6-11
353- refined -Werror patch
354
355* Mon Feb 25 2008 Harald Hoyer <harald@redhat.com> 1.1.6-10
356- patched to compile with -Werror (rhbz#429385)
357
358* Thu Feb 21 2008 Harald Hoyer <harald@redhat.com> 1.1.6-9
359- fixed loop on error message for old dev syntax (rhbz#429386)
360
361* Thu Feb 21 2008 Harald Hoyer <harald@redhat.com> 1.1.6-8
362- added file-devel to build requirements
363
364* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.6-7
365- Autorebuild for GCC 4.3
366
367* Tue Sep 25 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-6
368- fixed readcd man page symlink
369
370* Fri Sep 21 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-5
371- fixed rhbz#255001 - icedax --devices segfaults
372- fixed rhbz#249357 - Typo in wodim output
373
374* Fri Sep 21 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-4
375- play stupid tricks, to let alternatives make the links and
376  rpm not removing them afterwards
377- removed bogus warning for "." and ".."
378
379* Thu Sep 20 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-3
380- fixed rhbz#248262
381- switched to alternatives
382
383* Fri Aug 17 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-2
384- changed license to GPLv2
385
386* Wed Jun 20 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-1
387- version 1.1.6
388- added readcd symlink
389
390* Mon Apr 23 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-4
391- bump obsoletes/provides
392
393* Tue Feb 27 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-3
394- applied specfile changes as in bug #224365
395
396* Wed Jan 24 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-1
397- version 1.1.2
Note: See TracBrowser for help on using the repository browser.