source: projects/specs/trunk/c/cdrdao/cdrdao-vl.spec @ 3476

Revision 3476, 4.6 KB checked in by inagaki, 13 years ago (diff)

update: cdrdao

Line 
1Name: cdrdao
2Summary: Writes audio CD-Rs in disk-at-once (DAO) mode.
3Summary(ja): ディスクアットワンス(DAO)モードでオーディオデータを CD-R へ書き込むツール
4Version: 1.2.3
5Release: 1%{?_dist_release}
6
7Group: Applications/Multimedia
8License: GPLv2+
9URL: http://cdrdao.sourceforge.net/
10
11Source0:   http://prdownloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
12# Missing includes causes failure build
13Patch1: cdrdao-1.2.3-stat.patch
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: gtkmm2-devel
17BuildRequires: libgnomeuimm-devel
18BuildRequires: libsigc++-devel
19BuildRequires: libao-devel
20BuildRequires: libvorbis-devel >= 1.0
21#BuildRequires: pccts >= 1.33mr33
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26%description
27Cdrdao records audio CD-Rs in disk-at-once (DAO) mode, based on a
28textual description of the CD contents. Recording in DAO mode writes
29the complete disc (lead-in, one or more tracks, and lead-out) in a
30single step.
31
32%description -l ja
33Cdrdaoはディスクアットワンス(DAO)モードでaudioをCD-Rへ記録します。
34CD中身の原文の説明に基づきます。DAOモードのレコーディングは、一回のステップに完全なディスク(lead-in、一つ以上のトラックとlead-out)を書きます。
35
36
37%package -n gcdmaster
38Summary: Graphical front end to cdrdao for composing audio CDs
39Group: Applications/Multimedia
40Requires: %{name} = %{version}
41Requires(post): shared-mime-info
42Requires(postun): shared-mime-info
43
44%description -n gcdmaster
45gcdmaster allows the creation of toc-files for cdrdao and can control
46the recording process. Its main application is the composition of
47audio CDs from one or more audio files. It supports PQ-channel editing,
48entry of meta data like ISRC codes/CD-TEXT and non destructive cut of
49the audio data.
50
51
52%prep
53%setup -q
54%patch1 -p1 -b .stat
55
56%build
57%configure \
58        --with-xdao \
59        --without-scglib \
60        --without-mp3-support \
61        --without-lame
62# --with-pcctsinc=%{_includedir}/pccts \
63#           --without-lame \
64#           --without-mp3-support
65
66make %{?_smp_mflags}
67
68%install
69rm -rf $RPM_BUILD_ROOT
70
71make install DESTDIR=$RPM_BUILD_ROOT
72
73find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
74
75
76%pre -n gcdmaster
77if [ $1 -gt 1 ]; then
78    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
79    gconftool-2 --makefile-uninstall-rule \
80        %{_sysconfdir}/gconf/schemas/gcdmaster.schemas >& /dev/null ||:
81fi
82
83%post -n gcdmaster
84export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
85gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gcdmaster.schemas >& /dev/null ||:
86
87%posttrans -n gcdmaster
88update-mime-database %{_datadir}/mime >& /dev/null ||:
89
90%preun -n gcdmaster
91if [ $1 -eq 0 ]; then
92    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
93    gconftool-2 --makefile-uninstall-rule \
94        %{_sysconfdir}/gconf/schemas/gcdmaster.schemas >& /dev/null ||:
95fi
96
97%postun -n gcdmaster
98if [ $1 -eq 0 ] ; then
99    update-mime-database %{_datadir}/mime >& /dev/null ||:
100fi
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%files
106%defattr(-,root,root)
107%{_bindir}/cdrdao
108%{_datadir}/cdrdao/*
109%{_bindir}/toc2*
110%{_bindir}/cue2toc
111%{_mandir}/man1/*.gz
112%doc AUTHORS COPYING CREDITS ChangeLog README NEWS README.PlexDAE README.Win32
113
114%files -n gcdmaster
115%defattr(-,root,root)
116%doc AUTHORS COPYING README
117%{_sysconfdir}/gconf/schemas/gcdmaster.schemas
118%{_bindir}/gcdmaster
119%{_datadir}/application-registry/*
120%{_datadir}/applications/*
121%{_datadir}/gcdmaster
122%{_datadir}/mime-info/*
123%{_datadir}/mime/packages/*
124%{_datadir}/pixmaps/*
125
126%changelog
127* Tue Apr 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-4
128- add --without-mp3-support
129
130* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-3
131- add --without-lame
132- remove BR: libmad-devel
133
134* Sat Oct  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-2vl5
135- added BuildRequires: libao-devel, libmad-devel
136
137* Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.2-1vl5
138- applied new versioning policy, spec in utf-8
139- added cdrdao-1.2.2-sigc.patch from mdv
140    * Tue Sep 11 2007 Adam Williamson <awilliamson@mandriva.com> 1.2.2-5mdv2008.0
141    + Revision: 84331
142    - add patch0 to fix compilation issue caused by use of old sigc++ API
143
144* Sat Nov  4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
145- update to 1.2.2
146- fixed BuildRequires and Prereq
147
148* Mon May 22 2006 TOSHI <vine-jp@mail.goo.ne.jp> 1.1.9-0vl1
149- update to 1.1.9
150- added Requires -> libstdc++2_10,libstdc++2_10-compat
151
152* Mon Jun 10 2002 Tomoya TAKA <taka@vinelinux.org> 1.1.5-7vl2
153- separate gcdmaster into subpackage
154- add /etc/profile.d/gcdmaster.{sh,csh} to exec gcdmaster on C locale
155# end of file
Note: See TracBrowser for help on using the repository browser.