source: projects/specs/trunk/c/ccsm/ccsm-vl.spec @ 5701

Revision 5701, 4.4 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1Name:           ccsm
2Version:        0.8.4
3Release:        2%{?_dist_release}
4Summary:        Plugin and configuration tool - Compiz Fusion Project
5Summary(ja):    プラグインおよび設定ツール - Compiz Fusion プロジェクト
6Group:          User Interface/Desktops
7License:        GPLv2+
8URL:            http://www.opencompositing.org
9
10Source0:        http://releases.compiz-fusion.org/%{version}/%{name}-%{version}.tar.bz2
11Patch101:       ccsm-removeshebangs.patch
12# libdrm is not available on these arches
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15ExcludeArch:    s390 s390x ppc64
16BuildArch:      noarch
17BuildRequires:  python-devel, gettext, desktop-file-utils
18Requires:       compizconfig-python >= %{version}
19Requires:       libcompizconfig >= %{version}
20Requires:       pygtk2, python-sexy
21
22%description
23The Compiz Project brings 3D desktop visual effects that improve
24usability of the X Window System and provide increased productivity
25though plugins and themes contributed by the community giving a
26rich desktop experience.
27
28This package contains a gui configuration tool to configure Compiz
29plugins and the composite window manager.
30
31%prep
32%setup -q
33%patch101 -p1 -b .ccsm-removeshebangs
34
35%build
36#configure
37#make %{?_smp_mflags}
38python setup.py build
39
40%install
41rm -rf $RPM_BUILD_ROOT
42#make install DESTDIR=$RPM_BUILD_ROOT
43python setup.py install --prefix=%{_prefix} --root=$RPM_BUILD_ROOT
44desktop-file-install \
45      --vendor="" \
46      --dir=${RPM_BUILD_ROOT}%{_datadir}/applications \
47      --remove-category="Compiz" \
48      $RPM_BUILD_ROOT%{_datadir}/applications/ccsm.desktop
49
50%find_lang %{name}
51
52rm -f $RPM_BUILD_ROOT%{python_sitelib}/*.egg-info
53
54%post
55if [ -x /usr/bin/gtk-update-icon-cache ]; then
56        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
57fi
58
59%postun
60if [ -x /usr/bin/gtk-update-icon-cache ]; then
61        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
62fi
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67
68%files -f %{name}.lang
69%defattr(-,root,root,-)
70%doc AUTHORS COPYING VERSION
71%{_bindir}/ccsm
72%{_datadir}/applications/ccsm.desktop
73%{_datadir}/ccsm/
74%{_datadir}/icons/hicolor/*/apps/ccsm.*
75%{python_sitelib}/ccm/
76
77
78%changelog
79* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.4-2
80- rebuild with python-2.7.2
81
82* Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.4-1
83- new upstream release
84
85* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.2-2
86- rebuilt with python-2.6.4
87
88* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
89- new upstream release
90
91* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-1
92- new upstream release
93
94* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-3
95- remove vendor prefix from desktop filename.
96
97* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 0.7.6-2
98- rebuilt with python-2.5.2
99
100* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-1
101- new upstream release
102- add BuildRequires: python-sexy
103
104* Mon May 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4-1
105- new upstream release
106
107* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
108- initial build for Vine Linux
109
110* Tue Mar 29 2008 Mohd Izhar Firdaus Ismail <mohd.izhar.firdaus@gmail.com> 0.7.2-1
111- 0.7.2 update
112
113* Sat Dec 8 2007 Mohd Izhar Firdaus Ismail <mohd.izhar.firdaus@gmail.com> 0.6.0-5
114- added installed but unpackaged file ccsm-0.6.0-py2.5.egg-info
115
116* Sat Nov 25 2007 Mohd Izhar Firdaus Ismail <mohd.izhar.firdaus@gmail.com> 0.6.0-4
117- changed requires to allow flexible upgrade of compizconfig-python and libcompizconfig
118
119* Sun Aug 21 2007 Mohd Izhar Firdaus Ismail <mohd.izhar.firdaus@gmail.com> 0.6.0-3
120- fixed issue with remove shebangs patch
121
122* Sun Aug 21 2007 Mohd Izhar Firdaus Ismail <mohd.izhar.firdaus@gmail.com> 0.6.0-1
123- official upstream 0.6.0 tarball release
124- owns directory
125- removed shebangs from ccm
126- fixed desktop entry
127
128* Fri Aug 19 2007 Mohd Izhar Firdaus Ismail <mohd.izhar.firdaus@gmail.com> 0.6.0-0.3.20071018gita7fa7d
129- removed unneeded BuildReqs
130
131* Thu Aug 18 2007 Mohd Izhar Firdaus Ismail <mohd.izhar.firdaus@gmail.com> 0.6.0-0.2.20071018gita7fa7d
132- 0.6.0 branch
133
134* Sun Jun 30 2007 Mohd Izhar Firdaus Ismail <mohd.izhar.firdaus@gmail.com> 0.0.1-0.3.20070630git
135- 20070630git
136- Added BuildReq gettext
137- Added Require compizconfig-python
138- added require pygtk2
139
140* Sun Jun 24 2007 Mohd Izhar Firdaus Ismail <mohd.izhar.firdaus@gmail.com> 0.0.1-20070622git
141- Initial specfile, borrowing descriptions from Trevino ubuntu debs
Note: See TracBrowser for help on using the repository browser.