source: projects/specs/trunk/c/ccid/ccid-vl.spec @ 9543

Revision 9543, 5.1 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1%define dropdir %(pkg-config libpcsclite --variable usbdropdir 2>/dev/null)
2%define libusb1_ver 1.0.9
3%define pcsc_lite_ver 1.8.13
4
5Name:           ccid
6Version:        1.4.18
7Release:        1%{?_dist_release}
8Summary:        Generic USB CCID smart card reader driver
9Summary(ja):        Generic USB CCID smart card reader driver
10
11Group:          System Environment/Libraries
12License:        LGPLv2+
13URL:            http://pcsclite.alioth.debian.org/ccid.html
14Source0:        http://alioth.debian.org/download.php/1563/%{name}-%{version}.tar.bz2
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16
17BuildRequires:  libusb1-devel >= %{libusb1_ver}
18BuildRequires:  pcsc-lite-devel >= %{pcsc_lite_ver}
19Requires(post): initscripts
20Requires(postun): initscripts
21Requires:       libusb1
22Requires:       pcsc-lite
23Provides:       pcsc-ifd-handler
24Conflicts:      ccid145
25# 390 does not have libusb or smartCards
26ExcludeArch: s390 s390x
27
28
29%description
30Generic USB CCID (Chip/Smart Card Interface Devices) driver.
31
32
33%prep
34%setup -q
35for f in ChangeLog README ; do
36  iconv -f iso-8859-1 -t utf-8 $f > $f.utf8 ; mv $f.utf8 $f
37done
38
39
40%build
41%configure --disable-dependency-tracking --disable-static --enable-twinserial
42make %{?_smp_mflags}
43
44
45%install
46rm -rf $RPM_BUILD_ROOT
47make install DESTDIR=$RPM_BUILD_ROOT
48%{__mkdir_p} $RPM_BUILD_ROOT/%{_sysconfdir}/udev/rules.d
49%{__install} -m 644 src/92_pcscd_ccid.rules $RPM_BUILD_ROOT/%{_sysconfdir}/udev/rules.d/92-pcscd_ccid.rules
50
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55
56%post
57[ -x %{_initrddir}/pcscd ] && %{_initrddir}/pcscd status >> /dev/null 2>&1 && %{_sbindir}/pcscd -H > /dev/null 2>&1
58exit 0
59
60%postun
61[ -x %{_initrddir}/pcscd ] && %{_initrddir}/pcscd status >> /dev/null 2>&1 && %{_sbindir}/pcscd -H  > /dev/null 2>&1
62exit 0
63
64
65%files
66%defattr(-,root,root,-)
67%doc AUTHORS ChangeLog COPYING NEWS README SCARDGETATTRIB.txt
68%{dropdir}/ifd-ccid.bundle/
69%{dropdir}/serial/
70%config(noreplace) %{_sysconfdir}/reader.conf.d/libccidtwin
71%config %{_sysconfdir}/udev/rules.d/92-pcscd_ccid.rules
72
73
74%changelog
75* Mon May 04 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.18-1
76- new upstream release
77
78* Tue Jun 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.7-2
79- add Conflicts: ccid145
80
81* Sun Jun 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.7-1
82- new upstream release
83- change BuildRequires: libusb1-devel instead of libusb-devel
84
85* Mon Mar 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.8-1
86- initial build for Vine Linux
87
88* Tue Aug 26 2008 Bob Relyea <rrelyea@redhat.com> - 1.3.8-1
89- update to ccid 1.3.8
90
91* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.1-4
92- Autorebuild for GCC 4.3
93
94* Mon Aug 20 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-3
95- Update License description to the new Fedora standard
96
97* Mon Apr 30 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-2
98- Fix the missed use of the version macro
99
100* Tue Feb 06 2007 Bob Relyea <rrelyea@redhat.com> - 1.2.1-1
101- Pick up ccid 1.2.1
102- use pcscd 'hotplug' feature instead of restarting the daemon
103- add enable_udev
104
105* Mon Nov 06 2006 Bob Relyea <rrelyea@redhat.com> - 1.1.0-2
106- Fix version macro to remove '-'
107
108* Thu Nov 02 2006 Bob Relyea <rrelyea@redhat.com> - 1.1.0-1
109- Pickup ccid 1.1.0
110
111* Thu Jul 20 2006 Florian La Roche <laroche@redhat.com> - 1.0.1-5
112- require initscripts for post/postun
113
114* Sun Jul 16 2006 Florian La Roche <laroche@redhat.com> - 1.0.1-4
115- fix excludearch line
116
117* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-3.1
118- rebuild
119
120* Mon Jul 10 2006 Bob Relyea <rrelyea@redhat.com> - 1.0.1-3
121- remove s390 from the build
122
123* Mon Jun  5 2006 Bob Relyea <rrelyea@redhat.com> - 1.0.1-2
124- Move to Fedora Core, removed %%{_dist}.
125
126* Sat Apr 22 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.0.1-1
127- 1.0.1.
128
129* Mon Mar  6 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.0.0-1
130- 1.0.0, license changed to LGPL.
131
132* Wed Feb 15 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-7
133- Rebuild.
134
135* Thu Nov  3 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-6
136- Clean up build dependencies.
137- Convert docs to UTF-8.
138
139* Thu Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.4.1-5
140- rebuilt
141
142* Fri Feb 25 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.4.1-4
143- Drop Epoch: 0.
144- Improve summary.
145- Build with dependency tracking disabled.
146
147* Thu Jul  1 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.3
148- Restart pcscd in post(un)install phase if it's available and running.
149
150* Thu May 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.2
151- Provide pcsc-ifd-handler (idea from Debian).
152
153* Sat Feb 14 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.1-0.fdr.1
154- Update to 0.4.1.
155
156* Fri Feb 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.4.0-0.fdr.1
157- Update to 0.4.0.
158
159* Wed Nov  5 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.2-0.fdr.1
160- Update to 0.3.2.
161- Update URL.
162
163* Thu Oct 16 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.1-0.fdr.1
164- Update to 0.3.1.
165
166* Wed Sep 10 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.3.0-0.fdr.1
167- Update to 0.3.0.
168
169* Wed Aug 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.2.0-0.fdr.1
170- Update to 0.2.0.
171
172* Tue Aug 19 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.1.0-0.fdr.1
173- First build.
Note: See TracBrowser for help on using the repository browser.