source: projects/specs/trunk/c/cantor/cantor-vl.spec @ 6725

Revision 6725, 4.6 KB checked in by Takemikaduchi, 12 years ago (diff)

KDE-4.9.0

Line 
1Name: cantor
2Summary: Interface for mathematical applications
3Version: 4.9.0
4Release: 1%{?_dist_release}
5
6License: GPLv2+
7Group: Applications/Edutainment
8URL: http://edu.kde.org/cantor/
9
10Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
11
12## upstream patches
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: desktop-file-utils
16BuildRequires: gcc-gfortran
17BuildRequires: kdelibs4-devel >= %{version}
18BuildRequires: libspectre-devel
19BuildRequires: R libRmath-devel
20BuildRequires: soprano-devel
21BuildRequires: libqalculate-devel
22BuildRequires: analitza-devel
23
24Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
25
26Conflicts: kdeedu4 < 4.6.50
27
28%description
29Cantor is an application to allow you to you use your favorite mathematical applications from within an elegant KDE-integrated worksheet interface. It provides dialogs to assist with common tasks and allows you to share your worksheets with others.
30
31Cantor supports various mathematical applications as backends (provided in external packages):
32
33 * KAlgebra
34 * Maxima Computer Algebra System
35 * R Project for Statistical Computing (cantor-backend-R)
36 * Sage Mathematics Software
37 * Octave
38
39This package is part of the KDE education module.
40
41%package backend-R
42Summary: R backend for Cantor
43Summary(ja): Cantor の R バックエンド
44Group: Applications/Edutainment
45Requires: %{name} = %{version}-%{release}
46
47%description backend-R
48%{summary}.
49
50%package libs
51Summary: Runtime libraries for %{name}
52Summary(ja): %{name} のランタイムライブラリ
53Group:   System Environment/Libraries
54Conflicts: kdeedu4-math-libs < 4.6.50
55
56%description libs
57%{summary}.
58
59%package devel
60Summary: Development files for %{name}
61Summary(ja): %{name} の開発用ファイル
62Group: Development/Libraries
63Requires: %{name}-libs = %{version}-%{release}
64Conflicts: kdeedu4-devel < 4.6.50
65
66%description devel
67Header files for developing applications using %{name}.
68
69
70%prep
71%setup -q
72
73%build
74mkdir -p %{_target_platform}
75pushd %{_target_platform}
76%cmake \
77    -DCMAKE_BUILD_TYPE=release \
78    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
79    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
80    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
81    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
82    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
83    ..
84popd
85
86make %{?_smp_mflags} -C %{_target_platform}
87
88%install
89rm -rf $RPM_BUILD_ROOT
90make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%check
96for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
97    desktop-file-validate $f
98done
99
100
101%post
102touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
103
104%posttrans
105update-desktop-database -q &> /dev/null ||:
106gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
107
108%postun
109if [ $1 -eq 0 ] ; then
110    update-desktop-database -q &> /dev/null ||:
111    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
112    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
113fi
114
115%post backend-R
116touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
117
118%posttrans backend-R
119gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
120
121%postun backend-R
122if [ $1 -eq 0 ] ; then
123    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
124    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
125fi
126
127%post libs -p /sbin/ldconfig
128
129%postun libs -p /sbin/ldconfig
130
131
132%files
133%defattr(-,root,root)
134%doc COPYING COPYING.DOC
135%{_bindir}/cantor
136%{_libdir}/libcantor_config.so
137%{_libdir}/kde4/*.so
138%exclude %{_libdir}/kde4/cantor_rbackend.so
139%{_datadir}/applications/kde4/cantor.desktop
140%{_datadir}/config/*.knsrc
141%exclude %{_datadir}/config/cantor_r.knsrc
142%{_datadir}/config.kcfg/*.kcfg
143%exclude %{_datadir}/config.kcfg/rserver.kcfg
144%{_datadir}/icons/hicolor/*/*/*
145%exclude %{_datadir}/icons/hicolor/*/*/rbackend.*
146%{_datadir}/kde4/apps/cantor
147%{_datadir}/kde4/services/cantor/*.desktop
148%exclude %{_datadir}/kde4/services/cantor/rbackend.desktop
149%{_datadir}/kde4/servicetypes/cantor_*.desktop
150%doc %{_docdir}/HTML/en/cantor/
151
152%files backend-R
153%defattr(-,root,root,-)
154%{_bindir}/cantor_rserver
155%{_libdir}/kde4/cantor_rbackend.so
156%{_datadir}/config/cantor_r.knsrc
157%{_datadir}/config.kcfg/rserver.kcfg
158%{_datadir}/icons/hicolor/*/*/rbackend.*
159%{_datadir}/kde4/services/cantor/rbackend.desktop
160
161
162%files libs
163%defattr(-,root,root)
164%{_libdir}/libcantorlibs.so.*
165
166%files devel
167%defattr(-,root,root)
168%{_includedir}/kde4/cantor
169%{_libdir}/libcantorlibs.so
170
171%changelog
172* Mon Aug 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
173- new upstream release
174- add BuildRequires: libqalculate-devel, analitza-devel
175
176* Thu Sep  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
177- split from kdeedu
178
Note: See TracBrowser for help on using the repository browser.