source: projects/specs/trunk/c/calibre/calibre-vl.spec @ 5982

Revision 5982, 18.0 KB checked in by munepi, 12 years ago (diff)

updated calibre-vl.spec

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           calibre
4Version:        0.8.44
5Release:        1%{?_dist_release}
6Summary:        E-book converter and library management
7Group:          Applications/Multimedia
8License:        GPLv3
9URL:            http://calibre-ebook.com/
10
11# SourceURL: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
12
13# Upstream packages some unfree fonts which we cannot redistribute.
14# While we're at it, also delete the liberation fonts which we already have.
15#
16# Download the upstream tarball and invoke this script while in the tarball's
17# directory:
18# ./generate-tarball.sh %{version}
19Source0:        %{name}-%{version}-nofonts.tar.xz
20Source1:        generate-tarball.sh
21Source2:        calibre-mount-helper
22Patch0:         %{name}-manpages.patch
23Patch1:         %{name}-no-update.patch
24Patch2:         calibre-0.8.21-poppler.patch
25Patch10:        calibre-0.8.41-python27.patch
26BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
27
28BuildRequires:  python >= 2.7.1
29BuildRequires:  python-devel >= 2.7.1
30BuildRequires:  ImageMagick-devel >= 6.5.9
31BuildRequires:  python-setuptools
32BuildRequires:  qt4-devel >= 4.7.0
33BuildRequires:  PyQt4-devel >= 4.8.2
34BuildRequires:  poppler-qt4-devel >= 0.12
35BuildRequires:  podofo-devel >= 0.8.2
36BuildRequires:  desktop-file-utils
37BuildRequires:  python-mechanize >= 0.1.1
38BuildRequires:  python-lxml >= 2.2.1
39BuildRequires:  python-cssutils >= 0.9.6
40BuildRequires:  python-dateutil >= 1.4.1
41BuildRequires:  python-imaging >= 1.1.6
42BuildRequires:  xdg-utils >= 1.0.2
43BuildRequires:  python-BeautifulSoup >= 3.0.5
44BuildRequires:  xz
45BuildRequires:  unzip
46BuildRequires:  libwmf-devel >= 0.2.8
47BuildRequires:  chmlib-devel >= 0.40
48BuildRequires:  python-cssutils > 0.9.6
49BuildRequires:  sqlite3-devel
50BuildRequires:  libicu-devel >= 4.4
51
52Requires:       PyQt4
53Requires:       pyPdf
54Requires:       python-cherrypy
55Requires:       python-cssutils
56Requires:       ImageMagick
57Requires:       python-odf
58Requires:       python-django-tagging
59Requires:       python-lxml
60Requires:       python-imaging
61Requires:       python-mechanize
62Requires:       python-dateutil
63Requires:       python-genshi
64Requires:       python-BeautifulSoup
65
66## vine
67Requires:       TrueType-liberation
68
69%description
70Calibre is meant to be a complete e-library solution. It includes library
71management, format conversion, news feeds to ebook conversion as well as
72e-book reader sync features.
73
74Calibre is primarily a ebook cataloging program. It manages your ebook
75collection for you. It is designed around the concept of the logical book,
76i.e. a single entry in the database that may correspond to ebooks in several
77formats. It also supports conversion to and from a dozen different ebook
78formats.
79
80Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML, CBR, CBZ,
81RTF, TXT, PDF and LRS.
82
83%prep
84%setup -q -n %{name}
85
86# don't append calibre1 to the name of the manpages. No need to compress either
87# upstream won't fix: http://bugs.calibre-ebook.com/ticket/3770#comment:7
88%patch0 -p1 -b .manpages
89
90# don't check for new upstream version (that's what packagers do)
91%patch1 -p1 -b .no-update
92
93# modify poppler checks
94%patch2 -p1 -b .poppler
95
96# use python2.7
97%patch10 -p1 -b .vine
98
99# dos2unix newline conversion
100%{__sed} -i 's/\r//' src/calibre/web/feeds/recipes/*
101
102# remove shebangs
103%{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*/*.py
104%{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*.py
105%{__sed} -i -e '/^#![ ]*\//, 1d' src/calibre/*/*.py
106%{__sed} -i -e '/^#!\//, 1d' src/calibre/*.py
107%{__sed} -i -e '/^#!\//, 1d' src/templite/*.py
108%{__sed} -i -e '/^#!\//, 1d' resources/default_tweaks.py
109%{__sed} -i -e '/^#!\//, 1d' resources/catalog/section_list_templates.py
110
111%{__chmod} -x src/calibre/*/*/*/*.py
112%{__chmod} -x src/calibre/*/*/*.py
113%{__chmod} -x src/calibre/*/*.py
114%{__chmod} -x src/calibre/*.py
115
116%build
117OVERRIDE_CFLAGS="%{optflags}" QMAKE=%{_libdir}/qt4/bin/qmake python setup.py build
118
119%install
120%__rm -rf %{buildroot}
121
122%__mkdir -p %{buildroot}%{_datadir}
123
124# create directories for xdg-utils
125%__mkdir_p %{buildroot}%{_datadir}/icons
126%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor
127%__mkdir_p %{buildroot}%{_datadir}/packages
128%__mkdir_p %{buildroot}%{_datadir}/mime
129%__mkdir_p %{buildroot}%{_datadir}/mime/packages
130%__mkdir_p %{buildroot}%{_datadir}/applications
131%__mkdir_p %{buildroot}%{_datadir}/desktop-directories
132
133# create directory for calibre environment module
134# the install script assumes it's there.
135%__mkdir_p %{buildroot}%{python_sitelib}
136
137XDG_DATA_DIRS="%{buildroot}%{_datadir}" \
138XDG_UTILS_INSTALL_MODE="system" \
139LIBPATH="%{_libdir}" \
140python setup.py install --root=%{buildroot}%{_prefix} \
141                        --prefix=%{_prefix} \
142                        --libdir=%{_libdir} \
143                        --staging-libdir=%{buildroot}%{_libdir}
144
145# remove shebang from init_calibre.py here because
146# it just got spawned by the install script
147%{__sed} -i -e '/^#!\//, 1d' %{buildroot}%{python_sitelib}/init_calibre.py
148
149# icons
150%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
151%__cp -p resources/images/library.png \
152        %{buildroot}%{_datadir}/pixmaps/%{name}-gui.png
153%__cp -p resources/images/viewer.png \
154        %{buildroot}%{_datadir}/pixmaps/calibre-viewer.png
155
156# every file is empty here
157find %{buildroot}%{_datadir}/mime -maxdepth 1 -type f|xargs %__rm -f
158
159# packages aren't allowed to register mimetypes like this
160%__rm -f %{buildroot}%{_datadir}/applications/{defaults.list,mimeinfo.cache}
161
162desktop-file-validate \
163    %{buildroot}%{_datadir}/applications/calibre-ebook-viewer.desktop
164desktop-file-validate \
165    %{buildroot}%{_datadir}/applications/calibre-gui.desktop
166desktop-file-validate \
167    %{buildroot}%{_datadir}/applications/calibre-lrfviewer.desktop
168
169
170%__mv %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes \
171    %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes.xml
172
173# mimetype icon for lrf
174%__rm -rf %{buildroot}%{_datadir}/icons/hicolor/128x128
175%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable
176%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes
177%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/apps
178%__cp -p resources/images/mimetypes/lrf.png \
179    %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes/application-x-sony-bbeb.png
180%__cp -p resources/images/viewer.png \
181    %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/calibre-viewer.png
182
183# don't put bash completions in /usr/etc
184%__mv %{buildroot}%{_prefix}%{_sysconfdir} %{buildroot}
185
186# these are provided as separate packages
187%__rm -rf %{buildroot}%{_libdir}/%{name}/{odf,cherrypy,pyPdf,encutils,cssutils}
188%__rm -rf %{buildroot}%{_libdir}/%{name}/cal/utils/genshi
189%__rm -rf %{buildroot}%{_libdir}/%{name}/cal/trac
190
191# link to system fonts after we have deleted (see Source0) the non-free ones
192# http://bugs.calibre-ebook.com/ticket/3832
193%__mkdir_p %{buildroot}%{_datadir}/%{name}/fonts/prs500/
194%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSans-Regular.ttf \
195        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0003m_.ttf
196%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSerif-Regular.ttf \
197        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0011m_.ttf
198%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationMono-Regular.ttf \
199        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0419m_.ttf
200
201# http://bugs.calibre-ebook.com/ticket/3770#comment:7
202# man pages
203%__mv %{buildroot}%{_datadir}/%{name}/man %{buildroot}%{_mandir}
204
205# delete locales, calibre stores them in a zip file now
206rm -rf %{buildroot}%{_datadir}/%{name}/localization/locales/
207
208%{__rm} -f %{buildroot}%{_bindir}/%{name}-uninstall
209
210%__install -m 755 %{SOURCE2} %{buildroot}%{_bindir}/calibre-mount-helper
211
212%clean
213%{__rm} -rf %{buildroot}
214
215%post
216update-desktop-database &> /dev/null ||:
217update-mime-database %{_datadir}/mime &> /dev/null || :
218touch --no-create %{_datadir}/icons/hicolor || :
219if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
220    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
221fi
222
223%postun
224update-desktop-database &> /dev/null ||:
225update-mime-database %{_datadir}/mime &> /dev/null || :
226touch --no-create %{_datadir}/icons/hicolor || :
227if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
228    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
229fi
230
231%files
232%defattr(-,root,root,-)
233%doc COPYRIGHT LICENSE Changelog.yaml
234%{_bindir}/calibre
235%{_bindir}/calibre-complete
236%{_bindir}/calibre-customize
237%{_bindir}/calibre-debug
238%{_bindir}/calibre-parallel
239%{_bindir}/calibre-server
240%{_bindir}/calibre-smtp
241%{_bindir}/calibre-mount-helper
242%{_bindir}/calibredb
243%{_bindir}/ebook-convert
244%{_bindir}/ebook-device
245%{_bindir}/ebook-meta
246%{_bindir}/ebook-viewer
247%{_bindir}/epub-fix
248%{_bindir}/fetch-ebook-metadata
249%{_bindir}/lrf2lrs
250%{_bindir}/lrfviewer
251%{_bindir}/lrs2lrf
252%{_bindir}/markdown-calibre
253%{_bindir}/pdfmanipulate
254%{_bindir}/web2disk
255%config(noreplace) %{_sysconfdir}/bash_completion.d/
256%{_libdir}/%{name}
257%{_datadir}/%{name}
258%{_datadir}/pixmaps/*
259%{_datadir}/applications/*.desktop
260%{_datadir}/mime/packages/*
261%{_datadir}/icons/hicolor/scalable/mimetypes/*
262%{_datadir}/icons/hicolor/scalable/apps/*
263%{python_sitelib}/init_calibre.py*
264%{_mandir}/man1/*
265
266%changelog
267* Fri Mar 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.44-1
268- new upstream release
269
270* Sun Mar 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.41-1
271- new upstream release
272
273* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.50-2
274- rebuild with ImageMagick-6.7.5.10
275
276* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.50-1
277- new upstream release
278
279* Sat Feb 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.46-1
280- new upstream release
281
282* Thu Feb 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.44-1
283- new upstream release
284
285* Fri Feb 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.42-1
286- new upstream release
287
288* Fri Jan 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.40-1
289- new upstream release
290
291* Mon Dec 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.35-1
292- new upstream release
293
294* Sun Dec 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.34-1
295- new upstream release
296
297* Mon Dec 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.33-1
298- new upstream release
299- added BuildRequires: libicu-devel
300
301* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.32-1
302- new upstream release
303
304* Fri Nov 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.26-1
305- new upstream release
306
307* Sun Oct 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.25-1
308- new upstream release
309
310  * Tue Oct 19 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.24-1
311  - Update to 0.7.24
312
313  * Sat Oct 09 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.23-1
314  - Update to 0.7.23
315  - Fix up mount helper with our own local script.
316  - Change files to list binaries so missing ones can more easily be noted.
317
318  * Mon Oct 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.22-1
319  - Update to 0.7.22
320
321  * Fri Oct 01 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.21-1
322  - Update to 0.7.21
323
324  * Wed Sep 29 2010 jkeating - 0.7.20-2
325  - Rebuilt for gcc bug 634757
326
327  * Fri Sep 24 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.20-1
328  - Update to 0.7.20
329
330  * Wed Sep 15 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-3
331  - Rebuild for new ImageMagick
332
333* Wed Sep 29 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.18-1
334- new upstream release
335- Fix svg/png changes.
336
337  * Mon Sep 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-2
338  - Fix svg/png changes.
339
340  * Sun Sep 12 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-1
341  - Update to 0.7.18
342  - Require > 0.9.6 cssutils
343
344  * Fri Sep 03 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.17-1
345  - Update to 0.7.17
346
347  * Fri Aug 27 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.16-1
348  - Update to 0.7.16
349
350* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.15-1
351- initial build based on Fedora development
352
353* Sat Aug 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.15-1
354- Update to 0.7.15
355
356* Thu Aug 19 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.14-2
357- rebuild (poppler)
358
359* Fri Aug 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.14-1
360- Update to 0.7.14
361
362* Fri Aug 06 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.13-1
363- Update to 0.7.13
364
365* Mon Aug 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.12-1
366- Update to 0.7.12
367
368* Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.11-1
369- Update to 0.7.11
370
371* Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-2
372- Rebuilt for python2.7
373
374* Fri Jul 23 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-1
375- Update to 0.7.10
376
377* Sat Jul 17 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.9-1
378- Update to 0.7.9
379
380* Sun Jul 11 2010 Michal Nowak <mnowak@redhat.com> - 0.7.8-1
381- Update to 0.7.8
382- build tar.xz instead of tar.bz2
383
384* Fri Jul 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.7-1
385- Update to 0.7.7
386
387* Wed Jun 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.6-1
388- Update to 0.7.6
389
390* Fri Jun 25 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.5-1
391- Update to 0.7.5
392
393* Sun Jun 20 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.4-1
394- Update to 0.7.4
395
396* Tue Jun 08 2010 Dan Horák <dan@danny.cz> - 0.7.1-2
397- rebuilt with podofo 0.8.1
398
399* Mon Jun 07 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.1-1
400- Update to 0.7.1
401- Added versioned dep on python-cssutils to make sure at least 0.9.6 is installed.
402
403* Fri Jun 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.0-1
404- Update to 0.7.0
405
406* Fri May 28 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.55-1
407- Update to 0.6.55
408
409* Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.54-1
410- Update to 0.6.54
411
412* Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.53-1
413- Update to 0.6.53
414
415* Wed May  5 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.6.47-2
416- Rebuild against new poppler
417
418* Sat Apr 10 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.47-1
419- new upstream release 0.6.47
420- new chmlib requirement
421- create directory for calibre's environment module
422- use bzip2 instead of gzip when preparing tarball in generate-tarball.sh
423- remove cssutils patches (we now have python-cssutils 0.9.6 in Fedora)
424
425* Fri Feb 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.42-1
426- new upstream release 0.6.42
427- remove shebang from default_tweaks.py
428
429* Mon Feb  1 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.37-1
430- new upstream release 0.6.37
431
432* Fri Jan 29 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.36-1
433- new upstream release 0.6.36
434- fixed a cssprofiles issue with loading the profiles
435
436* Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-3
437- added -cssprofiles patch to cvs
438
439* Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-2
440- remove python-cssutils 0.9.6 dependency
441
442* Mon Jan 25 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-1
443- new upstream release
444- fedora includes cssutils >= 0.9.6 now; removed the cssprofiles patch
445- removed -executables patch, upstream fixed it: http://bugs.calibre-ebook.com/ticket/4437
446
447* Wed Jan  6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-2
448- fix for package tagged without adding new patch to cvs
449
450* Wed Jan  6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-1
451- new upstream release 0.6.32
452- project website has changed
453- added python-BeautifulSoup BuildRequire
454- new patch to fix full buildpath in binary files
455
456* Sun Dec  6 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.26-1
457- New upstream version
458- Regenerated no-update patch because of code relocation
459
460* Wed Dec  2 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.25-1
461- New upstream release
462
463* Wed Nov 18 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.24-1
464- New upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2416Nov2009
465
466* Mon Nov 16 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.23-1
467- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2313Nov2009
468- patch to stop checking for new upstream version
469
470* Sat Nov  7 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.21-1
471- new upstream version: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2106Nov2009
472- added python-BeautifulSoup requirement
473
474* Wed Nov  4 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.20-1
475- new upstream version:
476http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2030Oct2009
477- upstream now ships correct .desktop files
478- fixed missing dependency: PyQt4
479- fixed calibre-gui icon
480
481* Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-3
482- removed unfree fonts from source package
483
484* Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-2
485- readability enhancements
486- added python-genshi requires
487- removed libwmf require since ImageMagick provides libwmf-lite as a
488  dependency and that's what we actually need
489
490* Wed Oct 21 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-1
491- new upstream version:
492  http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1920Oct2009
493- delete fonts, calibre can find the system fonts
494- specify libdir as an install option, so calibre will link properly
495  even on 64bit
496
497* Mon Oct 19 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.18-1
498- updated requires list
499- new upstream release
500- can override CFLAGS now
501- removed trac and genshi duplicates
502- use xdg env variables to do desktop integration in the buildroot
503- added xdg-utils buildrequire
504- install udev rules in /usr/lib even on 64bit and don't own the whole dir
505- removed wrongly used Version field from .desktop files
506
507* Mon Oct 12 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-2
508- mimick what calibre's desktop-integration script does (mimetypes, icons etc.)
509- removed unneeded INSTALL file
510- marked bash completion file as config(noreplace) and take ownership of the dir
511
512* Sat Oct 10 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-1
513- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1709Oct2009
514- the install process changed significantly
515- locales were added
516
517* Thu Sep 10 2009 Ionuț Arțăriși <mapleoin@lavabit.com> - 0.6.11-1
518- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1104Sep2009
519- minor path fixes
520- rearranged files section
521
522* Fri Aug 28 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.10-1
523- handle desktop files
524- don't compress manpages and don't list them as duplicates
525- added lrfviewer icon
526
527* Tue Aug 25 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.8-1
528- Initial RPM release
Note: See TracBrowser for help on using the repository browser.