source: projects/specs/trunk/c/calibre/calibre-vl.spec @ 2540

Revision 2540, 18.3 KB checked in by munepi, 13 years ago (diff)

updated sigil-vl.spec, calibre-vl.spec

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           calibre
4Version:        0.7.40
5Release:        1%{?_dist_release}
6Summary:        E-book converter and library management
7Group:          Applications/Multimedia
8License:        GPLv3
9URL:            http://calibre-ebook.com/
10
11# SourceURL: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
12
13# Upstream packages some unfree fonts which we cannot redistribute.
14# While we're at it, also delete the liberation fonts which we already have.
15#
16# Download the upstream tarball and invoke this script while in the tarball's
17# directory:
18# ./generate-tarball.sh %{version}
19Source0:        %{name}-%{version}-nofonts.tar.xz
20Source1:        generate-tarball.sh
21Source2:        calibre-mount-helper
22Patch0:         %{name}-manpages.patch
23Patch1:         %{name}-no-update.patch
24#Patch2:         %{name}-0.6.53-mounthelper.patch
25BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
26
27BuildRequires:  python >= 2.6
28BuildRequires:  python-devel >= 2.6
29BuildRequires:  ImageMagick-devel >= 6.5.9
30BuildRequires:  python-setuptools
31BuildRequires:  qt4-devel >= 4.6.0
32BuildRequires:  PyQt4-devel >= 4.7.0
33BuildRequires:  poppler-qt4-devel >= 0.12
34BuildRequires:  podofo-devel
35BuildRequires:  desktop-file-utils
36BuildRequires:  python-mechanize >= 0.1.1
37BuildRequires:  python-lxml >= 2.2.1
38BuildRequires:  python-cssutils >= 0.9.6
39BuildRequires:  python-dateutil >= 1.4.1
40BuildRequires:  python-imaging >= 1.1.6
41BuildRequires:  xdg-utils >= 1.0.2
42BuildRequires:  python-BeautifulSoup >= 3.0.5
43BuildRequires:  xz
44BuildRequires:  unzip
45BuildRequires:  libwmf-devel >= 0.2.8
46BuildRequires:  chmlib-devel >= 0.40
47BuildRequires:  python-cssutils > 0.9.6
48BuildRequires:  sqlite3-devel
49
50## vine
51BuildRequires:  libicu-devel
52
53Requires:       PyQt4
54Requires:       pyPdf
55Requires:       python-cherrypy
56Requires:       python-cssutils
57Requires:       ImageMagick
58Requires:       python-odf
59Requires:       python-django-tagging
60Requires:       python-lxml
61Requires:       python-imaging
62Requires:       python-mechanize
63Requires:       python-dateutil
64Requires:       python-genshi
65Requires:       python-BeautifulSoup
66
67## vine
68Requires:       TrueType-liberation
69
70%description
71Calibre is meant to be a complete e-library solution. It includes library
72management, format conversion, news feeds to ebook conversion as well as
73e-book reader sync features.
74
75Calibre is primarily a ebook cataloging program. It manages your ebook
76collection for you. It is designed around the concept of the logical book,
77i.e. a single entry in the database that may correspond to ebooks in several
78formats. It also supports conversion to and from a dozen different ebook
79formats.
80
81Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML, CBR, CBZ,
82RTF, TXT, PDF and LRS.
83
84%prep
85%setup -q -n %{name}
86
87# don't append calibre1 to the name of the manpages. No need to compress either
88# upstream won't fix: http://bugs.calibre-ebook.com/ticket/3770#comment:7
89%patch0 -p1 -b .manpages
90
91# don't check for new upstream version (that's what packagers do)
92%patch1 -p1 -b .no-update
93
94# dos2unix newline conversion
95%{__sed} -i 's/\r//' src/calibre/web/feeds/recipes/*
96
97# remove shebangs
98%{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*/*.py
99%{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*.py
100%{__sed} -i -e '/^#![ ]*\//, 1d' src/calibre/*/*.py
101%{__sed} -i -e '/^#!\//, 1d' src/calibre/*.py
102%{__sed} -i -e '/^#!\//, 1d' src/templite/*.py
103%{__sed} -i -e '/^#!\//, 1d' resources/recipes/*
104%{__sed} -i -e '/^#!\//, 1d' resources/default_tweaks.py
105
106%{__chmod} -x src/calibre/*/*/*/*.py
107%{__chmod} -x src/calibre/*/*/*.py
108%{__chmod} -x src/calibre/*/*.py
109%{__chmod} -x src/calibre/*.py
110%{__chmod} -x resources/recipes/*
111
112%build
113OVERRIDE_CFLAGS="%{optflags}" QMAKE=%{_libdir}/qt4/bin/qmake python setup.py build
114
115%install
116%__rm -rf %{buildroot}
117
118%__mkdir -p %{buildroot}%{_datadir}
119
120# create directories for xdg-utils
121%__mkdir_p %{buildroot}%{_datadir}/icons
122%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor
123%__mkdir_p %{buildroot}%{_datadir}/packages
124%__mkdir_p %{buildroot}%{_datadir}/mime
125%__mkdir_p %{buildroot}%{_datadir}/mime/packages
126%__mkdir_p %{buildroot}%{_datadir}/applications
127%__mkdir_p %{buildroot}%{_datadir}/desktop-directories
128
129# create directory for calibre environment module
130# the install script assumes it's there.
131%__mkdir_p %{buildroot}%{python_sitelib}
132
133XDG_DATA_DIRS="%{buildroot}%{_datadir}" \
134XDG_UTILS_INSTALL_MODE="system" \
135LIBPATH="%{_libdir}" \
136python setup.py install --root=%{buildroot}%{_prefix} \
137                        --prefix=%{_prefix} \
138                        --libdir=%{_libdir} \
139                        --staging-libdir=%{buildroot}%{_libdir}
140
141# remove shebang from init_calibre.py here because
142# it just got spawned by the install script
143%{__sed} -i -e '/^#!\//, 1d' %{buildroot}%{python_sitelib}/init_calibre.py
144
145# icons
146%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
147%__cp -p resources/images/library.png \
148        %{buildroot}%{_datadir}/pixmaps/%{name}-gui.png
149%__cp -p resources/images/viewer.png \
150        %{buildroot}%{_datadir}/pixmaps/calibre-viewer.png
151
152# every file is empty here
153find %{buildroot}%{_datadir}/mime -maxdepth 1 -type f|xargs %__rm -f
154
155# packages aren't allowed to register mimetypes like this
156%__rm -f %{buildroot}%{_datadir}/applications/{defaults.list,mimeinfo.cache}
157
158desktop-file-validate \
159    %{buildroot}%{_datadir}/applications/calibre-ebook-viewer.desktop
160desktop-file-validate \
161    %{buildroot}%{_datadir}/applications/calibre-gui.desktop
162desktop-file-validate \
163    %{buildroot}%{_datadir}/applications/calibre-lrfviewer.desktop
164
165
166%__mv %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes \
167    %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes.xml
168
169# mimetype icon for lrf
170%__rm -rf %{buildroot}%{_datadir}/icons/hicolor/128x128
171%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable
172%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes
173%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/apps
174%__cp -p resources/images/mimetypes/lrf.png \
175    %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes/application-x-sony-bbeb.png
176%__cp -p resources/images/viewer.png \
177    %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/calibre-viewer.png
178
179# don't put bash completions in /usr/etc
180%__mv %{buildroot}%{_prefix}%{_sysconfdir} %{buildroot}
181
182# these are provided as separate packages
183%__rm -rf %{buildroot}%{_libdir}/%{name}/{odf,cherrypy,pyPdf,encutils,cssutils}
184%__rm -rf %{buildroot}%{_libdir}/%{name}/cal/utils/genshi
185%__rm -rf %{buildroot}%{_libdir}/%{name}/cal/trac
186
187# link to system fonts after we have deleted (see Source0) the non-free ones
188# http://bugs.calibre-ebook.com/ticket/3832
189%__mkdir_p %{buildroot}%{_datadir}/%{name}/fonts/prs500/
190%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSans-Regular.ttf \
191        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0003m_.ttf
192%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSerif-Regular.ttf \
193        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0011m_.ttf
194%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationMono-Regular.ttf \
195        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0419m_.ttf
196
197# http://bugs.calibre-ebook.com/ticket/3770#comment:7
198# man pages
199%__mv %{buildroot}%{_datadir}/%{name}/man %{buildroot}%{_mandir}
200
201# move locales
202%__mv %{buildroot}%{_datadir}/%{name}/localization/locales \
203    %{buildroot}%{_datadir}/locale
204for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/messages.mo; do
205    lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
206    %__mv %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/messages.mo \
207        %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}.mo
208done;
209for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/iso639.mo; do
210    lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
211    %__mv %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/iso639.mo \
212        %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}_iso639.mo
213done;
214for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/qt.qm; do
215    lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
216    %__mv $file %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}_$lang.qm
217done;
218
219%find_lang %{name} --with-qt --all-name
220
221# locales should be looked for in the proper place
222%{__sed} -i -e "s:P('localization/locales:('/usr/share/locale:" \
223        -e "s/messages.mo/calibre.mo/" \
224        -e "s/iso639.mo/calibre_iso639.mo/" \
225        %{buildroot}%{_libdir}/%{name}/%{name}/utils/localization.py
226
227%{__rm} -f %{buildroot}%{_bindir}/%{name}-uninstall
228
229%__cp -a %{SOURCE2} %{buildroot}%{_bindir}/
230
231%clean
232%{__rm} -rf %{buildroot}
233
234%post
235update-desktop-database &> /dev/null ||:
236update-mime-database %{_datadir}/mime &> /dev/null || :
237touch --no-create %{_datadir}/icons/hicolor || :
238if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
239    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
240fi
241
242%postun
243update-desktop-database &> /dev/null ||:
244update-mime-database %{_datadir}/mime &> /dev/null || :
245touch --no-create %{_datadir}/icons/hicolor || :
246if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
247    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
248fi
249
250%files -f %{name}.lang
251%defattr(-,root,root,-)
252%doc COPYRIGHT LICENSE Changelog.yaml
253%{_bindir}/calibre
254%{_bindir}/calibre-complete
255%{_bindir}/calibre-customize
256%{_bindir}/calibre-debug
257%{_bindir}/calibre-parallel
258%{_bindir}/calibre-server
259%{_bindir}/calibre-smtp
260%{_bindir}/calibre-mount-helper
261%{_bindir}/calibredb
262%{_bindir}/ebook-convert
263%{_bindir}/ebook-device
264%{_bindir}/ebook-meta
265%{_bindir}/ebook-viewer
266%{_bindir}/epub-fix
267%{_bindir}/fetch-ebook-metadata
268%{_bindir}/librarything
269%{_bindir}/lrf2lrs
270%{_bindir}/lrfviewer
271%{_bindir}/lrs2lrf
272%{_bindir}/markdown-calibre
273%{_bindir}/pdfmanipulate
274%{_bindir}/web2disk
275%config(noreplace) %{_sysconfdir}/bash_completion.d/
276%{_libdir}/%{name}
277%{_datadir}/%{name}
278%{_datadir}/pixmaps/*
279%{_datadir}/applications/*.desktop
280%{_datadir}/mime/packages/*
281%{_datadir}/icons/hicolor/scalable/mimetypes/*
282%{_datadir}/icons/hicolor/scalable/apps/*
283%{python_sitelib}/init_calibre.py*
284%{_mandir}/man1/*
285
286%changelog
287* Fri Jan 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.40-1
288- new upstream release
289
290* Mon Dec 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.35-1
291- new upstream release
292
293* Sun Dec 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.34-1
294- new upstream release
295
296* Mon Dec 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.33-1
297- new upstream release
298- added BuildRequires: libicu-devel
299
300* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.32-1
301- new upstream release
302
303* Fri Nov 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.26-1
304- new upstream release
305
306* Sun Oct 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.25-1
307- new upstream release
308
309  * Tue Oct 19 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.24-1
310  - Update to 0.7.24
311
312  * Sat Oct 09 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.23-1
313  - Update to 0.7.23
314  - Fix up mount helper with our own local script.
315  - Change files to list binaries so missing ones can more easily be noted.
316
317  * Mon Oct 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.22-1
318  - Update to 0.7.22
319
320  * Fri Oct 01 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.21-1
321  - Update to 0.7.21
322
323  * Wed Sep 29 2010 jkeating - 0.7.20-2
324  - Rebuilt for gcc bug 634757
325
326  * Fri Sep 24 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.20-1
327  - Update to 0.7.20
328
329  * Wed Sep 15 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-3
330  - Rebuild for new ImageMagick
331
332* Wed Sep 29 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.18-1
333- new upstream release
334- Fix svg/png changes.
335
336  * Mon Sep 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-2
337  - Fix svg/png changes.
338
339  * Sun Sep 12 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-1
340  - Update to 0.7.18
341  - Require > 0.9.6 cssutils
342
343  * Fri Sep 03 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.17-1
344  - Update to 0.7.17
345
346  * Fri Aug 27 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.16-1
347  - Update to 0.7.16
348
349* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.15-1
350- initial build based on Fedora development
351
352* Sat Aug 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.15-1
353- Update to 0.7.15
354
355* Thu Aug 19 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.14-2
356- rebuild (poppler)
357
358* Fri Aug 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.14-1
359- Update to 0.7.14
360
361* Fri Aug 06 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.13-1
362- Update to 0.7.13
363
364* Mon Aug 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.12-1
365- Update to 0.7.12
366
367* Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.11-1
368- Update to 0.7.11
369
370* Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-2
371- Rebuilt for python2.7
372
373* Fri Jul 23 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-1
374- Update to 0.7.10
375
376* Sat Jul 17 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.9-1
377- Update to 0.7.9
378
379* Sun Jul 11 2010 Michal Nowak <mnowak@redhat.com> - 0.7.8-1
380- Update to 0.7.8
381- build tar.xz instead of tar.bz2
382
383* Fri Jul 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.7-1
384- Update to 0.7.7
385
386* Wed Jun 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.6-1
387- Update to 0.7.6
388
389* Fri Jun 25 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.5-1
390- Update to 0.7.5
391
392* Sun Jun 20 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.4-1
393- Update to 0.7.4
394
395* Tue Jun 08 2010 Dan Horák <dan@danny.cz> - 0.7.1-2
396- rebuilt with podofo 0.8.1
397
398* Mon Jun 07 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.1-1
399- Update to 0.7.1
400- Added versioned dep on python-cssutils to make sure at least 0.9.6 is installed.
401
402* Fri Jun 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.0-1
403- Update to 0.7.0
404
405* Fri May 28 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.55-1
406- Update to 0.6.55
407
408* Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.54-1
409- Update to 0.6.54
410
411* Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.53-1
412- Update to 0.6.53
413
414* Wed May  5 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.6.47-2
415- Rebuild against new poppler
416
417* Sat Apr 10 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.47-1
418- new upstream release 0.6.47
419- new chmlib requirement
420- create directory for calibre's environment module
421- use bzip2 instead of gzip when preparing tarball in generate-tarball.sh
422- remove cssutils patches (we now have python-cssutils 0.9.6 in Fedora)
423
424* Fri Feb 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.42-1
425- new upstream release 0.6.42
426- remove shebang from default_tweaks.py
427
428* Mon Feb  1 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.37-1
429- new upstream release 0.6.37
430
431* Fri Jan 29 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.36-1
432- new upstream release 0.6.36
433- fixed a cssprofiles issue with loading the profiles
434
435* Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-3
436- added -cssprofiles patch to cvs
437
438* Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-2
439- remove python-cssutils 0.9.6 dependency
440
441* Mon Jan 25 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-1
442- new upstream release
443- fedora includes cssutils >= 0.9.6 now; removed the cssprofiles patch
444- removed -executables patch, upstream fixed it: http://bugs.calibre-ebook.com/ticket/4437
445
446* Wed Jan  6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-2
447- fix for package tagged without adding new patch to cvs
448
449* Wed Jan  6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-1
450- new upstream release 0.6.32
451- project website has changed
452- added python-BeautifulSoup BuildRequire
453- new patch to fix full buildpath in binary files
454
455* Sun Dec  6 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.26-1
456- New upstream version
457- Regenerated no-update patch because of code relocation
458
459* Wed Dec  2 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.25-1
460- New upstream release
461
462* Wed Nov 18 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.24-1
463- New upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2416Nov2009
464
465* Mon Nov 16 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.23-1
466- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2313Nov2009
467- patch to stop checking for new upstream version
468
469* Sat Nov  7 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.21-1
470- new upstream version: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2106Nov2009
471- added python-BeautifulSoup requirement
472
473* Wed Nov  4 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.20-1
474- new upstream version:
475http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2030Oct2009
476- upstream now ships correct .desktop files
477- fixed missing dependency: PyQt4
478- fixed calibre-gui icon
479
480* Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-3
481- removed unfree fonts from source package
482
483* Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-2
484- readability enhancements
485- added python-genshi requires
486- removed libwmf require since ImageMagick provides libwmf-lite as a
487  dependency and that's what we actually need
488
489* Wed Oct 21 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-1
490- new upstream version:
491  http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1920Oct2009
492- delete fonts, calibre can find the system fonts
493- specify libdir as an install option, so calibre will link properly
494  even on 64bit
495
496* Mon Oct 19 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.18-1
497- updated requires list
498- new upstream release
499- can override CFLAGS now
500- removed trac and genshi duplicates
501- use xdg env variables to do desktop integration in the buildroot
502- added xdg-utils buildrequire
503- install udev rules in /usr/lib even on 64bit and don't own the whole dir
504- removed wrongly used Version field from .desktop files
505
506* Mon Oct 12 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-2
507- mimick what calibre's desktop-integration script does (mimetypes, icons etc.)
508- removed unneeded INSTALL file
509- marked bash completion file as config(noreplace) and take ownership of the dir
510
511* Sat Oct 10 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-1
512- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1709Oct2009
513- the install process changed significantly
514- locales were added
515
516* Thu Sep 10 2009 Ionuț Arțăriși <mapleoin@lavabit.com> - 0.6.11-1
517- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1104Sep2009
518- minor path fixes
519- rearranged files section
520
521* Fri Aug 28 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.10-1
522- handle desktop files
523- don't compress manpages and don't list them as duplicates
524- added lrfviewer icon
525
526* Tue Aug 25 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.8-1
527- Initial RPM release
Note: See TracBrowser for help on using the repository browser.