source: projects/specs/trunk/c/calibre/calibre-vl.spec @ 2402

Revision 2402, 18.2 KB checked in by munepi, 13 years ago (diff)

updated calibre-vl.spec

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           calibre
4Version:        0.7.35
5Release:        1%{?_dist_release}
6Summary:        E-book converter and library management
7Group:          Applications/Multimedia
8License:        GPLv3
9URL:            http://calibre-ebook.com/
10
11# SourceURL: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
12
13# Upstream packages some unfree fonts which we cannot redistribute.
14# While we're at it, also delete the liberation fonts which we already have.
15#
16# Download the upstream tarball and invoke this script while in the tarball's
17# directory:
18# ./generate-tarball.sh %{version}
19Source0:        %{name}-%{version}-nofonts.tar.xz
20Source1:        generate-tarball.sh
21Source2:        calibre-mount-helper
22Patch0:         %{name}-manpages.patch
23Patch1:         %{name}-no-update.patch
24#Patch2:         %{name}-0.6.53-mounthelper.patch
25BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
26
27BuildRequires:  python >= 2.6
28BuildRequires:  python-devel >= 2.6
29BuildRequires:  ImageMagick-devel >= 6.5.9
30BuildRequires:  python-setuptools
31BuildRequires:  qt4-devel >= 4.6.0
32BuildRequires:  PyQt4-devel >= 4.7.0
33BuildRequires:  poppler-qt4-devel >= 0.12
34BuildRequires:  podofo-devel
35BuildRequires:  desktop-file-utils
36BuildRequires:  python-mechanize >= 0.1.1
37BuildRequires:  python-lxml >= 2.2.1
38BuildRequires:  python-cssutils >= 0.9.6
39BuildRequires:  python-dateutil >= 1.4.1
40BuildRequires:  python-imaging >= 1.1.6
41BuildRequires:  xdg-utils >= 1.0.2
42BuildRequires:  python-BeautifulSoup >= 3.0.5
43BuildRequires:  xz
44BuildRequires:  unzip
45BuildRequires:  libwmf-devel >= 0.2.8
46BuildRequires:  chmlib-devel >= 0.40
47BuildRequires:  python-cssutils > 0.9.6
48BuildRequires:  sqlite3-devel
49
50## vine
51BuildRequires:  libicu-devel
52
53Requires:       PyQt4
54Requires:       pyPdf
55Requires:       python-cherrypy
56Requires:       python-cssutils
57Requires:       ImageMagick
58Requires:       python-odf
59Requires:       python-django-tagging
60Requires:       python-lxml
61Requires:       python-imaging
62Requires:       python-mechanize
63Requires:       python-dateutil
64Requires:       python-genshi
65Requires:       python-BeautifulSoup
66
67## vine
68Requires:       TrueType-liberation
69
70%description
71Calibre is meant to be a complete e-library solution. It includes library
72management, format conversion, news feeds to ebook conversion as well as
73e-book reader sync features.
74
75Calibre is primarily a ebook cataloging program. It manages your ebook
76collection for you. It is designed around the concept of the logical book,
77i.e. a single entry in the database that may correspond to ebooks in several
78formats. It also supports conversion to and from a dozen different ebook
79formats.
80
81Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML, CBR, CBZ,
82RTF, TXT, PDF and LRS.
83
84%prep
85%setup -q -n %{name}
86
87# don't append calibre1 to the name of the manpages. No need to compress either
88# upstream won't fix: http://bugs.calibre-ebook.com/ticket/3770#comment:7
89%patch0 -p1 -b .manpages
90
91# don't check for new upstream version (that's what packagers do)
92%patch1 -p1 -b .no-update
93
94# dos2unix newline conversion
95%{__sed} -i 's/\r//' src/calibre/web/feeds/recipes/*
96
97# remove shebangs
98%{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*/*.py
99%{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*.py
100%{__sed} -i -e '/^#![ ]*\//, 1d' src/calibre/*/*.py
101%{__sed} -i -e '/^#!\//, 1d' src/calibre/*.py
102%{__sed} -i -e '/^#!\//, 1d' resources/recipes/*
103%{__sed} -i -e '/^#!\//, 1d' resources/default_tweaks.py
104
105%{__chmod} -x src/calibre/*/*/*/*.py
106%{__chmod} -x src/calibre/*/*/*.py
107%{__chmod} -x src/calibre/*/*.py
108%{__chmod} -x src/calibre/*.py
109%{__chmod} -x resources/recipes/*
110
111%build
112OVERRIDE_CFLAGS="%{optflags}" QMAKE=%{_libdir}/qt4/bin/qmake python setup.py build
113
114%install
115%__rm -rf %{buildroot}
116
117%__mkdir -p %{buildroot}%{_datadir}
118
119# create directories for xdg-utils
120%__mkdir_p %{buildroot}%{_datadir}/icons
121%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor
122%__mkdir_p %{buildroot}%{_datadir}/packages
123%__mkdir_p %{buildroot}%{_datadir}/mime
124%__mkdir_p %{buildroot}%{_datadir}/mime/packages
125%__mkdir_p %{buildroot}%{_datadir}/applications
126%__mkdir_p %{buildroot}%{_datadir}/desktop-directories
127
128# create directory for calibre environment module
129# the install script assumes it's there.
130%__mkdir_p %{buildroot}%{python_sitelib}
131
132XDG_DATA_DIRS="%{buildroot}%{_datadir}" \
133XDG_UTILS_INSTALL_MODE="system" \
134LIBPATH="%{_libdir}" \
135python setup.py install --root=%{buildroot}%{_prefix} \
136                        --prefix=%{_prefix} \
137                        --libdir=%{_libdir} \
138                        --staging-libdir=%{buildroot}%{_libdir}
139
140# remove shebang from init_calibre.py here because
141# it just got spawned by the install script
142%{__sed} -i -e '/^#!\//, 1d' %{buildroot}%{python_sitelib}/init_calibre.py
143
144# icons
145%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
146%__cp -p resources/images/library.png \
147        %{buildroot}%{_datadir}/pixmaps/%{name}-gui.png
148%__cp -p resources/images/viewer.png \
149        %{buildroot}%{_datadir}/pixmaps/calibre-viewer.png
150
151# every file is empty here
152find %{buildroot}%{_datadir}/mime -maxdepth 1 -type f|xargs %__rm -f
153
154# packages aren't allowed to register mimetypes like this
155%__rm -f %{buildroot}%{_datadir}/applications/{defaults.list,mimeinfo.cache}
156
157desktop-file-validate \
158    %{buildroot}%{_datadir}/applications/calibre-ebook-viewer.desktop
159desktop-file-validate \
160    %{buildroot}%{_datadir}/applications/calibre-gui.desktop
161desktop-file-validate \
162    %{buildroot}%{_datadir}/applications/calibre-lrfviewer.desktop
163
164
165%__mv %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes \
166    %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes.xml
167
168# mimetype icon for lrf
169%__rm -rf %{buildroot}%{_datadir}/icons/hicolor/128x128
170%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable
171%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes
172%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/apps
173%__cp -p resources/images/mimetypes/lrf.png \
174    %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes/application-x-sony-bbeb.png
175%__cp -p resources/images/viewer.png \
176    %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/calibre-viewer.png
177
178# don't put bash completions in /usr/etc
179%__mv %{buildroot}%{_prefix}%{_sysconfdir} %{buildroot}
180
181# these are provided as separate packages
182%__rm -rf %{buildroot}%{_libdir}/%{name}/{odf,cherrypy,pyPdf,encutils,cssutils}
183%__rm -rf %{buildroot}%{_libdir}/%{name}/cal/utils/genshi
184%__rm -rf %{buildroot}%{_libdir}/%{name}/cal/trac
185
186# link to system fonts after we have deleted (see Source0) the non-free ones
187# http://bugs.calibre-ebook.com/ticket/3832
188%__mkdir_p %{buildroot}%{_datadir}/%{name}/fonts/prs500/
189%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSans-Regular.ttf \
190        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0003m_.ttf
191%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSerif-Regular.ttf \
192        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0011m_.ttf
193%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationMono-Regular.ttf \
194        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0419m_.ttf
195
196# http://bugs.calibre-ebook.com/ticket/3770#comment:7
197# man pages
198%__mv %{buildroot}%{_datadir}/%{name}/man %{buildroot}%{_mandir}
199
200# move locales
201%__mv %{buildroot}%{_datadir}/%{name}/localization/locales \
202    %{buildroot}%{_datadir}/locale
203for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/messages.mo; do
204    lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
205    %__mv %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/messages.mo \
206        %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}.mo
207done;
208for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/iso639.mo; do
209    lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
210    %__mv %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/iso639.mo \
211        %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}_iso639.mo
212done;
213for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/qt.qm; do
214    lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
215    %__mv $file %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}_$lang.qm
216done;
217
218%find_lang %{name} --with-qt --all-name
219
220# locales should be looked for in the proper place
221%{__sed} -i -e "s:P('localization/locales:('/usr/share/locale:" \
222        -e "s/messages.mo/calibre.mo/" \
223        -e "s/iso639.mo/calibre_iso639.mo/" \
224        %{buildroot}%{_libdir}/%{name}/%{name}/utils/localization.py
225
226%{__rm} -f %{buildroot}%{_bindir}/%{name}-uninstall
227
228%__cp -a %{SOURCE2} %{buildroot}%{_bindir}/
229
230%clean
231%{__rm} -rf %{buildroot}
232
233%post
234update-desktop-database &> /dev/null ||:
235update-mime-database %{_datadir}/mime &> /dev/null || :
236touch --no-create %{_datadir}/icons/hicolor || :
237if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
238    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
239fi
240
241%postun
242update-desktop-database &> /dev/null ||:
243update-mime-database %{_datadir}/mime &> /dev/null || :
244touch --no-create %{_datadir}/icons/hicolor || :
245if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
246    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
247fi
248
249%files -f %{name}.lang
250%defattr(-,root,root,-)
251%doc COPYRIGHT LICENSE Changelog.yaml
252%{_bindir}/calibre
253%{_bindir}/calibre-complete
254%{_bindir}/calibre-customize
255%{_bindir}/calibre-debug
256%{_bindir}/calibre-parallel
257%{_bindir}/calibre-server
258%{_bindir}/calibre-smtp
259%{_bindir}/calibre-mount-helper
260%{_bindir}/calibredb
261%{_bindir}/ebook-convert
262%{_bindir}/ebook-device
263%{_bindir}/ebook-meta
264%{_bindir}/ebook-viewer
265%{_bindir}/epub-fix
266%{_bindir}/fetch-ebook-metadata
267%{_bindir}/librarything
268%{_bindir}/lrf2lrs
269%{_bindir}/lrfviewer
270%{_bindir}/lrs2lrf
271%{_bindir}/markdown-calibre
272%{_bindir}/pdfmanipulate
273%{_bindir}/web2disk
274%config(noreplace) %{_sysconfdir}/bash_completion.d/
275%{_libdir}/%{name}
276%{_datadir}/%{name}
277%{_datadir}/pixmaps/*
278%{_datadir}/applications/*
279%{_datadir}/mime/packages/*
280%{_datadir}/icons/hicolor/scalable/mimetypes/*
281%{_datadir}/icons/hicolor/scalable/apps/*
282%{python_sitelib}/init_calibre.py*
283%{_mandir}/man1/*
284
285%changelog
286* Mon Dec 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.35-1
287- new upstream release
288
289* Sun Dec 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.34-1
290- new upstream release
291
292* Mon Dec 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.33-1
293- new upstream release
294- added BuildRequires: libicu-devel
295
296* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.32-1
297- new upstream release
298
299* Fri Nov 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.26-1
300- new upstream release
301
302* Sun Oct 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.25-1
303- new upstream release
304
305  * Tue Oct 19 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.24-1
306  - Update to 0.7.24
307
308  * Sat Oct 09 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.23-1
309  - Update to 0.7.23
310  - Fix up mount helper with our own local script.
311  - Change files to list binaries so missing ones can more easily be noted.
312
313  * Mon Oct 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.22-1
314  - Update to 0.7.22
315
316  * Fri Oct 01 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.21-1
317  - Update to 0.7.21
318
319  * Wed Sep 29 2010 jkeating - 0.7.20-2
320  - Rebuilt for gcc bug 634757
321
322  * Fri Sep 24 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.20-1
323  - Update to 0.7.20
324
325  * Wed Sep 15 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-3
326  - Rebuild for new ImageMagick
327
328* Wed Sep 29 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.18-1
329- new upstream release
330- Fix svg/png changes.
331
332  * Mon Sep 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-2
333  - Fix svg/png changes.
334
335  * Sun Sep 12 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-1
336  - Update to 0.7.18
337  - Require > 0.9.6 cssutils
338
339  * Fri Sep 03 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.17-1
340  - Update to 0.7.17
341
342  * Fri Aug 27 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.16-1
343  - Update to 0.7.16
344
345* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.15-1
346- initial build based on Fedora development
347
348* Sat Aug 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.15-1
349- Update to 0.7.15
350
351* Thu Aug 19 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.14-2
352- rebuild (poppler)
353
354* Fri Aug 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.14-1
355- Update to 0.7.14
356
357* Fri Aug 06 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.13-1
358- Update to 0.7.13
359
360* Mon Aug 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.12-1
361- Update to 0.7.12
362
363* Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.11-1
364- Update to 0.7.11
365
366* Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-2
367- Rebuilt for python2.7
368
369* Fri Jul 23 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-1
370- Update to 0.7.10
371
372* Sat Jul 17 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.9-1
373- Update to 0.7.9
374
375* Sun Jul 11 2010 Michal Nowak <mnowak@redhat.com> - 0.7.8-1
376- Update to 0.7.8
377- build tar.xz instead of tar.bz2
378
379* Fri Jul 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.7-1
380- Update to 0.7.7
381
382* Wed Jun 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.6-1
383- Update to 0.7.6
384
385* Fri Jun 25 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.5-1
386- Update to 0.7.5
387
388* Sun Jun 20 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.4-1
389- Update to 0.7.4
390
391* Tue Jun 08 2010 Dan Horák <dan@danny.cz> - 0.7.1-2
392- rebuilt with podofo 0.8.1
393
394* Mon Jun 07 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.1-1
395- Update to 0.7.1
396- Added versioned dep on python-cssutils to make sure at least 0.9.6 is installed.
397
398* Fri Jun 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.0-1
399- Update to 0.7.0
400
401* Fri May 28 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.55-1
402- Update to 0.6.55
403
404* Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.54-1
405- Update to 0.6.54
406
407* Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.53-1
408- Update to 0.6.53
409
410* Wed May  5 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.6.47-2
411- Rebuild against new poppler
412
413* Sat Apr 10 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.47-1
414- new upstream release 0.6.47
415- new chmlib requirement
416- create directory for calibre's environment module
417- use bzip2 instead of gzip when preparing tarball in generate-tarball.sh
418- remove cssutils patches (we now have python-cssutils 0.9.6 in Fedora)
419
420* Fri Feb 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.42-1
421- new upstream release 0.6.42
422- remove shebang from default_tweaks.py
423
424* Mon Feb  1 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.37-1
425- new upstream release 0.6.37
426
427* Fri Jan 29 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.36-1
428- new upstream release 0.6.36
429- fixed a cssprofiles issue with loading the profiles
430
431* Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-3
432- added -cssprofiles patch to cvs
433
434* Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-2
435- remove python-cssutils 0.9.6 dependency
436
437* Mon Jan 25 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-1
438- new upstream release
439- fedora includes cssutils >= 0.9.6 now; removed the cssprofiles patch
440- removed -executables patch, upstream fixed it: http://bugs.calibre-ebook.com/ticket/4437
441
442* Wed Jan  6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-2
443- fix for package tagged without adding new patch to cvs
444
445* Wed Jan  6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-1
446- new upstream release 0.6.32
447- project website has changed
448- added python-BeautifulSoup BuildRequire
449- new patch to fix full buildpath in binary files
450
451* Sun Dec  6 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.26-1
452- New upstream version
453- Regenerated no-update patch because of code relocation
454
455* Wed Dec  2 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.25-1
456- New upstream release
457
458* Wed Nov 18 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.24-1
459- New upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2416Nov2009
460
461* Mon Nov 16 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.23-1
462- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2313Nov2009
463- patch to stop checking for new upstream version
464
465* Sat Nov  7 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.21-1
466- new upstream version: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2106Nov2009
467- added python-BeautifulSoup requirement
468
469* Wed Nov  4 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.20-1
470- new upstream version:
471http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2030Oct2009
472- upstream now ships correct .desktop files
473- fixed missing dependency: PyQt4
474- fixed calibre-gui icon
475
476* Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-3
477- removed unfree fonts from source package
478
479* Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-2
480- readability enhancements
481- added python-genshi requires
482- removed libwmf require since ImageMagick provides libwmf-lite as a
483  dependency and that's what we actually need
484
485* Wed Oct 21 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-1
486- new upstream version:
487  http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1920Oct2009
488- delete fonts, calibre can find the system fonts
489- specify libdir as an install option, so calibre will link properly
490  even on 64bit
491
492* Mon Oct 19 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.18-1
493- updated requires list
494- new upstream release
495- can override CFLAGS now
496- removed trac and genshi duplicates
497- use xdg env variables to do desktop integration in the buildroot
498- added xdg-utils buildrequire
499- install udev rules in /usr/lib even on 64bit and don't own the whole dir
500- removed wrongly used Version field from .desktop files
501
502* Mon Oct 12 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-2
503- mimick what calibre's desktop-integration script does (mimetypes, icons etc.)
504- removed unneeded INSTALL file
505- marked bash completion file as config(noreplace) and take ownership of the dir
506
507* Sat Oct 10 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-1
508- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1709Oct2009
509- the install process changed significantly
510- locales were added
511
512* Thu Sep 10 2009 Ionuț Arțăriși <mapleoin@lavabit.com> - 0.6.11-1
513- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1104Sep2009
514- minor path fixes
515- rearranged files section
516
517* Fri Aug 28 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.10-1
518- handle desktop files
519- don't compress manpages and don't list them as duplicates
520- added lrfviewer icon
521
522* Tue Aug 25 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.8-1
523- Initial RPM release
Note: See TracBrowser for help on using the repository browser.