source: projects/specs/trunk/c/calibre/calibre-vl.spec @ 2175

Revision 2175, 17.7 KB checked in by munepi, 14 years ago (diff)

updated calibre

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           calibre
4Version:        0.7.26
5Release:        1%{?_dist_release}
6Summary:        E-book converter and library management
7Group:          Applications/Multimedia
8License:        GPLv3
9URL:            http://calibre-ebook.com/
10
11# SourceURL: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
12
13# Upstream packages some unfree fonts which we cannot redistribute.
14# While we're at it, also delete the liberation fonts which we already have.
15#
16# Download the upstream tarball and invoke this script while in the tarball's
17# directory:
18# ./generate-tarball.sh %{version}
19Source0:        %{name}-%{version}-nofonts.tar.xz
20Source1:        generate-tarball.sh
21Source2:        calibre-mount-helper
22Patch0:         %{name}-manpages.patch
23Patch1:         %{name}-no-update.patch
24#Patch2:         %{name}-0.6.53-mounthelper.patch
25BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
26
27BuildRequires:  python >= 2.6
28BuildRequires:  python-devel >= 2.6
29BuildRequires:  ImageMagick-devel >= 6.5.9
30BuildRequires:  python-setuptools
31BuildRequires:  qt4-devel >= 4.6.0
32BuildRequires:  PyQt4-devel >= 4.7.0
33BuildRequires:  poppler-qt4-devel >= 0.12
34BuildRequires:  podofo-devel
35BuildRequires:  desktop-file-utils
36BuildRequires:  python-mechanize >= 0.1.1
37BuildRequires:  python-lxml >= 2.2.1
38BuildRequires:  python-cssutils >= 0.9.6
39BuildRequires:  python-dateutil >= 1.4.1
40BuildRequires:  python-imaging >= 1.1.6
41BuildRequires:  xdg-utils >= 1.0.2
42BuildRequires:  python-BeautifulSoup >= 3.0.5
43BuildRequires:  xz
44BuildRequires:  unzip
45BuildRequires:  libwmf-devel >= 0.2.8
46BuildRequires:  chmlib-devel >= 0.40
47
48Requires:       PyQt4
49Requires:       pyPdf
50Requires:       python-cherrypy
51Requires:       python-cssutils
52Requires:       ImageMagick
53Requires:       python-odf
54Requires:       python-django-tagging
55Requires:       python-lxml
56Requires:       python-imaging
57Requires:       python-mechanize
58Requires:       python-dateutil
59Requires:       python-genshi
60Requires:       python-BeautifulSoup
61
62## vine
63Requires:       TrueType-liberation
64
65%description
66Calibre is meant to be a complete e-library solution. It includes library
67management, format conversion, news feeds to ebook conversion as well as
68e-book reader sync features.
69
70Calibre is primarily a ebook cataloging program. It manages your ebook
71collection for you. It is designed around the concept of the logical book,
72i.e. a single entry in the database that may correspond to ebooks in several
73formats. It also supports conversion to and from a dozen different ebook
74formats.
75
76Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML, CBR, CBZ,
77RTF, TXT, PDF and LRS.
78
79%prep
80%setup -q -n %{name}
81
82# don't append calibre1 to the name of the manpages. No need to compress either
83# upstream won't fix: http://bugs.calibre-ebook.com/ticket/3770#comment:7
84%patch0 -p1 -b .manpages
85
86# don't check for new upstream version (that's what packagers do)
87%patch1 -p1 -b .no-update
88
89# # Enable mount helper
90#%patch2 -p1 -b .mounthelper
91
92# dos2unix newline conversion
93%{__sed} -i 's/\r//' src/calibre/web/feeds/recipes/*
94
95# remove shebangs
96%{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*/*.py
97%{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*.py
98%{__sed} -i -e '/^#![ ]*\//, 1d' src/calibre/*/*.py
99%{__sed} -i -e '/^#!\//, 1d' src/calibre/*.py
100%{__sed} -i -e '/^#!\//, 1d' resources/recipes/*
101%{__sed} -i -e '/^#!\//, 1d' resources/default_tweaks.py
102
103%{__chmod} -x src/calibre/*/*/*/*.py
104%{__chmod} -x src/calibre/*/*/*.py
105%{__chmod} -x src/calibre/*/*.py
106%{__chmod} -x src/calibre/*.py
107%{__chmod} -x resources/recipes/*
108
109%build
110OVERRIDE_CFLAGS="%{optflags}" QMAKE=%{_libdir}/qt4/bin/qmake python setup.py build
111
112%install
113%__rm -rf %{buildroot}
114
115%__mkdir -p %{buildroot}%{_datadir}
116
117# create directories for xdg-utils
118%__mkdir_p %{buildroot}%{_datadir}/icons
119%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor
120%__mkdir_p %{buildroot}%{_datadir}/packages
121%__mkdir_p %{buildroot}%{_datadir}/mime
122%__mkdir_p %{buildroot}%{_datadir}/mime/packages
123%__mkdir_p %{buildroot}%{_datadir}/applications
124%__mkdir_p %{buildroot}%{_datadir}/desktop-directories
125
126# create directory for calibre environment module
127# the install script assumes it's there.
128%__mkdir_p %{buildroot}%{python_sitelib}
129
130XDG_DATA_DIRS="%{buildroot}%{_datadir}" \
131XDG_UTILS_INSTALL_MODE="system" \
132LIBPATH="%{_libdir}" \
133python setup.py install --root=%{buildroot}%{_prefix} \
134                        --prefix=%{_prefix} \
135                        --libdir=%{_libdir} \
136                        --staging-libdir=%{buildroot}%{_libdir}
137
138# remove shebang from init_calibre.py here because
139# it just got spawned by the install script
140%{__sed} -i -e '/^#!\//, 1d' %{buildroot}%{python_sitelib}/init_calibre.py
141
142# icons
143%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
144%__cp -p resources/images/library.png \
145        %{buildroot}%{_datadir}/pixmaps/%{name}-gui.png
146%__cp -p resources/images/viewer.png \
147        %{buildroot}%{_datadir}/pixmaps/calibre-viewer.png
148
149# every file is empty here
150find %{buildroot}%{_datadir}/mime -maxdepth 1 -type f|xargs %__rm -f
151
152# packages aren't allowed to register mimetypes like this
153%__rm -f %{buildroot}%{_datadir}/applications/{defaults.list,mimeinfo.cache}
154
155desktop-file-validate \
156    %{buildroot}%{_datadir}/applications/calibre-ebook-viewer.desktop
157desktop-file-validate \
158    %{buildroot}%{_datadir}/applications/calibre-gui.desktop
159desktop-file-validate \
160    %{buildroot}%{_datadir}/applications/calibre-lrfviewer.desktop
161
162
163%__mv %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes \
164    %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes.xml
165
166# mimetype icon for lrf
167%__rm -rf %{buildroot}%{_datadir}/icons/hicolor/128x128
168%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable
169%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes
170%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/apps
171%__cp -p resources/images/mimetypes/lrf.png \
172    %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes/application-x-sony-bbeb.png
173%__cp -p resources/images/viewer.png \
174    %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/calibre-viewer.png
175
176# don't put bash completions in /usr/etc
177%__mv %{buildroot}%{_prefix}%{_sysconfdir} %{buildroot}
178
179# these are provided as separate packages
180%__rm -rf %{buildroot}%{_libdir}/%{name}/{odf,cherrypy,pyPdf,encutils,cssutils}
181%__rm -rf %{buildroot}%{_libdir}/%{name}/cal/utils/genshi
182%__rm -rf %{buildroot}%{_libdir}/%{name}/cal/trac
183
184# link to system fonts after we have deleted (see Source0) the non-free ones
185# http://bugs.calibre-ebook.com/ticket/3832
186%__mkdir_p %{buildroot}%{_datadir}/%{name}/fonts/prs500/
187%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSans-Regular.ttf \
188        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0003m_.ttf
189%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSerif-Regular.ttf \
190        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0011m_.ttf
191%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationMono-Regular.ttf \
192        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0419m_.ttf
193
194# http://bugs.calibre-ebook.com/ticket/3770#comment:7
195# man pages
196%__mv %{buildroot}%{_datadir}/%{name}/man %{buildroot}%{_mandir}
197
198# move locales
199%__mv %{buildroot}%{_datadir}/%{name}/localization/locales \
200    %{buildroot}%{_datadir}/locale
201for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/messages.mo; do
202    lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
203    %__mv %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/messages.mo \
204        %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}.mo
205done;
206for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/iso639.mo; do
207    lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
208    %__mv %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/iso639.mo \
209        %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}_iso639.mo
210done;
211for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/qt.qm; do
212    lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
213    %__mv $file %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}_$lang.qm
214done;
215
216%find_lang %{name} --with-qt --all-name
217
218# locales should be looked for in the proper place
219%{__sed} -i -e "s:P('localization/locales:('/usr/share/locale:" \
220        -e "s/messages.mo/calibre.mo/" \
221        -e "s/iso639.mo/calibre_iso639.mo/" \
222        %{buildroot}%{_libdir}/%{name}/%{name}/utils/localization.py
223
224%{__rm} -f %{buildroot}%{_bindir}/%{name}-uninstall
225
226%__cp -a %{SOURCE2} %{buildroot}%{_bindir}/
227
228%clean
229%{__rm} -rf %{buildroot}
230
231%post
232update-desktop-database &> /dev/null ||:
233update-mime-database %{_datadir}/mime &> /dev/null || :
234touch --no-create %{_datadir}/icons/hicolor || :
235if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
236    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
237fi
238
239%postun
240update-desktop-database &> /dev/null ||:
241update-mime-database %{_datadir}/mime &> /dev/null || :
242touch --no-create %{_datadir}/icons/hicolor || :
243if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
244    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
245fi
246
247%files -f %{name}.lang
248
249%defattr(-,root,root,-)
250%doc COPYRIGHT LICENSE Changelog.yaml
251%{_bindir}/calibre
252%{_bindir}/calibre-complete
253%{_bindir}/calibre-customize
254%{_bindir}/calibre-debug
255%{_bindir}/calibre-parallel
256%{_bindir}/calibre-server
257%{_bindir}/calibre-smtp
258%{_bindir}/calibre-mount-helper
259%{_bindir}/calibredb
260%{_bindir}/ebook-convert
261%{_bindir}/ebook-device
262%{_bindir}/ebook-meta
263%{_bindir}/ebook-viewer
264%{_bindir}/epub-fix
265%{_bindir}/fetch-ebook-metadata
266%{_bindir}/librarything
267%{_bindir}/lrf2lrs
268%{_bindir}/lrfviewer
269%{_bindir}/lrs2lrf
270%{_bindir}/markdown-calibre
271%{_bindir}/pdfmanipulate
272%{_bindir}/web2disk
273%config(noreplace) %{_sysconfdir}/bash_completion.d/
274%{_libdir}/%{name}
275%{_datadir}/%{name}
276%{_datadir}/pixmaps/*
277%{_datadir}/applications/*
278%{_datadir}/mime/packages/*
279%{_datadir}/icons/hicolor/scalable/mimetypes/*
280%{_datadir}/icons/hicolor/scalable/apps/*
281%{python_sitelib}/init_calibre.py*
282%{_mandir}/man1/*
283
284%changelog
285* Fri Nov 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.26-1
286- new upstream release
287
288* Sun Oct 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.25-1
289- new upstream release
290
291  * Tue Oct 19 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.24-1
292  - Update to 0.7.24
293
294  * Sat Oct 09 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.23-1
295  - Update to 0.7.23
296  - Fix up mount helper with our own local script.
297  - Change files to list binaries so missing ones can more easily be noted.
298
299  * Mon Oct 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.22-1
300  - Update to 0.7.22
301
302  * Fri Oct 01 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.21-1
303  - Update to 0.7.21
304
305  * Wed Sep 29 2010 jkeating - 0.7.20-2
306  - Rebuilt for gcc bug 634757
307
308  * Fri Sep 24 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.20-1
309  - Update to 0.7.20
310
311  * Wed Sep 15 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-3
312  - Rebuild for new ImageMagick
313
314* Wed Sep 29 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.18-1
315- new upstream release
316- Fix svg/png changes.
317
318  * Mon Sep 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-2
319  - Fix svg/png changes.
320
321  * Sun Sep 12 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-1
322  - Update to 0.7.18
323  - Require > 0.9.6 cssutils
324
325  * Fri Sep 03 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.17-1
326  - Update to 0.7.17
327
328  * Fri Aug 27 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.16-1
329  - Update to 0.7.16
330
331* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.15-1
332- initial build based on Fedora development
333
334* Sat Aug 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.15-1
335- Update to 0.7.15
336
337* Thu Aug 19 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.14-2
338- rebuild (poppler)
339
340* Fri Aug 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.14-1
341- Update to 0.7.14
342
343* Fri Aug 06 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.13-1
344- Update to 0.7.13
345
346* Mon Aug 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.12-1
347- Update to 0.7.12
348
349* Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.11-1
350- Update to 0.7.11
351
352* Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-2
353- Rebuilt for python2.7
354
355* Fri Jul 23 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-1
356- Update to 0.7.10
357
358* Sat Jul 17 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.9-1
359- Update to 0.7.9
360
361* Sun Jul 11 2010 Michal Nowak <mnowak@redhat.com> - 0.7.8-1
362- Update to 0.7.8
363- build tar.xz instead of tar.bz2
364
365* Fri Jul 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.7-1
366- Update to 0.7.7
367
368* Wed Jun 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.6-1
369- Update to 0.7.6
370
371* Fri Jun 25 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.5-1
372- Update to 0.7.5
373
374* Sun Jun 20 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.4-1
375- Update to 0.7.4
376
377* Tue Jun 08 2010 Dan Horák <dan@danny.cz> - 0.7.1-2
378- rebuilt with podofo 0.8.1
379
380* Mon Jun 07 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.1-1
381- Update to 0.7.1
382- Added versioned dep on python-cssutils to make sure at least 0.9.6 is installed.
383
384* Fri Jun 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.0-1
385- Update to 0.7.0
386
387* Fri May 28 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.55-1
388- Update to 0.6.55
389
390* Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.54-1
391- Update to 0.6.54
392
393* Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.53-1
394- Update to 0.6.53
395
396* Wed May  5 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.6.47-2
397- Rebuild against new poppler
398
399* Sat Apr 10 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.47-1
400- new upstream release 0.6.47
401- new chmlib requirement
402- create directory for calibre's environment module
403- use bzip2 instead of gzip when preparing tarball in generate-tarball.sh
404- remove cssutils patches (we now have python-cssutils 0.9.6 in Fedora)
405
406* Fri Feb 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.42-1
407- new upstream release 0.6.42
408- remove shebang from default_tweaks.py
409
410* Mon Feb  1 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.37-1
411- new upstream release 0.6.37
412
413* Fri Jan 29 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.36-1
414- new upstream release 0.6.36
415- fixed a cssprofiles issue with loading the profiles
416
417* Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-3
418- added -cssprofiles patch to cvs
419
420* Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-2
421- remove python-cssutils 0.9.6 dependency
422
423* Mon Jan 25 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-1
424- new upstream release
425- fedora includes cssutils >= 0.9.6 now; removed the cssprofiles patch
426- removed -executables patch, upstream fixed it: http://bugs.calibre-ebook.com/ticket/4437
427
428* Wed Jan  6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-2
429- fix for package tagged without adding new patch to cvs
430
431* Wed Jan  6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-1
432- new upstream release 0.6.32
433- project website has changed
434- added python-BeautifulSoup BuildRequire
435- new patch to fix full buildpath in binary files
436
437* Sun Dec  6 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.26-1
438- New upstream version
439- Regenerated no-update patch because of code relocation
440
441* Wed Dec  2 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.25-1
442- New upstream release
443
444* Wed Nov 18 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.24-1
445- New upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2416Nov2009
446
447* Mon Nov 16 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.23-1
448- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2313Nov2009
449- patch to stop checking for new upstream version
450
451* Sat Nov  7 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.21-1
452- new upstream version: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2106Nov2009
453- added python-BeautifulSoup requirement
454
455* Wed Nov  4 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.20-1
456- new upstream version:
457http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2030Oct2009
458- upstream now ships correct .desktop files
459- fixed missing dependency: PyQt4
460- fixed calibre-gui icon
461
462* Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-3
463- removed unfree fonts from source package
464
465* Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-2
466- readability enhancements
467- added python-genshi requires
468- removed libwmf require since ImageMagick provides libwmf-lite as a
469  dependency and that's what we actually need
470
471* Wed Oct 21 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-1
472- new upstream version:
473  http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1920Oct2009
474- delete fonts, calibre can find the system fonts
475- specify libdir as an install option, so calibre will link properly
476  even on 64bit
477
478* Mon Oct 19 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.18-1
479- updated requires list
480- new upstream release
481- can override CFLAGS now
482- removed trac and genshi duplicates
483- use xdg env variables to do desktop integration in the buildroot
484- added xdg-utils buildrequire
485- install udev rules in /usr/lib even on 64bit and don't own the whole dir
486- removed wrongly used Version field from .desktop files
487
488* Mon Oct 12 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-2
489- mimick what calibre's desktop-integration script does (mimetypes, icons etc.)
490- removed unneeded INSTALL file
491- marked bash completion file as config(noreplace) and take ownership of the dir
492
493* Sat Oct 10 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-1
494- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1709Oct2009
495- the install process changed significantly
496- locales were added
497
498* Thu Sep 10 2009 Ionuț Arțăriși <mapleoin@lavabit.com> - 0.6.11-1
499- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1104Sep2009
500- minor path fixes
501- rearranged files section
502
503* Fri Aug 28 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.10-1
504- handle desktop files
505- don't compress manpages and don't list them as duplicates
506- added lrfviewer icon
507
508* Tue Aug 25 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.8-1
509- Initial RPM release
Note: See TracBrowser for help on using the repository browser.