source: projects/specs/trunk/c/calibre/calibre-vl.spec @ 7766

Revision 7766, 18.4 KB checked in by Takemikaduchi, 11 years ago (diff)

ETL,ImageMagick?,minitube,synfig,synfigstudio,xine-lib: new upstream release
others: rebuild with ImageMagick?-6.8.6.8

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           calibre
4Version:        0.8.50
5Release:        2%{?_dist_release}
6Summary:        E-book converter and library management
7Group:          Applications/Multimedia
8License:        GPLv3
9URL:            http://calibre-ebook.com/
10
11# SourceURL: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
12
13# Upstream packages some unfree fonts which we cannot redistribute.
14# While we're at it, also delete the liberation fonts which we already have.
15#
16# Download the upstream tarball and invoke this script while in the tarball's
17# directory:
18# ./generate-tarball.sh %{version}
19Source0:        %{name}-%{version}-nofonts.tar.xz
20Source1:        generate-tarball.sh
21Source2:        calibre-mount-helper
22Patch0:         %{name}-manpages.patch
23Patch1:         %{name}-no-update.patch
24Patch2:         calibre-0.8.21-poppler.patch
25Patch3:         calibre-0.8.50-poppler-0.20.x.patch
26Patch10:        calibre-0.8.41-python27.patch
27BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
28
29BuildRequires:  python >= 2.7.1
30BuildRequires:  python-devel >= 2.7.1
31BuildRequires:  ImageMagick-devel >= 6.5.9
32BuildRequires:  python-setuptools
33BuildRequires:  qt4-devel >= 4.7.0
34BuildRequires:  PyQt4-devel >= 4.8.2
35BuildRequires:  poppler-qt4-devel >= 0.12
36BuildRequires:  podofo-devel >= 0.8.2
37BuildRequires:  desktop-file-utils
38BuildRequires:  python-mechanize >= 0.1.1
39BuildRequires:  python-lxml >= 2.2.1
40BuildRequires:  python-cssutils >= 0.9.6
41BuildRequires:  python-dateutil >= 1.4.1
42BuildRequires:  python-imaging >= 1.1.6
43BuildRequires:  xdg-utils >= 1.0.2
44BuildRequires:  python-BeautifulSoup >= 3.0.5
45BuildRequires:  xz
46BuildRequires:  unzip
47BuildRequires:  libwmf-devel >= 0.2.8
48BuildRequires:  chmlib-devel >= 0.40
49BuildRequires:  python-cssutils > 0.9.6
50BuildRequires:  sqlite3-devel
51BuildRequires:  libicu-devel >= 4.4
52
53Requires:       PyQt4
54Requires:       pyPdf
55Requires:       python-cherrypy
56Requires:       python-cssutils
57Requires:       ImageMagick
58Requires:       python-odf
59Requires:       python-django-tagging
60Requires:       python-lxml
61Requires:       python-imaging
62Requires:       python-mechanize
63Requires:       python-dateutil
64Requires:       python-genshi
65Requires:       python-BeautifulSoup
66
67## vine
68Requires:       TrueType-liberation
69
70%description
71Calibre is meant to be a complete e-library solution. It includes library
72management, format conversion, news feeds to ebook conversion as well as
73e-book reader sync features.
74
75Calibre is primarily a ebook cataloging program. It manages your ebook
76collection for you. It is designed around the concept of the logical book,
77i.e. a single entry in the database that may correspond to ebooks in several
78formats. It also supports conversion to and from a dozen different ebook
79formats.
80
81Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML, CBR, CBZ,
82RTF, TXT, PDF and LRS.
83
84%prep
85%setup -q -n %{name}
86
87# don't append calibre1 to the name of the manpages. No need to compress either
88# upstream won't fix: http://bugs.calibre-ebook.com/ticket/3770#comment:7
89%patch0 -p1 -b .manpages
90
91# don't check for new upstream version (that's what packagers do)
92%patch1 -p1 -b .no-update
93
94# modify poppler checks
95%patch2 -p1 -b .poppler
96%patch3 -p1 -b .poppler.0.20
97
98# use python2.7
99%patch10 -p1 -b .vine
100
101# dos2unix newline conversion
102%{__sed} -i 's/\r//' src/calibre/web/feeds/recipes/*
103
104# remove shebangs
105%{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*/*.py
106%{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*.py
107%{__sed} -i -e '/^#![ ]*\//, 1d' src/calibre/*/*.py
108%{__sed} -i -e '/^#!\//, 1d' src/calibre/*.py
109%{__sed} -i -e '/^#!\//, 1d' src/templite/*.py
110%{__sed} -i -e '/^#!\//, 1d' resources/default_tweaks.py
111%{__sed} -i -e '/^#!\//, 1d' resources/catalog/section_list_templates.py
112
113%{__chmod} -x src/calibre/*/*/*/*.py
114%{__chmod} -x src/calibre/*/*/*.py
115%{__chmod} -x src/calibre/*/*.py
116%{__chmod} -x src/calibre/*.py
117
118%build
119OVERRIDE_CFLAGS="%{optflags}" QMAKE=%{_libdir}/qt4/bin/qmake python setup.py build
120
121%install
122%__rm -rf %{buildroot}
123
124%__mkdir -p %{buildroot}%{_datadir}
125
126# create directories for xdg-utils
127%__mkdir_p %{buildroot}%{_datadir}/icons
128%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor
129%__mkdir_p %{buildroot}%{_datadir}/packages
130%__mkdir_p %{buildroot}%{_datadir}/mime
131%__mkdir_p %{buildroot}%{_datadir}/mime/packages
132%__mkdir_p %{buildroot}%{_datadir}/applications
133%__mkdir_p %{buildroot}%{_datadir}/desktop-directories
134
135# create directory for calibre environment module
136# the install script assumes it's there.
137%__mkdir_p %{buildroot}%{python_sitelib}
138
139XDG_DATA_DIRS="%{buildroot}%{_datadir}" \
140XDG_UTILS_INSTALL_MODE="system" \
141LIBPATH="%{_libdir}" \
142python setup.py install --root=%{buildroot}%{_prefix} \
143                        --prefix=%{_prefix} \
144                        --libdir=%{_libdir} \
145                        --staging-libdir=%{buildroot}%{_libdir}
146
147# remove shebang from init_calibre.py here because
148# it just got spawned by the install script
149%{__sed} -i -e '/^#!\//, 1d' %{buildroot}%{python_sitelib}/init_calibre.py
150
151# icons
152%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
153%__cp -p resources/images/library.png \
154        %{buildroot}%{_datadir}/pixmaps/%{name}-gui.png
155%__cp -p resources/images/viewer.png \
156        %{buildroot}%{_datadir}/pixmaps/calibre-viewer.png
157
158# every file is empty here
159find %{buildroot}%{_datadir}/mime -maxdepth 1 -type f|xargs %__rm -f
160
161# packages aren't allowed to register mimetypes like this
162%__rm -f %{buildroot}%{_datadir}/applications/{defaults.list,mimeinfo.cache}
163
164desktop-file-validate \
165    %{buildroot}%{_datadir}/applications/calibre-ebook-viewer.desktop
166desktop-file-validate \
167    %{buildroot}%{_datadir}/applications/calibre-gui.desktop
168desktop-file-validate \
169    %{buildroot}%{_datadir}/applications/calibre-lrfviewer.desktop
170
171
172%__mv %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes \
173    %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes.xml
174
175# mimetype icon for lrf
176%__rm -rf %{buildroot}%{_datadir}/icons/hicolor/128x128
177%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable
178%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes
179%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/apps
180%__cp -p resources/images/mimetypes/lrf.png \
181    %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes/application-x-sony-bbeb.png
182%__cp -p resources/images/viewer.png \
183    %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/calibre-viewer.png
184
185# don't put bash completions in /usr/etc
186%__mv %{buildroot}%{_prefix}%{_sysconfdir} %{buildroot}
187
188# these are provided as separate packages
189%__rm -rf %{buildroot}%{_libdir}/%{name}/{odf,cherrypy,pyPdf,encutils,cssutils}
190%__rm -rf %{buildroot}%{_libdir}/%{name}/cal/utils/genshi
191%__rm -rf %{buildroot}%{_libdir}/%{name}/cal/trac
192
193# link to system fonts after we have deleted (see Source0) the non-free ones
194# http://bugs.calibre-ebook.com/ticket/3832
195%__mkdir_p %{buildroot}%{_datadir}/%{name}/fonts/prs500/
196%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSans-Regular.ttf \
197        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0003m_.ttf
198%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSerif-Regular.ttf \
199        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0011m_.ttf
200%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationMono-Regular.ttf \
201        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0419m_.ttf
202
203# http://bugs.calibre-ebook.com/ticket/3770#comment:7
204# man pages
205%__mv %{buildroot}%{_datadir}/%{name}/man %{buildroot}%{_mandir}
206
207# delete locales, calibre stores them in a zip file now
208rm -rf %{buildroot}%{_datadir}/%{name}/localization/locales/
209
210%{__rm} -f %{buildroot}%{_bindir}/%{name}-uninstall
211
212%__install -m 755 %{SOURCE2} %{buildroot}%{_bindir}/calibre-mount-helper
213
214%clean
215%{__rm} -rf %{buildroot}
216
217%post
218update-desktop-database &> /dev/null ||:
219update-mime-database %{_datadir}/mime &> /dev/null || :
220touch --no-create %{_datadir}/icons/hicolor || :
221if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
222    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
223fi
224
225%postun
226update-desktop-database &> /dev/null ||:
227update-mime-database %{_datadir}/mime &> /dev/null || :
228touch --no-create %{_datadir}/icons/hicolor || :
229if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
230    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
231fi
232
233%files
234%defattr(-,root,root,-)
235%doc COPYRIGHT LICENSE Changelog.yaml
236%{_bindir}/calibre
237%{_bindir}/calibre-complete
238%{_bindir}/calibre-customize
239%{_bindir}/calibre-debug
240%{_bindir}/calibre-parallel
241%{_bindir}/calibre-server
242%{_bindir}/calibre-smtp
243%{_bindir}/calibre-mount-helper
244%{_bindir}/calibredb
245%{_bindir}/ebook-convert
246%{_bindir}/ebook-device
247%{_bindir}/ebook-meta
248%{_bindir}/ebook-viewer
249%{_bindir}/epub-fix
250%{_bindir}/fetch-ebook-metadata
251%{_bindir}/lrf2lrs
252%{_bindir}/lrfviewer
253%{_bindir}/lrs2lrf
254%{_bindir}/markdown-calibre
255%{_bindir}/pdfmanipulate
256%{_bindir}/web2disk
257%config(noreplace) %{_sysconfdir}/bash_completion.d/
258%{_libdir}/%{name}
259%{_datadir}/%{name}
260%{_datadir}/pixmaps/*
261%{_datadir}/applications/*.desktop
262%{_datadir}/mime/packages/*
263%{_datadir}/icons/hicolor/scalable/mimetypes/*
264%{_datadir}/icons/hicolor/scalable/apps/*
265%{python_sitelib}/init_calibre.py*
266%{_mandir}/man1/*
267
268%changelog
269* Sun Aug 25 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.50-2
270- rebuild with ImageMagick-6.8.6.8
271- add Patch3 (calibre-0.8.50-poppler-0.20.x.patch)
272
273* Tue May  8 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.50-1
274- new upstream release
275- BuildRequires: qt4-devel >= 4.8.0
276- BuildRequires: PyQt4-devel >= 4.9.1
277
278* Fri Mar 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.44-1
279- new upstream release
280
281* Sun Mar 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.41-1
282- new upstream release
283
284* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.50-2
285- rebuild with ImageMagick-6.7.5.10
286
287* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.50-1
288- new upstream release
289
290* Sat Feb 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.46-1
291- new upstream release
292
293* Thu Feb 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.44-1
294- new upstream release
295
296* Fri Feb 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.42-1
297- new upstream release
298
299* Fri Jan 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.40-1
300- new upstream release
301
302* Mon Dec 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.35-1
303- new upstream release
304
305* Sun Dec 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.34-1
306- new upstream release
307
308* Mon Dec 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.33-1
309- new upstream release
310- added BuildRequires: libicu-devel
311
312* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.32-1
313- new upstream release
314
315* Fri Nov 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.26-1
316- new upstream release
317
318* Sun Oct 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.25-1
319- new upstream release
320
321  * Tue Oct 19 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.24-1
322  - Update to 0.7.24
323
324  * Sat Oct 09 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.23-1
325  - Update to 0.7.23
326  - Fix up mount helper with our own local script.
327  - Change files to list binaries so missing ones can more easily be noted.
328
329  * Mon Oct 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.22-1
330  - Update to 0.7.22
331
332  * Fri Oct 01 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.21-1
333  - Update to 0.7.21
334
335  * Wed Sep 29 2010 jkeating - 0.7.20-2
336  - Rebuilt for gcc bug 634757
337
338  * Fri Sep 24 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.20-1
339  - Update to 0.7.20
340
341  * Wed Sep 15 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-3
342  - Rebuild for new ImageMagick
343
344* Wed Sep 29 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.18-1
345- new upstream release
346- Fix svg/png changes.
347
348  * Mon Sep 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-2
349  - Fix svg/png changes.
350
351  * Sun Sep 12 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-1
352  - Update to 0.7.18
353  - Require > 0.9.6 cssutils
354
355  * Fri Sep 03 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.17-1
356  - Update to 0.7.17
357
358  * Fri Aug 27 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.16-1
359  - Update to 0.7.16
360
361* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.15-1
362- initial build based on Fedora development
363
364* Sat Aug 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.15-1
365- Update to 0.7.15
366
367* Thu Aug 19 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.14-2
368- rebuild (poppler)
369
370* Fri Aug 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.14-1
371- Update to 0.7.14
372
373* Fri Aug 06 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.13-1
374- Update to 0.7.13
375
376* Mon Aug 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.12-1
377- Update to 0.7.12
378
379* Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.11-1
380- Update to 0.7.11
381
382* Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-2
383- Rebuilt for python2.7
384
385* Fri Jul 23 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-1
386- Update to 0.7.10
387
388* Sat Jul 17 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.9-1
389- Update to 0.7.9
390
391* Sun Jul 11 2010 Michal Nowak <mnowak@redhat.com> - 0.7.8-1
392- Update to 0.7.8
393- build tar.xz instead of tar.bz2
394
395* Fri Jul 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.7-1
396- Update to 0.7.7
397
398* Wed Jun 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.6-1
399- Update to 0.7.6
400
401* Fri Jun 25 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.5-1
402- Update to 0.7.5
403
404* Sun Jun 20 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.4-1
405- Update to 0.7.4
406
407* Tue Jun 08 2010 Dan Horák <dan@danny.cz> - 0.7.1-2
408- rebuilt with podofo 0.8.1
409
410* Mon Jun 07 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.1-1
411- Update to 0.7.1
412- Added versioned dep on python-cssutils to make sure at least 0.9.6 is installed.
413
414* Fri Jun 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.0-1
415- Update to 0.7.0
416
417* Fri May 28 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.55-1
418- Update to 0.6.55
419
420* Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.54-1
421- Update to 0.6.54
422
423* Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.53-1
424- Update to 0.6.53
425
426* Wed May  5 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.6.47-2
427- Rebuild against new poppler
428
429* Sat Apr 10 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.47-1
430- new upstream release 0.6.47
431- new chmlib requirement
432- create directory for calibre's environment module
433- use bzip2 instead of gzip when preparing tarball in generate-tarball.sh
434- remove cssutils patches (we now have python-cssutils 0.9.6 in Fedora)
435
436* Fri Feb 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.42-1
437- new upstream release 0.6.42
438- remove shebang from default_tweaks.py
439
440* Mon Feb  1 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.37-1
441- new upstream release 0.6.37
442
443* Fri Jan 29 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.36-1
444- new upstream release 0.6.36
445- fixed a cssprofiles issue with loading the profiles
446
447* Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-3
448- added -cssprofiles patch to cvs
449
450* Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-2
451- remove python-cssutils 0.9.6 dependency
452
453* Mon Jan 25 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-1
454- new upstream release
455- fedora includes cssutils >= 0.9.6 now; removed the cssprofiles patch
456- removed -executables patch, upstream fixed it: http://bugs.calibre-ebook.com/ticket/4437
457
458* Wed Jan  6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-2
459- fix for package tagged without adding new patch to cvs
460
461* Wed Jan  6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-1
462- new upstream release 0.6.32
463- project website has changed
464- added python-BeautifulSoup BuildRequire
465- new patch to fix full buildpath in binary files
466
467* Sun Dec  6 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.26-1
468- New upstream version
469- Regenerated no-update patch because of code relocation
470
471* Wed Dec  2 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.25-1
472- New upstream release
473
474* Wed Nov 18 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.24-1
475- New upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2416Nov2009
476
477* Mon Nov 16 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.23-1
478- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2313Nov2009
479- patch to stop checking for new upstream version
480
481* Sat Nov  7 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.21-1
482- new upstream version: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2106Nov2009
483- added python-BeautifulSoup requirement
484
485* Wed Nov  4 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.20-1
486- new upstream version:
487http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2030Oct2009
488- upstream now ships correct .desktop files
489- fixed missing dependency: PyQt4
490- fixed calibre-gui icon
491
492* Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-3
493- removed unfree fonts from source package
494
495* Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-2
496- readability enhancements
497- added python-genshi requires
498- removed libwmf require since ImageMagick provides libwmf-lite as a
499  dependency and that's what we actually need
500
501* Wed Oct 21 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-1
502- new upstream version:
503  http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1920Oct2009
504- delete fonts, calibre can find the system fonts
505- specify libdir as an install option, so calibre will link properly
506  even on 64bit
507
508* Mon Oct 19 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.18-1
509- updated requires list
510- new upstream release
511- can override CFLAGS now
512- removed trac and genshi duplicates
513- use xdg env variables to do desktop integration in the buildroot
514- added xdg-utils buildrequire
515- install udev rules in /usr/lib even on 64bit and don't own the whole dir
516- removed wrongly used Version field from .desktop files
517
518* Mon Oct 12 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-2
519- mimick what calibre's desktop-integration script does (mimetypes, icons etc.)
520- removed unneeded INSTALL file
521- marked bash completion file as config(noreplace) and take ownership of the dir
522
523* Sat Oct 10 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-1
524- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1709Oct2009
525- the install process changed significantly
526- locales were added
527
528* Thu Sep 10 2009 Ionuț Arțăriși <mapleoin@lavabit.com> - 0.6.11-1
529- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1104Sep2009
530- minor path fixes
531- rearranged files section
532
533* Fri Aug 28 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.10-1
534- handle desktop files
535- don't compress manpages and don't list them as duplicates
536- added lrfviewer icon
537
538* Tue Aug 25 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.8-1
539- Initial RPM release
Note: See TracBrowser for help on using the repository browser.