source: projects/specs/trunk/c/calibre/calibre-vl.spec @ 6167

Revision 6167, 18.2 KB checked in by munepi, 12 years ago (diff)

updated calibre

RevLine 
[1741]1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           calibre
[6167]4Version:        0.8.50
[5899]5Release:        1%{?_dist_release}
[1987]6Summary:        E-book converter and library management
[1741]7Group:          Applications/Multimedia
8License:        GPLv3
9URL:            http://calibre-ebook.com/
10
11# SourceURL: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
12
13# Upstream packages some unfree fonts which we cannot redistribute.
14# While we're at it, also delete the liberation fonts which we already have.
15#
16# Download the upstream tarball and invoke this script while in the tarball's
17# directory:
18# ./generate-tarball.sh %{version}
19Source0:        %{name}-%{version}-nofonts.tar.xz
20Source1:        generate-tarball.sh
[2164]21Source2:        calibre-mount-helper
[1741]22Patch0:         %{name}-manpages.patch
23Patch1:         %{name}-no-update.patch
[5899]24Patch2:         calibre-0.8.21-poppler.patch
25Patch10:        calibre-0.8.41-python27.patch
[1741]26BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
27
[5899]28BuildRequires:  python >= 2.7.1
29BuildRequires:  python-devel >= 2.7.1
[1741]30BuildRequires:  ImageMagick-devel >= 6.5.9
31BuildRequires:  python-setuptools
[5899]32BuildRequires:  qt4-devel >= 4.7.0
33BuildRequires:  PyQt4-devel >= 4.8.2
[1741]34BuildRequires:  poppler-qt4-devel >= 0.12
[5899]35BuildRequires:  podofo-devel >= 0.8.2
[1741]36BuildRequires:  desktop-file-utils
37BuildRequires:  python-mechanize >= 0.1.1
38BuildRequires:  python-lxml >= 2.2.1
39BuildRequires:  python-cssutils >= 0.9.6
40BuildRequires:  python-dateutil >= 1.4.1
41BuildRequires:  python-imaging >= 1.1.6
42BuildRequires:  xdg-utils >= 1.0.2
43BuildRequires:  python-BeautifulSoup >= 3.0.5
44BuildRequires:  xz
45BuildRequires:  unzip
46BuildRequires:  libwmf-devel >= 0.2.8
47BuildRequires:  chmlib-devel >= 0.40
[2345]48BuildRequires:  python-cssutils > 0.9.6
49BuildRequires:  sqlite3-devel
[5899]50BuildRequires:  libicu-devel >= 4.4
[2345]51
[1741]52Requires:       PyQt4
53Requires:       pyPdf
54Requires:       python-cherrypy
55Requires:       python-cssutils
56Requires:       ImageMagick
57Requires:       python-odf
58Requires:       python-django-tagging
59Requires:       python-lxml
60Requires:       python-imaging
61Requires:       python-mechanize
62Requires:       python-dateutil
63Requires:       python-genshi
64Requires:       python-BeautifulSoup
65
66## vine
67Requires:       TrueType-liberation
68
69%description
70Calibre is meant to be a complete e-library solution. It includes library
71management, format conversion, news feeds to ebook conversion as well as
72e-book reader sync features.
73
74Calibre is primarily a ebook cataloging program. It manages your ebook
75collection for you. It is designed around the concept of the logical book,
76i.e. a single entry in the database that may correspond to ebooks in several
77formats. It also supports conversion to and from a dozen different ebook
78formats.
79
80Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML, CBR, CBZ,
81RTF, TXT, PDF and LRS.
82
83%prep
84%setup -q -n %{name}
85
86# don't append calibre1 to the name of the manpages. No need to compress either
87# upstream won't fix: http://bugs.calibre-ebook.com/ticket/3770#comment:7
88%patch0 -p1 -b .manpages
89
90# don't check for new upstream version (that's what packagers do)
91%patch1 -p1 -b .no-update
92
[5899]93# modify poppler checks
94%patch2 -p1 -b .poppler
95
96# use python2.7
97%patch10 -p1 -b .vine
98
[1741]99# dos2unix newline conversion
100%{__sed} -i 's/\r//' src/calibre/web/feeds/recipes/*
101
102# remove shebangs
103%{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*/*.py
104%{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*.py
105%{__sed} -i -e '/^#![ ]*\//, 1d' src/calibre/*/*.py
106%{__sed} -i -e '/^#!\//, 1d' src/calibre/*.py
[2540]107%{__sed} -i -e '/^#!\//, 1d' src/templite/*.py
[1741]108%{__sed} -i -e '/^#!\//, 1d' resources/default_tweaks.py
[5899]109%{__sed} -i -e '/^#!\//, 1d' resources/catalog/section_list_templates.py
[1741]110
111%{__chmod} -x src/calibre/*/*/*/*.py
112%{__chmod} -x src/calibre/*/*/*.py
113%{__chmod} -x src/calibre/*/*.py
114%{__chmod} -x src/calibre/*.py
115
116%build
117OVERRIDE_CFLAGS="%{optflags}" QMAKE=%{_libdir}/qt4/bin/qmake python setup.py build
118
119%install
120%__rm -rf %{buildroot}
121
122%__mkdir -p %{buildroot}%{_datadir}
123
124# create directories for xdg-utils
125%__mkdir_p %{buildroot}%{_datadir}/icons
126%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor
127%__mkdir_p %{buildroot}%{_datadir}/packages
128%__mkdir_p %{buildroot}%{_datadir}/mime
129%__mkdir_p %{buildroot}%{_datadir}/mime/packages
130%__mkdir_p %{buildroot}%{_datadir}/applications
131%__mkdir_p %{buildroot}%{_datadir}/desktop-directories
132
133# create directory for calibre environment module
134# the install script assumes it's there.
135%__mkdir_p %{buildroot}%{python_sitelib}
136
137XDG_DATA_DIRS="%{buildroot}%{_datadir}" \
138XDG_UTILS_INSTALL_MODE="system" \
139LIBPATH="%{_libdir}" \
140python setup.py install --root=%{buildroot}%{_prefix} \
141                        --prefix=%{_prefix} \
142                        --libdir=%{_libdir} \
143                        --staging-libdir=%{buildroot}%{_libdir}
144
145# remove shebang from init_calibre.py here because
146# it just got spawned by the install script
147%{__sed} -i -e '/^#!\//, 1d' %{buildroot}%{python_sitelib}/init_calibre.py
148
149# icons
150%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
151%__cp -p resources/images/library.png \
152        %{buildroot}%{_datadir}/pixmaps/%{name}-gui.png
[1970]153%__cp -p resources/images/viewer.png \
154        %{buildroot}%{_datadir}/pixmaps/calibre-viewer.png
[1741]155
156# every file is empty here
157find %{buildroot}%{_datadir}/mime -maxdepth 1 -type f|xargs %__rm -f
158
159# packages aren't allowed to register mimetypes like this
160%__rm -f %{buildroot}%{_datadir}/applications/{defaults.list,mimeinfo.cache}
161
162desktop-file-validate \
163    %{buildroot}%{_datadir}/applications/calibre-ebook-viewer.desktop
164desktop-file-validate \
165    %{buildroot}%{_datadir}/applications/calibre-gui.desktop
166desktop-file-validate \
167    %{buildroot}%{_datadir}/applications/calibre-lrfviewer.desktop
168
169
170%__mv %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes \
171    %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes.xml
172
173# mimetype icon for lrf
174%__rm -rf %{buildroot}%{_datadir}/icons/hicolor/128x128
175%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable
176%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes
177%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/apps
[1970]178%__cp -p resources/images/mimetypes/lrf.png \
179    %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes/application-x-sony-bbeb.png
180%__cp -p resources/images/viewer.png \
181    %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/calibre-viewer.png
[1741]182
183# don't put bash completions in /usr/etc
184%__mv %{buildroot}%{_prefix}%{_sysconfdir} %{buildroot}
185
186# these are provided as separate packages
187%__rm -rf %{buildroot}%{_libdir}/%{name}/{odf,cherrypy,pyPdf,encutils,cssutils}
188%__rm -rf %{buildroot}%{_libdir}/%{name}/cal/utils/genshi
189%__rm -rf %{buildroot}%{_libdir}/%{name}/cal/trac
190
191# link to system fonts after we have deleted (see Source0) the non-free ones
192# http://bugs.calibre-ebook.com/ticket/3832
193%__mkdir_p %{buildroot}%{_datadir}/%{name}/fonts/prs500/
194%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSans-Regular.ttf \
195        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0003m_.ttf
196%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSerif-Regular.ttf \
197        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0011m_.ttf
198%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationMono-Regular.ttf \
199        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0419m_.ttf
200
201# http://bugs.calibre-ebook.com/ticket/3770#comment:7
202# man pages
203%__mv %{buildroot}%{_datadir}/%{name}/man %{buildroot}%{_mandir}
204
[5899]205# delete locales, calibre stores them in a zip file now
206rm -rf %{buildroot}%{_datadir}/%{name}/localization/locales/
[1741]207
[2164]208%{__rm} -f %{buildroot}%{_bindir}/%{name}-uninstall
[1741]209
[5899]210%__install -m 755 %{SOURCE2} %{buildroot}%{_bindir}/calibre-mount-helper
[2164]211
[1741]212%clean
213%{__rm} -rf %{buildroot}
214
215%post
[2164]216update-desktop-database &> /dev/null ||:
217update-mime-database %{_datadir}/mime &> /dev/null || :
[1741]218touch --no-create %{_datadir}/icons/hicolor || :
[2164]219if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
220    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
221fi
[1987]222
223%postun
[2164]224update-desktop-database &> /dev/null ||:
225update-mime-database %{_datadir}/mime &> /dev/null || :
226touch --no-create %{_datadir}/icons/hicolor || :
[1741]227if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
228    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
229fi
230
[5899]231%files
[1741]232%defattr(-,root,root,-)
233%doc COPYRIGHT LICENSE Changelog.yaml
[2164]234%{_bindir}/calibre
235%{_bindir}/calibre-complete
236%{_bindir}/calibre-customize
237%{_bindir}/calibre-debug
238%{_bindir}/calibre-parallel
239%{_bindir}/calibre-server
240%{_bindir}/calibre-smtp
241%{_bindir}/calibre-mount-helper
242%{_bindir}/calibredb
243%{_bindir}/ebook-convert
244%{_bindir}/ebook-device
245%{_bindir}/ebook-meta
246%{_bindir}/ebook-viewer
247%{_bindir}/epub-fix
248%{_bindir}/fetch-ebook-metadata
249%{_bindir}/lrf2lrs
250%{_bindir}/lrfviewer
251%{_bindir}/lrs2lrf
252%{_bindir}/markdown-calibre
253%{_bindir}/pdfmanipulate
254%{_bindir}/web2disk
[1741]255%config(noreplace) %{_sysconfdir}/bash_completion.d/
256%{_libdir}/%{name}
257%{_datadir}/%{name}
258%{_datadir}/pixmaps/*
[2540]259%{_datadir}/applications/*.desktop
[1741]260%{_datadir}/mime/packages/*
261%{_datadir}/icons/hicolor/scalable/mimetypes/*
262%{_datadir}/icons/hicolor/scalable/apps/*
263%{python_sitelib}/init_calibre.py*
264%{_mandir}/man1/*
265
266%changelog
[6167]267* Tue May  8 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.50-1
268- new upstream release
269- BuildRequires: qt4-devel >= 4.8.0
270- BuildRequires: PyQt4-devel >= 4.9.1
271
[5982]272* Fri Mar 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.44-1
273- new upstream release
274
[5899]275* Sun Mar 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.41-1
276- new upstream release
277
[5879]278* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.50-2
279- rebuild with ImageMagick-6.7.5.10
280
[3017]281* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.50-1
282- new upstream release
[2998]283
[2722]284* Sat Feb 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.46-1
285- new upstream release
286
[2667]287* Thu Feb 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.44-1
288- new upstream release
289
[2634]290* Fri Feb 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.42-1
291- new upstream release
292
[2540]293* Fri Jan 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.40-1
294- new upstream release
295
[2402]296* Mon Dec 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.35-1
297- new upstream release
298
[2369]299* Sun Dec 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.34-1
300- new upstream release
301
[2345]302* Mon Dec 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.33-1
303- new upstream release
304- added BuildRequires: libicu-devel
305
306* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.32-1
307- new upstream release
308
[2175]309* Fri Nov 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.26-1
310- new upstream release
311
[2164]312* Sun Oct 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.25-1
313- new upstream release
[2051]314
[2164]315  * Tue Oct 19 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.24-1
316  - Update to 0.7.24
[1987]317
[2164]318  * Sat Oct 09 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.23-1
319  - Update to 0.7.23
320  - Fix up mount helper with our own local script.
321  - Change files to list binaries so missing ones can more easily be noted.
322
323  * Mon Oct 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.22-1
324  - Update to 0.7.22
325
326  * Fri Oct 01 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.21-1
327  - Update to 0.7.21
328
329  * Wed Sep 29 2010 jkeating - 0.7.20-2
330  - Rebuilt for gcc bug 634757
331
332  * Fri Sep 24 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.20-1
333  - Update to 0.7.20
334
335  * Wed Sep 15 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-3
336  - Rebuild for new ImageMagick
337
[1970]338* Wed Sep 29 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.18-1
339- new upstream release
340- Fix svg/png changes.
341
[2164]342  * Mon Sep 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-2
343  - Fix svg/png changes.
344
345  * Sun Sep 12 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-1
346  - Update to 0.7.18
347  - Require > 0.9.6 cssutils
348
349  * Fri Sep 03 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.17-1
350  - Update to 0.7.17
351
352  * Fri Aug 27 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.16-1
353  - Update to 0.7.16
354
[1970]355* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.15-1
[1741]356- initial build based on Fedora development
357
[1970]358* Sat Aug 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.15-1
359- Update to 0.7.15
[1741]360
[1970]361* Thu Aug 19 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.14-2
362- rebuild (poppler)
[1741]363
[1970]364* Fri Aug 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.14-1
365- Update to 0.7.14
[1741]366
[1970]367* Fri Aug 06 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.13-1
368- Update to 0.7.13
[1741]369
[1970]370* Mon Aug 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.12-1
371- Update to 0.7.12
[1741]372
[1970]373* Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.11-1
374- Update to 0.7.11
[1741]375
[1970]376* Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-2
377- Rebuilt for python2.7
[1741]378
[1970]379* Fri Jul 23 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-1
380- Update to 0.7.10
[1741]381
[1970]382* Sat Jul 17 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.9-1
383- Update to 0.7.9
[1741]384
[1970]385* Sun Jul 11 2010 Michal Nowak <mnowak@redhat.com> - 0.7.8-1
386- Update to 0.7.8
387- build tar.xz instead of tar.bz2
[1741]388
[1970]389* Fri Jul 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.7-1
390- Update to 0.7.7
[1741]391
[1970]392* Wed Jun 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.6-1
393- Update to 0.7.6
394
395* Fri Jun 25 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.5-1
396- Update to 0.7.5
397
398* Sun Jun 20 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.4-1
399- Update to 0.7.4
400
401* Tue Jun 08 2010 Dan Horák <dan@danny.cz> - 0.7.1-2
402- rebuilt with podofo 0.8.1
403
404* Mon Jun 07 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.1-1
405- Update to 0.7.1
406- Added versioned dep on python-cssutils to make sure at least 0.9.6 is installed.
407
408* Fri Jun 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.0-1
409- Update to 0.7.0
410
411* Fri May 28 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.55-1
412- Update to 0.6.55
413
414* Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.54-1
415- Update to 0.6.54
416
417* Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.53-1
418- Update to 0.6.53
419
420* Wed May  5 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.6.47-2
421- Rebuild against new poppler
422
423* Sat Apr 10 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.47-1
424- new upstream release 0.6.47
425- new chmlib requirement
426- create directory for calibre's environment module
427- use bzip2 instead of gzip when preparing tarball in generate-tarball.sh
428- remove cssutils patches (we now have python-cssutils 0.9.6 in Fedora)
429
430* Fri Feb 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.42-1
431- new upstream release 0.6.42
432- remove shebang from default_tweaks.py
433
434* Mon Feb  1 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.37-1
435- new upstream release 0.6.37
436
437* Fri Jan 29 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.36-1
438- new upstream release 0.6.36
439- fixed a cssprofiles issue with loading the profiles
440
441* Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-3
442- added -cssprofiles patch to cvs
443
444* Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-2
445- remove python-cssutils 0.9.6 dependency
446
447* Mon Jan 25 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-1
448- new upstream release
449- fedora includes cssutils >= 0.9.6 now; removed the cssprofiles patch
450- removed -executables patch, upstream fixed it: http://bugs.calibre-ebook.com/ticket/4437
451
452* Wed Jan  6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-2
453- fix for package tagged without adding new patch to cvs
454
455* Wed Jan  6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-1
456- new upstream release 0.6.32
457- project website has changed
458- added python-BeautifulSoup BuildRequire
459- new patch to fix full buildpath in binary files
460
461* Sun Dec  6 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.26-1
462- New upstream version
463- Regenerated no-update patch because of code relocation
464
465* Wed Dec  2 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.25-1
466- New upstream release
467
468* Wed Nov 18 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.24-1
469- New upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2416Nov2009
470
471* Mon Nov 16 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.23-1
472- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2313Nov2009
473- patch to stop checking for new upstream version
474
475* Sat Nov  7 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.21-1
476- new upstream version: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2106Nov2009
477- added python-BeautifulSoup requirement
478
479* Wed Nov  4 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.20-1
480- new upstream version:
481http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2030Oct2009
482- upstream now ships correct .desktop files
483- fixed missing dependency: PyQt4
484- fixed calibre-gui icon
485
486* Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-3
487- removed unfree fonts from source package
488
489* Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-2
490- readability enhancements
491- added python-genshi requires
492- removed libwmf require since ImageMagick provides libwmf-lite as a
493  dependency and that's what we actually need
494
495* Wed Oct 21 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-1
496- new upstream version:
497  http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1920Oct2009
498- delete fonts, calibre can find the system fonts
499- specify libdir as an install option, so calibre will link properly
500  even on 64bit
501
502* Mon Oct 19 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.18-1
503- updated requires list
504- new upstream release
505- can override CFLAGS now
506- removed trac and genshi duplicates
507- use xdg env variables to do desktop integration in the buildroot
508- added xdg-utils buildrequire
509- install udev rules in /usr/lib even on 64bit and don't own the whole dir
510- removed wrongly used Version field from .desktop files
511
512* Mon Oct 12 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-2
513- mimick what calibre's desktop-integration script does (mimetypes, icons etc.)
514- removed unneeded INSTALL file
515- marked bash completion file as config(noreplace) and take ownership of the dir
516
517* Sat Oct 10 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-1
518- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1709Oct2009
519- the install process changed significantly
520- locales were added
521
522* Thu Sep 10 2009 Ionuț Arțăriși <mapleoin@lavabit.com> - 0.6.11-1
523- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1104Sep2009
524- minor path fixes
525- rearranged files section
526
527* Fri Aug 28 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.10-1
528- handle desktop files
529- don't compress manpages and don't list them as duplicates
530- added lrfviewer icon
531
532* Tue Aug 25 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.8-1
533- Initial RPM release
Note: See TracBrowser for help on using the repository browser.