source: projects/specs/trunk/c/calibre/calibre-vl.spec @ 11453

Revision 11453, 20.0 KB checked in by ara_t, 6 years ago (diff)

calibre: rebuild under current VineSeed

RevLine 
[1741]1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           calibre
[10606]4Version:        2.62.0
[11453]5Release:        2%{?_dist_release}
[1987]6Summary:        E-book converter and library management
[1741]7Group:          Applications/Multimedia
8License:        GPLv3
9URL:            http://calibre-ebook.com/
10
[10606]11Vendor:         Project Vine
12Distribution:   Vine Linux
13
[1741]14# SourceURL: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
15
16# Upstream packages some unfree fonts which we cannot redistribute.
17# While we're at it, also delete the liberation fonts which we already have.
18#
19# Download the upstream tarball and invoke this script while in the tarball's
20# directory:
21# ./generate-tarball.sh %{version}
22Source0:        %{name}-%{version}-nofonts.tar.xz
23Source1:        generate-tarball.sh
[10606]24Source2:        calibre-mount-helper
25Source3:        calibre-gui.appdata.xml
26#
27# Disable auto update from inside the app
28#
[1741]29Patch1:         %{name}-no-update.patch
[10606]30#
31# Do not display multiple apps in desktop files, only the main app
32# This is so gnome-software only 'sees' calibre once.
33#
34Patch3:         calibre-nodisplay.patch
[1741]35
[5899]36BuildRequires:  python >= 2.7.1
37BuildRequires:  python-devel >= 2.7.1
[10606]38BuildRequires:  python-setuptools >= 2.7.1
[1741]39BuildRequires:  python-setuptools
[10606]40BuildRequires:  python-qt5-devel
41BuildRequires:  python-qt5
42BuildRequires:  python-qt5-webkit
[5899]43BuildRequires:  podofo-devel >= 0.8.2
[1741]44BuildRequires:  desktop-file-utils
[10606]45BuildRequires:  python-mechanize
46BuildRequires:  python-lxml
47BuildRequires:  python-dateutil
48BuildRequires:  python-imaging
[1741]49BuildRequires:  xdg-utils >= 1.0.2
50BuildRequires:  python-BeautifulSoup >= 3.0.5
51BuildRequires:  chmlib-devel >= 0.40
[10606]52BuildRequires:  python-cssutils >= 0.9.6
53BuildRequires:  sqlite3-devel
[5899]54BuildRequires:  libicu-devel >= 4.4
[10606]55BuildRequires:  libpng-devel
56BuildRequires:  libmtp-devel
57BuildRequires:  qt5-qtbase-devel
58#BuildRequires: web-assets-devel
59BuildRequires:  qt5-qtbase-static
60BuildRequires:  libXrender-devel
61BuildRequires:  qt5-qtwebkit-devel
62BuildRequires:  openssl-devel
63# calibre installer is so smart that it check for the presence of the
64# directory (and then installs in the wrong place)
65BuildRequires:  bash-completion
66BuildRequires:  python-apsw
67BuildRequires:  glib2-devel
68BuildRequires:  fontconfig-devel
69BuildRequires:  libinput-devel
70BuildRequires:  libxkbcommon-devel
[2345]71
[10606]72%{?pyqt5_requires}
73# once ^^ %%pyqt5_requires is everywhere, can drop python-qt5 dep below -- rex
74
75# Add hard dep to specific qtbase pkg, see build message below -- rex
76# Project MESSAGE: This project is using private headers and will therefore be tied to this specific Qt module build version.
77# Project MESSAGE: Running this project against other versions of the Qt modules may crash at any arbitrary point.
78# Project MESSAGE: This is not a bug, but a result of using Qt internals. You have been warned!
79BuildRequires:  qt5-qtbase-private-devel
80%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
81
82
83Requires:       python-qt5
84Requires:       python-qt5-webkit
85Requires:       qt5-qtwebkit
86Requires:       qt5-qtsvg
87Requires:       qt5-qtsensors
[1741]88Requires:       python-cherrypy
[11453]89Requires:       python-cssutils
[10606]90Requires:       odfpy
[1741]91Requires:       python-lxml
92Requires:       python-imaging
93Requires:       python-mechanize
94Requires:       python-dateutil
95Requires:       python-genshi
96Requires:       python-BeautifulSoup
[10606]97Requires:       poppler-utils
98#Requires:      python-feedparser
99Requires:       python-netifaces
100Requires:       python-dns
101Requires:       python-apsw
102Requires:       python-psutil
103Requires:       python-pygments > 2.0.1
104Requires:       optipng
105#Requires:      python-cssselect
106#Requires:      mathjax
[1741]107
108## vine
109Requires:       TrueType-liberation
110
111%description
112Calibre is meant to be a complete e-library solution. It includes library
113management, format conversion, news feeds to ebook conversion as well as
114e-book reader sync features.
115
116Calibre is primarily a ebook cataloging program. It manages your ebook
117collection for you. It is designed around the concept of the logical book,
118i.e. a single entry in the database that may correspond to ebooks in several
119formats. It also supports conversion to and from a dozen different ebook
120formats.
121
122Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML, CBR, CBZ,
123RTF, TXT, PDF and LRS.
124
125%prep
[10606]126%setup -q
[1741]127
128# don't check for new upstream version (that's what packagers do)
129%patch1 -p1 -b .no-update
[10606]130# Hide individual launchers for ebook-edit, ebook-viewer and lrfviewer as they
131# are all accessible in the main calibre GUI.
132%patch3 -p1 -b .nodisplay
[1741]133
134# dos2unix newline conversion
[10606]135sed -i 's/\r//' src/calibre/web/feeds/recipes/*
[1741]136
137# remove shebangs
[10606]138sed -i -e '/^#!\//, 1d' src/calibre/*/*/*/*.py
139sed -i -e '/^#!\//, 1d' src/calibre/*/*/*.py
140sed -i -e '/^#![ ]*\//, 1d' src/calibre/*/*.py
141sed -i -e '/^#!\//, 1d' src/calibre/*.py
142sed -i -e '/^#!\//, 1d' src/templite/*.py
143sed -i -e '/^#!\//, 1d' resources/default_tweaks.py
144sed -i -e '/^#!\//, 1d' resources/catalog/section_list_templates.py
[1741]145
[10606]146chmod -x src/calibre/*/*/*/*.py \
147    src/calibre/*/*/*.py \
148    src/calibre/*/*.py \
149    src/calibre/*.py
[1741]150
[10606]151rm -rvf resources/viewer/mathjax
152
[1741]153%build
[10606]154OVERRIDE_CFLAGS="%{optflags}" python setup.py build
[1741]155
156%install
157%__rm -rf %{buildroot}
158
159%__mkdir -p %{buildroot}%{_datadir}
160
161# create directories for xdg-utils
[10606]162mkdir -p %{buildroot}%{_datadir}/icons
163mkdir -p %{buildroot}%{_datadir}/icons/hicolor
164mkdir -p %{buildroot}%{_datadir}/packages
165mkdir -p %{buildroot}%{_datadir}/mime
166mkdir -p %{buildroot}%{_datadir}/mime/packages
167mkdir -p %{buildroot}%{_datadir}/applications
168mkdir -p %{buildroot}%{_datadir}/desktop-directories
[1741]169
[10606]170# create directory for gnome software data
171mkdir -p %{buildroot}%{_datadir}/appdata
172
[1741]173# create directory for calibre environment module
174# the install script assumes it's there.
[10606]175mkdir -p %{buildroot}%{python_sitelib}
[1741]176
[10606]177# create directory for completion files, so calibre knows where
178# to install them
179mkdir -p %{buildroot}%{_datadir}/bash-completion/completions
180mkdir -p %{buildroot}%{_datadir}/zsh/site-functions
181
[1741]182XDG_DATA_DIRS="%{buildroot}%{_datadir}" \
183XDG_UTILS_INSTALL_MODE="system" \
184LIBPATH="%{_libdir}" \
185python setup.py install --root=%{buildroot}%{_prefix} \
[10606]186                        --prefix=%{_prefix} \
187                        --libdir=%{_libdir} \
188                        --staging-libdir=%{buildroot}%{_libdir} \
189                        --staging-sharedir=%{buildroot}%{_datadir}
[1741]190
191# remove shebang from init_calibre.py here because
192# it just got spawned by the install script
[10606]193sed -i -e '/^#!\//, 1d' %{buildroot}%{python_sitelib}/init_calibre.py
[1741]194
195# icons
[10606]196mkdir -p %{buildroot}%{_datadir}/pixmaps/
197cp -p resources/images/library.png                \
198   %{buildroot}%{_datadir}/pixmaps/%{name}-gui.png
199cp -p resources/images/viewer.png                 \
200   %{buildroot}%{_datadir}/pixmaps/calibre-viewer.png
201cp -p resources/images/tweak.png                 \
202   %{buildroot}%{_datadir}/pixmaps/calibre-ebook-edit.png
[1741]203
204# every file is empty here
[10606]205find %{buildroot}%{_datadir}/mime -maxdepth 1 -type f -print -delete
[1741]206
207# packages aren't allowed to register mimetypes like this
[10606]208rm -f %{buildroot}%{_datadir}/applications/defaults.list
209rm -f %{buildroot}%{_datadir}/applications/mimeinfo.cache
210rm -f %{buildroot}%{_datadir}/mime/application/*.xml
211rm -f %{buildroot}%{_datadir}/mime/text/*.xml
[1741]212
213desktop-file-validate \
[10606]214%{buildroot}%{_datadir}/applications/calibre-ebook-viewer.desktop
[1741]215desktop-file-validate \
[10606]216%{buildroot}%{_datadir}/applications/calibre-gui.desktop
[1741]217desktop-file-validate \
[10606]218%{buildroot}%{_datadir}/applications/calibre-lrfviewer.desktop
[1741]219
220# mimetype icon for lrf
[10606]221rm -rf %{buildroot}%{_datadir}/icons/hicolor/128x128
222mkdir -p %{buildroot}%{_datadir}/icons/hicolor/scalable
223mkdir -p %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes
224mkdir -p %{buildroot}%{_datadir}/icons/hicolor/scalable/apps
225cp -p resources/images/mimetypes/lrf.png \
226      %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes/application-x-sony-bbeb.png
227cp -p resources/images/viewer.png \
228      %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/calibre-viewer.png
[1741]229
230# these are provided as separate packages
[10606]231rm -rf %{buildroot}%{_libdir}/%{name}/{odf,cherrypy,encutils,cssutils}
232rm -rf %{buildroot}%{_libdir}/%{name}/cal/utils/genshi
233rm -rf %{buildroot}%{_libdir}/%{name}/cal/trac
[1741]234
[10606]235# rm empty feedparser files.
236rm -rf %{buildroot}%{_libdir}/%{name}/%{name}/web/feeds/feedparser.*
[1741]237
[10606]238ln -s %{python_sitelib}/feedparser.py \
239      %{buildroot}%{_libdir}/%{name}/%{name}/web/feeds/feedparser.py
240ln -s %{python_sitelib}/feedparser.pyc \
241      %{buildroot}%{_libdir}/%{name}/%{name}/web/feeds/feedparser.pyc
242ln -s %{python_sitelib}/feedparser.pyo \
243      %{buildroot}%{_libdir}/%{name}/%{name}/web/feeds/feedparser.pyo
[1741]244
[10606]245for f in %{_datadir}/fonts/TrueType-liberation/*; do
246  ln -s $f %{buildroot}%{_datadir}/%{name}/fonts/liberation/
247done
248
[5899]249# delete locales, calibre stores them in a zip file now
250rm -rf %{buildroot}%{_datadir}/%{name}/localization/locales/
[1741]251
[10606]252rm -f %{buildroot}%{_bindir}/%{name}-uninstall
[1741]253
[10606]254cp -p %{SOURCE2} %{buildroot}%{_bindir}/calibre-mount-helper
[2164]255
[10606]256cp -p %{SOURCE3} %{buildroot}%{_datadir}/appdata/
257
[1741]258%clean
259%{__rm} -rf %{buildroot}
260
261%post
[2164]262update-desktop-database &> /dev/null ||:
263update-mime-database %{_datadir}/mime &> /dev/null || :
[1741]264touch --no-create %{_datadir}/icons/hicolor || :
[2164]265if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
266    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
267fi
[1987]268
269%postun
[2164]270update-desktop-database &> /dev/null ||:
271update-mime-database %{_datadir}/mime &> /dev/null || :
272touch --no-create %{_datadir}/icons/hicolor || :
[1741]273if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
274    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
275fi
276
[5899]277%files
[1741]278%defattr(-,root,root,-)
[10606]279%license COPYRIGHT LICENSE
280%doc Changelog.yaml
[2164]281%{_bindir}/calibre
282%{_bindir}/calibre-complete
283%{_bindir}/calibre-customize
284%{_bindir}/calibre-debug
285%{_bindir}/calibre-parallel
286%{_bindir}/calibre-server
287%{_bindir}/calibre-smtp
288%{_bindir}/calibre-mount-helper
289%{_bindir}/calibredb
290%{_bindir}/ebook-convert
291%{_bindir}/ebook-device
292%{_bindir}/ebook-meta
293%{_bindir}/ebook-viewer
294%{_bindir}/fetch-ebook-metadata
295%{_bindir}/lrf2lrs
296%{_bindir}/lrfviewer
297%{_bindir}/lrs2lrf
298%{_bindir}/markdown-calibre
299%{_bindir}/web2disk
[10606]300%{_bindir}/ebook-polish
301%{_bindir}/ebook-edit
[1741]302%{_libdir}/%{name}
303%{_datadir}/%{name}
304%{_datadir}/pixmaps/*
[2540]305%{_datadir}/applications/*.desktop
[1741]306%{_datadir}/mime/packages/*
[10606]307%{_datadir}/icons/hicolor/*/mimetypes/*
308%{_datadir}/icons/hicolor/*/apps/*
[1741]309%{python_sitelib}/init_calibre.py*
[10606]310%{_datadir}/bash-completion/completions/%{name}
311%{_datadir}/zsh/site-functions/_%{name}
312%{_datadir}/appdata/calibre*.appdata.xml
[1741]313
314%changelog
[11453]315* Sat Jan 27 2018 Toshiaki Ara <ara_t@384.jp> 2.62.0-2
316- rebuild under current VineSeed
317
[10606]318* Tue Jul 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.62.0-1
319- new upstream release.
320
[7766]321* Sun Aug 25 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.50-2
322- rebuild with ImageMagick-6.8.6.8
323- add Patch3 (calibre-0.8.50-poppler-0.20.x.patch)
324
[6167]325* Tue May  8 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.50-1
326- new upstream release
327- BuildRequires: qt4-devel >= 4.8.0
328- BuildRequires: PyQt4-devel >= 4.9.1
329
[5982]330* Fri Mar 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.44-1
331- new upstream release
332
[5899]333* Sun Mar 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.41-1
334- new upstream release
335
[5879]336* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.50-2
337- rebuild with ImageMagick-6.7.5.10
338
[3017]339* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.50-1
340- new upstream release
[2998]341
[2722]342* Sat Feb 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.46-1
343- new upstream release
344
[2667]345* Thu Feb 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.44-1
346- new upstream release
347
[2634]348* Fri Feb 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.42-1
349- new upstream release
350
[2540]351* Fri Jan 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.40-1
352- new upstream release
353
[2402]354* Mon Dec 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.35-1
355- new upstream release
356
[2369]357* Sun Dec 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.34-1
358- new upstream release
359
[2345]360* Mon Dec 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.33-1
361- new upstream release
362- added BuildRequires: libicu-devel
363
364* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.32-1
365- new upstream release
366
[2175]367* Fri Nov 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.26-1
368- new upstream release
369
[2164]370* Sun Oct 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.25-1
371- new upstream release
[2051]372
[2164]373  * Tue Oct 19 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.24-1
374  - Update to 0.7.24
[1987]375
[2164]376  * Sat Oct 09 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.23-1
377  - Update to 0.7.23
378  - Fix up mount helper with our own local script.
379  - Change files to list binaries so missing ones can more easily be noted.
380
381  * Mon Oct 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.22-1
382  - Update to 0.7.22
383
384  * Fri Oct 01 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.21-1
385  - Update to 0.7.21
386
387  * Wed Sep 29 2010 jkeating - 0.7.20-2
388  - Rebuilt for gcc bug 634757
389
390  * Fri Sep 24 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.20-1
391  - Update to 0.7.20
392
393  * Wed Sep 15 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-3
394  - Rebuild for new ImageMagick
395
[1970]396* Wed Sep 29 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.18-1
397- new upstream release
398- Fix svg/png changes.
399
[2164]400  * Mon Sep 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-2
401  - Fix svg/png changes.
402
403  * Sun Sep 12 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-1
404  - Update to 0.7.18
405  - Require > 0.9.6 cssutils
406
407  * Fri Sep 03 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.17-1
408  - Update to 0.7.17
409
410  * Fri Aug 27 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.16-1
411  - Update to 0.7.16
412
[1970]413* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.15-1
[1741]414- initial build based on Fedora development
415
[1970]416* Sat Aug 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.15-1
417- Update to 0.7.15
[1741]418
[1970]419* Thu Aug 19 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.14-2
420- rebuild (poppler)
[1741]421
[1970]422* Fri Aug 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.14-1
423- Update to 0.7.14
[1741]424
[1970]425* Fri Aug 06 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.13-1
426- Update to 0.7.13
[1741]427
[1970]428* Mon Aug 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.12-1
429- Update to 0.7.12
[1741]430
[1970]431* Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.11-1
432- Update to 0.7.11
[1741]433
[1970]434* Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-2
435- Rebuilt for python2.7
[1741]436
[1970]437* Fri Jul 23 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-1
438- Update to 0.7.10
[1741]439
[1970]440* Sat Jul 17 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.9-1
441- Update to 0.7.9
[1741]442
[1970]443* Sun Jul 11 2010 Michal Nowak <mnowak@redhat.com> - 0.7.8-1
444- Update to 0.7.8
445- build tar.xz instead of tar.bz2
[1741]446
[1970]447* Fri Jul 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.7-1
448- Update to 0.7.7
[1741]449
[1970]450* Wed Jun 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.6-1
451- Update to 0.7.6
452
453* Fri Jun 25 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.5-1
454- Update to 0.7.5
455
456* Sun Jun 20 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.4-1
457- Update to 0.7.4
458
459* Tue Jun 08 2010 Dan Horák <dan@danny.cz> - 0.7.1-2
460- rebuilt with podofo 0.8.1
461
462* Mon Jun 07 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.1-1
463- Update to 0.7.1
464- Added versioned dep on python-cssutils to make sure at least 0.9.6 is installed.
465
466* Fri Jun 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.0-1
467- Update to 0.7.0
468
469* Fri May 28 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.55-1
470- Update to 0.6.55
471
472* Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.54-1
473- Update to 0.6.54
474
475* Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.53-1
476- Update to 0.6.53
477
478* Wed May  5 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.6.47-2
479- Rebuild against new poppler
480
481* Sat Apr 10 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.47-1
482- new upstream release 0.6.47
483- new chmlib requirement
484- create directory for calibre's environment module
485- use bzip2 instead of gzip when preparing tarball in generate-tarball.sh
486- remove cssutils patches (we now have python-cssutils 0.9.6 in Fedora)
487
488* Fri Feb 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.42-1
489- new upstream release 0.6.42
490- remove shebang from default_tweaks.py
491
492* Mon Feb  1 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.37-1
493- new upstream release 0.6.37
494
495* Fri Jan 29 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.36-1
496- new upstream release 0.6.36
497- fixed a cssprofiles issue with loading the profiles
498
499* Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-3
500- added -cssprofiles patch to cvs
501
502* Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-2
503- remove python-cssutils 0.9.6 dependency
504
505* Mon Jan 25 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-1
506- new upstream release
507- fedora includes cssutils >= 0.9.6 now; removed the cssprofiles patch
508- removed -executables patch, upstream fixed it: http://bugs.calibre-ebook.com/ticket/4437
509
510* Wed Jan  6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-2
511- fix for package tagged without adding new patch to cvs
512
513* Wed Jan  6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-1
514- new upstream release 0.6.32
515- project website has changed
516- added python-BeautifulSoup BuildRequire
517- new patch to fix full buildpath in binary files
518
519* Sun Dec  6 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.26-1
520- New upstream version
521- Regenerated no-update patch because of code relocation
522
523* Wed Dec  2 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.25-1
524- New upstream release
525
526* Wed Nov 18 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.24-1
527- New upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2416Nov2009
528
529* Mon Nov 16 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.23-1
530- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2313Nov2009
531- patch to stop checking for new upstream version
532
533* Sat Nov  7 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.21-1
534- new upstream version: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2106Nov2009
535- added python-BeautifulSoup requirement
536
537* Wed Nov  4 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.20-1
538- new upstream version:
539http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2030Oct2009
540- upstream now ships correct .desktop files
541- fixed missing dependency: PyQt4
542- fixed calibre-gui icon
543
544* Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-3
545- removed unfree fonts from source package
546
547* Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-2
548- readability enhancements
549- added python-genshi requires
550- removed libwmf require since ImageMagick provides libwmf-lite as a
551  dependency and that's what we actually need
552
553* Wed Oct 21 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-1
554- new upstream version:
555  http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1920Oct2009
556- delete fonts, calibre can find the system fonts
557- specify libdir as an install option, so calibre will link properly
558  even on 64bit
559
560* Mon Oct 19 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.18-1
561- updated requires list
562- new upstream release
563- can override CFLAGS now
564- removed trac and genshi duplicates
565- use xdg env variables to do desktop integration in the buildroot
566- added xdg-utils buildrequire
567- install udev rules in /usr/lib even on 64bit and don't own the whole dir
568- removed wrongly used Version field from .desktop files
569
570* Mon Oct 12 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-2
571- mimick what calibre's desktop-integration script does (mimetypes, icons etc.)
572- removed unneeded INSTALL file
573- marked bash completion file as config(noreplace) and take ownership of the dir
574
575* Sat Oct 10 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-1
576- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1709Oct2009
577- the install process changed significantly
578- locales were added
579
580* Thu Sep 10 2009 Ionuț Arțăriși <mapleoin@lavabit.com> - 0.6.11-1
581- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1104Sep2009
582- minor path fixes
583- rearranged files section
584
585* Fri Aug 28 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.10-1
586- handle desktop files
587- don't compress manpages and don't list them as duplicates
588- added lrfviewer icon
589
590* Tue Aug 25 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.8-1
591- Initial RPM release
Note: See TracBrowser for help on using the repository browser.