source: projects/specs/trunk/c/cairo/cairo-vl.spec @ 9560

Revision 9560, 12.7 KB checked in by Takemikaduchi, 9 years ago (diff)

ImageMagick?: new upstream release
others: remove *.la files

Line 
1Summary:        Cairo - multi-platform 2D graphics library.
2Summary(ja):    Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
3Name:           cairo
4Version:        1.14.2
5Release:        2%{?_dist_release}
6License:        LGPL/MPL
7Group:          System Environment/Libraries
8Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.xz
9
10# don't use serverside gradients, most drivers don't handle those and are
11# really slow, should workaround performances issues for ati, nouveau and nvidia
12# https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
13Patch1:         cairo-1.10.0-dont_use_server_side_gradients.patch
14
15URL:            http://cairographics.org/
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires: pkgconfig
19BuildRequires: pixman-devel
20BuildRequires: glib2-devel
21BuildRequires: libpng-devel
22BuildRequires: freetype2-devel
23BuildRequires: fontconfig-devel
24BuildRequires: libX11-devel
25BuildRequires: libXrender-devel
26BuildRequires: gtk-doc
27BuildRequires: librsvg2-devel
28BuildRequires: mesa-libGL-devel
29BuildRequires: mesa-libEGL-devel
30
31BuildConflicts: XOrg-compat70-devel
32
33%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39Cairo provides anti-aliased vector-based rendering for X. Paths
40consist of line segments and cubic splines and can be rendered at any
41width with various join and cap styles. All colors may be specified
42with optional translucence (opacity/alpha) and combined using the
43extended Porter/Duff compositing algebra as found in the X Render
44Extension.
45
46Cairo exports a stateful rendering API similar in spirit to the path
47construction, text, and painting operators of PostScript, (with the
48significant addition of translucence in the imaging model). When
49complete, the API is intended to support the complete imaging model of
50PDF 1.4.
51
52Cairo relies on the Xc library for backend rendering. Xc provides an
53abstract interface for rendering to multiple target types. As of this
54writing, Xc allows Cairo to target X drawables as well as generic
55image buffers. Future backends such as PostScript, PDF, and perhaps
56OpenGL are currently being planned.
57
58%package -n compat32-%{name}
59Summary:        Cairo - multi-platform 2D graphics library.
60Summary(ja):    Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
61Group:          System Environment/Libraries
62Requires:       %{name} = %{version}
63
64%description -n compat32-%{name}
65Cairo provides anti-aliased vector-based rendering for X. Paths
66consist of line segments and cubic splines and can be rendered at any
67width with various join and cap styles. All colors may be specified
68with optional translucence (opacity/alpha) and combined using the
69extended Porter/Duff compositing algebra as found in the X Render
70Extension.
71
72Cairo exports a stateful rendering API similar in spirit to the path
73construction, text, and painting operators of PostScript, (with the
74significant addition of translucence in the imaging model). When
75complete, the API is intended to support the complete imaging model of
76PDF 1.4.
77
78Cairo relies on the Xc library for backend rendering. Xc provides an
79abstract interface for rendering to multiple target types. As of this
80writing, Xc allows Cairo to target X drawables as well as generic
81image buffers. Future backends such as PostScript, PDF, and perhaps
82OpenGL are currently being planned.
83
84%package devel
85Summary:        Development files for Cairo library.
86Summary(ja):    Cairo ライブラリの開発用ファイル
87Group:          Development/Libraries
88Provides:       lib%{name}-devel = %{version}-%{release}
89Requires:       %{name} = %{version}
90Requires:       libpng-devel
91Requires:       freetype2-devel
92Requires:       fontconfig-devel
93Requires:       libX11-devel
94Requires:       libXrender-devel
95Requires:       pixman-devel
96Requires:       glib2-devel
97Requires:       mesa-libEGL-devel
98
99%description devel
100Development files for Cairo library.
101
102%package tools
103Summary: Development tools for cairo
104Group: Development/Tools
105
106%description tools
107Cairo is a 2D graphics library designed to provide high-quality display
108and print output.
109
110This package contains tools for working with the cairo graphics library.
111 * cairo-trace: Record cairo library calls for later playback
112
113
114%prep
115%setup -q
116%patch1 -p1 -b .dont-use-server-side-gradients
117
118%build
119%configure --disable-static \
120           --enable-gtk-doc \
121           --enable-xlib \
122           --enable-freetype \
123           --enable-ps \
124           --enable-pdf \
125           --enable-svg \
126           --enable-tee \
127           --enable-gobject \
128           --enable-gl
129
130sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
131sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
132
133make %{?_smp_mflags}
134
135%install
136rm -rf $RPM_BUILD_ROOT
137
138%makeinstall
139find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
144%post   -p /sbin/ldconfig
145%postun -p /sbin/ldconfig
146
147%post   -n compat32-%{name} -p /sbin/ldconfig
148%postun -n compat32-%{name} -p /sbin/ldconfig
149
150
151%files
152%defattr(644,root,root,755)
153%doc AUTHORS BUGS COPYING COPYING-* ChangeLog NEWS README
154%{_libdir}/lib*.so.*
155
156%files devel
157%defattr(644,root,root,755)
158%{_libdir}/lib*.so
159%{_includedir}/*
160%{_libdir}/pkgconfig/*.pc
161#{_libdir}/lib*.a
162%{_datadir}/gtk-doc/html/cairo
163
164%files tools
165%defattr(-,root,root,-)
166%{_bindir}/cairo-trace
167%{_bindir}/cairo-sphinx
168%{_libdir}/cairo
169
170%if %{build_compat32}
171%files -n compat32-%{name}
172%defattr(644,root,root,755)
173%{_libdir}/lib*.so.*
174%endif
175
176%changelog
177* Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-2
178- remove *.la files
179
180* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-1
181- new upstream release
182
183* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.18-1
184- new upstream release
185
186* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.16-2
187- rebuild with libpng-1.6.12
188
189* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.16-1
190- new upstream release
191
192* Sat May 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.14-2
193- remove hardcoded libdir and runpath from libtool
194
195* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.14-1
196- new upstream release
197
198* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.8-1
199- new upstream release
200
201* Fri Nov 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.6-1
202- new upstream release
203
204* Sat Oct 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.4-1
205- new upstream release
206
207* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-2
208- add Requires: mesa-libEGL-devel
209
210* Sat Jul 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-1
211- new upstream release
212- Enable OpenGL backend
213- add BR: librsvg2-devel, mesa-libGL-devel, mesa-libEGL-devel
214
215* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
216- new upstream release
217
218* Mon Mar 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-2
219- enable tee support
220- add configure options specifically
221- disable static library
222
223* Wed Jan 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
224- new upstream release
225- add BuildRequires: glib2-devel
226- add Requires: glib2-devel (devel package)
227
228* Wed Oct 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
229- add patch1 from ubuntu to fix performance regressions
230  - don't use serverside gradients, most drivers don't handle those and are
231    really slow, should workaround performances issues for ati, nouveau and nvidia
232    https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
233
234* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
235- new upstream release
236- add tools sub package
237
238* Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.10-3
239- add BuildRequires: fontconfig-devel
240- add Requires: fontconfig-devel (devel package)
241
242* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.8.10-2
243- build with rpm-4.8.1-1 for pkg-config file
244
245* Tue Mar  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.8.10-1
246- new upstream release
247
248* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
249- new upstream release
250
251* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.8.6-2
252- applied cairo-1.8.6-status-return-fix.patch from Gentoo Linux
253- added BuildRequires: gtk-doc
254
255* Sat Jan 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-1
256- new upstream release
257
258* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.4-1
259- new upstream release
260
261* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
262- new upstream release
263
264* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
265- new upstream release
266
267* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-1
268- new upstream release
269
270* Wed May 28 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.4-3
271- add  Requires: pixman-devel to -devel
272
273* Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-2
274- rebuilt with xorg-x11 7.3
275- spec in UTF-8
276
277* Thu May  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-1
278- new upstream release
279- removed lib*.la from devel package
280
281* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-1vl5
282- used %%{?_dist_release}
283
284* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-0vl1
285- new upstream release
286
287* Sun Dec  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.12-0vl1
288- new upstream release
289
290* Tue Jul 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.10-0vl1
291- new upstream release
292
293* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
294- new upstream release
295- remove BuildRequires: pango-devel, gtk2-devel
296  (these are only needed for testing)
297
298* Sat Mar 31 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.4.2-0vl1
299- upstream release
300- Patch30 and Patch40 is skipped (not working correctly)
301  but held in src.rpm
302- add BUGS, ROADMAP to %%doc
303- add BuildRequires: pango-devel, gtk2-devel
304
305* Tue Oct 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl2
306- rebuild without XOrg-compat70-devel
307- add BuildConflicts: XOrg-compat70-devel
308
309* Sun Oct 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl1
310- new upstream release
311- remove unneeded Patch20 which breaks 8bpp rendering (<BTS:297>)
312
313* Tue Sep 19 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl3
314- added Patch40 for 15bpp problem
315
316* Tue Sep  5 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl2
317- added ad-hoc Patch30 for 16bpp problem
318
319* Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
320- new upstream release
321
322* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
323- new upstream release
324
325* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
326- new upstream release
327
328* Sat May 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.2-0vl4
329- added compat32- package for x86_64 architecture support
330
331* Sun Mar 05 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
332- added x86_64 architecture support
333
334* Sat Dec 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
335- add Patch20 to fix broken desktop rendering on xorg-x11-6.9
336  - add X.Org 6.9.0 (6090000) to blacklist
337
338* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
339- new upstream release
340
341* Tue Oct 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl5
342- update Patch10
343
344* Sun Oct 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl4
345- add Patch10 to use embedded bitmap font if available.
346  (controllable by "embeddedbitmap" in fontconfig)
347
348* Thu Sep 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl3
349- rebuild with new fontconfig
350
351* Sun Sep 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl2
352- add Requires: libpng-devel, XOrg-devel, freetype2-devel
353  to devel package instead of BuildRequires (typo)
354- add Japanese summaries
355
356* Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
357- new upstream release
358- remove libpixman dependency (which is now included in cairo)
359- obsoletes libpixman <= 0.1.6
360- add more BuildRequires
361
362* Sat Aug 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.2-0vl1
363- new upstream version
364
365* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1-0vl1
366- new upstream version
367- fixed License (http://cairographics.org/introduction)
368
369* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
370- new upstream version
371- include gtk-doc files
372
373* Sun Jan 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
374- new upstream version
375- add Requires: libpixman
376
377* Mon Nov 01 2004 Satoshi MACHINO <machino@vinelinux.org> 0.2.0-0vl1
378- new upstream version (cairo-0.2.0)
379
380* Mon Oct 11 2004 Satoshi MACHINO <machino@vinelinux.org> 0.1.23-1vl1
381- rebuilt for VineLinux
382
383* Tue Jun 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.23-1mdk
384- 0.1.23
385- reenable libtoolize
386
387* Wed May  5 2004 G魚Waschk <waschk@linux-mandrake.com> 0.1.22-1mdk
388- fix devel provides
389- drop redundant buildrequires
390- requires new pixman
391- autoconf 2.5 macro
392- New release 0.1.22
393
394* Fri Feb 06 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-2mdk
395- build with X11
396
397* Sun Feb 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-1mdk
398- 0.1.17
399- provides cairo
400- drop patch, use --disable-xlib
401- buildrequires
402- don't run libtoolize
403
404* Sun Dec 14 2003 Marcel Pol <mpol@mandrake.org> 0.1.13-1mdk
405- initial mandrake package
406
Note: See TracBrowser for help on using the repository browser.