source: projects/specs/trunk/c/cairo/cairo-vl.spec @ 9092

Revision 9092, 12.6 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1Summary:        Cairo - multi-platform 2D graphics library.
2Summary(ja):    Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
3Name:           cairo
4Version:        1.12.18
5Release:        1%{?_dist_release}
6License:        LGPL/MPL
7Group:          System Environment/Libraries
8Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.xz
9
10# don't use serverside gradients, most drivers don't handle those and are
11# really slow, should workaround performances issues for ati, nouveau and nvidia
12# https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
13Patch1:         cairo-1.10.0-dont_use_server_side_gradients.patch
14
15URL:            http://cairographics.org/
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires: pkgconfig
19BuildRequires: pixman-devel
20BuildRequires: glib2-devel
21BuildRequires: libpng-devel
22BuildRequires: freetype2-devel
23BuildRequires: fontconfig-devel
24BuildRequires: libX11-devel
25BuildRequires: libXrender-devel
26BuildRequires: gtk-doc
27BuildRequires: librsvg2-devel
28BuildRequires: mesa-libGL-devel
29BuildRequires: mesa-libEGL-devel
30
31BuildConflicts: XOrg-compat70-devel
32
33%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39Cairo provides anti-aliased vector-based rendering for X. Paths
40consist of line segments and cubic splines and can be rendered at any
41width with various join and cap styles. All colors may be specified
42with optional translucence (opacity/alpha) and combined using the
43extended Porter/Duff compositing algebra as found in the X Render
44Extension.
45
46Cairo exports a stateful rendering API similar in spirit to the path
47construction, text, and painting operators of PostScript, (with the
48significant addition of translucence in the imaging model). When
49complete, the API is intended to support the complete imaging model of
50PDF 1.4.
51
52Cairo relies on the Xc library for backend rendering. Xc provides an
53abstract interface for rendering to multiple target types. As of this
54writing, Xc allows Cairo to target X drawables as well as generic
55image buffers. Future backends such as PostScript, PDF, and perhaps
56OpenGL are currently being planned.
57
58%package -n compat32-%{name}
59Summary:        Cairo - multi-platform 2D graphics library.
60Summary(ja):    Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
61Group:          System Environment/Libraries
62Requires:       %{name} = %{version}
63
64%description -n compat32-%{name}
65Cairo provides anti-aliased vector-based rendering for X. Paths
66consist of line segments and cubic splines and can be rendered at any
67width with various join and cap styles. All colors may be specified
68with optional translucence (opacity/alpha) and combined using the
69extended Porter/Duff compositing algebra as found in the X Render
70Extension.
71
72Cairo exports a stateful rendering API similar in spirit to the path
73construction, text, and painting operators of PostScript, (with the
74significant addition of translucence in the imaging model). When
75complete, the API is intended to support the complete imaging model of
76PDF 1.4.
77
78Cairo relies on the Xc library for backend rendering. Xc provides an
79abstract interface for rendering to multiple target types. As of this
80writing, Xc allows Cairo to target X drawables as well as generic
81image buffers. Future backends such as PostScript, PDF, and perhaps
82OpenGL are currently being planned.
83
84%package devel
85Summary:        Development files for Cairo library.
86Summary(ja):    Cairo ライブラリの開発用ファイル
87Group:          Development/Libraries
88Provides:       lib%{name}-devel = %{version}-%{release}
89Requires:       %{name} = %{version}
90Requires:       libpng-devel
91Requires:       freetype2-devel
92Requires:       fontconfig-devel
93Requires:       libX11-devel
94Requires:       libXrender-devel
95Requires:       pixman-devel
96Requires:       glib2-devel
97Requires:       mesa-libEGL-devel
98
99%description devel
100Development files for Cairo library.
101
102%package tools
103Summary: Development tools for cairo
104Group: Development/Tools
105
106%description tools
107Cairo is a 2D graphics library designed to provide high-quality display
108and print output.
109
110This package contains tools for working with the cairo graphics library.
111 * cairo-trace: Record cairo library calls for later playback
112
113
114%prep
115%setup -q
116%patch1 -p1 -b .dont-use-server-side-gradients
117
118%build
119%configure --disable-static \
120           --enable-gtk-doc \
121           --enable-xlib \
122           --enable-freetype \
123           --enable-ps \
124           --enable-pdf \
125           --enable-svg \
126           --enable-tee \
127           --enable-gobject \
128           --enable-gl
129
130sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
131sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
132
133make %{?_smp_mflags}
134
135%install
136rm -rf $RPM_BUILD_ROOT
137
138%makeinstall
139rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
140
141%clean
142rm -rf $RPM_BUILD_ROOT
143
144%post   -p /sbin/ldconfig
145%postun -p /sbin/ldconfig
146
147%post   -n compat32-%{name} -p /sbin/ldconfig
148%postun -n compat32-%{name} -p /sbin/ldconfig
149
150
151%files
152%defattr(644,root,root,755)
153%doc AUTHORS BUGS COPYING COPYING-* ChangeLog NEWS README
154%{_libdir}/lib*.so.*
155
156%files devel
157%defattr(644,root,root,755)
158%{_libdir}/lib*.so
159#{_libdir}/lib*.la
160%{_includedir}/*
161%{_libdir}/pkgconfig/*.pc
162#{_libdir}/lib*.a
163%{_datadir}/gtk-doc/html/cairo
164
165%files tools
166%defattr(-,root,root,-)
167%{_bindir}/cairo-trace
168%{_bindir}/cairo-sphinx
169%{_libdir}/cairo
170
171%if %{build_compat32}
172%files -n compat32-%{name}
173%defattr(644,root,root,755)
174%{_libdir}/lib*.so.*
175%endif
176
177%changelog
178* Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.18-1
179- new upstream release
180
181* Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.16-2
182- rebuild with libpng-1.6.12
183
184* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.16-1
185- new upstream release
186
187* Sat May 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.14-2
188- remove hardcoded libdir and runpath from libtool
189
190* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.14-1
191- new upstream release
192
193* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.8-1
194- new upstream release
195
196* Fri Nov 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.6-1
197- new upstream release
198
199* Sat Oct 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.4-1
200- new upstream release
201
202* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-2
203- add Requires: mesa-libEGL-devel
204
205* Sat Jul 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-1
206- new upstream release
207- Enable OpenGL backend
208- add BR: librsvg2-devel, mesa-libGL-devel, mesa-libEGL-devel
209
210* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
211- new upstream release
212
213* Mon Mar 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-2
214- enable tee support
215- add configure options specifically
216- disable static library
217
218* Wed Jan 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
219- new upstream release
220- add BuildRequires: glib2-devel
221- add Requires: glib2-devel (devel package)
222
223* Wed Oct 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
224- add patch1 from ubuntu to fix performance regressions
225  - don't use serverside gradients, most drivers don't handle those and are
226    really slow, should workaround performances issues for ati, nouveau and nvidia
227    https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
228
229* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
230- new upstream release
231- add tools sub package
232
233* Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.10-3
234- add BuildRequires: fontconfig-devel
235- add Requires: fontconfig-devel (devel package)
236
237* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.8.10-2
238- build with rpm-4.8.1-1 for pkg-config file
239
240* Tue Mar  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.8.10-1
241- new upstream release
242
243* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
244- new upstream release
245
246* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.8.6-2
247- applied cairo-1.8.6-status-return-fix.patch from Gentoo Linux
248- added BuildRequires: gtk-doc
249
250* Sat Jan 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-1
251- new upstream release
252
253* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.4-1
254- new upstream release
255
256* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
257- new upstream release
258
259* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
260- new upstream release
261
262* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-1
263- new upstream release
264
265* Wed May 28 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.4-3
266- add  Requires: pixman-devel to -devel
267
268* Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-2
269- rebuilt with xorg-x11 7.3
270- spec in UTF-8
271
272* Thu May  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-1
273- new upstream release
274- removed lib*.la from devel package
275
276* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-1vl5
277- used %%{?_dist_release}
278
279* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-0vl1
280- new upstream release
281
282* Sun Dec  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.12-0vl1
283- new upstream release
284
285* Tue Jul 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.10-0vl1
286- new upstream release
287
288* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
289- new upstream release
290- remove BuildRequires: pango-devel, gtk2-devel
291  (these are only needed for testing)
292
293* Sat Mar 31 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.4.2-0vl1
294- upstream release
295- Patch30 and Patch40 is skipped (not working correctly)
296  but held in src.rpm
297- add BUGS, ROADMAP to %%doc
298- add BuildRequires: pango-devel, gtk2-devel
299
300* Tue Oct 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl2
301- rebuild without XOrg-compat70-devel
302- add BuildConflicts: XOrg-compat70-devel
303
304* Sun Oct 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl1
305- new upstream release
306- remove unneeded Patch20 which breaks 8bpp rendering (<BTS:297>)
307
308* Tue Sep 19 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl3
309- added Patch40 for 15bpp problem
310
311* Tue Sep  5 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl2
312- added ad-hoc Patch30 for 16bpp problem
313
314* Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
315- new upstream release
316
317* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
318- new upstream release
319
320* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
321- new upstream release
322
323* Sat May 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.2-0vl4
324- added compat32- package for x86_64 architecture support
325
326* Sun Mar 05 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
327- added x86_64 architecture support
328
329* Sat Dec 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
330- add Patch20 to fix broken desktop rendering on xorg-x11-6.9
331  - add X.Org 6.9.0 (6090000) to blacklist
332
333* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
334- new upstream release
335
336* Tue Oct 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl5
337- update Patch10
338
339* Sun Oct 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl4
340- add Patch10 to use embedded bitmap font if available.
341  (controllable by "embeddedbitmap" in fontconfig)
342
343* Thu Sep 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl3
344- rebuild with new fontconfig
345
346* Sun Sep 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl2
347- add Requires: libpng-devel, XOrg-devel, freetype2-devel
348  to devel package instead of BuildRequires (typo)
349- add Japanese summaries
350
351* Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
352- new upstream release
353- remove libpixman dependency (which is now included in cairo)
354- obsoletes libpixman <= 0.1.6
355- add more BuildRequires
356
357* Sat Aug 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.2-0vl1
358- new upstream version
359
360* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1-0vl1
361- new upstream version
362- fixed License (http://cairographics.org/introduction)
363
364* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
365- new upstream version
366- include gtk-doc files
367
368* Sun Jan 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
369- new upstream version
370- add Requires: libpixman
371
372* Mon Nov 01 2004 Satoshi MACHINO <machino@vinelinux.org> 0.2.0-0vl1
373- new upstream version (cairo-0.2.0)
374
375* Mon Oct 11 2004 Satoshi MACHINO <machino@vinelinux.org> 0.1.23-1vl1
376- rebuilt for VineLinux
377
378* Tue Jun 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.23-1mdk
379- 0.1.23
380- reenable libtoolize
381
382* Wed May  5 2004 G魚Waschk <waschk@linux-mandrake.com> 0.1.22-1mdk
383- fix devel provides
384- drop redundant buildrequires
385- requires new pixman
386- autoconf 2.5 macro
387- New release 0.1.22
388
389* Fri Feb 06 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-2mdk
390- build with X11
391
392* Sun Feb 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-1mdk
393- 0.1.17
394- provides cairo
395- drop patch, use --disable-xlib
396- buildrequires
397- don't run libtoolize
398
399* Sun Dec 14 2003 Marcel Pol <mpol@mandrake.org> 0.1.13-1mdk
400- initial mandrake package
401
Note: See TracBrowser for help on using the repository browser.