source: projects/specs/trunk/c/cairo/cairo-vl.spec @ 7702

Revision 7702, 12.2 KB checked in by daisuke, 11 years ago (diff)

cairo: remove hardcoded libdir/runpath

Line 
1Summary:        Cairo - multi-platform 2D graphics library.
2Summary(ja):    Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
3Name:           cairo
4Version:        1.12.14
5Release:        2%{?_dist_release}
6License:        LGPL/MPL
7Group:          System Environment/Libraries
8Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.xz
9
10# don't use serverside gradients, most drivers don't handle those and are
11# really slow, should workaround performances issues for ati, nouveau and nvidia
12# https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
13Patch1:         cairo-1.10.0-dont_use_server_side_gradients.patch
14
15URL:            http://cairographics.org/
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires: pkgconfig
19BuildRequires: pixman-devel
20BuildRequires: glib2-devel
21BuildRequires: libpng-devel
22BuildRequires: freetype2-devel
23BuildRequires: fontconfig-devel
24BuildRequires: libX11-devel
25BuildRequires: libXrender-devel
26BuildRequires: gtk-doc
27BuildRequires: librsvg2-devel
28BuildRequires: mesa-libGL-devel
29BuildRequires: mesa-libEGL-devel
30
31BuildConflicts: XOrg-compat70-devel
32
33%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
34
35%description
36Cairo provides anti-aliased vector-based rendering for X. Paths
37consist of line segments and cubic splines and can be rendered at any
38width with various join and cap styles. All colors may be specified
39with optional translucence (opacity/alpha) and combined using the
40extended Porter/Duff compositing algebra as found in the X Render
41Extension.
42
43Cairo exports a stateful rendering API similar in spirit to the path
44construction, text, and painting operators of PostScript, (with the
45significant addition of translucence in the imaging model). When
46complete, the API is intended to support the complete imaging model of
47PDF 1.4.
48
49Cairo relies on the Xc library for backend rendering. Xc provides an
50abstract interface for rendering to multiple target types. As of this
51writing, Xc allows Cairo to target X drawables as well as generic
52image buffers. Future backends such as PostScript, PDF, and perhaps
53OpenGL are currently being planned.
54
55%package -n compat32-%{name}
56Summary:        Cairo - multi-platform 2D graphics library.
57Summary(ja):    Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
58Group:          System Environment/Libraries
59Requires:       %{name} = %{version}
60
61%description -n compat32-%{name}
62Cairo provides anti-aliased vector-based rendering for X. Paths
63consist of line segments and cubic splines and can be rendered at any
64width with various join and cap styles. All colors may be specified
65with optional translucence (opacity/alpha) and combined using the
66extended Porter/Duff compositing algebra as found in the X Render
67Extension.
68
69Cairo exports a stateful rendering API similar in spirit to the path
70construction, text, and painting operators of PostScript, (with the
71significant addition of translucence in the imaging model). When
72complete, the API is intended to support the complete imaging model of
73PDF 1.4.
74
75Cairo relies on the Xc library for backend rendering. Xc provides an
76abstract interface for rendering to multiple target types. As of this
77writing, Xc allows Cairo to target X drawables as well as generic
78image buffers. Future backends such as PostScript, PDF, and perhaps
79OpenGL are currently being planned.
80
81%package devel
82Summary:        Development files for Cairo library.
83Summary(ja):    Cairo ライブラリの開発用ファイル
84Group:          Development/Libraries
85Provides:       lib%{name}-devel = %{version}-%{release}
86Requires:       %{name} = %{version}
87Requires:       libpng-devel
88Requires:       freetype2-devel
89Requires:       fontconfig-devel
90Requires:       libX11-devel
91Requires:       libXrender-devel
92Requires:       pixman-devel
93Requires:       glib2-devel
94Requires:       mesa-libEGL-devel
95
96%description devel
97Development files for Cairo library.
98
99%package tools
100Summary: Development tools for cairo
101Group: Development/Tools
102
103%description tools
104Cairo is a 2D graphics library designed to provide high-quality display
105and print output.
106
107This package contains tools for working with the cairo graphics library.
108 * cairo-trace: Record cairo library calls for later playback
109
110
111%prep
112%setup -q
113%patch1 -p1 -b .dont-use-server-side-gradients
114
115%build
116%configure --disable-static \
117           --enable-gtk-doc \
118           --enable-xlib \
119           --enable-freetype \
120           --enable-ps \
121           --enable-pdf \
122           --enable-svg \
123           --enable-tee \
124           --enable-gobject \
125           --enable-gl
126
127sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
128sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
129
130make %{?_smp_mflags}
131
132%install
133rm -rf $RPM_BUILD_ROOT
134
135%makeinstall
136rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
137
138%clean
139rm -rf $RPM_BUILD_ROOT
140
141%post   -p /sbin/ldconfig
142%postun -p /sbin/ldconfig
143
144%post   -n compat32-%{name} -p /sbin/ldconfig
145%postun -n compat32-%{name} -p /sbin/ldconfig
146
147
148%files
149%defattr(644,root,root,755)
150%doc AUTHORS BUGS COPYING COPYING-* ChangeLog NEWS README
151%{_libdir}/lib*.so.*
152
153%files devel
154%defattr(644,root,root,755)
155%{_libdir}/lib*.so
156#{_libdir}/lib*.la
157%{_includedir}/*
158%{_libdir}/pkgconfig/*.pc
159#{_libdir}/lib*.a
160%{_datadir}/gtk-doc/html/cairo
161
162%files tools
163%defattr(-,root,root,-)
164%{_bindir}/cairo-trace
165%{_bindir}/cairo-sphinx
166%{_libdir}/cairo
167
168%if %{build_compat32}
169%files -n compat32-%{name}
170%defattr(644,root,root,755)
171%{_libdir}/lib*.so.*
172%endif
173
174%changelog
175* Sat May 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.14-2
176- remove hardcoded libdir and runpath from libtool
177
178* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.14-1
179- new upstream release
180
181* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.8-1
182- new upstream release
183
184* Fri Nov 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.6-1
185- new upstream release
186
187* Sat Oct 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.4-1
188- new upstream release
189
190* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-2
191- add Requires: mesa-libEGL-devel
192
193* Sat Jul 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-1
194- new upstream release
195- Enable OpenGL backend
196- add BR: librsvg2-devel, mesa-libGL-devel, mesa-libEGL-devel
197
198* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
199- new upstream release
200
201* Mon Mar 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-2
202- enable tee support
203- add configure options specifically
204- disable static library
205
206* Wed Jan 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
207- new upstream release
208- add BuildRequires: glib2-devel
209- add Requires: glib2-devel (devel package)
210
211* Wed Oct 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
212- add patch1 from ubuntu to fix performance regressions
213  - don't use serverside gradients, most drivers don't handle those and are
214    really slow, should workaround performances issues for ati, nouveau and nvidia
215    https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
216
217* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
218- new upstream release
219- add tools sub package
220
221* Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.10-3
222- add BuildRequires: fontconfig-devel
223- add Requires: fontconfig-devel (devel package)
224
225* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.8.10-2
226- build with rpm-4.8.1-1 for pkg-config file
227
228* Tue Mar  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.8.10-1
229- new upstream release
230
231* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
232- new upstream release
233
234* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.8.6-2
235- applied cairo-1.8.6-status-return-fix.patch from Gentoo Linux
236- added BuildRequires: gtk-doc
237
238* Sat Jan 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-1
239- new upstream release
240
241* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.4-1
242- new upstream release
243
244* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
245- new upstream release
246
247* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
248- new upstream release
249
250* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-1
251- new upstream release
252
253* Wed May 28 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.4-3
254- add  Requires: pixman-devel to -devel
255
256* Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-2
257- rebuilt with xorg-x11 7.3
258- spec in UTF-8
259
260* Thu May  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-1
261- new upstream release
262- removed lib*.la from devel package
263
264* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-1vl5
265- used %%{?_dist_release}
266
267* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-0vl1
268- new upstream release
269
270* Sun Dec  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.12-0vl1
271- new upstream release
272
273* Tue Jul 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.10-0vl1
274- new upstream release
275
276* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
277- new upstream release
278- remove BuildRequires: pango-devel, gtk2-devel
279  (these are only needed for testing)
280
281* Sat Mar 31 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.4.2-0vl1
282- upstream release
283- Patch30 and Patch40 is skipped (not working correctly)
284  but held in src.rpm
285- add BUGS, ROADMAP to %%doc
286- add BuildRequires: pango-devel, gtk2-devel
287
288* Tue Oct 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl2
289- rebuild without XOrg-compat70-devel
290- add BuildConflicts: XOrg-compat70-devel
291
292* Sun Oct 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl1
293- new upstream release
294- remove unneeded Patch20 which breaks 8bpp rendering (<BTS:297>)
295
296* Tue Sep 19 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl3
297- added Patch40 for 15bpp problem
298
299* Tue Sep  5 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl2
300- added ad-hoc Patch30 for 16bpp problem
301
302* Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
303- new upstream release
304
305* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
306- new upstream release
307
308* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
309- new upstream release
310
311* Sat May 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.2-0vl4
312- added compat32- package for x86_64 architecture support
313
314* Sun Mar 05 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
315- added x86_64 architecture support
316
317* Sat Dec 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
318- add Patch20 to fix broken desktop rendering on xorg-x11-6.9
319  - add X.Org 6.9.0 (6090000) to blacklist
320
321* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
322- new upstream release
323
324* Tue Oct 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl5
325- update Patch10
326
327* Sun Oct 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl4
328- add Patch10 to use embedded bitmap font if available.
329  (controllable by "embeddedbitmap" in fontconfig)
330
331* Thu Sep 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl3
332- rebuild with new fontconfig
333
334* Sun Sep 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl2
335- add Requires: libpng-devel, XOrg-devel, freetype2-devel
336  to devel package instead of BuildRequires (typo)
337- add Japanese summaries
338
339* Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
340- new upstream release
341- remove libpixman dependency (which is now included in cairo)
342- obsoletes libpixman <= 0.1.6
343- add more BuildRequires
344
345* Sat Aug 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.2-0vl1
346- new upstream version
347
348* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1-0vl1
349- new upstream version
350- fixed License (http://cairographics.org/introduction)
351
352* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
353- new upstream version
354- include gtk-doc files
355
356* Sun Jan 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
357- new upstream version
358- add Requires: libpixman
359
360* Mon Nov 01 2004 Satoshi MACHINO <machino@vinelinux.org> 0.2.0-0vl1
361- new upstream version (cairo-0.2.0)
362
363* Mon Oct 11 2004 Satoshi MACHINO <machino@vinelinux.org> 0.1.23-1vl1
364- rebuilt for VineLinux
365
366* Tue Jun 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.23-1mdk
367- 0.1.23
368- reenable libtoolize
369
370* Wed May  5 2004 G魚Waschk <waschk@linux-mandrake.com> 0.1.22-1mdk
371- fix devel provides
372- drop redundant buildrequires
373- requires new pixman
374- autoconf 2.5 macro
375- New release 0.1.22
376
377* Fri Feb 06 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-2mdk
378- build with X11
379
380* Sun Feb 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-1mdk
381- 0.1.17
382- provides cairo
383- drop patch, use --disable-xlib
384- buildrequires
385- don't run libtoolize
386
387* Sun Dec 14 2003 Marcel Pol <mpol@mandrake.org> 0.1.13-1mdk
388- initial mandrake package
389
Note: See TracBrowser for help on using the repository browser.