source: projects/specs/trunk/c/cairo/cairo-vl.spec @ 7062

Revision 7062, 12.0 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1Summary:        Cairo - multi-platform 2D graphics library.
2Summary(ja):    Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
3Name:           cairo
4Version:        1.12.6
5Release:        1%{?_dist_release}
6License:        LGPL/MPL
7Group:          System Environment/Libraries
8Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.xz
9
10# don't use serverside gradients, most drivers don't handle those and are
11# really slow, should workaround performances issues for ati, nouveau and nvidia
12# https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
13Patch1:         cairo-1.10.0-dont_use_server_side_gradients.patch
14
15URL:            http://cairographics.org/
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires: pkgconfig
19BuildRequires: pixman-devel
20BuildRequires: glib2-devel
21BuildRequires: libpng-devel
22BuildRequires: freetype2-devel
23BuildRequires: fontconfig-devel
24BuildRequires: libX11-devel
25BuildRequires: libXrender-devel
26BuildRequires: gtk-doc
27BuildRequires: librsvg2-devel
28BuildRequires: mesa-libGL-devel
29BuildRequires: mesa-libEGL-devel
30
31BuildConflicts: XOrg-compat70-devel
32
33%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
34
35%description
36Cairo provides anti-aliased vector-based rendering for X. Paths
37consist of line segments and cubic splines and can be rendered at any
38width with various join and cap styles. All colors may be specified
39with optional translucence (opacity/alpha) and combined using the
40extended Porter/Duff compositing algebra as found in the X Render
41Extension.
42
43Cairo exports a stateful rendering API similar in spirit to the path
44construction, text, and painting operators of PostScript, (with the
45significant addition of translucence in the imaging model). When
46complete, the API is intended to support the complete imaging model of
47PDF 1.4.
48
49Cairo relies on the Xc library for backend rendering. Xc provides an
50abstract interface for rendering to multiple target types. As of this
51writing, Xc allows Cairo to target X drawables as well as generic
52image buffers. Future backends such as PostScript, PDF, and perhaps
53OpenGL are currently being planned.
54
55%package -n compat32-%{name}
56Summary:        Cairo - multi-platform 2D graphics library.
57Summary(ja):    Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
58Group:          System Environment/Libraries
59Requires:       %{name} = %{version}
60
61%description -n compat32-%{name}
62Cairo provides anti-aliased vector-based rendering for X. Paths
63consist of line segments and cubic splines and can be rendered at any
64width with various join and cap styles. All colors may be specified
65with optional translucence (opacity/alpha) and combined using the
66extended Porter/Duff compositing algebra as found in the X Render
67Extension.
68
69Cairo exports a stateful rendering API similar in spirit to the path
70construction, text, and painting operators of PostScript, (with the
71significant addition of translucence in the imaging model). When
72complete, the API is intended to support the complete imaging model of
73PDF 1.4.
74
75Cairo relies on the Xc library for backend rendering. Xc provides an
76abstract interface for rendering to multiple target types. As of this
77writing, Xc allows Cairo to target X drawables as well as generic
78image buffers. Future backends such as PostScript, PDF, and perhaps
79OpenGL are currently being planned.
80
81%package devel
82Summary:        Development files for Cairo library.
83Summary(ja):    Cairo ライブラリの開発用ファイル
84Group:          Development/Libraries
85Provides:       lib%{name}-devel = %{version}-%{release}
86Requires:       %{name} = %{version}
87Requires:       libpng-devel
88Requires:       freetype2-devel
89Requires:       fontconfig-devel
90Requires:       libX11-devel
91Requires:       libXrender-devel
92Requires:       pixman-devel
93Requires:       glib2-devel
94Requires:       mesa-libEGL-devel
95
96%description devel
97Development files for Cairo library.
98
99%package tools
100Summary: Development tools for cairo
101Group: Development/Tools
102
103%description tools
104Cairo is a 2D graphics library designed to provide high-quality display
105and print output.
106
107This package contains tools for working with the cairo graphics library.
108 * cairo-trace: Record cairo library calls for later playback
109
110
111%prep
112%setup -q
113%patch1 -p1 -b .dont-use-server-side-gradients
114
115%build
116%configure --disable-static \
117           --enable-gtk-doc \
118           --enable-xlib \
119           --enable-freetype \
120           --enable-ps \
121           --enable-pdf \
122           --enable-svg \
123           --enable-tee \
124           --enable-gobject \
125           --enable-gl
126
127%ifarch x86_64
128cp libtool libtool.old
129ldpath="/lib64 /usr/lib64 /usr/lib /usr/X11R6/lib64 /usr/X11R6/lib"
130sed "s|^sys_lib_search_path_spec=.*|sys_lib_search_path_spec=$ldpath|" libtool.old \
131        > libtool
132rm libtool.old
133%endif
134make
135
136%install
137rm -rf $RPM_BUILD_ROOT
138
139%makeinstall
140rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
141
142%clean
143rm -rf $RPM_BUILD_ROOT
144
145%post   -p /sbin/ldconfig
146%postun -p /sbin/ldconfig
147
148%post   -n compat32-%{name} -p /sbin/ldconfig
149%postun -n compat32-%{name} -p /sbin/ldconfig
150
151
152%files
153%defattr(644,root,root,755)
154%doc AUTHORS BUGS COPYING COPYING-* ChangeLog NEWS README
155%{_libdir}/lib*.so.*
156
157%files devel
158%defattr(644,root,root,755)
159%{_libdir}/lib*.so
160#{_libdir}/lib*.la
161%{_includedir}/*
162%{_libdir}/pkgconfig/*.pc
163#{_libdir}/lib*.a
164%{_datadir}/gtk-doc/html/cairo
165
166%files tools
167%defattr(-,root,root,-)
168%{_bindir}/cairo-trace
169%{_bindir}/cairo-sphinx
170%{_libdir}/cairo
171
172%if %{build_compat32}
173%files -n compat32-%{name}
174%defattr(644,root,root,755)
175%{_libdir}/lib*.so.*
176%endif
177
178%changelog
179* Fri Nov 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.6-1
180- new upstream release
181
182* Sat Oct 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.4-1
183- new upstream release
184
185* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-2
186- add Requires: mesa-libEGL-devel
187
188* Sat Jul 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-1
189- new upstream release
190- Enable OpenGL backend
191- add BR: librsvg2-devel, mesa-libGL-devel, mesa-libEGL-devel
192
193* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
194- new upstream release
195
196* Tue Mar 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-2
197- enable tee support
198- add configure options specifically
199- disable static library
200
201* Wed Jan 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
202- new upstream release
203- add BuildRequires: glib2-devel
204- add Requires: glib2-devel (devel package)
205
206* Wed Oct 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
207- add patch1 from ubuntu to fix performance regressions
208  - don't use serverside gradients, most drivers don't handle those and are
209    really slow, should workaround performances issues for ati, nouveau and nvidia
210    https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
211
212* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
213- new upstream release
214- add tools sub package
215
216* Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.10-3
217- add BuildRequires: fontconfig-devel
218- add Requires: fontconfig-devel (devel package)
219
220* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.8.10-2
221- build with rpm-4.8.1-1 for pkg-config file
222
223* Tue Mar  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.8.10-1
224- new upstream release
225
226* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
227- new upstream release
228
229* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.8.6-2
230- applied cairo-1.8.6-status-return-fix.patch from Gentoo Linux
231- added BuildRequires: gtk-doc
232
233* Sat Jan 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-1
234- new upstream release
235
236* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.4-1
237- new upstream release
238
239* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
240- new upstream release
241
242* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
243- new upstream release
244
245* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-1
246- new upstream release
247
248* Wed May 28 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.4-3
249- add  Requires: pixman-devel to -devel
250
251* Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-2
252- rebuilt with xorg-x11 7.3
253- spec in UTF-8
254
255* Thu May  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-1
256- new upstream release
257- removed lib*.la from devel package
258
259* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-1vl5
260- used %%{?_dist_release}
261
262* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-0vl1
263- new upstream release
264
265* Sun Dec  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.12-0vl1
266- new upstream release
267
268* Tue Jul 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.10-0vl1
269- new upstream release
270
271* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
272- new upstream release
273- remove BuildRequires: pango-devel, gtk2-devel
274  (these are only needed for testing)
275
276* Sat Mar 31 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.4.2-0vl1
277- upstream release
278- Patch30 and Patch40 is skipped (not working correctly)
279  but held in src.rpm
280- add BUGS, ROADMAP to %%doc
281- add BuildRequires: pango-devel, gtk2-devel
282
283* Tue Oct 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl2
284- rebuild without XOrg-compat70-devel
285- add BuildConflicts: XOrg-compat70-devel
286
287* Sun Oct 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl1
288- new upstream release
289- remove unneeded Patch20 which breaks 8bpp rendering (<BTS:297>)
290
291* Tue Sep 19 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl3
292- added Patch40 for 15bpp problem
293
294* Tue Sep  5 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl2
295- added ad-hoc Patch30 for 16bpp problem
296
297* Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
298- new upstream release
299
300* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
301- new upstream release
302
303* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
304- new upstream release
305
306* Sat May 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.2-0vl4
307- added compat32- package for x86_64 architecture support
308
309* Sun Mar 05 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
310- added x86_64 architecture support
311
312* Sat Dec 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
313- add Patch20 to fix broken desktop rendering on xorg-x11-6.9
314  - add X.Org 6.9.0 (6090000) to blacklist
315
316* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
317- new upstream release
318
319* Tue Oct 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl5
320- update Patch10
321
322* Sun Oct 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl4
323- add Patch10 to use embedded bitmap font if available.
324  (controllable by "embeddedbitmap" in fontconfig)
325
326* Thu Sep 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl3
327- rebuild with new fontconfig
328
329* Sun Sep 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl2
330- add Requires: libpng-devel, XOrg-devel, freetype2-devel
331  to devel package instead of BuildRequires (typo)
332- add Japanese summaries
333
334* Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
335- new upstream release
336- remove libpixman dependency (which is now included in cairo)
337- obsoletes libpixman <= 0.1.6
338- add more BuildRequires
339
340* Sat Aug 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.2-0vl1
341- new upstream version
342
343* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1-0vl1
344- new upstream version
345- fixed License (http://cairographics.org/introduction)
346
347* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
348- new upstream version
349- include gtk-doc files
350
351* Sun Jan 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
352- new upstream version
353- add Requires: libpixman
354
355* Mon Nov 01 2004 Satoshi MACHINO <machino@vinelinux.org> 0.2.0-0vl1
356- new upstream version (cairo-0.2.0)
357
358* Mon Oct 11 2004 Satoshi MACHINO <machino@vinelinux.org> 0.1.23-1vl1
359- rebuilt for VineLinux
360
361* Tue Jun 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.23-1mdk
362- 0.1.23
363- reenable libtoolize
364
365* Wed May  5 2004 G魚Waschk <waschk@linux-mandrake.com> 0.1.22-1mdk
366- fix devel provides
367- drop redundant buildrequires
368- requires new pixman
369- autoconf 2.5 macro
370- New release 0.1.22
371
372* Fri Feb 06 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-2mdk
373- build with X11
374
375* Sun Feb 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-1mdk
376- 0.1.17
377- provides cairo
378- drop patch, use --disable-xlib
379- buildrequires
380- don't run libtoolize
381
382* Sun Dec 14 2003 Marcel Pol <mpol@mandrake.org> 0.1.13-1mdk
383- initial mandrake package
384
Note: See TracBrowser for help on using the repository browser.