source: projects/specs/trunk/c/cairo/cairo-vl.spec @ 521

Revision 521, 9.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        Cairo - multi-platform 2D graphics library.
2Summary(ja):    Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
3Name:           cairo
4Version:        1.8.10
5Release:        1%{?_dist_release}
6License:        LGPL/MPL
7Group:          System Environment/Libraries
8Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
9
10URL:            http://cairographics.org/
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12
13BuildRequires: pkgconfig
14BuildRequires: pixman-devel
15BuildRequires: libpng-devel
16BuildRequires: freetype2-devel
17BuildRequires: libX11-devel
18BuildRequires: libXrender-devel
19BuildRequires: gtk-doc
20
21BuildConflicts: XOrg-compat70-devel
22
23%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
24
25%description
26Cairo provides anti-aliased vector-based rendering for X. Paths
27consist of line segments and cubic splines and can be rendered at any
28width with various join and cap styles. All colors may be specified
29with optional translucence (opacity/alpha) and combined using the
30extended Porter/Duff compositing algebra as found in the X Render
31Extension.
32
33Cairo exports a stateful rendering API similar in spirit to the path
34construction, text, and painting operators of PostScript, (with the
35significant addition of translucence in the imaging model). When
36complete, the API is intended to support the complete imaging model of
37PDF 1.4.
38
39Cairo relies on the Xc library for backend rendering. Xc provides an
40abstract interface for rendering to multiple target types. As of this
41writing, Xc allows Cairo to target X drawables as well as generic
42image buffers. Future backends such as PostScript, PDF, and perhaps
43OpenGL are currently being planned.
44
45%package -n compat32-%{name}
46Summary:        Cairo - multi-platform 2D graphics library.
47Summary(ja):    Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
48Group:          System Environment/Libraries
49Requires:       %{name} = %{version}
50
51%description -n compat32-%{name}
52Cairo provides anti-aliased vector-based rendering for X. Paths
53consist of line segments and cubic splines and can be rendered at any
54width with various join and cap styles. All colors may be specified
55with optional translucence (opacity/alpha) and combined using the
56extended Porter/Duff compositing algebra as found in the X Render
57Extension.
58
59Cairo exports a stateful rendering API similar in spirit to the path
60construction, text, and painting operators of PostScript, (with the
61significant addition of translucence in the imaging model). When
62complete, the API is intended to support the complete imaging model of
63PDF 1.4.
64
65Cairo relies on the Xc library for backend rendering. Xc provides an
66abstract interface for rendering to multiple target types. As of this
67writing, Xc allows Cairo to target X drawables as well as generic
68image buffers. Future backends such as PostScript, PDF, and perhaps
69OpenGL are currently being planned.
70
71%package devel
72Summary:        Development files for Cairo library.
73Summary(ja):    Cairo ライブラリの開発用ファイル
74Group:          Development/Libraries
75Provides:       lib%{name}-devel = %{version}-%{release}
76Requires:       %{name} = %{version}
77Requires:       libpng-devel
78Requires:       freetype2-devel
79Requires:       libX11-devel
80Requires:       libXrender-devel
81Requires:       pixman-devel
82
83%description devel
84Development files for Cairo library.
85
86
87%prep
88%setup -q
89
90%build
91%configure --enable-gtk-doc
92%ifarch x86_64
93cp libtool libtool.old
94ldpath="/lib64 /usr/lib64 /usr/lib /usr/X11R6/lib64 /usr/X11R6/lib"
95sed "s|^sys_lib_search_path_spec=.*|sys_lib_search_path_spec=$ldpath|" libtool.old \
96        > libtool
97rm libtool.old
98%endif
99make
100
101%install
102rm -rf $RPM_BUILD_ROOT
103
104%makeinstall
105rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%post   -p /sbin/ldconfig
111%postun -p /sbin/ldconfig
112
113%post   -n compat32-%{name} -p /sbin/ldconfig
114%postun -n compat32-%{name} -p /sbin/ldconfig
115
116
117%files
118%defattr(644,root,root,755)
119%doc AUTHORS BUGS COPYING COPYING-* ChangeLog NEWS README
120%{_libdir}/lib*.so.*
121
122%files devel
123%defattr(644,root,root,755)
124%{_libdir}/lib*.so
125#{_libdir}/lib*.la
126%{_includedir}/*
127%{_libdir}/pkgconfig/*.pc
128%{_libdir}/lib*.a
129%{_datadir}/gtk-doc/html/cairo
130
131%if %{build_compat32}
132%files -n compat32-%{name}
133%defattr(644,root,root,755)
134%{_libdir}/lib*.so.*
135%endif
136
137%changelog
138* Tue Mar  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.8.10-1
139- new upstream release
140
141* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
142- new upstream release
143
144* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.8.6-2
145- applied cairo-1.8.6-status-return-fix.patch from Gentoo Linux
146- added BuildRequires: gtk-doc
147
148* Sat Jan 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-1
149- new upstream release
150
151* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.4-1
152- new upstream release
153
154* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
155- new upstream release
156
157* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
158- new upstream release
159
160* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-1
161- new upstream release
162
163* Wed May 28 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.4-3
164- add  Requires: pixman-devel to -devel
165
166* Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-2
167- rebuilt with xorg-x11 7.3
168- spec in UTF-8
169
170* Thu May  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-1
171- new upstream release
172- removed lib*.la from devel package
173
174* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-1vl5
175- used %%{?_dist_release}
176
177* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-0vl1
178- new upstream release
179
180* Sun Dec  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.12-0vl1
181- new upstream release
182
183* Tue Jul 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.10-0vl1
184- new upstream release
185
186* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
187- new upstream release
188- remove BuildRequires: pango-devel, gtk2-devel
189  (these are only needed for testing)
190
191* Sat Mar 31 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.4.2-0vl1
192- upstream release
193- Patch30 and Patch40 is skipped (not working correctly)
194  but held in src.rpm
195- add BUGS, ROADMAP to %%doc
196- add BuildRequires: pango-devel, gtk2-devel
197
198* Tue Oct 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl2
199- rebuild without XOrg-compat70-devel
200- add BuildConflicts: XOrg-compat70-devel
201
202* Sun Oct 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl1
203- new upstream release
204- remove unneeded Patch20 which breaks 8bpp rendering (<BTS:297>)
205
206* Tue Sep 19 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl3
207- added Patch40 for 15bpp problem
208
209* Tue Sep  5 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl2
210- added ad-hoc Patch30 for 16bpp problem
211
212* Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
213- new upstream release
214
215* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
216- new upstream release
217
218* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
219- new upstream release
220
221* Sat May 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.2-0vl4
222- added compat32- package for x86_64 architecture support
223
224* Sun Mar 05 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
225- added x86_64 architecture support
226
227* Sat Dec 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
228- add Patch20 to fix broken desktop rendering on xorg-x11-6.9
229  - add X.Org 6.9.0 (6090000) to blacklist
230
231* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
232- new upstream release
233
234* Tue Oct 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl5
235- update Patch10
236
237* Sun Oct 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl4
238- add Patch10 to use embedded bitmap font if available.
239  (controllable by "embeddedbitmap" in fontconfig)
240
241* Thu Sep 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl3
242- rebuild with new fontconfig
243
244* Sun Sep 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl2
245- add Requires: libpng-devel, XOrg-devel, freetype2-devel
246  to devel package instead of BuildRequires (typo)
247- add Japanese summaries
248
249* Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
250- new upstream release
251- remove libpixman dependency (which is now included in cairo)
252- obsoletes libpixman <= 0.1.6
253- add more BuildRequires
254
255* Sat Aug 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.2-0vl1
256- new upstream version
257
258* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1-0vl1
259- new upstream version
260- fixed License (http://cairographics.org/introduction)
261
262* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
263- new upstream version
264- include gtk-doc files
265
266* Sun Jan 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
267- new upstream version
268- add Requires: libpixman
269
270* Mon Nov 01 2004 Satoshi MACHINO <machino@vinelinux.org> 0.2.0-0vl1
271- new upstream version (cairo-0.2.0)
272
273* Mon Oct 11 2004 Satoshi MACHINO <machino@vinelinux.org> 0.1.23-1vl1
274- rebuilt for VineLinux
275
276* Tue Jun 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.23-1mdk
277- 0.1.23
278- reenable libtoolize
279
280* Wed May  5 2004 G魚Waschk <waschk@linux-mandrake.com> 0.1.22-1mdk
281- fix devel provides
282- drop redundant buildrequires
283- requires new pixman
284- autoconf 2.5 macro
285- New release 0.1.22
286
287* Fri Feb 06 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-2mdk
288- build with X11
289
290* Sun Feb 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-1mdk
291- 0.1.17
292- provides cairo
293- drop patch, use --disable-xlib
294- buildrequires
295- don't run libtoolize
296
297* Sun Dec 14 2003 Marcel Pol <mpol@mandrake.org> 0.1.13-1mdk
298- initial mandrake package
299
Note: See TracBrowser for help on using the repository browser.