source: projects/specs/trunk/c/cairo/cairo-vl.spec @ 6011

Revision 6011, 11.4 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

RevLine 
[521]1Summary:        Cairo - multi-platform 2D graphics library.
2Summary(ja):    Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
3Name:           cairo
[6011]4Version:        1.12.0
5Release:        1%{?_dist_release}
[521]6License:        LGPL/MPL
7Group:          System Environment/Libraries
8Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
9
[2052]10# don't use serverside gradients, most drivers don't handle those and are
11# really slow, should workaround performances issues for ati, nouveau and nvidia
12# https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
13Patch1:         cairo-1.10.0-dont_use_server_side_gradients.patch
14
[521]15URL:            http://cairographics.org/
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires: pkgconfig
19BuildRequires: pixman-devel
[2444]20BuildRequires: glib2-devel
[521]21BuildRequires: libpng-devel
22BuildRequires: freetype2-devel
[1864]23BuildRequires: fontconfig-devel
[521]24BuildRequires: libX11-devel
25BuildRequires: libXrender-devel
26BuildRequires: gtk-doc
27
28BuildConflicts: XOrg-compat70-devel
29
30%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
31
32%description
33Cairo provides anti-aliased vector-based rendering for X. Paths
34consist of line segments and cubic splines and can be rendered at any
35width with various join and cap styles. All colors may be specified
36with optional translucence (opacity/alpha) and combined using the
37extended Porter/Duff compositing algebra as found in the X Render
38Extension.
39
40Cairo exports a stateful rendering API similar in spirit to the path
41construction, text, and painting operators of PostScript, (with the
42significant addition of translucence in the imaging model). When
43complete, the API is intended to support the complete imaging model of
44PDF 1.4.
45
46Cairo relies on the Xc library for backend rendering. Xc provides an
47abstract interface for rendering to multiple target types. As of this
48writing, Xc allows Cairo to target X drawables as well as generic
49image buffers. Future backends such as PostScript, PDF, and perhaps
50OpenGL are currently being planned.
51
52%package -n compat32-%{name}
53Summary:        Cairo - multi-platform 2D graphics library.
54Summary(ja):    Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
55Group:          System Environment/Libraries
56Requires:       %{name} = %{version}
57
58%description -n compat32-%{name}
59Cairo provides anti-aliased vector-based rendering for X. Paths
60consist of line segments and cubic splines and can be rendered at any
61width with various join and cap styles. All colors may be specified
62with optional translucence (opacity/alpha) and combined using the
63extended Porter/Duff compositing algebra as found in the X Render
64Extension.
65
66Cairo exports a stateful rendering API similar in spirit to the path
67construction, text, and painting operators of PostScript, (with the
68significant addition of translucence in the imaging model). When
69complete, the API is intended to support the complete imaging model of
70PDF 1.4.
71
72Cairo relies on the Xc library for backend rendering. Xc provides an
73abstract interface for rendering to multiple target types. As of this
74writing, Xc allows Cairo to target X drawables as well as generic
75image buffers. Future backends such as PostScript, PDF, and perhaps
76OpenGL are currently being planned.
77
78%package devel
79Summary:        Development files for Cairo library.
80Summary(ja):    Cairo ライブラリの開発用ファイル
81Group:          Development/Libraries
82Provides:       lib%{name}-devel = %{version}-%{release}
83Requires:       %{name} = %{version}
84Requires:       libpng-devel
85Requires:       freetype2-devel
[1864]86Requires:       fontconfig-devel
[521]87Requires:       libX11-devel
88Requires:       libXrender-devel
89Requires:       pixman-devel
[2444]90Requires:       glib2-devel
[521]91
92%description devel
93Development files for Cairo library.
94
[2041]95%package tools
96Summary: Development tools for cairo
97Group: Development/Tools
[521]98
[2041]99%description tools
100Cairo is a 2D graphics library designed to provide high-quality display
101and print output.
102
103This package contains tools for working with the cairo graphics library.
104 * cairo-trace: Record cairo library calls for later playback
105
106
[521]107%prep
108%setup -q
[2052]109%patch1 -p1 -b .dont-use-server-side-gradients
[521]110
111%build
[3191]112%configure --disable-static \
113           --enable-gtk-doc \
114           --enable-xlib \
115           --enable-freetype \
116           --enable-ps \
117           --enable-pdf \
118           --enable-svg \
119           --enable-tee \
120           --enable-gobject
121
[521]122%ifarch x86_64
123cp libtool libtool.old
124ldpath="/lib64 /usr/lib64 /usr/lib /usr/X11R6/lib64 /usr/X11R6/lib"
125sed "s|^sys_lib_search_path_spec=.*|sys_lib_search_path_spec=$ldpath|" libtool.old \
126        > libtool
127rm libtool.old
128%endif
129make
130
131%install
132rm -rf $RPM_BUILD_ROOT
133
134%makeinstall
135rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
136
137%clean
138rm -rf $RPM_BUILD_ROOT
139
140%post   -p /sbin/ldconfig
141%postun -p /sbin/ldconfig
142
143%post   -n compat32-%{name} -p /sbin/ldconfig
144%postun -n compat32-%{name} -p /sbin/ldconfig
145
146
147%files
148%defattr(644,root,root,755)
149%doc AUTHORS BUGS COPYING COPYING-* ChangeLog NEWS README
150%{_libdir}/lib*.so.*
151
152%files devel
153%defattr(644,root,root,755)
154%{_libdir}/lib*.so
155#{_libdir}/lib*.la
156%{_includedir}/*
157%{_libdir}/pkgconfig/*.pc
[3191]158#{_libdir}/lib*.a
[521]159%{_datadir}/gtk-doc/html/cairo
160
[2041]161%files tools
162%defattr(-,root,root,-)
163%{_bindir}/cairo-trace
[6011]164%{_bindir}/cairo-sphinx
[2041]165%{_libdir}/cairo
166
[521]167%if %{build_compat32}
168%files -n compat32-%{name}
169%defattr(644,root,root,755)
170%{_libdir}/lib*.so.*
171%endif
172
173%changelog
[6011]174* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
175- new upstream release
176
[3191]177* Tue Mar 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-2
178- enable tee support
179- add configure options specifically
180- disable static library
181
[2444]182* Wed Jan 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
183- new upstream release
184- add BuildRequires: glib2-devel
185- add Requires: glib2-devel (devel package)
186
[2052]187* Wed Oct 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
188- add patch1 from ubuntu to fix performance regressions
189  - don't use serverside gradients, most drivers don't handle those and are
190    really slow, should workaround performances issues for ati, nouveau and nvidia
191    https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
192
[2041]193* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
194- new upstream release
195- add tools sub package
196
[1864]197* Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.10-3
198- add BuildRequires: fontconfig-devel
199- add Requires: fontconfig-devel (devel package)
200
[1851]201* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.8.10-2
202- build with rpm-4.8.1-1 for pkg-config file
203
[521]204* Tue Mar  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.8.10-1
205- new upstream release
206
207* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
208- new upstream release
209
210* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.8.6-2
211- applied cairo-1.8.6-status-return-fix.patch from Gentoo Linux
212- added BuildRequires: gtk-doc
213
214* Sat Jan 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-1
215- new upstream release
216
217* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.4-1
218- new upstream release
219
220* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
221- new upstream release
222
223* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
224- new upstream release
225
226* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-1
227- new upstream release
228
229* Wed May 28 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.4-3
230- add  Requires: pixman-devel to -devel
231
232* Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-2
233- rebuilt with xorg-x11 7.3
234- spec in UTF-8
235
236* Thu May  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-1
237- new upstream release
238- removed lib*.la from devel package
239
240* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-1vl5
241- used %%{?_dist_release}
242
243* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-0vl1
244- new upstream release
245
246* Sun Dec  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.12-0vl1
247- new upstream release
248
249* Tue Jul 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.10-0vl1
250- new upstream release
251
252* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
253- new upstream release
254- remove BuildRequires: pango-devel, gtk2-devel
255  (these are only needed for testing)
256
257* Sat Mar 31 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.4.2-0vl1
258- upstream release
259- Patch30 and Patch40 is skipped (not working correctly)
260  but held in src.rpm
261- add BUGS, ROADMAP to %%doc
262- add BuildRequires: pango-devel, gtk2-devel
263
264* Tue Oct 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl2
265- rebuild without XOrg-compat70-devel
266- add BuildConflicts: XOrg-compat70-devel
267
268* Sun Oct 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl1
269- new upstream release
270- remove unneeded Patch20 which breaks 8bpp rendering (<BTS:297>)
271
272* Tue Sep 19 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl3
273- added Patch40 for 15bpp problem
274
275* Tue Sep  5 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl2
276- added ad-hoc Patch30 for 16bpp problem
277
278* Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
279- new upstream release
280
281* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
282- new upstream release
283
284* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
285- new upstream release
286
287* Sat May 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.2-0vl4
288- added compat32- package for x86_64 architecture support
289
290* Sun Mar 05 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
291- added x86_64 architecture support
292
293* Sat Dec 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
294- add Patch20 to fix broken desktop rendering on xorg-x11-6.9
295  - add X.Org 6.9.0 (6090000) to blacklist
296
297* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
298- new upstream release
299
300* Tue Oct 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl5
301- update Patch10
302
303* Sun Oct 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl4
304- add Patch10 to use embedded bitmap font if available.
305  (controllable by "embeddedbitmap" in fontconfig)
306
307* Thu Sep 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl3
308- rebuild with new fontconfig
309
310* Sun Sep 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl2
311- add Requires: libpng-devel, XOrg-devel, freetype2-devel
312  to devel package instead of BuildRequires (typo)
313- add Japanese summaries
314
315* Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
316- new upstream release
317- remove libpixman dependency (which is now included in cairo)
318- obsoletes libpixman <= 0.1.6
319- add more BuildRequires
320
321* Sat Aug 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.2-0vl1
322- new upstream version
323
324* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1-0vl1
325- new upstream version
326- fixed License (http://cairographics.org/introduction)
327
328* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
329- new upstream version
330- include gtk-doc files
331
332* Sun Jan 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
333- new upstream version
334- add Requires: libpixman
335
336* Mon Nov 01 2004 Satoshi MACHINO <machino@vinelinux.org> 0.2.0-0vl1
337- new upstream version (cairo-0.2.0)
338
339* Mon Oct 11 2004 Satoshi MACHINO <machino@vinelinux.org> 0.1.23-1vl1
340- rebuilt for VineLinux
341
342* Tue Jun 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.23-1mdk
343- 0.1.23
344- reenable libtoolize
345
346* Wed May  5 2004 G魚Waschk <waschk@linux-mandrake.com> 0.1.22-1mdk
347- fix devel provides
348- drop redundant buildrequires
349- requires new pixman
350- autoconf 2.5 macro
351- New release 0.1.22
352
353* Fri Feb 06 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-2mdk
354- build with X11
355
356* Sun Feb 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-1mdk
357- 0.1.17
358- provides cairo
359- drop patch, use --disable-xlib
360- buildrequires
361- don't run libtoolize
362
363* Sun Dec 14 2003 Marcel Pol <mpol@mandrake.org> 0.1.13-1mdk
364- initial mandrake package
365
Note: See TracBrowser for help on using the repository browser.