source: projects/specs/trunk/c/caching-nameserver/caching-nameserver-vl.spec @ 521

Revision 521, 5.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: The configuration files for setting up a caching name server.
2Summary(ja): キャッシュネームサーバ用の設定ファイル
3Name: caching-nameserver
4Version: 7.1
5Release: 4%{?_dist_release}
6License: Public Domain
7Group: System Environment/Daemons
8Source0: ftp://ftp.internic.com/domain/named.root
9Source2: named.local
10Source3: named.conf
11Source4: Copyright.caching-nameserver
12Source5: localhost.zone
13Requires: bind
14Prereq: bind textutils grep
15BuildRoot: %{_tmppath}/caching-nameserver-root
16BuildArch: noarch
17
18%description
19The caching-nameserver package includes the configuration files which
20will make BIND, the DNS name server, act as a simple caching nameserver.
21Many users on dialup connections use this package along with BIND for
22such a purpose.
23
24If you would like to set up a caching name server, you'll need to install
25the caching-nameserver package; you'll also need to install bind.
26
27%description -l ja
28caching-nameserver パッケージは BIND (DNS ネームサーバ) をシンプルな
29キャッシュサーバとして動作させるための設定ファイルを含んでいます。
30ダイアルアップで接続している多くのユーザーは、上記のような目的でこの
31パッケージを BIND と一緒に使用しています。
32
33もしあなたがキャッシュネームサーバを利用したい場合は、このパッケージを
34インストールする必要があります。また BIND も一緒にインストールする必要
35があります。
36
37
38%prep
39%setup -c -T
40
41%install
42rm -rf $RPM_BUILD_ROOT
43mkdir -p $RPM_BUILD_ROOT/{etc,var/named}
44
45install -m 644 %{SOURCE0} $RPM_BUILD_ROOT/var/named/named.ca
46install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/var/named/named.local
47install -m 644 %{SOURCE5} $RPM_BUILD_ROOT/var/named/localhost.zone
48install -m 644 %{SOURCE3} $RPM_BUILD_ROOT/etc/named.conf
49install -m 644 %{SOURCE4} ./Copyright
50
51%clean
52rm -rf $RPM_BUILD_ROOT
53
54%post
55if ! grep ^nameserver /etc/resolv.conf >/dev/null 2>&1 ; then
56    echo "nameserver 127.0.0.1" >> /etc/resolv.conf
57fi
58if ! grep -q "^key" /etc/named.conf; then
59  if [ -f /etc/rndc.conf ]; then
60    KEY=`cat /etc/rndc.conf |grep secret |head -n1`
61    if [ -n "$KEY" ]; then
62cat >>/etc/named.conf <<EOF
63key "key" {
64        algorithm hmac-md5;
65$KEY
66};
67EOF
68    fi
69  fi
70fi
71
72%files
73%defattr(-,root,root)
74%config(noreplace) /etc/named.conf
75%defattr(-,named,named)
76%config /var/named/named.ca
77%config /var/named/named.local
78%config /var/named/localhost.zone
79%defattr(-,root,root)
80%doc Copyright
81
82%changelog
83* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 7.1-4vl5
84- applied new versioning policy, spec in utf-8
85
86* Mon Nov 26 2007 IWAI, Masaharu <iwai@alib.jp> 7.1-3vl8
87- update named.root (Source0) for changing the L.ROOTSERVERS.NET's IP Address.
88
89* Mon Jul 16 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp>  7.1-3vl7
90- rebuild with new toolchains and environment.
91- s/Copyright/License/
92- add japanese description and summary.
93
94* Sun Jul 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 7.1-3vl6
95- rebuilt
96
97* Fri Feb 13 2004 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 7.1-3vl5
98- update named.root (zone serial # 2004012900)
99
100* Thu Nov 14 2002 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 7.1-3vl4
101- update named.root (zone serial # 2002110501) from internic
102
103* Thu Nov 14 2002 IWAI Masaharu <iwai@alib.jp> 7.1-3vl3
104- update named.root (Source0) for changing the J.ROOTSERVERS.NET's IP Address.
105
106* Wed Jun  6 2001 Jun Nishii <jun@vinelinux.org>
107- 7.1-3vl2
108- check the existence of rndc.conf in %post script
109
110* Thu May 31 2001 Jun Nishii <jun@vinelinux.org>
111- 7.1-3vl1
112- build for VineSeed
113
114* Tue Mar 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
115- Remove extra ";" (#31382)
116
117* Thu Mar  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
118- Don't add key { } stuff if it's already there
119  (e.g. update from beta to final)
120
121* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
122- Add key { } stuff to named.conf so rndc works out of the box
123
124* Mon Feb 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
125- change to noreplace configs in /etc #21651
126
127* Tue Aug  8 2000 Florian La Roche <Florian.LaRoche@redhat.com>
128- docu owned by root now
129
130* Mon Aug  7 2000 Florian La Roche <Florian.LaRoche@redhat.com>
131- add default TTL to shut up warning message
132- add "localhost" zone
133
134* Sun Aug  6 2000 Florian La Roche <Florian.LaRoche@redhat.com>
135- changing /var/named/* to root was silly - reverted
136
137* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
138- automatic rebuild
139
140* Mon Jul  3 2000 Florian La Roche <Florian.LaRoche@redhat.com>
141- change ownerships back to root:root. normally nobody should
142  need to change these files and they never have to be updated
143  by the named server himself.
144
145* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
146- rebuild in new environment
147
148* Tue Apr 18 2000 Nalin Dahyabhai <nalin@redhat.com>
149- change ownerships to named.named
150
151* Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
152- if there are no nameserver lines in /etc/resolv.conf, add one
153- add a Copyright file
154
155* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
156- auto rebuild in the new build environment (release 2)
157
158* Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
159- rebuilt for the 6.0
160
161* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
162- install bind-8.1.2 named.conf
163
164* Mon May 04 1998 Donnie Barnes <djb@redhat.com>
165- upgraded from 1.1 to 5.1 to make caching-nameserver version the same
166  as the version of Red Hat that it runs on. 
167- updated named.root
168
169* Wed Oct 15 1997 Donnie Barnes <djb@redhat.com>
170- updated named.root to latest
171- updated copyright
172
173* Tue Sep 23 1997 Erik Troan <ewt@redhat.com>
174- made a noarch package
Note: See TracBrowser for help on using the repository browser.