source: projects/specs/trunk/c/cabextract/cabextract-vl.spec @ 521

Revision 521, 2.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define pkg_major_version 1.2
2%define pkg_name cabextract
3%define pkg_release 2%{?_dist_release}
4%define tarball %(cd %{_sourcedir};ls %{pkg_name}-%{pkg_major_version}.tar.gz | tail -n 1)
5## PAR_define pkg_minor_version %(echo %{tarball} | cut -d '.' -f3 | tr -d 0)
6
7# NEW Release: numbering rule. -- Release: 1%{?_dist_release}
8
9Summary: A program to extract Microsoft Cabinet files
10Summary(ja): Microsoftキャビネットファイルを抽出するプログラム
11Name: %{pkg_name}
12Version: %{pkg_major_version}
13Release: %{pkg_release}
14License: GPL
15Group: Applications/Archiving
16Source: http://www.kyz.uklinux.net/downloads/%{name}-%{version}.tar.gz
17URL: http://www.kyz.uklinux.net/cabextract.php
18Vendor: Stuart Caie
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20Prefix: /usr
21
22#--------------------------------------------------------------------
23%description
24Cabinet (.CAB) files are a form of archive, which Microsoft use to
25distribute their software, and things like Windows Font Packs. The
26cabextract program unpacks these files.
27
28%description -l ja
29Microsoft社の配布するソフトウェア、例えば Windowsフォントパック等で
30使用されているキャビネット(.CAB)形式のアーカイブファイルがあります。
31cabextractプログラムはこれらのファイルの解凍を行います。
32
33#--------------------------------------------------------------------
34%prep
35%setup
36
37%build
38CFLAGS=${RPM_OPT_FLAGS} ./configure --prefix=%{prefix}
39make
40
41%install
42rm -rf ${RPM_BUILD_ROOT}
43%makeinstall
44
45%clean
46[ ${RPM_BUILD_ROOT} != "/" ] && rm -rf ${RPM_BUILD_ROOT}
47
48#--------------------------------------------------------------------
49%files
50%defattr(0644, root, root, 0755)
51%doc AUTHORS ChangeLog NEWS README
52%attr(0755, root, root) %{_bindir}/cabextract
53%{_mandir}/man1/cabextract.1*
54
55#--------------------------------------------------------------------
56%changelog
57* Fri Jul 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.2-2
58- spec in UTF-8
59
60* Mon Mar 24 2008 Seiichirou Babasaki 1.2
61- Import cabextract - Packager: Babasaki
62- Updated specfile
Note: See TracBrowser for help on using the repository browser.