source: projects/specs/trunk/c/cabal-install/cabal-install.vl.spec @ 10156

Revision 10156, 1.6 KB checked in by ara_t, 8 years ago (diff)

A command-line program simplifies the process of managing Haskell software

Line 
1%define pkg_name    cabal-install
2%define pkg_version 1.22.8.0
3%define pkg_release 3%{?_dist_release}
4
5Summary: A command-line program simplifies the process of managing Haskell software
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: BSD3
11Group:   Applications/Languages
12URL:     http://hackage.haskell.org
13Source0: cabal-install-%{pkg_version}.tar.gz
14
15BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
16
17BuildRequires: ghc
18BuildRequires: haskell-platform-base cabal-install
19BuildRequires: libffi-devel gmp-devel zlib-devel
20Requires: ghc
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: ara_t
25
26
27%description
28The 'cabal' command-line program simplifies the process of
29managing Haskell software by automating the fetching, configuration,
30compilation and installation of Haskell libraries and programs.
31
32
33%prep
34%{__rm} -rf ${RPM_BUILD_ROOT}
35%setup -q
36
37%build
38cabal configure --prefix=%{_usr} \
39                --docdir=%{_docdir}/%{name}-%{version}
40cabal build
41
42%install
43cabal copy --destdir=${RPM_BUILD_ROOT}
44%{__rm} -rf ${RPM_BUILD_ROOT}%{_libdir}
45
46%clean
47%{__rm} -rf ${RPM_BUILD_ROOT}
48
49
50%files
51%defattr(-, root, root)
52%doc changelog LICENSE README.md
53%{_bindir}/
54
55
56%changelog
57* Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 1.22.8.0-2
58- correct SPEC file
59
60* Sat Feb 20 2016 Toshiaki Ara <ara_t@384.jp> 1.22.8.0-2
61- rebuild under ghc-7.10.3 and haskell-platform-2015.7.10.3
62
63* Mon Feb 15 2016 Toshiaki Ara <ara_t@384.jp> 1.22.8.0-1
64- update to 1.22.8.0
65
66* Thu Feb 11 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-2
67- correct Requires
68
69* Thu Feb 11 2016 Toshiaki Ara <ara_t@384.jp> 1.16.0.2-1
70- subpackage of haskell-platform
71
Note: See TracBrowser for help on using the repository browser.