source: projects/specs/trunk/b/bzip2/bzip2-vl.spec @ 6596

Revision 6596, 8.8 KB checked in by daisuke, 12 years ago (diff)

update to 1.0.6

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define buildpdf 0
3
4Summary:     A file compression utility.
5Summary(ja): ファイル圧縮ユーティリティ
6Name: bzip2
7Version: 1.0.6
8Release: 1%{?_dist_release}
9License: BSD
10Group: Applications/Archiving
11URL: http://www.bzip.org/
12Source: http://www.bzip.org/%{version}/bzip2-%{version}.tar.gz
13Patch0: bzip2-1.0.5-autoconflibtoolize.patch
14Patch1: bzip2-1.0.4-saneso.patch
15Patch2: bzip2-1.0.4-cflags.patch
16Patch3: bzip2-1.0.4-bzip2recover.patch
17
18# P2 implements a progress counter (in %). It also
19# display the percentage of the original file the new file is (size).
20# URL: http://www.vanheusden.com/Linux/bzip2-1.0.2.diff.gz
21Patch10: bzip2-1.0.2.diff.bz2
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24
25%if %buildpdf
26BuildRequires: tetex-dvips tetex-latex
27%endif
28BuildRequires: texinfo
29
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%description
34Bzip2 is a freely available, patent-free, high quality data compressor.
35Bzip2 compresses files to within 10 to 15 percent of the capabilities
36of the best techniques available.  However, bzip2 has the added benefit
37of being approximately two times faster at compression and six times
38faster at decompression than those techniques.  Bzip2 is not the
39fastest compression utility, but it does strike a balance between speed
40and compression capability.
41
42Install bzip2 if you need a compression utility.
43
44
45%package devel
46Summary: Header files and libraries for developing apps which will use bzip2.
47Summary(ja): bzip2 を使うプログラム開発に必要なヘッダファイルとライブラリ
48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50
51%description devel
52Header files and a static library of bzip2 functions, for developing apps
53which will use the library.
54
55## to build compat32 for x86_64 architecture support
56%package -n compat32-%{name}
57Summary: A file compression utility.
58Summary(ja): ファイル圧縮ユーティリティ
59Group: System Environment/Libraries
60Requires: %{name} = %{version}-%{release}
61
62%description -n compat32-%{name}
63Bzip2 is a freely available, patent-free, high quality data compressor.
64Bzip2 compresses files to within 10 to 15 percent of the capabilities
65of the best techniques available.  However, bzip2 has the added benefit
66of being approximately two times faster at compression and six times
67faster at decompression than those techniques.  Bzip2 is not the
68fastest compression utility, but it does strike a balance between speed
69and compression capability.
70
71Install bzip2 if you need a compression utility.
72
73%package -n compat32-%{name}-devel
74Summary: Header files and libraries for developing apps which will use bzip2.
75Summary(ja): bzip2 を使うプログラム開発に必要なヘッダファイルとライブラリ
76Group: Development/Libraries
77Requires: compat32-%{name} = %{version}-%{release}
78Requires: %{name}-devel = %{version}-%{release}
79
80%description -n compat32-%{name}-devel
81Header files and a static library of bzip2 functions, for developing apps
82which will use the library.
83
84%prep
85%setup -q
86
87%patch0 -p1 -b .autoconf
88%patch1 -p1 -b .saneso
89%patch2 -p1 -b .cflags
90%patch3 -p1 -b .bz2recover
91
92%patch10 -p1
93
94cp CHANGES ChangeLog
95mv CHANGES NEWS
96mv LICENSE COPYING
97cp m4/largefile.m4 .
98chmod a+x configure
99libtoolize -f --automake
100aclocal
101autoconf
102automake -a --foreign
103autoheader
104
105%build
106%configure --libdir=%{_libdir} --enable-shared --disable-static
107make
108
109%if %buildpdf
110texi2dvi --pdf manual.texi
111%endif
112
113%install
114rm -rf %{buildroot}
115
116%makeinstall
117
118cp bzgrep %{buildroot}%{_bindir}
119chmod 0755 %{buildroot}%{_bindir}/bzgrep
120
121rm -f %{buildroot}%{_libdir}/*.{a,la}
122
123%post -p /sbin/ldconfig
124
125%postun -p /sbin/ldconfig
126
127%post -n compat32-%{name} -p /sbin/ldconfig
128
129%postun -n compat32-%{name} -p /sbin/ldconfig
130
131%clean
132rm -rf %{buildroot}
133
134%files
135%defattr(-,root,root)
136%doc AUTHORS COPYING README README.COMPILATION.PROBLEMS NEWS ChangeLog
137%{_bindir}/*
138%{_mandir}/*/*
139%{_libdir}/*so.*
140
141%files devel
142%defattr(-,root,root)
143%{_includedir}/*
144%{_libdir}/*so
145
146## to build compat32 for x86_64 architecture support
147%if %{build_compat32}
148%files -n compat32-%{name}
149%defattr(-,root,root)
150%{_libdir}/*so.*
151
152%files -n compat32-%{name}-devel
153%defattr(-,root,root)
154%{_libdir}/*so
155%endif
156
157%changelog
158* Sat Jul 14 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
159- update to 1.0.6
160
161* Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 1.0.5-5vl6
162- build on current VineSeed
163- update URL and Source0 tags URL
164
165* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-4
166- rebuild with new toolchain
167
168* Sun Jul 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.5-3
169- updated Patch0: bzip2-1.0.5-autoconflibtoolize.patch
170- removed unneccesary %if !%{build_compat32} case condition
171
172* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-2
173- spec in utf-8
174- remove static library
175
176* Thu Mar 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-1
177- new upstream release with security fix
178- drop old patches (patch3-6) which are included in new release
179- build under new versioning policy
180
181* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl2
182- changed Group to Applications/Archiving
183- changed compat32-bzip2 Group to System Environment/Libraries
184
185* Tue Feb 21 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.3-0vl1
186- new upstream release
187- add Patch3-6 from Fedora Core (includes CAN-2005-0758/0953)
188
189* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl5
190- fixed %%postun (missing to build as scriptlet by invalid comment)
191
192* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl4
193- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
194
195* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
196- added compat32- packages for x86_64 architecture support
197- changed autoconf-2.13 to current autoconf
198
199* Mon May 05 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0.2-0vl2
200- added patch 1 from Rawhide 1.0.2-8
201- added patch 2 from Mandrake 1.0.2-14mdk
202
203* Sun Sep 29 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.0.2-0vl1
204- previous patch is so incomplete that "bzip2 -f" fails.
205  instead, update the source which fixes this and other bugs.
206
207* Fri May 24 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
208- fix race condition.
209
210* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
211- 1.0.1-3vl2
212- added Japanese summary
213- rebuilt under new %%{_mandir} definition
214
215* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 1.0.1-3vl1
216- build on Vine Linux with gcc-2.95.3
217- partially used rpmmacros
218 
219* Fri Jul 21 2000 Trond Eivind Glomsr <teg@redhat.com>
220- new URL and source location
221
222* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
223- automatic rebuild
224
225* Sat Jul 01 2000 Trond Eivind Glomsr <teg@redhat.com>
226- 1.0.1
227- ported my patch
228
229* Tue Jun 13 2000 Jeff Johnson <jbj@redhat.com>
230- FHS packaging to build on solaris2.5.1.
231- remove config.cache from autoconf patch.
232- sparc: use %%configure, but not the m4 macros.
233
234* Tue Jun 06 2000 Trond Eivind Glomsr <teg@redhat.com>
235- Use %%configure, %%makeinstall, %%{_manpath} and %%{_tmpdir}
236
237* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
238- 1.0.0 - ported my 1.0pre8 libtoolizedautoconf patch
239
240* Tue May 16 2000 Trond Eivind Glomsr <teg@redhat.com>
241- use soft links, not hardlinks, for binaries
242- mv .so to devel
243
244* Mon May 15 2000 Trond Eivind Glomsr <teg@redhat.com>
245- autoconfed and libtoolized package
246- fixed Copyright (it's BSD, not GPL)
247- dumped bzless (less works fine with bz2-files)
248- rewrote build and install parts
249- separated main package and devel package
250
251* Mon May  8 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
252- 1.0pre8
253
254* Fri Apr 14 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
255- Add bzgrep (a version of zgrep hacked to do bzip2)
256
257* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
258- handle compressed manpages
259
260* Fri Dec 31 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
261- 0.9.5d
262- Update download URL, add URL: tag in header
263
264* Tue Aug 10 1999 Jeff Johnson <jbj@redhat.com>
265- upgrade to 0.9.5c.
266
267* Mon Aug  9 1999 Bill Nottingham <notting@redhat.com>
268- install actual bzip2 binary, not libtool cruft.
269
270* Sun Aug  8 1999 Jeff Johnson <jbj@redhat.com>
271- run ldconfig to get shared library.
272
273* Mon Aug  2 1999 Jeff Johnson <jbj@redhat.com>
274- create shared libbz1.so.* library.
275
276* Sun Apr  4 1999 Jeff Johnson <jbj@redhat.com>
277- update to bzip2-0.9.0c.
278
279* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
280- auto rebuild in the new build environment (release 4)
281
282* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
283- build against glibc 2.1
284
285* Wed Sep 30 1998 Cristian Gafton <gafton@redhat.com>
286- force compilation with egcs to avoid gcc optimization bug (thank God
287  we haven't been beaten by it)
288
289* Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
290- version 0.9.0b
291
292* Tue Sep 08 1998 Cristian Gafton <gafton@redhat.com>
293- updated to 0.9.0
294
295* Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
296- first build for Manhattan
Note: See TracBrowser for help on using the repository browser.