source: projects/specs/trunk/b/bzip2/bzip2-vl.spec @ 521

Revision 521, 8.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define buildpdf 0
3
4Summary:     A file compression utility.
5Summary(ja): ファイル圧縮ユーティリティ
6Name: bzip2
7Version: 1.0.5
8Release: 4%{?_dist_release}
9License: BSD
10Group: Applications/Archiving
11URL: http://sources.redhat.com/bzip2/
12Source: ftp://sources.redhat.com/pub/bzip2/v100/bzip2-%{version}.tar.gz
13Patch: bzip2-1.0.5-autoconflibtoolize.patch
14Patch1: bzip2-1.0.5-saneso.patch
15
16# P2 implements a progress counter (in %). It also
17# display the percentage of the original file the new file is (size).
18# URL: http://www.vanheusden.com/Linux/bzip2-1.0.2.diff.gz
19Patch2: bzip2-1.0.2.diff.bz2
20
21# Security Patches
22# Patch3: bzip2-1.0.2-tempfile.patch
23# Patch4: bzip2-1.0.2-chmod.patch
24# Patch5: bzip2-1.0.2-NULL-ptr-check.patch
25# Patch6: bzip2-1.0.2-bzgrep.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28
29%if %buildpdf
30BuildRequires: tetex-dvips tetex-latex
31%endif
32BuildRequires: texinfo
33
34Vendor: Project Vine
35Distribution: Vine Linux
36
37%description
38Bzip2 is a freely available, patent-free, high quality data compressor.
39Bzip2 compresses files to within 10 to 15 percent of the capabilities
40of the best techniques available.  However, bzip2 has the added benefit
41of being approximately two times faster at compression and six times
42faster at decompression than those techniques.  Bzip2 is not the
43fastest compression utility, but it does strike a balance between speed
44and compression capability.
45
46Install bzip2 if you need a compression utility.
47
48
49%package devel
50Summary: Header files and libraries for developing apps which will use bzip2.
51Summary(ja): bzip2 を使うプログラム開発に必要なヘッダファイルとライブラリ
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54
55%description devel
56Header files and a static library of bzip2 functions, for developing apps
57which will use the library.
58
59## to build compat32 for x86_64 architecture support
60%package -n compat32-%{name}
61Summary: A file compression utility.
62Summary(ja): ファイル圧縮ユーティリティ
63Group: System Environment/Libraries
64Requires: %{name} = %{version}-%{release}
65
66%description -n compat32-%{name}
67Bzip2 is a freely available, patent-free, high quality data compressor.
68Bzip2 compresses files to within 10 to 15 percent of the capabilities
69of the best techniques available.  However, bzip2 has the added benefit
70of being approximately two times faster at compression and six times
71faster at decompression than those techniques.  Bzip2 is not the
72fastest compression utility, but it does strike a balance between speed
73and compression capability.
74
75Install bzip2 if you need a compression utility.
76
77%package -n compat32-%{name}-devel
78Summary: Header files and libraries for developing apps which will use bzip2.
79Summary(ja): bzip2 を使うプログラム開発に必要なヘッダファイルとライブラリ
80Group: Development/Libraries
81Requires: compat32-%{name} = %{version}-%{release}
82Requires: %{name}-devel = %{version}-%{release}
83
84%description -n compat32-%{name}-devel
85Header files and a static library of bzip2 functions, for developing apps
86which will use the library.
87
88%prep
89%setup -q
90
91%patch -p1 -b .autoconf
92%patch1 -p1
93%patch2 -p1
94
95cp CHANGES ChangeLog
96mv CHANGES NEWS
97mv LICENSE COPYING
98cp m4/largefile.m4 .
99chmod a+x configure
100libtoolize -f --automake
101aclocal
102autoconf
103automake -a --foreign
104autoheader
105
106%build
107%configure --libdir=%{_libdir} --enable-shared --disable-static
108make
109
110%if %buildpdf
111texi2dvi --pdf manual.texi
112%endif
113
114%install
115rm -rf %{buildroot}
116
117%makeinstall
118
119cp bzgrep %{buildroot}%{_bindir}
120chmod 0755 %{buildroot}%{_bindir}/bzgrep
121
122rm -f %{buildroot}%{_libdir}/*.{a,la}
123
124%post -p /sbin/ldconfig
125
126%postun -p /sbin/ldconfig
127
128%post -n compat32-%{name} -p /sbin/ldconfig
129
130%postun -n compat32-%{name} -p /sbin/ldconfig
131
132%clean
133rm -rf %{buildroot}
134
135%files
136%defattr(-,root,root)
137%doc AUTHORS COPYING README README.COMPILATION.PROBLEMS NEWS ChangeLog
138%{_bindir}/*
139%{_mandir}/*/*
140%{_libdir}/*so.*
141
142%files devel
143%defattr(-,root,root)
144%{_includedir}/*
145%{_libdir}/*so
146
147## to build compat32 for x86_64 architecture support
148%if %{build_compat32}
149%files -n compat32-%{name}
150%defattr(-,root,root)
151%{_libdir}/*so.*
152
153%files -n compat32-%{name}-devel
154%defattr(-,root,root)
155%{_libdir}/*so
156%endif
157
158%changelog
159* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-4
160- rebuild with new toolchain
161
162* Sun Jul 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.5-3
163- updated Patch0: bzip2-1.0.5-autoconflibtoolize.patch
164- removed unneccesary %if !%{build_compat32} case condition
165
166* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-2
167- spec in utf-8
168- remove static library
169
170* Thu Mar 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-1
171- new upstream release with security fix
172- drop old patches (patch3-6) which are included in new release
173- build under new versioning policy
174
175* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl2
176- changed Group to Applications/Archiving
177- changed compat32-bzip2 Group to System Environment/Libraries
178
179* Tue Feb 21 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.3-0vl1
180- new upstream release
181- add Patch3-6 from Fedora Core (includes CAN-2005-0758/0953)
182
183* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl5
184- fixed %%postun (missing to build as scriptlet by invalid comment)
185
186* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl4
187- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
188
189* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
190- added compat32- packages for x86_64 architecture support
191- changed autoconf-2.13 to current autoconf
192
193* Mon May 05 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0.2-0vl2
194- added patch 1 from Rawhide 1.0.2-8
195- added patch 2 from Mandrake 1.0.2-14mdk
196
197* Sun Sep 29 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.0.2-0vl1
198- previous patch is so incomplete that "bzip2 -f" fails.
199  instead, update the source which fixes this and other bugs.
200
201* Fri May 24 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
202- fix race condition.
203
204* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
205- 1.0.1-3vl2
206- added Japanese summary
207- rebuilt under new %%{_mandir} definition
208
209* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 1.0.1-3vl1
210- build on Vine Linux with gcc-2.95.3
211- partially used rpmmacros
212 
213* Fri Jul 21 2000 Trond Eivind Glomsr <teg@redhat.com>
214- new URL and source location
215
216* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
217- automatic rebuild
218
219* Sat Jul 01 2000 Trond Eivind Glomsr <teg@redhat.com>
220- 1.0.1
221- ported my patch
222
223* Tue Jun 13 2000 Jeff Johnson <jbj@redhat.com>
224- FHS packaging to build on solaris2.5.1.
225- remove config.cache from autoconf patch.
226- sparc: use %%configure, but not the m4 macros.
227
228* Tue Jun 06 2000 Trond Eivind Glomsr <teg@redhat.com>
229- Use %%configure, %%makeinstall, %%{_manpath} and %%{_tmpdir}
230
231* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
232- 1.0.0 - ported my 1.0pre8 libtoolizedautoconf patch
233
234* Tue May 16 2000 Trond Eivind Glomsr <teg@redhat.com>
235- use soft links, not hardlinks, for binaries
236- mv .so to devel
237
238* Mon May 15 2000 Trond Eivind Glomsr <teg@redhat.com>
239- autoconfed and libtoolized package
240- fixed Copyright (it's BSD, not GPL)
241- dumped bzless (less works fine with bz2-files)
242- rewrote build and install parts
243- separated main package and devel package
244
245* Mon May  8 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
246- 1.0pre8
247
248* Fri Apr 14 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
249- Add bzgrep (a version of zgrep hacked to do bzip2)
250
251* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
252- handle compressed manpages
253
254* Fri Dec 31 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
255- 0.9.5d
256- Update download URL, add URL: tag in header
257
258* Tue Aug 10 1999 Jeff Johnson <jbj@redhat.com>
259- upgrade to 0.9.5c.
260
261* Mon Aug  9 1999 Bill Nottingham <notting@redhat.com>
262- install actual bzip2 binary, not libtool cruft.
263
264* Sun Aug  8 1999 Jeff Johnson <jbj@redhat.com>
265- run ldconfig to get shared library.
266
267* Mon Aug  2 1999 Jeff Johnson <jbj@redhat.com>
268- create shared libbz1.so.* library.
269
270* Sun Apr  4 1999 Jeff Johnson <jbj@redhat.com>
271- update to bzip2-0.9.0c.
272
273* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
274- auto rebuild in the new build environment (release 4)
275
276* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
277- build against glibc 2.1
278
279* Wed Sep 30 1998 Cristian Gafton <gafton@redhat.com>
280- force compilation with egcs to avoid gcc optimization bug (thank God
281  we haven't been beaten by it)
282
283* Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
284- version 0.9.0b
285
286* Tue Sep 08 1998 Cristian Gafton <gafton@redhat.com>
287- updated to 0.9.0
288
289* Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
290- first build for Manhattan
Note: See TracBrowser for help on using the repository browser.