source: projects/specs/trunk/b/bzip2/bzip2-vl.spec @ 12337

Revision 12337, 10.3 KB checked in by tomop, 4 years ago (diff)

updated 9 packages

bzip2-1.0.8-1

coreutils-8.32-1

dconf-0.36.0-1

gnome-calculator-3.30.1-1

gtksourceview3-3.24.11-1

libbytesize-2.2-1

libcroco-0.6.13-1

pkgconfig-0.29.2-1

which-2.21-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:     A file compression utility.
4Summary(ja): ファイル圧縮ユーティリティ
5Name: bzip2
6Version: 1.0.8
7Release: 1%{?_dist_release}
8License: BSD
9Group: Applications/Archiving
10URL: http://www.bzip.org/
11Source0: https://sourceware.org/pub/bzip2/%{name}-%{version}.tar.gz
12Source1: bzip2.pc
13Patch0: bzip2-saneso.patch
14Patch1: bzip2-cflags.patch
15Patch2: bzip2-ldflags.patch
16
17# P2 implements a progress counter (in %). It also
18# display the percentage of the original file the new file is (size).
19# URL: http://www.vanheusden.com/Linux/bzip2-1.0.2.diff.gz
20Patch10: bzip2-1.0.2.diff.bz2
21
22# security patch(es)
23# none
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26
27BuildRequires: texinfo
28
29Vendor: Project Vine
30Distribution: Vine Linux
31
32%description
33Bzip2 is a freely available, patent-free, high quality data compressor.
34Bzip2 compresses files to within 10 to 15 percent of the capabilities
35of the best techniques available.  However, bzip2 has the added benefit
36of being approximately two times faster at compression and six times
37faster at decompression than those techniques.  Bzip2 is not the
38fastest compression utility, but it does strike a balance between speed
39and compression capability.
40
41Install bzip2 if you need a compression utility.
42
43
44%package devel
45Summary: Header files and libraries for developing apps which will use bzip2.
46Summary(ja): bzip2 を使うプログラム開発に必要なヘッダファイルとライブラリ
47Group: Development/Libraries
48Requires: %{name} = %{version}-%{release}
49
50%description devel
51Header files and a static library of bzip2 functions, for developing apps
52which will use the library.
53
54## to build compat32 for x86_64 architecture support
55%package -n compat32-%{name}
56Summary: A file compression utility.
57Summary(ja): ファイル圧縮ユーティリティ
58Group: System Environment/Libraries
59Requires: %{name} = %{version}-%{release}
60
61%description -n compat32-%{name}
62Bzip2 is a freely available, patent-free, high quality data compressor.
63Bzip2 compresses files to within 10 to 15 percent of the capabilities
64of the best techniques available.  However, bzip2 has the added benefit
65of being approximately two times faster at compression and six times
66faster at decompression than those techniques.  Bzip2 is not the
67fastest compression utility, but it does strike a balance between speed
68and compression capability.
69
70Install bzip2 if you need a compression utility.
71
72%package -n compat32-%{name}-devel
73Summary: Header files and libraries for developing apps which will use bzip2.
74Summary(ja): bzip2 を使うプログラム開発に必要なヘッダファイルとライブラリ
75Group: Development/Libraries
76Requires: compat32-%{name} = %{version}-%{release}
77Requires: %{name}-devel = %{version}-%{release}
78
79%description -n compat32-%{name}-devel
80Header files and a static library of bzip2 functions, for developing apps
81which will use the library.
82
83%prep
84%setup -q
85%patch0 -p1
86%patch1 -p1
87%patch2 -p1
88
89%patch10 -p1
90
91cp -a %{SOURCE1} .
92sed -i "s|^libdir=|libdir=%{_libdir}|" bzip2.pc
93
94%build
95make -f Makefile-libbz2_so \
96        CC="%{__cc}" \
97        AR="%{__ar}" \
98        RANLIB="%{__ranlib}" \
99        CFLAGS="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64 -fpic -fPIC" \
100        LDFLAGS="" \
101        %{?_smp_mflags} all
102
103rm -f *.o
104make \
105        CC="%{__cc}" \
106        AR="%{__ar}" \
107        RANLIB="%{__ranlib}" \
108        CFLAGS="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64" \
109        LDFLAGS="" \
110        %{?_smp_mflags} all
111
112%install
113rm -rf %{buildroot}
114
115chmod 644 bzlib.h
116mkdir -p %{buildroot}{%{_bindir},%{_mandir}/man1,%{_libdir}/pkgconfig,%{_includedir}}
117cp -p bzlib.h %{buildroot}%{_includedir}
118install -m 755 libbz2.so.* %{buildroot}%{_libdir}
119#install -m 644 libbz2.a %{buildroot}%{_libdir}
120install -m 644 bzip2.pc %{buildroot}%{_libdir}/pkgconfig/bzip2.pc
121install -m 755 bzip2-shared  %{buildroot}%{_bindir}/bzip2
122install -m 755 bzip2recover bzgrep bzdiff bzmore  %{buildroot}%{_bindir}/
123cp -p bzip2.1 bzdiff.1 bzgrep.1 bzmore.1  %{buildroot}%{_mandir}/man1/
124ln -s bzip2 %{buildroot}%{_bindir}/bunzip2
125ln -s bzip2 %{buildroot}%{_bindir}/bzcat
126ln -s bzdiff %{buildroot}%{_bindir}/bzcmp
127ln -s bzmore %{buildroot}%{_bindir}/bzless
128ln -s bzgrep %{buildroot}%{_bindir}/bzegrep
129ln -s bzgrep %{buildroot}%{_bindir}/bzfgrep
130ln -s libbz2.so.%{library_version} %{buildroot}%{_libdir}/libbz2.so.1
131ln -s libbz2.so.1 %{buildroot}%{_libdir}/libbz2.so
132ln -s bzip2.1 %{buildroot}%{_mandir}/man1/bzip2recover.1
133ln -s bzip2.1 %{buildroot}%{_mandir}/man1/bunzip2.1
134ln -s bzip2.1 %{buildroot}%{_mandir}/man1/bzcat.1
135ln -s bzdiff.1 %{buildroot}%{_mandir}/man1/bzcmp.1
136ln -s bzmore.1 %{buildroot}%{_mandir}/man1/bzless.1
137ln -s bzgrep.1 %{buildroot}%{_mandir}/man1/bzegrep.1
138ln -s bzgrep.1 %{buildroot}%{_mandir}/man1/bzfgrep.1
139
140
141%post -p /sbin/ldconfig
142
143%postun -p /sbin/ldconfig
144
145%post -n compat32-%{name} -p /sbin/ldconfig
146
147%postun -n compat32-%{name} -p /sbin/ldconfig
148
149%clean
150rm -rf %{buildroot}
151
152%files
153%defattr(-,root,root)
154%{!?_licensedir:%global license %%doc}
155%license COPYING
156%doc CHANGES README
157%{_bindir}/*
158%{_mandir}/*/*
159%{_libdir}/*so.*
160
161%files devel
162%defattr(-,root,root)
163%{_includedir}/*
164%{_libdir}/*so
165%{_libdir}/pkgconfig/*
166
167## to build compat32 for x86_64 architecture support
168%if %{build_compat32}
169%files -n compat32-%{name}
170%defattr(-,root,root)
171%{_libdir}/*so.*
172
173%files -n compat32-%{name}-devel
174%defattr(-,root,root)
175%{_libdir}/*so
176%{_libdir}/pkgconfig/*
177%endif
178
179%changelog
180* Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.8-1
181- new upstream release.
182- dropped Patch0-3 and 1000.
183- imported Patch0-2 from rawhide.
184
185* Tue Jul 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.6-4
186- fixed %%files.
187
188* Tue Jul  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.6-3
189- added Patch1000 to fix CVE-2016-3189.
190
191* Wed Jan  1 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.6-2
192- rebuilt with new vineseed toolchain
193
194* Sat Jul 14 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
195- update to 1.0.6
196
197* Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 1.0.5-5vl6
198- build on current VineSeed
199- update URL and Source0 tags URL
200
201* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-4
202- rebuild with new toolchain
203
204* Sun Jul 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.5-3
205- updated Patch0: bzip2-1.0.5-autoconflibtoolize.patch
206- removed unneccesary %if !%{build_compat32} case condition
207
208* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-2
209- spec in utf-8
210- remove static library
211
212* Thu Mar 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-1
213- new upstream release with security fix
214- drop old patches (patch3-6) which are included in new release
215- build under new versioning policy
216
217* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl2
218- changed Group to Applications/Archiving
219- changed compat32-bzip2 Group to System Environment/Libraries
220
221* Tue Feb 21 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.3-0vl1
222- new upstream release
223- add Patch3-6 from Fedora Core (includes CAN-2005-0758/0953)
224
225* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl5
226- fixed %%postun (missing to build as scriptlet by invalid comment)
227
228* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl4
229- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
230
231* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
232- added compat32- packages for x86_64 architecture support
233- changed autoconf-2.13 to current autoconf
234
235* Mon May 05 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0.2-0vl2
236- added patch 1 from Rawhide 1.0.2-8
237- added patch 2 from Mandrake 1.0.2-14mdk
238
239* Sun Sep 29 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.0.2-0vl1
240- previous patch is so incomplete that "bzip2 -f" fails.
241  instead, update the source which fixes this and other bugs.
242
243* Fri May 24 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
244- fix race condition.
245
246* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
247- 1.0.1-3vl2
248- added Japanese summary
249- rebuilt under new %%{_mandir} definition
250
251* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 1.0.1-3vl1
252- build on Vine Linux with gcc-2.95.3
253- partially used rpmmacros
254 
255* Fri Jul 21 2000 Trond Eivind Glomsr <teg@redhat.com>
256- new URL and source location
257
258* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
259- automatic rebuild
260
261* Sat Jul 01 2000 Trond Eivind Glomsr <teg@redhat.com>
262- 1.0.1
263- ported my patch
264
265* Tue Jun 13 2000 Jeff Johnson <jbj@redhat.com>
266- FHS packaging to build on solaris2.5.1.
267- remove config.cache from autoconf patch.
268- sparc: use %%configure, but not the m4 macros.
269
270* Tue Jun 06 2000 Trond Eivind Glomsr <teg@redhat.com>
271- Use %%configure, %%makeinstall, %%{_manpath} and %%{_tmpdir}
272
273* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
274- 1.0.0 - ported my 1.0pre8 libtoolizedautoconf patch
275
276* Tue May 16 2000 Trond Eivind Glomsr <teg@redhat.com>
277- use soft links, not hardlinks, for binaries
278- mv .so to devel
279
280* Mon May 15 2000 Trond Eivind Glomsr <teg@redhat.com>
281- autoconfed and libtoolized package
282- fixed Copyright (it's BSD, not GPL)
283- dumped bzless (less works fine with bz2-files)
284- rewrote build and install parts
285- separated main package and devel package
286
287* Mon May  8 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
288- 1.0pre8
289
290* Fri Apr 14 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
291- Add bzgrep (a version of zgrep hacked to do bzip2)
292
293* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
294- handle compressed manpages
295
296* Fri Dec 31 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
297- 0.9.5d
298- Update download URL, add URL: tag in header
299
300* Tue Aug 10 1999 Jeff Johnson <jbj@redhat.com>
301- upgrade to 0.9.5c.
302
303* Mon Aug  9 1999 Bill Nottingham <notting@redhat.com>
304- install actual bzip2 binary, not libtool cruft.
305
306* Sun Aug  8 1999 Jeff Johnson <jbj@redhat.com>
307- run ldconfig to get shared library.
308
309* Mon Aug  2 1999 Jeff Johnson <jbj@redhat.com>
310- create shared libbz1.so.* library.
311
312* Sun Apr  4 1999 Jeff Johnson <jbj@redhat.com>
313- update to bzip2-0.9.0c.
314
315* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
316- auto rebuild in the new build environment (release 4)
317
318* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
319- build against glibc 2.1
320
321* Wed Sep 30 1998 Cristian Gafton <gafton@redhat.com>
322- force compilation with egcs to avoid gcc optimization bug (thank God
323  we haven't been beaten by it)
324
325* Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
326- version 0.9.0b
327
328* Tue Sep 08 1998 Cristian Gafton <gafton@redhat.com>
329- updated to 0.9.0
330
331* Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
332- first build for Manhattan
Note: See TracBrowser for help on using the repository browser.