source: projects/specs/trunk/b/bzip2/bzip2-vl.spec @ 10541

Revision 10541, 9.1 KB checked in by tomop, 8 years ago (diff)

bzip2-1.0.6-3

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define buildpdf 0
3
4Summary:     A file compression utility.
5Summary(ja): ファイル圧縮ユーティリティ
6Name: bzip2
7Version: 1.0.6
8Release: 3%{?_dist_release}
9License: BSD
10Group: Applications/Archiving
11URL: http://www.bzip.org/
12Source: http://www.bzip.org/%{version}/bzip2-%{version}.tar.gz
13Patch0: bzip2-1.0.5-autoconflibtoolize.patch
14Patch1: bzip2-1.0.4-saneso.patch
15Patch2: bzip2-1.0.4-cflags.patch
16Patch3: bzip2-1.0.4-bzip2recover.patch
17
18# P2 implements a progress counter (in %). It also
19# display the percentage of the original file the new file is (size).
20# URL: http://www.vanheusden.com/Linux/bzip2-1.0.2.diff.gz
21Patch10: bzip2-1.0.2.diff.bz2
22
23# security patch(es)
24Patch1000: CVE-2016-3189.patch
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27
28%if %buildpdf
29BuildRequires: tetex-dvips tetex-latex
30%endif
31BuildRequires: texinfo
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37Bzip2 is a freely available, patent-free, high quality data compressor.
38Bzip2 compresses files to within 10 to 15 percent of the capabilities
39of the best techniques available.  However, bzip2 has the added benefit
40of being approximately two times faster at compression and six times
41faster at decompression than those techniques.  Bzip2 is not the
42fastest compression utility, but it does strike a balance between speed
43and compression capability.
44
45Install bzip2 if you need a compression utility.
46
47
48%package devel
49Summary: Header files and libraries for developing apps which will use bzip2.
50Summary(ja): bzip2 を使うプログラム開発に必要なヘッダファイルとライブラリ
51Group: Development/Libraries
52Requires: %{name} = %{version}-%{release}
53
54%description devel
55Header files and a static library of bzip2 functions, for developing apps
56which will use the library.
57
58## to build compat32 for x86_64 architecture support
59%package -n compat32-%{name}
60Summary: A file compression utility.
61Summary(ja): ファイル圧縮ユーティリティ
62Group: System Environment/Libraries
63Requires: %{name} = %{version}-%{release}
64
65%description -n compat32-%{name}
66Bzip2 is a freely available, patent-free, high quality data compressor.
67Bzip2 compresses files to within 10 to 15 percent of the capabilities
68of the best techniques available.  However, bzip2 has the added benefit
69of being approximately two times faster at compression and six times
70faster at decompression than those techniques.  Bzip2 is not the
71fastest compression utility, but it does strike a balance between speed
72and compression capability.
73
74Install bzip2 if you need a compression utility.
75
76%package -n compat32-%{name}-devel
77Summary: Header files and libraries for developing apps which will use bzip2.
78Summary(ja): bzip2 を使うプログラム開発に必要なヘッダファイルとライブラリ
79Group: Development/Libraries
80Requires: compat32-%{name} = %{version}-%{release}
81Requires: %{name}-devel = %{version}-%{release}
82
83%description -n compat32-%{name}-devel
84Header files and a static library of bzip2 functions, for developing apps
85which will use the library.
86
87%prep
88%setup -q
89
90%patch0 -p1 -b .autoconf
91%patch1 -p1 -b .saneso
92%patch2 -p1 -b .cflags
93%patch3 -p1 -b .bz2recover
94
95%patch10 -p1
96
97%patch1000 -p1 -b .CVE-2016-3189
98
99cp CHANGES ChangeLog
100mv CHANGES NEWS
101mv LICENSE COPYING
102cp m4/largefile.m4 .
103chmod a+x configure
104libtoolize -f --automake
105aclocal
106autoconf
107automake -a --foreign
108autoheader
109
110%build
111%configure --libdir=%{_libdir} --enable-shared --disable-static
112make
113
114%if %buildpdf
115texi2dvi --pdf manual.texi
116%endif
117
118%install
119rm -rf %{buildroot}
120
121%makeinstall
122
123cp bzgrep %{buildroot}%{_bindir}
124chmod 0755 %{buildroot}%{_bindir}/bzgrep
125
126rm -f %{buildroot}%{_libdir}/*.{a,la}
127
128%post -p /sbin/ldconfig
129
130%postun -p /sbin/ldconfig
131
132%post -n compat32-%{name} -p /sbin/ldconfig
133
134%postun -n compat32-%{name} -p /sbin/ldconfig
135
136%clean
137rm -rf %{buildroot}
138
139%files
140%defattr(-,root,root)
141%license COPYING
142%doc AUTHORS README README.COMPILATION.PROBLEMS NEWS ChangeLog
143%{_bindir}/*
144%{_mandir}/*/*
145%{_libdir}/*so.*
146
147%files devel
148%defattr(-,root,root)
149%{_includedir}/*
150%{_libdir}/*so
151
152## to build compat32 for x86_64 architecture support
153%if %{build_compat32}
154%files -n compat32-%{name}
155%defattr(-,root,root)
156%{_libdir}/*so.*
157
158%files -n compat32-%{name}-devel
159%defattr(-,root,root)
160%{_libdir}/*so
161%endif
162
163%changelog
164* Tue Jul  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.6-3
165- added Patch1000 to fix CVE-2016-3189.
166
167* Wed Jan  1 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.6-2
168- rebuilt with new vineseed toolchain
169
170* Sat Jul 14 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
171- update to 1.0.6
172
173* Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 1.0.5-5vl6
174- build on current VineSeed
175- update URL and Source0 tags URL
176
177* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-4
178- rebuild with new toolchain
179
180* Sun Jul 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.5-3
181- updated Patch0: bzip2-1.0.5-autoconflibtoolize.patch
182- removed unneccesary %if !%{build_compat32} case condition
183
184* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-2
185- spec in utf-8
186- remove static library
187
188* Thu Mar 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-1
189- new upstream release with security fix
190- drop old patches (patch3-6) which are included in new release
191- build under new versioning policy
192
193* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl2
194- changed Group to Applications/Archiving
195- changed compat32-bzip2 Group to System Environment/Libraries
196
197* Tue Feb 21 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.3-0vl1
198- new upstream release
199- add Patch3-6 from Fedora Core (includes CAN-2005-0758/0953)
200
201* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl5
202- fixed %%postun (missing to build as scriptlet by invalid comment)
203
204* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl4
205- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
206
207* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
208- added compat32- packages for x86_64 architecture support
209- changed autoconf-2.13 to current autoconf
210
211* Mon May 05 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0.2-0vl2
212- added patch 1 from Rawhide 1.0.2-8
213- added patch 2 from Mandrake 1.0.2-14mdk
214
215* Sun Sep 29 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.0.2-0vl1
216- previous patch is so incomplete that "bzip2 -f" fails.
217  instead, update the source which fixes this and other bugs.
218
219* Fri May 24 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
220- fix race condition.
221
222* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
223- 1.0.1-3vl2
224- added Japanese summary
225- rebuilt under new %%{_mandir} definition
226
227* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 1.0.1-3vl1
228- build on Vine Linux with gcc-2.95.3
229- partially used rpmmacros
230 
231* Fri Jul 21 2000 Trond Eivind Glomsr <teg@redhat.com>
232- new URL and source location
233
234* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
235- automatic rebuild
236
237* Sat Jul 01 2000 Trond Eivind Glomsr <teg@redhat.com>
238- 1.0.1
239- ported my patch
240
241* Tue Jun 13 2000 Jeff Johnson <jbj@redhat.com>
242- FHS packaging to build on solaris2.5.1.
243- remove config.cache from autoconf patch.
244- sparc: use %%configure, but not the m4 macros.
245
246* Tue Jun 06 2000 Trond Eivind Glomsr <teg@redhat.com>
247- Use %%configure, %%makeinstall, %%{_manpath} and %%{_tmpdir}
248
249* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
250- 1.0.0 - ported my 1.0pre8 libtoolizedautoconf patch
251
252* Tue May 16 2000 Trond Eivind Glomsr <teg@redhat.com>
253- use soft links, not hardlinks, for binaries
254- mv .so to devel
255
256* Mon May 15 2000 Trond Eivind Glomsr <teg@redhat.com>
257- autoconfed and libtoolized package
258- fixed Copyright (it's BSD, not GPL)
259- dumped bzless (less works fine with bz2-files)
260- rewrote build and install parts
261- separated main package and devel package
262
263* Mon May  8 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
264- 1.0pre8
265
266* Fri Apr 14 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
267- Add bzgrep (a version of zgrep hacked to do bzip2)
268
269* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
270- handle compressed manpages
271
272* Fri Dec 31 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
273- 0.9.5d
274- Update download URL, add URL: tag in header
275
276* Tue Aug 10 1999 Jeff Johnson <jbj@redhat.com>
277- upgrade to 0.9.5c.
278
279* Mon Aug  9 1999 Bill Nottingham <notting@redhat.com>
280- install actual bzip2 binary, not libtool cruft.
281
282* Sun Aug  8 1999 Jeff Johnson <jbj@redhat.com>
283- run ldconfig to get shared library.
284
285* Mon Aug  2 1999 Jeff Johnson <jbj@redhat.com>
286- create shared libbz1.so.* library.
287
288* Sun Apr  4 1999 Jeff Johnson <jbj@redhat.com>
289- update to bzip2-0.9.0c.
290
291* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
292- auto rebuild in the new build environment (release 4)
293
294* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
295- build against glibc 2.1
296
297* Wed Sep 30 1998 Cristian Gafton <gafton@redhat.com>
298- force compilation with egcs to avoid gcc optimization bug (thank God
299  we haven't been beaten by it)
300
301* Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
302- version 0.9.0b
303
304* Tue Sep 08 1998 Cristian Gafton <gafton@redhat.com>
305- updated to 0.9.0
306
307* Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
308- first build for Manhattan
Note: See TracBrowser for help on using the repository browser.