source: projects/specs/trunk/b/busybox/busybox-vl.spec @ 12278

Revision 12278, 9.8 KB checked in by tomop, 5 years ago (diff)

updated 8 packages

apr-1.7.0-1

busybox-1.30.1-1

file-5.37-1

libgsf-1.14.46-1

libsndfile-1.0.28-2

subversion-1.12.2-1

uClibc-ng-1.0.32-1

wireshark-3.0.5-1

RevLine 
[521]1Summary: Statically linked binary providing simplified versions of system commands
2Name: busybox
[12278]3Version: 1.30.1
[3963]4Release: 1%{?_dist_release}
[12278]5Group: System Environment/Shells
[521]6License: GPLv2
[12278]7URL: https://www.busybox.net/
8Source: https://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
[3963]9Source10: busybox-static.config
10Source11: busybox-anaconda.config
[521]11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
[12278]12BuildRequires: uClibc-ng-devel
[521]13
[3963]14Vendor: Project Vine
15Distribution: Vine Linux
16
[521]17%description
18Busybox is a single binary which includes versions of a large number
19of system commands, including a shell.  This package can be very
20useful for recovering from certain types of system failures,
21particularly those involving broken shared libraries.
22
23%package anaconda
24Group: System Environment/Shells
25Summary: Version of busybox configured for use with anaconda
26
27%description anaconda
28Busybox is a single binary which includes versions of a large number
29of system commands, including a shell.  The version contained in this
30package is designed for use with the Red Hat installation program,
31anaconda. The busybox package provides a binary better suited to
32normal use.
33
[3963]34
[521]35%prep
[3963]36%setup -q
[521]37
38%build
[3963]39# create static busybox
[521]40arch=`uname -m | sed -e 's/i.86/i386/' -e 's/ppc/powerpc/' -e 's/ppc64//' -e 's/powerpc64//'`
[3963]41cp %{SOURCE10} .config
42yes "" | make oldconfig
[521]43# gcc needs to be convinced to use neither system headers, nor libs,
44# nor startfiles (i.e. crtXXX.o files)
45if test "$arch"; then \
46    mv .config .config1 && \
[12278]47    grep -v \
48        -e ^CONFIG_SELINUX \
49        -e ^CONFIG_FEATURE_HAVE_RPC \
50        -e ^CONFIG_FEATURE_MOUNT_NFS \
51        -e ^CONFIG_FEATURE_INETD_RPC \
52        .config1 >.config && \
53    echo "# CONFIG_FEATURE_HAVE_RPC is not set" >>.config && \
54    echo "# CONFIG_FEATURE_MOUNT_NFS is not set" >>.config && \
55    echo "# CONFIG_FEATURE_INETD_RPC is not set" >>.config && \
[521]56    yes "" | make oldconfig && \
57    cat .config && \
[12278]58    make V=1 %{_smp_mflags} \
[3963]59        EXTRA_CFLAGS="-isystem %{_includedir}/uClibc" \
60        CFLAGS_busybox="-static -nostartfiles -L%{_libdir}/uClibc %{_libdir}/uClibc/crt1.o %{_libdir}/uClibc/crti.o %{_libdir}/uClibc/crtn.o"; \
[521]61else \
62    cat .config && \
63    make V=1 CC="gcc $RPM_OPT_FLAGS"; \
64fi
[3963]65cp busybox busybox.static
66cp docs/busybox.1 docs/busybox.static.1
67
[521]68# create busybox optimized for anaconda
69make clean
[3963]70#
[12278]71grep -v \
72    -e ^CONFIG_SELINUX \
73    -e ^CONFIG_FEATURE_HAVE_RPC \
74    -e ^CONFIG_FEATURE_MOUNT_NFS \
75    -e ^CONFIG_FEATURE_INETD_RPC \
76    %{SOURCE11} >.config && \
77echo "# CONFIG_FEATURE_HAVE_RPC is not set" >>.config && \
78echo "# CONFIG_FEATURE_MOUNT_NFS is not set" >>.config && \
79echo "# CONFIG_FEATURE_INETD_RPC is not set" >>.config && \
[3963]80yes "" | make oldconfig
[12278]81make %{_smp_mflags} CONFIG_DEBUG=y CC="gcc $RPM_OPT_FLAGS"
[521]82cp busybox busybox.anaconda
[3963]83cp docs/busybox.1 docs/busybox.anaconda.1
[521]84
85%install
86rm -rf $RPM_BUILD_ROOT
87mkdir -p $RPM_BUILD_ROOT/sbin
[3963]88install -m 755 busybox.static $RPM_BUILD_ROOT/sbin/busybox
[521]89install -m 755 busybox.anaconda $RPM_BUILD_ROOT/sbin/busybox.anaconda
[3963]90mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
91install -m 644 docs/busybox.static.1 $RPM_BUILD_ROOT/%{_mandir}/man1/busybox.1
92install -m 644 docs/busybox.anaconda.1 $RPM_BUILD_ROOT/%{_mandir}/man1/busybox.anaconda.1
[521]93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%files
98%defattr(-,root,root,-)
[12278]99%license LICENSE
100%doc README
[521]101/sbin/busybox
[3963]102%{_mandir}/man1/busybox.1.gz
[521]103
104%files anaconda
105%defattr(-,root,root,-)
[12278]106%license LICENSE
107%doc README
[521]108/sbin/busybox.anaconda
[3963]109%{_mandir}/man1/busybox.anaconda.1.gz
[521]110
111%changelog
[12278]112* Sat Oct 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.30.1-1
113- new upstream release.
114- dropped all patches.
115
[7156]116* Mon Nov 26 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20.2-1
117- update to 1.20.2
118- Patch1: change uname -p behavior to coreutils's uname
119- small config changes
120
[3963]121* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.4-1
122- update to 1.18.4
123- build with system uClibc
124
[521]125* Fri May 08 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.13.4-2
126- add Patch20 to fix build failure on ppc
127  http://lists.uclibc.org/pipermail/uclibc-cvs/2009-January/025891.html
128
129* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13.4-1
130- new upstream release
131- use uClibc for static build instead of glibc
132
133* Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.0-1vl5
134- applied new versioning policy
135
136* Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
137- initial build for Vine Linux based on FC-devel
138
139* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:1.2.0-1.1
140- rebuild
141
142* Tue Jul  4 2006 Ivana Varekova <varekova@redhat.com> - 1:1.2.0-1
143- update to 1.2.0
144
145* Thu Jun  8 2006 Jeremy Katz <katzj@redhat.com> - 1:1.1.3-2
146- fix so that busybox.anaconda has sh
147
148* Wed May 31 2006 Ivana Varekova <varekova@redhat.com> - 1:1.1.3-1
149- update to 1.1.3
150
151* Mon May 29 2006 Ivana Varekova <varekova@redhat.com> - 1:1.1.2-3
152- fix Makefile typo (#193354)
153
154* Fri May  5 2006 Ivana Varekova <varekova@redhat.com> - 1:1.1.2-1
155- update to 1.1.2
156
157* Thu May  4 2006 Ivana Varekova <varekova@redhat.com> - 1:1.1.1-2
158- add -Z option to id command, rename ps command -Z option (#190534)
159
160* Wed May 03 2006 Ivana Varekova <varekova@redhat.com> - 1:1.1.1-1
161- update to 1.1.1
162- fix CVE-2006-1058 - BusyBox passwd command
163  fails to generate password with salt (#187386)
164- add -minimal-toc option
165- add RPM_OPT_FLAGS
166- remove asm/page.h used sysconf command to get PAGE_SIZE
167- add overfl patch to aviod Buffer warning
168
169* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1:1.01-2.2.1
170- bump again for double-long bug on ppc(64)
171
172* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1:1.01-2.2
173- rebuilt for new gcc4.1 snapshot and glibc changes
174
175* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
176- rebuilt
177
178* Thu Oct 13 2005 Daniel Walsh <dwalsh@redhat.com> -  1.01-2
179- Add sepol for linking load_policy
180
181* Thu Sep  1 2005 Ivana Varekova <varekova@redhat.com> - 1.01-1
182- update to 1.01
183 
[12278]184* Wed May 11 2005 Ivana Varekova <varekova@redhat.com> - 1.00-5
[521]185- add debug files to debug_package
186
187* Mon Mar  7 2005 Ivana Varekova <varekova@redhat.com> - 1.00-4
188- rebuilt
189
190* Wed Jan 26 2005 Ivana Varekova <varekova@redhat.com> - 1.00-3
191- update to 1.00 - fix bug #145681
192- rebuild
193
194* Thu Jan 13 2005 Jeremy Katz <katzj@redhat.com> - 1.00.rc1-6
195- enable ash as the shell in busybox-anaconda
196
197* Sat Oct  2 2004 Bill Nottingham <notting@redhat.com> - 1.00.rc1-5
198- fix segfault in SELinux patch (#134404, #134406)
199
200* Fri Sep 17 2004 Phil Knirsch <pknirsch@redhat.com> - 1.00.rc1-4
201- Fixed double free in freecon() call (#132809)
202
203* Fri Sep 10 2004 Daniel Walsh <dwalsh@redhat.com> - 1.00.rc1-3
204- Add CONFIG_STATIC=y for static builds
205
206* Wed Aug 25 2004 Jeremy Katz <katzj@redhat.com> - 1.00.rc1-2
207- rebuild
208
209* Fri Jun 25 2004 Dan Walsh <dwalsh@redhat.com> 1.00-pre10.1
210- Add BuildRequires libselinux-devel
211- Update to latest from upstream
212
213* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
214- rebuilt
215
216* Tue May 11 2004 Karsten Hopp <karsten@redhat.de> 1.00.pre8-4
217- add mknod to busybox-anaconda
218
219* Wed Apr 21 2004 Karsten Hopp <karsten@redhat.de> 1.00.pre8-3
220- fix LS_COLOR in anaconda patch
221
222* Tue Mar 23 2004 Jeremy Katz <katzj@redhat.com> 1.00.pre8-2
223- add awk to busybox-anaconda
224
225* Sat Mar 20 2004 Dan Walsh <dwalsh@redhat.com> 1.00-pre8.1
226- Update with latest patch.
227- Turn off LS_COLOR in static patch
228
229* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
230- rebuilt
231
232* Tue Jan 27 2004 Dan Walsh <dwalsh@redhat.com> 1.00-pre5.2
233- Fix is_selinux_enabled calls
234
235* Mon Dec 29 2003 Dan Walsh <dwalsh@redhat.com> 1.00-pre5.1
236-Latest update
237
238* Wed Nov 26 2003 Dan Walsh <dwalsh@redhat.com> 1.00-pre3.2
239- Add insmod
240
241* Mon Sep 15 2003 Dan Walsh <dwalsh@redhat.com> 1.00-pre3.1
242- Upgrade to pre3
243
244* Thu Sep 11 2003 Dan Walsh <dwalsh@redhat.com> 1.00.2
245- Upgrade selinux support
246
247* Wed Jul 23 2003 Dan Walsh <dwalsh@redhat.com> 1.00.1
248- Upgrade to 1.00 package
249
250* Wed Jul 16 2003 Elliot Lee <sopwith@redhat.com> 0.60.5-10
251- Rebuild
252
253* Mon Jul 14 2003 Jeremy Katz <katzj@redhat.com> 0.60.5-9
254- rebuild
255
256* Mon Jul 14 2003 Jeremy Katz <katzj@redhat.com> 0.60.5-8
257- add dmesg to busybox-anaconda
258
259* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
260- rebuilt
261
262* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
263- rebuilt
264
265* Mon Jan 13 2003 Jeremy Katz <katzj@redhat.com> 0.60.5-5
266- lost nolock for anaconda mount when rediffing, it returns (#81764)
267
268* Mon Jan 6 2003 Dan Walsh <dwalsh@redhat.com> 0.60.5-4
269- Upstream developers wanted to eliminate the use of floats
270
[12278]271* Fri Jan 3 2003 Dan Walsh <dwalsh@redhat.com> 0.60.5-3
[521]272- Fix free to work on large memory machines.
273
274* Sat Dec 28 2002 Jeremy Katz <katzj@redhat.com> 0.60.5-2
275- update Config.h for anaconda build to include more useful utils
276
277* Thu Dec 19 2002 Dan Walsh <dwalsh@redhat.com> 0.60.5-1
278- update latest release
279
280* Thu Dec 19 2002 Dan Walsh <dwalsh@redhat.com> 0.60.2-8
281- incorporate hammer changes
282
283* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
284- automated rebuild
285
286* Thu May 23 2002 Tim Powers <timp@redhat.com>
287- automated rebuild
288
289* Mon May 06 2002 Florian La Roche <Florian.LaRoche@redhat.de>
290- fix compilation on mainframe
291
292* Tue Apr  2 2002 Jeremy Katz <katzj@redhat.com>
293- fix static busybox (#60701)
294
295* Thu Feb 28 2002 Jeremy Katz <katzj@redhat.com>
296- don't include mknod in busybox.anaconda so we get collage mknod
297
298* Fri Feb 22 2002 Jeremy Katz <katzj@redhat.com>
299- rebuild in new environment
300
301* Wed Jan 30 2002 Jeremy Katz <katzj@redhat.com>
302- update to 0.60.2
303- include more pieces for the anaconda version so that collage can go away
304- make the mount in busybox.anaconda default to -onolock
305
306* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
307`- automated rebuild
308
309* Mon Jul  9 2001 Tim Powers <timp@redhat.com>
310- don't obsolete sash
311- fix URL and spelling in desc. to satisfy rpmlint
312
313* Thu Jul 05 2001 Florian La Roche <Florian.LaRoche@redhat.de>
314- add missing defattr for anaconda subpackage
315
316* Thu Jun 28 2001 Erik Troan <ewt@redhat.com>
317- initial build for Red Hat
Note: See TracBrowser for help on using the repository browser.