source: projects/specs/trunk/b/bug-buddy/bug-buddy-vl.spec @ 521

Revision 521, 4.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define ver     2.28.0
2%define rel     1%{?_dist_release}
3
4Summary:        A bug reporting utility for GNOME.
5Summary(ja):    GNOME用バグ報告ユーティリティ
6Name:           bug-buddy
7Version:        %{ver}
8Release:        %{rel}
9License:        GPL
10Group:          Applications/System
11Source:         ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/2.28/%{name}-%{ver}.tar.bz2
12URL:            http://ftp.gnome.org/pub/GNOME/sources/bug-buddy/
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires: libbonobo-devel
16BuildRequires: libxml2-devel >= 2.4.6
17BuildRequires: gtk2-devel >= 2.16.0
18BuildRequires: glib2-devel >= 2.16.0
19BuildRequires: libsoup-devel >= 2.4.0
20BuildRequires: libgtop2-devel >= 2.26.0
21BuildRequires: GConf2-devel
22BuildRequires: evolution-data-server >= 1.3.0
23
24Requires(post,postun): scrollkeeper
25Requires(post): GConf2
26
27%description
28Bug-buddy is a bug reporting utility for the GNOME desktop GUI
29environment. Bug-buddy can obtain a stack trace from a core file or
30crashed application; it can determine the versions of packages
31installed on your system; it can be started from gmc (by
32double-clicking on a core file) and from the crash dialog; and it
33supports the GNOME, KDE, Debian, and Ximian bug tracking systems.
34
35%prep
36%setup -q
37
38%build
39%configure --disable-schemas-install --disable-scrollkeeper
40
41%__make %{?_smp_mflags}
42
43%install
44[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
45
46export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
47%makeinstall
48unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
49
50rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
51rm -f  $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
52rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/libgnomebreakpad.{a,la}
53rm -f $RPM_BUILD_ROOT%{_libdir}/bug-buddy/libbreakpad.{a,la}
54
55%find_lang %{name}
56
57%clean
58[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
59
60%post
61scrollkeeper-update > /dev/null 2>&1 || :
62export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
63gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/bug-buddy.schemas > /dev/null
64
65%postun
66scrollkeeper-update > /dev/null 2>&1 || :
67
68%files -f %{name}.lang
69%defattr(-, root, root)
70%doc AUTHORS COPYING ChangeLog NEWS README TODO
71%config %{_sysconfdir}/gconf/schemas/bug-buddy.schemas
72%{_bindir}/*
73%{_libdir}/gtk-2.0/modules/*.so
74%{_datadir}/bug-buddy
75%{_datadir}/applications/*
76%{_datadir}/icons/*
77%{_mandir}/man1/*
78%ifarch %{ix86}
79%{_libdir}/bug-buddy/*.so*
80%endif
81
82
83%changelog
84* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
85- new upstream release
86
87* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
88- new upstream release
89
90* Tue Oct 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.1-1vl5
91- new upstream release
92
93* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.0-1vl5
94- new upstream release
95- spec in UTF-8
96
97* Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
98- new upstream release
99- added BuildRequires: libsoup-devel >= 2.4.0
100
101* Tue Jan 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.1-0vl2
102- fixed %%files (if not i386)
103
104* Mon Dec 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
105- new upstream release
106
107* Sat Jul 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.1-0vl3
108- rebuilt with evolution-data-server-devel 1.10.3.1
109
110* Mon Jul 02 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.1-0vl2
111- add following BuildRequires:
112  gnome-desktop-devel, libgtop2-devel, evolution-data-server-devel
113
114* Sun Jun 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.1-0vl1
115- new upstream release
116
117* Sun Oct 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
118- new upstream release
119
120* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.90-0vl1
121- new upstream release
122
123* Mon Sep 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
124- new upstream release
125- added %post, %postun section
126
127* Fri Sep 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.0-1vl1
128- new upstream release
129- chagned URL (based on Rawhide 2.4.0-1)
130
131* Sat Jul 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.106-0vl1
132- rebuild with new toolchains and gnome2
133- s/Copyright/License/
134
135* Wed Mar 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.2-0vl1
136- Build for Vine.
137
138* Wed Feb 23 2000  Jacob Berkman  <jacob@helixcode.com>
139- don't say we own the pixmaps/ dir
140
141* Wed Nov 10 1999  Jacob Berkman  <jberkman@andrew.cmu.edu>
142- fixed up for insertion into the CVS
143
144* Fri Nov 05 1999  Ned Rhudy  <nrhudy@pabus.com>
145- the first incarnation of the spec file...watch it not work
146
Note: See TracBrowser for help on using the repository browser.