source: projects/specs/trunk/b/btparse/btparse-vl.spec @ 5758

Revision 5758, 4.7 KB checked in by munepi, 12 years ago (diff)

updated btparse-vl.spec

Line 
1%define libname libbtparse
2
3Name:             btparse
4Version:          0.35
5Release:          2%{?_dist_release}
6Summary:          Tool for parsing and processing BibTeX data files
7Summary(ja):      BibTeX ファイルを解析処理するツール
8License:          GPLv2
9Distribution:     Vine Linux
10Group:            Applications/Publishing
11Source:           http://search.cpan.org/CPAN/authors/id/A/AM/AMBS/btparse/%{name}-%{version}.tar.gz
12URL:              http://search.cpan.org/~ambs/btparse/
13BuildRoot:        %{_tmppath}/%{name}-%{version}-root
14
15## BuildRequires:       
16## Requires:       
17
18%description
19btparse is a C library for parsing and processing BibTeX files. It provides a
20lexical scanner and LR parser (constructed by PCCTS), both of which are
21efficient and offer good error detection and recovery; a set of functions for
22traversing the AST (abstract syntax tree) generated by the parser; and utility
23functions for manipulating strings according to BibTeX conventions. (Note that
24nothing in the library assumes that you're using BibTeX files for their
25original purpose of bibliographic data for scholarly publications; you could
26use the file format for any conceivable purpose that fits it. However, there is
27some code in the library that is really only appropriate for use with strings
28meant to be processed in the same way that BibTeX itself does. This is all
29entirely optional, though.)
30
31Note that the interface provided by btparse, while complete, is fairly
32low-level. If you have more sophisticated needs, you might be interested my
33Text::BibTeX module for Perl 5 (available on CPAN).
34
35%description -l ja
36BibTeXファイルを解析処理するツールです.
37
38%package -n %{libname}
39Summary:        C library for parsing and processing BibTeX data files
40Summary(ja):    BibTeX ファイルを解析処理する C ライブラリ
41Group:          System Environment/Libraries
42
43%description -n %{libname}
44btparse is a C library for parsing and processing BibTeX files. It provides a
45lexical scanner and LR parser (constructed by PCCTS), both of which are
46efficient and offer good error detection and recovery; a set of functions for
47traversing the AST (abstract syntax tree) generated by the parser; and utility
48functions for manipulating strings according to BibTeX conventions. (Note that
49nothing in the library assumes that you're using BibTeX files for their
50original purpose of bibliographic data for scholarly publications; you could
51use the file format for any conceivable purpose that fits it. However, there is
52some code in the library that is really only appropriate for use with strings
53meant to be processed in the same way that BibTeX itself does. This is all
54entirely optional, though.)
55
56Note that the interface provided by btparse, while complete, is fairly
57low-level. If you have more sophisticated needs, you might be interested my
58Text::BibTeX module for Perl 5 (available on CPAN).
59
60%description -l ja
61BibTeX ファイルを解析処理する C ライブラリです.
62
63%package -n %{libname}-devel
64Summary:        Headers for developing programs that will use %{name}
65Summary(ja):    %{name} のヘッダファイル
66Group:          Development/Libraries
67Requires:       %{libname} = %{version}
68Provides:       %{name}-devel = %{version}-%{release}
69Provides:       lib%{name}-devel = %{version}-%{release}
70
71%description -n %{libname}-devel
72This package contains the headers that programmers will need to develop
73applications which will use %{name}.
74
75
76%prep
77
78%setup -q
79
80%build
81%configure --disable-static
82%{__make}
83
84%install
85rm -rf $RPM_BUILD_ROOT
86%makeinstall
87%{__install} -d -m 755 %{buildroot}%{_datadir}/%{name}
88%{__install} -m 644 tests/data/* %{buildroot}%{_datadir}/%{name}
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%post -n %{libname} -p /sbin/ldconfig
94
95%postun -n %{libname} -p /sbin/ldconfig
96
97
98%files
99%defattr(-,root,root)
100%doc COPYING ChangeLog INSTALL README TODO
101%{_bindir}/*
102
103%files -n %{libname}
104%defattr (-,root,root)
105%{_libdir}/lib*.so.*
106
107%files -n %{libname}-devel
108%defattr (-,root,root)
109%{_includedir}/*
110#%{_libdir}/lib*.a
111%exclude %{_libdir}/lib*.la
112%{_libdir}/lib*.so
113%{_libdir}/pkgconfig/*.pc
114%{_mandir}/*/*
115%{_datadir}/%{name}
116# %{_libdir}/pkgconfig/%{name}.pc
117
118%changelog
119* Sat Feb 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.35-2
120- remove %%{_libdir}/lib*.a from %%files -n libbtparse-devel
121
122* Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 0.35-1vl5
123- applied new versioning policy, spec in utf-8
124- excluded *.la
125
126* Tue Nov 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.35-0vl1
127- new upstream release
128- updated URL
129
130* Wed Jun  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.34-0vl2
131- rebuilt for VineSeed(plus)
132- changed Group
133
134* Mon Oct 31 2005 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
135- Initial package for VineLinux3.2
136
Note: See TracBrowser for help on using the repository browser.