source: projects/specs/trunk/b/bookview/bookview-vl.spec @ 521

Revision 521, 3.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: BookView is a NDTP client.
2Summary(ja): BookView - NDTP クライアント
3Name: bookview
4Version: 3.2
5Release: 1%{?_dist_release}
6Source: ftp://ftp.sra.co.jp/pub/net/ndtp/bookview/%{name}-%{version}.tar.gz
7Source1: %{name}-redhat.tar.gz
8License: GPL
9Group: Applications/Text
10Url: http://www.sra.co.jp/people/m-kasahr/bookview/
11Buildarch: noarch
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: tcl >= 8.0.5_jp
14Requires: tk >= 8.0.5_jp
15BuildPrereq: tcl >= 8.4
16%define tkpath /usr/lib/tk8.0jp
17%define appsdir /etc/X11/applnk
18%define docpath %{_docdir}/%{name}-%{version}
19
20%description
21BookView is a NDTP (Network Dictionary Transfer Protocol) client
22written in Tcl /Tk. It requires Tcl/Tk8.0jp or Tcl/Tk8.3 and higher
23 (`jp' means `Japanized version').
24
25#'
26
27%description -l ja
28BookView は CD-ROM 書籍を読むための、Tcl/Tkで書かれた NDTP
29(Network Dictionary Transfer Protocol) クライアントです。
30動作させるには Tcl/Tk8.0jp あるいは Tcl/Tk8.3 以上が必要です。
31
32%prep
33rm -rf $RPM_BUILD_ROOT
34
35%setup -q -a 1
36
37# correct documents
38for i in doc/bookview.texi doc-ja/bookview-ja.texi;do
39    mv $i $i.org
40    cat $i.org | sed \
41        -e 's:/usr/local/etc/bookview.conf:/etc/%{name}/bookview.conf:g' \
42        -e 's:/usr/local:%{_prefix}:g' \
43        > $i
44done
45
46%build
47./configure --prefix=%{_prefix}       \
48    --sysconfdir=/etc/%{name}       \
49    --infodir=%{_infodir}
50make
51
52%install
53make DESTDIR=$RPM_BUILD_ROOT install
54install -d $RPM_BUILD_ROOT/etc/%{name}
55install -m 644 %{name}.conf  $RPM_BUILD_ROOT/etc/%{name}
56install -d $RPM_BUILD_ROOT%{_datadir}/pixmaps
57install -m 644 *.xpm  $RPM_BUILD_ROOT%{_datadir}/pixmaps
58install -d $RPM_BUILD_ROOT%{appsdir}/Applications
59install -m 644 *.desktop  $RPM_BUILD_ROOT%{appsdir}/Applications
60
61echo "Categories=Application;Utility;" >> \
62    $RPM_BUILD_ROOT%{appsdir}/Applications/BookView.desktop
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%post
68if [ -x /bin/grep -a -f /etc/services ] ; then
69grep -q "^ndtp" /etc/services || \
70echo "ndtp          2010/tcp       # added by bookview RPM" >>  /etc/services
71fi
72
73if [ -f %{tkpath}/kinput.tcl -a -x /bin/grep -a -x /bin/sed ]; then
74    if ! grep -q 'set KIStart .*<Shift-space>'  %{tkpath}/kinput.tcl; then
75        cat %{tkpath}/kinput.tcl  | \
76        sed 's/set KIStart "/set KIStart "<Shift-space> /' \
77             > %{tkpath}/kinput.tmp
78        mv  %{tkpath}/kinput.tcl %{tkpath}/kinput.tcl.rpmsave
79        echo Original file is saved as %{tkpath}/kinput.tcl.rpmsave
80        mv  %{tkpath}/kinput.tmp %{tkpath}/kinput.tcl
81    fi
82fi
83
84%files
85%defattr(-,root,root)
86%doc [ACNR]* doc*/help*.txt
87%{_bindir}/*
88%dir /etc/%{name}
89%config(missingok) /etc/%{name}/*
90%{_infodir}/*
91%{_datadir}/bookview/*
92%{_datadir}/pixmaps/*.xpm
93%config(missingok) %{appsdir}/Applications/*.desktop
94
95%changelog
96* Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-1vl5
97- applied new versioning policy, spec in utf-8
98
99* Sun Dec  5 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-0vl3
100- fixed .desktop
101
102* Tue Nov 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-0vl2
103- fixed spec file encoding (it was utf-8...)
104- fixed Group to Applications/Text
105
106* Wed Jun 25 2003 Masaki Shinomiya <shino@pos.to> 3.2-0vl1
107- new upstream release supports Tcl/Tk-8.3 and higher
108- noarch, omit documents for install
109- buildrequire tcl >= 8.4 to prevent to rebuild on Vine 2.x
110-
111- if you want to use this version on Vine 2.x,
112- just install noarch.rpm build with tcl >= 8.4.
113- it may works.
114
115* Sat Jun 14 2003 Masaki Shinomiya <shino@pos.to> 3.1.1-0vl1
116- post install script to modify services and kinput.tcl
117- configure with specifying sysconfdir and infdir
118- files, add luncher, description ja, requires, bookview.conf
119- requires, buildprereq
120
121* Sun May 20 2001 UECHI Yasumasa <uh@u.dhis.portside.net>
122- 1st release
123
Note: See TracBrowser for help on using the repository browser.