source: projects/specs/trunk/b/bonobo/bonobo-vl.spec @ 521

Revision 521, 5.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Note this is NOT a relocatable thing :)
2%define name    bonobo
3%define ver     1.0.22
4%define rel     6%{?_dist_release}
5
6Summary:        CORBA-based component system
7Summary(ja):    CORBAベースのコンポーネントシステム
8Name:           %{name}
9Version:        %{ver}
10Release:        %{rel}
11License:        GPL
12Group:          System Environment/Libraries
13Source:         ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.0/%{name}-%{ver}.tar.bz2
14URL:            http://www.gnome.org/
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildRequires:  gnome-libs-devel >= 1.4.2-2vl5
18BuildRequires:  ORBit-devel >= 0.5.8
19BuildRequires:  oaf-devel
20BuildRequires:  libxml-devel >= 1.8.15
21BuildRequires:  gdk-pixbuf-devel >= 0.21.0-0vl2
22BuildRequires:  gnome-print-devel >= 0.37-2vl5
23BuildRequires:  openjade gtk+-devel glib-devel
24#BuildRequires:  autoconf213, automake14
25Requires:       gnome-libs >= 1.4.2-2vl5
26Requires:       ORBit >= 0.5.8
27Requires:       oaf >= 0.6.2
28Requires:       libxml >= 1.8.15
29Requires:       gdk-pixbuf >= 0.21.0-0vl2
30Requires:       libgnomeprint15 >= 0.37-2vl5
31
32Patch0:         bonobo-1.0.17-config.patch
33Patch1:         bonobo-1.0.22-nonstatic.patch
34
35%description
36Bonobo is a library that provides the necessary framework for GNOME
37applications to deal with compound documents, i.e. those with a
38spreadsheet and graphic embedded in a word-processing document.
39
40%package devel
41Summary:        Libraries and include files for the Bonobo document model
42Summary(ja):    Bonobo の開発用ライブラリおよびヘッダファイル
43Group:          Development/Libraries
44Requires:       pkgconfig
45Requires:       %{name} = %{version}
46
47%description devel
48This package provides the necessary development libraries and include
49files to allow you to develop programs using the Bonobo document model.
50
51%prep
52%setup -q
53%patch1 -p1 -b .nonstatic
54
55%build
56%configure --disable-gtk-doc --disable-static
57export tagname=CC
58make LIBTOOL=/usr/bin/libtool
59
60%install
61[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
62export tagname=CC
63%makeinstall LIBTOOL=/usr/bin/libtool
64
65%find_lang %{name}
66
67## remove unuse files
68rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
69rm -rf $RPM_BUILD_ROOT%{_libdir}/*.a
70#rm -rf $RPM_BUILD_ROOT%{_libdir}/bonobo/*.la
71rm -rf $RPM_BUILD_ROOT%{_libdir}/bonobo/*/*.la
72rm -rf $RPM_BUILD_ROOT%{_libdir}/bonobo/*/*.a
73
74%clean
75[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
76
77%post -p /sbin/ldconfig
78 
79%postun -p /sbin/ldconfig
80
81%files -f %{name}.lang
82%defattr(-, root, root)
83%doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
84%{_bindir}/*
85%exclude %{_bindir}/libefs-config
86%{_libdir}/*.so.*
87%{_libdir}/bonobo/plugin/*.so
88%{_libdir}/bonobo/monikers/*.so
89%{_datadir}/bonobo/*
90%{_datadir}/gnome/*
91%{_datadir}/oaf/*
92#%{_datadir}/libefs/*
93%{_datadir}/idl/*
94
95%files devel
96%defattr (-, root, root)
97%{_bindir}/libefs-config
98%{_libdir}/*.so
99#{_libdir}/*.a
100#{_libdir}/*.la
101%{_libdir}/*.sh
102#%{_libdir}/bonobo/*/*.a
103#%{_libdir}/bonobo/*/*.la
104%{_libdir}/pkgconfig/*.pc
105%{_includedir}/*
106
107%changelog
108* Sat May  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.22-6
109- rebuilt with gnome-libs-1.4.2-2vl5 (linking with db-4.6)
110- remove *.a
111
112* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.22-5vl5
113- applied new versioning policy, spec in utf-8
114- remove *.la
115
116* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.22-4vl3
117- rebuild with new toolchain
118- dropped Patch0
119- added Patch1 for compiling new toolchain
120
121* Tue Oct 26 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.22-4vl2
122- rebuild with db4-4.2.52 and libgnomeprint-0.37
123- s/Copyright/License/
124- add Japanese summary
125- libefs-config moved to devel package
126
127* Sun May 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.22-4vl1
128- 1.0.22 based on Redhat Rawhide 1.0.22-4
129- changed Summary and Source URL
130
131* Wed Mar  5 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.17-0vl3
132- rebuilt with new toolchains
133- rebuilt with gdk-pixbuf-0.21.0-0vl2
134- use legacy autoconf-2.13 and automake-1.4
135
136* Wed Mar 27 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.17-0vl2
137- rebuilt with gdk-pixbuf-0.16.0-0vl1
138
139* Tue Dec 18 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.17-0vl1
140- New upstream release.
141
142* Fri Nov 23 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.9-0vl1
143- updated to the new upstream 1.0.9 release
144
145* Sat Jul 28 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
146- 1.0.7-0vl1
147- updated to new upstream release
148
149* Tue Jun 19 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.4-0vl1
150- New upstream release.
151- Fixed packaging mistake.
152
153* Tue May  8 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl2
154- Fixed missing files.
155
156* Tue May  8 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.0.3-0vl1
157- New upstream release.
158
159* Fri Mar 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.37-0vl2
160- Fixed defattr macro.
161
162* Tue Mar 13 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.37-0vl1
163- New upstream release.
164- Added relative execute for config.
165
166* Thu Dec 28 2000 Akira TAGOH <tagoh@gnome.gr.jp> 0.31.cvs20001221-0vl1
167- Build for Vine
168
169* Wed Oct 18 2000 Eskil Heyn Olsen <eskil@eazel.com>
170- Added requirements to the base package
171- Added bonobo-ui-extract to the file list of the base pacakge
172
173* Tue Feb 22 2000 Jens Finke <jens.finke@informatik.uni-oldenburg.de>
174- Added bonobo.h to the file list of devel package.
175
176* Wed Nov 10 1999 Alexander Skwar <ASkwar@DigitalProjects.com>
177- Updated to version 0.5
178- fixed spec file
179- Un-quiet things
180- stripped binaries
181- unsetted language environment variables
182
183* Sat Oct 2 1999 Gregory McLean <gregm@comstar.net>
184- Updated the spec for version 0.4
185- Updated the files section.
186
187* Sun Aug 1 1999 Gregory McLean <gregm@comstar.net>
188- Some updates. sysconfdir stuff, quiet down the prep/configure stage.
189
190* Sat May 1 1999 Erik Walthinsen <omega@cse.ogi.edu>
191- created spec file
Note: See TracBrowser for help on using the repository browser.