source: projects/specs/trunk/b/bogofilter/bogofilter-vl.spec @ 7227

Revision 7227, 5.4 KB checked in by daisuke, 11 years ago (diff)

bogofilter:

  • update to 1.2.3
  • use mecab instead of kakasi
  • BR: mecab-devel
Line 
1Name:           bogofilter
2Summary:        fast anti-spam filtering by Bayesian statistical analysis
3Summary(ja):    ベイジアン解析による高速アンチスパムフィルタリング
4Version:        1.2.3
5Release:        1%{?_dist_release}
6URL:            http://bogofilter.sourceforge.net/
7Source0:        http://prdownloads.sourceforge.net/bogofilter/bogofilter-%{version}.tar.bz2
8Source999:      filter-requires-bogofilter.sh
9Patch10:        http://www.c-wind.com/bogofilter/bogofilter-%{version}+mecab-0.1.patch.gz
10License:        GPLv2
11Group:          Applications/Internet
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  db4-devel >= 4.3.29, mecab-devel, gsl-devel, flex
15
16%define __find_requires %{SOURCE999}
17
18%description
19Bogofilter is a Bayesian spam filter.  In its normal mode of
20operation, it takes an email message or other text on standard input,
21does a statistical check against lists of "good" and "bad" words, and
22returns a status code indicating whether or not the message is spam.
23Bogofilter is designed with fast algorithms (including Berkeley DB system),
24coded directly in C, and tuned for speed, so it can be used for production
25by sites that process a lot of mail.
26
27%prep
28[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
29
30%setup -q
31%patch10 -p1 -b .mecab
32
33%build
34export CFLAGS="$RPM_OPT_FLAGS -DWAKATI"
35export LIBS="`mecab-config --libs`"
36%configure --program-prefix=
37%__make
38
39%install
40[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
41make install DESTDIR=$RPM_BUILD_ROOT
42
43%__cp -p %{buildroot}%{_sysconfdir}/bogofilter.cf.example \
44        %{buildroot}%{_sysconfdir}/bogofilter.cf
45
46for n in xml html ; do
47        %__install -d -m755 .inst/$n
48        %__install -p -m644 doc/*.$n .inst/$n
49done
50
51#for d in contrib ; do
52#       %__install -d -m755 %{buildroot}%{_datadir}/%{name}/$d
53#       for f in $(%{_bindir}/find $d -maxdepth 1 -type f) ; do
54#               case $f in
55#                       *.c|*.o|*.obj|*/Makefile*)
56#                               continue
57#                               ;;
58#                       *.1)
59#                               %__cp -p $f %{buildroot}%{_mandir}/man1
60#                               ;;
61#                       *)
62#                               %__cp -p $f %{buildroot}%{_datadir}/%{name}/$d
63#                               ;;
64#               esac
65#       done
66#done
67%{__chmod} -x contrib/*
68
69for README in contrib randomtrain ; do
70        %__ln_s ../../%{name}/contrib/README.$README doc/README.$README
71done
72
73# drop executable bit from contrib/* to avoid unneeded dependencies
74#%{_bindir}/find %{buildroot}%{_datadir}/%{name}/contrib -type f \
75#       -exec %__chmod -x '{}' \;
76
77%clean
78[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
79
80%files
81%defattr(-,root,root)
82%doc AUTHORS COPYING INSTALL NEWS
83%doc README* RELEASE.NOTES* TODO GETTING.STARTED
84%doc doc/README* doc/bogofilter-SA* doc/integrating* doc/rpm.notes.BerkeleyDB
85%doc doc/programmer
86%doc .inst/html .inst/xml
87%doc contrib
88
89%{_sysconfdir}/bogofilter.cf.example
90%config(noreplace) %{_sysconfdir}/bogofilter.cf
91
92%{_bindir}/bogofilter
93%{_bindir}/bogolexer
94%{_bindir}/bogotune
95%{_bindir}/bogoutil
96%{_bindir}/bogoupgrade
97%{_bindir}/bf_compact
98%{_bindir}/bf_copy
99%{_bindir}/bf_tar
100%{_mandir}/man1/bogofilter.1*
101%{_mandir}/man1/bogolexer.1*
102%{_mandir}/man1/bogotune.1*
103%{_mandir}/man1/bogoutil.1*
104%{_mandir}/man1/bogoupgrade.1*
105%{_mandir}/man1/bf_compact.1*
106%{_mandir}/man1/bf_copy.1*
107%{_mandir}/man1/bf_tar.1*
108
109%changelog
110* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
111- update to 1.2.3
112- use mecab instead of kakasi
113- BR: mecab-devel
114
115* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-2
116- rebuild with current VineSeed environment
117- fix perl requirements
118
119* Thu Dec 30 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.2.2-1
120- new upstream release
121- update Patch10
122- add Requires: kakasi (<BTS:VineLinux:852>)
123- updates Source999: add filtering string
124
125* Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.2-1vl5
126- applied new versioning policy, spec in utf-8
127
128* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl5
129- rebuild with gsl-1.9
130
131* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl4
132- rebuild with db4-4.3
133
134* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl3
135- add filter-requires-bogofilter.sh (source999)
136
137* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
138- rebuild
139
140* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
141- new upstream release
142- modified kakasi patch
143
144* Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl2
145- rebuild
146
147* Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl1
148- new upstream release
149- update kakasi patch
150- remove unneeded macro %%mydocdir
151- fix symlink
152- add Japanese summary
153- drop executable bit from contrib/*
154
155* Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl2
156- rebuild
157
158* Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl1
159- new upstream release
160- update and modify kakasi patch
161- fix dependencies
162  - add BuildRequires: kakasi-devel, gsl-devel, flex
163  - add Requires: gsl
164- update %%files
165  - update %%doc
166  - add %%{_bindir}/bf_{compact,copy,tar} and corresponding man pages
167
168* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.92.6-0vl2
169- rebuilt with db4-4.2.52
170
171* Tue Sep 21 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.6-0vl1
172- new upstream release.
173- update kakasi patch.
174
175* Sun May  2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.5-0vl1
176- new upstream release
177- add kakasi patch (http://www.ono.org/software/bogofilter/)
178
179* Sun Jun 15 2003 IWAI Masaharu <iwai@alib.jp> 0.13.6.2-0vl1
180- upstream release
181- using --program-prefix option with configure script
182- update %%files section
183
184* Fri May 16 2003 IWAI Masaharu <iwai@alib.jp> 0.12.3-0vl1
185- first release for Vine Linux
186
Note: See TracBrowser for help on using the repository browser.