source: projects/specs/trunk/b/bogofilter/bogofilter-vl.spec @ 2420

Revision 2420, 5.1 KB checked in by kazutaka, 13 years ago (diff)

<BTS:VineLinux:852>対応ついでにソースも更新

Line 
1Name:           bogofilter
2Summary:        fast anti-spam filtering by Bayesian statistical analysis
3Summary(ja):    ベイジアン解析による高速アンチスパムフィルタリング
4Version:        1.2.2
5Release:        1%{?_dist_release}
6URL:            http://bogofilter.sourceforge.net/
7Source0:        http://prdownloads.sourceforge.net/bogofilter/bogofilter-%{version}.tar.bz2
8Source999:      filter-requires-bogofilter.sh
9#Patch10:       http://www.ono.org/software/dist/%{name}-%{version}+kakasi-0.5.patch.gz
10Patch10:        http://www.c-wind.com/bogofilter/%{name}-%{version}+kakasi-0.5.patch.gz
11License:        GPL
12Group:          Applications/Internet
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14
15Requires:       kakasi
16BuildRequires:  db4-devel >= 4.3.29, kakasi, kakasi-devel, gsl-devel, flex
17
18%define __find_requires %{SOURCE999}
19
20%description
21Bogofilter is a Bayesian spam filter.  In its normal mode of
22operation, it takes an email message or other text on standard input,
23does a statistical check against lists of "good" and "bad" words, and
24returns a status code indicating whether or not the message is spam.
25Bogofilter is designed with fast algorithms (including Berkeley DB system),
26coded directly in C, and tuned for speed, so it can be used for production
27by sites that process a lot of mail.
28
29%prep
30[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
31
32%setup -q
33%patch10 -p1 -b .kakasi
34
35%build
36%configure --program-prefix=
37%__make
38
39%install
40[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
41%makeinstall
42
43%__cp -p %{buildroot}%{_sysconfdir}/bogofilter.cf.example \
44        %{buildroot}%{_sysconfdir}/bogofilter.cf
45
46for n in xml html ; do
47        %__install -d -m755 .inst/$n
48        %__install -p -m644 doc/*.$n .inst/$n
49done
50
51for d in contrib ; do
52        %__install -d -m755 %{buildroot}%{_datadir}/%{name}/$d
53        for f in $(%{_bindir}/find $d -maxdepth 1 -type f) ; do
54                case $f in
55                        *.c|*.o|*.obj|*/Makefile*)
56                                continue
57                                ;;
58                        *.1)
59                                %__cp -p $f %{buildroot}%{_mandir}/man1
60                                ;;
61                        *)
62                                %__cp -p $f %{buildroot}%{_datadir}/%{name}/$d
63                                ;;
64                esac
65        done
66done
67
68for README in contrib randomtrain ; do
69        %__ln_s ../../%{name}/contrib/README.$README doc/README.$README
70done
71
72# drop executable bit from contrib/* to avoid unneeded dependencies
73#%{_bindir}/find %{buildroot}%{_datadir}/%{name}/contrib -type f \
74#       -exec %__chmod -x '{}' \;
75
76%clean
77[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
78
79%files
80%defattr(-,root,root)
81%doc AUTHORS COPYING INSTALL NEWS
82%doc README* RELEASE.NOTES* TODO GETTING.STARTED
83%doc doc/README* doc/bogofilter-SA* doc/integrating* doc/rpm.notes.BerkeleyDB
84%doc doc/programmer
85%doc .inst/html .inst/xml
86
87%{_sysconfdir}/bogofilter.cf.example
88%config(noreplace) %{_sysconfdir}/bogofilter.cf
89
90%{_bindir}/bogofilter
91%{_bindir}/bogolexer
92%{_bindir}/bogotune
93%{_bindir}/bogoutil
94%{_bindir}/bogoupgrade
95%{_bindir}/bf_compact
96%{_bindir}/bf_copy
97%{_bindir}/bf_tar
98%{_datadir}/%{name}
99%{_mandir}/man1/bogofilter.1*
100%{_mandir}/man1/bogolexer.1*
101%{_mandir}/man1/bogotune.1*
102%{_mandir}/man1/bogoutil.1*
103%{_mandir}/man1/bogoupgrade.1*
104%{_mandir}/man1/bf_compact.1*
105%{_mandir}/man1/bf_copy.1*
106%{_mandir}/man1/bf_tar.1*
107
108%changelog
109* Thu Dec 30 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.2.2-1
110- new upstream release
111- update Patch10
112- add Requires: kakasi (<BTS:VineLinux:852>)
113- updates Source999: add filtering string
114
115* Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.2-1vl5
116- applied new versioning policy, spec in utf-8
117
118* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl5
119- rebuild with gsl-1.9
120
121* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl4
122- rebuild with db4-4.3
123
124* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl3
125- add filter-requires-bogofilter.sh (source999)
126
127* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
128- rebuild
129
130* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
131- new upstream release
132- modified kakasi patch
133
134* Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl2
135- rebuild
136
137* Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl1
138- new upstream release
139- update kakasi patch
140- remove unneeded macro %%mydocdir
141- fix symlink
142- add Japanese summary
143- drop executable bit from contrib/*
144
145* Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl2
146- rebuild
147
148* Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl1
149- new upstream release
150- update and modify kakasi patch
151- fix dependencies
152  - add BuildRequires: kakasi-devel, gsl-devel, flex
153  - add Requires: gsl
154- update %%files
155  - update %%doc
156  - add %%{_bindir}/bf_{compact,copy,tar} and corresponding man pages
157
158* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.92.6-0vl2
159- rebuilt with db4-4.2.52
160
161* Tue Sep 21 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.6-0vl1
162- new upstream release.
163- update kakasi patch.
164
165* Sun May  2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.5-0vl1
166- new upstream release
167- add kakasi patch (http://www.ono.org/software/bogofilter/)
168
169* Sun Jun 15 2003 IWAI Masaharu <iwai@alib.jp> 0.13.6.2-0vl1
170- upstream release
171- using --program-prefix option with configure script
172- update %%files section
173
174* Fri May 16 2003 IWAI Masaharu <iwai@alib.jp> 0.12.3-0vl1
175- first release for Vine Linux
176
Note: See TracBrowser for help on using the repository browser.