source: projects/specs/trunk/b/bogofilter/bogofilter-vl.spec @ 521

Revision 521, 4.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           bogofilter
2Summary:        fast anti-spam filtering by Bayesian statistical analysis
3Summary(ja):    ベイジアン解析による高速アンチスパムフィルタリング
4Version:        1.0.2
5Release:        1%{?_dist_release}
6URL:            http://bogofilter.sourceforge.net/
7Source0:        http://prdownloads.sourceforge.net/bogofilter/bogofilter-%{version}.tar.bz2
8Source999:      filter-requires-bogofilter.sh
9#Patch10:       http://www.ono.org/software/dist/%{name}-%{version}+kakasi-0.5.patch.gz
10Patch10:        %{name}-%{version}+kakasi-0.5.patch
11License:        GPL
12Group:          Applications/Internet
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  db4-devel >= 4.3.29, kakasi-devel, gsl-devel, flex
15
16%define __find_requires %{SOURCE999}
17
18%description
19Bogofilter is a Bayesian spam filter.  In its normal mode of
20operation, it takes an email message or other text on standard input,
21does a statistical check against lists of "good" and "bad" words, and
22returns a status code indicating whether or not the message is spam.
23Bogofilter is designed with fast algorithms (including Berkeley DB system),
24coded directly in C, and tuned for speed, so it can be used for production
25by sites that process a lot of mail.
26
27%prep
28[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
29
30%setup -q
31%patch10 -p1 -b .kakasi
32
33%build
34%configure --program-prefix=
35%__make
36
37%install
38[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
39%makeinstall
40
41%__cp -p %{buildroot}%{_sysconfdir}/bogofilter.cf.example \
42        %{buildroot}%{_sysconfdir}/bogofilter.cf
43
44for n in xml html ; do
45        %__install -d -m755 .inst/$n
46        %__install -p -m644 doc/*.$n .inst/$n
47done
48
49for d in contrib ; do
50        %__install -d -m755 %{buildroot}%{_datadir}/%{name}/$d
51        for f in $(%{_bindir}/find $d -maxdepth 1 -type f) ; do
52                case $f in
53                        *.c|*.o|*.obj|*/Makefile*)
54                                continue
55                                ;;
56                        *.1)
57                                %__cp -p $f %{buildroot}%{_mandir}/man1
58                                ;;
59                        *)
60                                %__cp -p $f %{buildroot}%{_datadir}/%{name}/$d
61                                ;;
62                esac
63        done
64done
65
66for README in contrib randomtrain ; do
67        %__ln_s ../../%{name}/contrib/README.$README doc/README.$README
68done
69
70# drop executable bit from contrib/* to avoid unneeded dependencies
71#%{_bindir}/find %{buildroot}%{_datadir}/%{name}/contrib -type f \
72#       -exec %__chmod -x '{}' \;
73
74%clean
75[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
76
77%files
78%defattr(-,root,root)
79%doc AUTHORS COPYING INSTALL NEWS
80%doc README* RELEASE.NOTES* TODO GETTING.STARTED
81%doc doc/README* doc/bogofilter-SA* doc/integrating* doc/rpm.notes.BerkeleyDB
82%doc doc/programmer
83%doc .inst/html .inst/xml
84
85%{_sysconfdir}/bogofilter.cf.example
86%config(noreplace) %{_sysconfdir}/bogofilter.cf
87
88%{_bindir}/bogofilter
89%{_bindir}/bogolexer
90%{_bindir}/bogotune
91%{_bindir}/bogoutil
92%{_bindir}/bogoupgrade
93%{_bindir}/bf_compact
94%{_bindir}/bf_copy
95%{_bindir}/bf_tar
96%{_datadir}/%{name}
97%{_mandir}/man1/bogofilter.1*
98%{_mandir}/man1/bogolexer.1*
99%{_mandir}/man1/bogotune.1*
100%{_mandir}/man1/bogoutil.1*
101%{_mandir}/man1/bogoupgrade.1*
102%{_mandir}/man1/bf_compact.1*
103%{_mandir}/man1/bf_copy.1*
104%{_mandir}/man1/bf_tar.1*
105
106%changelog
107* Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.2-1vl5
108- applied new versioning policy, spec in utf-8
109
110* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl5
111- rebuild with gsl-1.9
112
113* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl4
114- rebuild with db4-4.3
115
116* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl3
117- add filter-requires-bogofilter.sh (source999)
118
119* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
120- rebuild
121
122* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
123- new upstream release
124- modified kakasi patch
125
126* Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl2
127- rebuild
128
129* Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl1
130- new upstream release
131- update kakasi patch
132- remove unneeded macro %%mydocdir
133- fix symlink
134- add Japanese summary
135- drop executable bit from contrib/*
136
137* Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl2
138- rebuild
139
140* Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl1
141- new upstream release
142- update and modify kakasi patch
143- fix dependencies
144  - add BuildRequires: kakasi-devel, gsl-devel, flex
145  - add Requires: gsl
146- update %%files
147  - update %%doc
148  - add %%{_bindir}/bf_{compact,copy,tar} and corresponding man pages
149
150* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.92.6-0vl2
151- rebuilt with db4-4.2.52
152
153* Tue Sep 21 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.6-0vl1
154- new upstream release.
155- update kakasi patch.
156
157* Sun May  2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.5-0vl1
158- new upstream release
159- add kakasi patch (http://www.ono.org/software/bogofilter/)
160
161* Sun Jun 15 2003 IWAI Masaharu <iwai@alib.jp> 0.13.6.2-0vl1
162- upstream release
163- using --program-prefix option with configure script
164- update %%files section
165
166* Fri May 16 2003 IWAI Masaharu <iwai@alib.jp> 0.12.3-0vl1
167- first release for Vine Linux
168
Note: See TracBrowser for help on using the repository browser.