source: projects/specs/trunk/b/bogofilter/bogofilter-vl.spec @ 12268

Revision 12268, 6.0 KB checked in by ara_t, 5 years ago (diff)

bogofilter: rebuild with gsl-2.6

Line 
1Name:      bogofilter
2Summary:   fast anti-spam filtering by Bayesian statistical analysis
3Summary(ja):  ベイジアン解析による高速アンチスパムフィルタリング
4Version:   1.2.4
5Release:   5%{?_dist_release}
6License:   GPLv2
7Group:     Applications/Internet
8URL:       http://bogofilter.sourceforge.net/
9Source0:   http://prdownloads.sourceforge.net/bogofilter/bogofilter-%{version}.tar.bz2
10Source999: filter-requires-bogofilter.sh
11Patch10:   http://www.c-wind.com/bogofilter/bogofilter-%{version}+mecab-0.1.patch.gz
12
13BuildRoot:  %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  libdb-devel
15BuildRequires:  mecab-devel
16BuildRequires:  gsl-devel
17BuildRequires:  flex
18BuildRequires:  xmlto
19
20%define __find_requires %{SOURCE999}
21
22%description
23Bogofilter is a Bayesian spam filter.  In its normal mode of
24operation, it takes an email message or other text on standard input,
25does a statistical check against lists of "good" and "bad" words, and
26returns a status code indicating whether or not the message is spam.
27Bogofilter is designed with fast algorithms (including Berkeley DB system),
28coded directly in C, and tuned for speed, so it can be used for production
29by sites that process a lot of mail.
30
31%prep
32[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
33
34%setup -q
35%patch10 -p1 -b .mecab
36
37%build
38export CFLAGS="$RPM_OPT_FLAGS -DWAKATI"
39export LIBS="`mecab-config --libs`"
40%configure --program-prefix=
41%__make
42
43%install
44[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
45make install DESTDIR=$RPM_BUILD_ROOT
46
47%__cp -p %{buildroot}%{_sysconfdir}/bogofilter.cf.example \
48      %{buildroot}%{_sysconfdir}/bogofilter.cf
49
50for n in xml html ; do
51    %__install -d -m755 .inst/$n
52    %__install -p -m644 doc/*.$n .inst/$n
53done
54
55#for d in contrib ; do
56#  %__install -d -m755 %{buildroot}%{_datadir}/%{name}/$d
57#  for f in $(%{_bindir}/find $d -maxdepth 1 -type f) ; do
58#    case $f in
59#      *.c|*.o|*.obj|*/Makefile*)
60#        continue
61#        ;;
62#      *.1)
63#        %__cp -p $f %{buildroot}%{_mandir}/man1
64#        ;;
65#      *)
66#        %__cp -p $f %{buildroot}%{_datadir}/%{name}/$d
67#        ;;
68#    esac
69#  done
70#done
71%{__chmod} -x contrib/*
72
73for README in contrib randomtrain ; do
74    %__ln_s ../../%{name}/contrib/README.$README doc/README.$README
75done
76
77# drop executable bit from contrib/* to avoid unneeded dependencies
78#%{_bindir}/find %{buildroot}%{_datadir}/%{name}/contrib -type f \
79#  -exec %__chmod -x '{}' \;
80
81%clean
82[ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
83
84
85%files
86%defattr(-,root,root)
87%doc AUTHORS COPYING INSTALL NEWS
88%doc README* RELEASE.NOTES* TODO GETTING.STARTED
89%doc doc/README* doc/bogofilter-SA* doc/integrating* doc/rpm.notes.BerkeleyDB
90%doc doc/programmer
91%doc .inst/html .inst/xml
92%doc contrib
93
94%{_sysconfdir}/bogofilter.cf.example
95%config(noreplace) %{_sysconfdir}/bogofilter.cf
96
97%{_bindir}/bogofilter
98%{_bindir}/bogolexer
99%{_bindir}/bogotune
100%{_bindir}/bogoutil
101%{_bindir}/bogoupgrade
102%{_bindir}/bf_compact
103%{_bindir}/bf_copy
104%{_bindir}/bf_tar
105%{_mandir}/man1/bogofilter.1*
106%{_mandir}/man1/bogolexer.1*
107%{_mandir}/man1/bogotune.1*
108%{_mandir}/man1/bogoutil.1*
109%{_mandir}/man1/bogoupgrade.1*
110%{_mandir}/man1/bf_compact.1*
111%{_mandir}/man1/bf_copy.1*
112%{_mandir}/man1/bf_tar.1*
113
114
115%changelog
116* Mon Oct 14 2019 Toshiaki Ara <ara_t@384.jp> 1.2.4-5
117- rebuild under gsl-2.6
118
119* Sun Jun 03 2018 Toshiaki Ara <ara_t@384.jp> 1.2.4-4
120- rebuild under gsl-2.4
121
122* Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 1.2.4-3
123- rebuild under gsl-2.2.1
124
125* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-2
126- rebuild with gcc-5.4.0
127
128* Thu Feb  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.4-1
129- update to 1.2.4
130- built with libdb 5.3.28
131- BR: xmlto
132
133* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
134- update to 1.2.3
135- use mecab instead of kakasi
136- BR: mecab-devel
137
138* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-2
139- rebuild with current VineSeed environment
140- fix perl requirements
141
142* Thu Dec 30 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.2.2-1
143- new upstream release
144- update Patch10
145- add Requires: kakasi (<BTS:VineLinux:852>)
146- updates Source999: add filtering string
147
148* Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.2-1vl5
149- applied new versioning policy, spec in utf-8
150
151* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl5
152- rebuild with gsl-1.9
153
154* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl4
155- rebuild with db4-4.3
156
157* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl3
158- add filter-requires-bogofilter.sh (source999)
159
160* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
161- rebuild
162
163* Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
164- new upstream release
165- modified kakasi patch
166
167* Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl2
168- rebuild
169
170* Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl1
171- new upstream release
172- update kakasi patch
173- remove unneeded macro %%mydocdir
174- fix symlink
175- add Japanese summary
176- drop executable bit from contrib/*
177
178* Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl2
179- rebuild
180
181* Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl1
182- new upstream release
183- update and modify kakasi patch
184- fix dependencies
185  - add BuildRequires: kakasi-devel, gsl-devel, flex
186  - add Requires: gsl
187- update %%files
188  - update %%doc
189  - add %%{_bindir}/bf_{compact,copy,tar} and corresponding man pages
190
191* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.92.6-0vl2
192- rebuilt with db4-4.2.52
193
194* Tue Sep 21 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.6-0vl1
195- new upstream release.
196- update kakasi patch.
197
198* Sun May  2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.5-0vl1
199- new upstream release
200- add kakasi patch (http://www.ono.org/software/bogofilter/)
201
202* Sun Jun 15 2003 IWAI Masaharu <iwai@alib.jp> 0.13.6.2-0vl1
203- upstream release
204- using --program-prefix option with configure script
205- update %%files section
206
207* Fri May 16 2003 IWAI Masaharu <iwai@alib.jp> 0.12.3-0vl1
208- first release for Vine Linux
209
Note: See TracBrowser for help on using the repository browser.