source: projects/specs/trunk/b/bogl/bogl-vl.spec @ 521

Revision 521, 7.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A terminal program for displaying Unicode on the console.
2Summary(ja): コンソール上でユニコードを表示するためのターミナルプログラム
3Name: bogl
4Version: 0.1.18
5Release: 9%{?_dist_release}
6URL: http://www.msu.edu/user/pfaffben/projects.html
7Source0: http://ftp.debian.org/debian/pool/main/b/bogl/bogl_0.1.18-1.5.tar.gz
8Source1: wlite-0.8.1.tar.gz
9Source4: 14x14cjk.bdf.gz
10Patch: bogl-0.1.18-1.5-vine.patch
11Patch1: bogl-0.1.9-fpic.patch
12Patch3: bogl-0.1.9-2.6fbdev.patch
13Patch5: bogl-0.1.18-noexecstack.patch
14Epoch: 0
15License: GPL
16Group: System Environment/Libraries
17BuildRoot: %{_tmppath}/%{name}-root
18BuildRequires: gd-devel, libpng-devel
19
20%description
21BOGL stands for Ben's Own Graphics Library.  It is a small graphics
22library for Linux kernel frame buffers.  It supports only very simple
23graphics.
24
25%package devel
26Summary: Development files required to build BOGL applications.
27Group: Development/Libraries
28Requires: bogl = %{epoch}:%{version}-%{release}
29
30%description devel
31The bogl-devel package contains the static libraries and header files
32for writing BOGL applications.
33
34%package bterm
35Summary: A Unicode capable terminal program for the Linux frame buffer.
36Group: Applications/System
37Requires: bogl = %{epoch}:%{version}-%{release}
38
39%description bterm
40The bterm application is a terminal emulator that displays to a Linux
41frame buffer.  It is able to display Unicode text on the console.
42
43%prep
44%setup -q -a 1
45%patch -p1 -b .rh
46%patch1 -p1 -b .fpic
47%patch3 -p1 -b .26fbdev
48%patch5 -p1 -b .noexecstack
49
50%build
51make CFLAGS="$RPM_OPT_FLAGS"
52gunzip -c %{SOURCE4} > font.bdf
53./bdftobogl -b font.bdf > font.bgf
54
55%install
56rm -rf $RPM_BUILD_ROOT
57make DESTDIR=$RPM_BUILD_ROOT libdir=%{_libdir} install
58make -C wlite prefix=$RPM_BUILD_ROOT/%{_prefix} libdir=$RPM_BUILD_ROOT/%{_libdir} install
59if [ -f wlite/libwlitediet.a ]; then
60    install -m 644 wlite/libwlitediet.a $RPM_BUILD_ROOT/%{_libdir}
61fi
62mkdir -p $RPM_BUILD_ROOT/usr/lib/bogl/
63cp font.bgf $RPM_BUILD_ROOT/usr/lib/bogl/
64cp font.bdf $RPM_BUILD_ROOT/usr/lib/bogl/
65gzip -9 $RPM_BUILD_ROOT/usr/lib/bogl/font.bgf
66gzip -9 $RPM_BUILD_ROOT/usr/lib/bogl/font.bdf
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71%post -p /sbin/ldconfig
72
73%postun -p /sbin/ldconfig
74
75%files
76%defattr(-,root,root)
77%doc README
78%{_libdir}/*.so.*
79
80%files devel
81%defattr(-,root,root)
82%{_bindir}/bdftobogl
83%{_bindir}/mergebdf
84%{_bindir}/pngtobogl
85%{_bindir}/reduce-font
86%{_libdir}/*.a
87%{_libdir}/*.so
88%{_includedir}/bogl
89%{_includedir}/wlite*
90
91%files bterm
92%defattr(-,root,root)
93%doc README.BOGL-bterm
94%{_bindir}/bterm
95%dir %{_datadir}/terminfo/b
96%{_datadir}/terminfo/b/bterm
97/usr/lib/bogl
98
99%changelog
100* Sat Apr 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.18-9
101- add font.bdf for anaconda
102
103* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.18-8
104- update to 0.1.18-1.5
105- spec in utf-8, new versioning policy
106- remove unused ucs fonts
107- remove unneeded font.bdf
108
109* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.18-7vl1
110- initial build for Vine Linux
111
112* Fri Mar  4 2005 Miloslav Trmac <mitr@redhat.com> - 0:0.1.18-7
113- Add missing includes in bogl-0.1.18-rh.patch
114- Rebuild with gcc 4
115
116* Thu Feb 17 2005 Miloslav Trmac <mitr@redhat.com> - 0:0.1.18-6
117- Don't require executable stack
118- Fix build with gcc 4
119- Use $RPM_OPT_FLAGS
120
121* Tue Nov 23 2004 Jeremy Katz <katzj@redhat.com> - 0:0.1.18-5
122- don't build against dietlibc anymore on x86
123
124* Wed Oct 20 2004 Jeremy Katz <katzj@redhat.com> - 0:0.1.18-4
125- rebuild again
126
127* Tue Oct 19 2004 Jeremy Katz <katzj@redhat.com> - 0:0.1.18-3
128- rebuild against newer diet with fixed signal handling
129
130* Mon Sep  6 2004 Jeremy Katz <katzj@redhat.com> - 0:0.1.18-2
131- fPIC on ppc too (#130719)
132
133* Mon Jul 05 2004 Akira TAGOH <tagoh@redhat.com> 0:0.1.18-1
134- New upstream release.
135  #113910 has been fixed in this release.
136- bogl-0.1.18-rh.patch: updated to be able to apply it for this release.
137- bogl-0.1.9-vga16-others.patch: removed. no need this patch anymore.
138
139* Fri Jun 18 2004 Jeremy Katz <katzj@redhat.com> - 0:0.1.9-33
140- fix build with gcc 3.4
141
142* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
143- rebuilt
144
145* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
146- rebuilt
147
148* Wed Feb 18 2004 Jeremy Katz <katzj@redhat.com> - 0:0.1.9-31
149- fix build
150
151* Tue Feb 17 2004 Jeremy Katz <katzj@redhat.com> - 0:0.1.9-30
152- fix to work with changed 2.6 fbdev semantics
153
154* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
155- rebuilt
156
157* Mon Dec 15 2003 Matt Wilson <msw@redhat.com> 0:0.1.9-28
158- add BuildRequires: gd-devel, libpng-devel (#111165)
159
160* Mon Aug 25 2003 Jeremy Katz <katzj@redhat.com> 0:0.1.9-27
161- add hack to fix #92240
162
163* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
164- rebuilt
165
166* Fri May 30 2003 Matt Wilson <msw@redhat.com> 0:0.1.9-25
167- rebuild
168
169* Fri May 30 2003 Matt Wilson <msw@redhat.com> 0:0.1.9-24
170- enable vga16 support on ia64
171- removed workaround for AMD64, kernel should be fixed now
172
173* Tue May 06 2003 Phil Knirsch <pknirsch@redhat.com>  0:0.1.9-23
174- Bumped release and rebuilt due to new gd version.
175
176* Wed Apr  2 2003 Matt Wilson <msw@redhat.com> 0:0.1.9-22
177- add a workaround for AMD64 that calls iopl(3) in order to gain io
178  port access until ioperm() is fixed (#87835).  Workaround for
179  (#86321)
180- gzip font.bgf
181
182* Wed Mar 19 2003 Jeremy Katz <katzj@redhat.com> 0:0.1.9-21
183- include vga16fb support on x86_64 (#86321)
184
185* Thu Feb 13 2003 Adrian Havill <havill@redhat.com> 0:0.1.9-20
186- Change the font combo to add zh, change ja to k14 (#81717, #82888)
187
188* Tue Feb 11 2003 Jeremy Katz <katzj@redhat.com> 0:0.1.9-19
189- actually do the test correctly
190- buildrequire dietlibc on i386
191
192* Tue Feb 11 2003 Jeremy Katz <katzj@redhat.com> 0:0.1.9-18
193- only fPIC on needed arches, and do it everywhere
194
195* Mon Feb 10 2003 Matt Wilson <msw@redhat.com> 0:0.1.9-17
196- always use wlite for bogl/bterm (for now) (#83980)
197  (this makes bterm useless for any non-UTF-8 locale)
198- fixed 'bterm' for the normal usage case
199
200* Mon Feb  3 2003 Matt Wilson <msw@redhat.com> 0:0.1.9-16
201- add back the Epoch: to support upgrading from betas
202
203* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
204- rebuilt
205
206* Mon Dec 30 2002 Jeremy Katz <katzj@redhat.com> 0.1.9-14
207- build wlite with -fPIC
208- fix deps of subpackages
209
210* Sun Dec 29 2002 Florian La Roche <Florian.LaRoche@redhat.de>
211- delete "Epoch: 0" line in spec file
212
213* Mon Dec 16 2002 Adrian Havill <havill@redhat.com> 0.1.9-12
214- added bogl.bdf.gz to allow us to reduce-font in loader build
215
216* Mon Dec 16 2002 Adrian Havill <havill@redhat.com> 0.1.9-11
217- fixed broken reduce-font to test ENCODING x instead of STARTCHAR x
218
219* Mon Dec 16 2002 Matt Wilson <msw@redhat.com> 0.1.9-10
220- made more changes to the rh patch to enable bogl embedding insode loader
221
222* Tue Dec 10 2002 Matt Wilson <msw@redhat.com>
223- use all fb drivers on non-i386
224- package wlite for use in loader
225- use %%{_libdir} to get lib64 right
226
227* Mon Dec 10 2002 Adrian Havill <havill@redhat.com>
228- swapped out utf8 code with new and improved wlite
229
230* Tue Nov 26 2002 Adrian Havill <havill@redhat.com>
231- re-write font loader so it can load uncompressed or gzipped files
232- utf8 lib updated
233- fixed bug in bogl_term_new() so struct is inited (s/malloc/calloc/)
234- added term bell (screen flash)
235- changed background/foreground to pretty pretty blue/white
236
237* Thu Nov 21 2002 Adrian Havill <havill@redhat.com>
238- updated utf8 library
239- made bogl_term_out reset the state at every call so glibc
240  and utf8.c behave consistently
241- concatenated two Red Hat diff patches
242
243* Wed Nov 20 2002 Adrian Havill <havill@redhat.com>
244- changed behavior of bogl_term_out to queue and save UTF broken between two
245  buffers
246- utf8 lib improvements
247
248* Thu Nov 14 2002 root <msw@redhat.com>
249- integrate havill's utf8 for diet libs
250- build and install font
251
252* Tue Jul 23 2002 Matt Wilson <msw@redhat.com>
253- Initial build.
Note: See TracBrowser for help on using the repository browser.