source: projects/specs/trunk/b/bluez/bluez-vl.spec @ 7791

Revision 7791, 13.5 KB checked in by daisuke, 11 years ago (diff)

bluez: build with sbc

Line 
1Summary: Bluetooth utilities
2Summary(ja): Bluetooth ユーティリティ
3Name: bluez
4Version: 4.101
5Release: 2%{?_dist_release}
6License: GPLv2+
7Group: Applications/System
8
9URL: http://www.bluez.org/
10
11Vendor: Project Vine
12Distribution: Vine Linux
13Packager: daisuke, Takemikaduchi
14
15#----------------------------------------------------------------------------
16
17Source: http://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.gz
18Source1: bluetooth.init.vine
19Source3: bluez-uinput.modules
20
21Source11: trusts.txt
22Source20: main.conf
23
24# http://thread.gmane.org/gmane.linux.bluez.kernel/1754
25Patch3: bluez-activate-wacom-mode2.patch
26# https://bugzilla.redhat.com/show_bug.cgi?id=498756
27Patch4: bluez-socket-mobile-cf-connection-kit.patch
28
29#----------------------------------------------------------------------------
30BuildRoot:      %{_tmppath}/%{name}-%{version}-root
31
32BuildRequires:  flex
33BuildRequires:  bison
34BuildRequires:  check-devel
35BuildRequires:  dbus-devel
36BuildRequires:  glib2-devel
37BuildRequires:  libusb-devel
38BuildRequires:  libudev-devel
39BuildRequires:  alsa-lib-devel
40BuildRequires:  gstreamer-devel
41BuildRequires:  gstreamer-plugins-base-devel
42BuildRequires:  libsndfile-devel
43BuildRequires:  readline-devel
44BuildRequires:  sbc-devel
45
46ExcludeArch: s390 s390x
47
48Obsoletes: bluez-pan < 4.0, bluez-sdp < 4.0
49Requires: initscripts, bluez-libs = %{version}
50Requires: dbus >= 0.60
51# Requires: fuse
52## Requires: hwdata >= 0.215
53Requires: hwdata >= 0.146
54# virtual provides "dbus-bluez-pin-helper" ex. bluez-gnome
55Requires: dbus-bluez-pin-helper
56Requires(preun): /sbin/chkconfig, /sbin/service
57Requires(post): /sbin/chkconfig, /sbin/service
58#----------------------------------------------------------------------------
59
60Obsoletes: bluez-utils < 4.5-2
61Provides: bluez-utils = %{version}-%{release}
62
63#----------------------------------------------------------------------------
64%description
65Utilities for use in Bluetooth applications:
66        - hcitool
67        - hciattach
68        - hciconfig
69        - bluetoothd
70        - l2ping
71        - start scripts VineLinux (RedHat base)
72        - pcmcia configuration files
73
74 Please, read %{_defaultdocdir}/%{name}-%{version}/trusts.txt
75
76The BLUETOOTH trademarks are owned by Bluetooth SIG, Inc., U.S.A.
77
78%description -l ja
79Bluetooth ユーティリティ (bluez-utils):
80        - hcitool
81        - hciattach
82        - hciconfig
83        - l2ping
84        - 起動スクリプト (Red Hat用をVineLinuxに合わせました)
85        - pcmcia コンフィグレーション ファイル
86※付属の%{_defaultdocdir}/%{name}-%{version}/trusts.txtもご覧下さい。
87
88(BLUETOOTH は Bluetooth SIG, Inc.(USA)のトレードマークです)
89
90#----------------------------------------------------------------------------
91%package libs
92Summary: Libraries for use in Bluetooth applications
93Summary(ja): BlueTooth アプリケーションの使用するライブラリ(BlueZ)
94Group: System Environment/Libraries
95
96%description libs
97Libraries for use in Bluetooth applications.
98
99%description libs -l ja
100Bluetooth アプリケーションのためのライブラリです。
101※BlueZ のユーティリティのためにも必要です
102
103#----------------------------------------------------------------------------
104%package libs-devel
105Summary: Development libraries for Bluetooth applications
106Summary(ja): Bluetooth アプリケーション開発のためのdevelパッケージ
107Group: Development/Libraries
108Requires: bluez-libs = %{version}
109Requires: pkgconfig
110Obsoletes: bluez-sdp-devel < 4.0
111
112%description libs-devel
113bluez-libs-devel contains development libraries and headers for
114use in Bluetooth applications.
115
116%description libs-devel -l ja
117bluez-libs-devel パッケージは Bluetooth アプリケーション開発のための
118ライブラリやヘッダーファイルを提供します。
119
120#----------------------------------------------------------------------------
121%package cups
122Summary: CUPS printer backend for Bluetooth printers
123Summary(ja): Bluetooth 経由の CUPS プリンタシステム用
124Group: System Environment/Daemons
125Obsoletes: bluez-utils-cups < 4.5-2
126Provides: bluez-utils-cups = %{version}-%{release}
127Requires: bluez-libs = %{version}
128Requires: cups
129
130%description cups
131This package contains the CUPS backend
132
133%description cups -l ja
134Bluetooth対応 プリンターを CUPS印刷システムから利用する
135ためのバックエンドです。
136
137#----------------------------------------------------------------------------
138%package gstreamer
139Summary: GStreamer support for SBC audio format
140Summary(ja):GStreamer で SBCオーディオプロファイルをサポートします
141Group: System Environment/Daemons
142Obsoletes: bluez-utils-gstreamer < 4.5-2
143Provides: bluez-utils-gstreamer = %{version}-%{release}
144Requires: bluez-libs = %{version}
145
146%description gstreamer
147This package contains gstreamer plugins for the Bluetooth SBC audio format
148
149%description gstreamer -l ja
150Bluetooth の SBCオーディオプロファイルを扱う gstreamer プラグインが
151含まれています。
152
153#----------------------------------------------------------------------------
154%package alsa
155Summary: ALSA support for Bluetooth audio devices
156Summary(ja): Bluetooth オーディオ機器の ALSA サポート
157Obsoletes: bluez-utils-alsa < 4.5-2
158Provides: bluez-utils-alsa = %{version}-%{release}
159Group: System Environment/Daemons
160Requires: bluez-libs = %{version}
161
162%description alsa
163This package contains ALSA support for Bluetooth audio devices
164
165%description alsa -l ja
166Bluetooth オーディオ機器のためのALSAサポートを含むパッケージです。
167
168#----------------------------------------------------------------------------
169
170%prep
171rm -rf $RPM_BUILD_ROOT
172
173%setup -q
174%patch3 -p1 -b .wacom
175%patch4 -p1 -b .socket-mobile
176
177%build
178libtoolize -f -c
179autoreconf
180%configure \
181    --enable-cups --enable-hid2hci --enable-dfutool \
182    --enable-tools --enable-bccmd --enable-gstreamer \
183    --enable-hidd --enable-pand --enable-dund
184
185# copy txt
186cp %{SOURCE11} .
187
188make
189
190#----------------------------------------------------------------------------
191%install
192rm -rf $RPM_BUILD_ROOT
193make install DESTDIR=$RPM_BUILD_ROOT
194/sbin/ldconfig -n $RPM_BUILD_ROOT/%{_libdir}
195# Remove autocrap and libtool droppings
196rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la                           \
197        $RPM_BUILD_ROOT/%{_libdir}/alsa-lib/*.la                \
198        $RPM_BUILD_ROOT/%{_libdir}/bluetooth/plugins/*.la       \
199        $RPM_BUILD_ROOT/%{_libdir}/gstreamer-0.10/*.la
200
201install -D -m0755 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/bluetooth
202
203# replace main.conf
204rm -f $RPM_BUILD_ROOT%{_sysconfdir}/bluetooth/main.conf
205install -D -m0644 %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/bluetooth/
206# rename serial-api.txt
207mv  doc/serial-api.txt doc/serial-api_doc.txt
208
209
210rm -f ${RPM_BUILD_ROOT}/%{_sysconfdir}/udev/*.rules
211install -D -m0644 scripts/bluetooth-serial.rules ${RPM_BUILD_ROOT}/%{_sysconfdir}/udev/rules.d/97-bluetooth-serial.rules
212install -D -m0755 scripts/bluetooth_serial ${RPM_BUILD_ROOT}/lib/udev/bluetooth_serial
213install -D -m0644 scripts/bluetooth-hid2hci.rules ${RPM_BUILD_ROOT}/%{_sysconfdir}/udev/rules.d/97-bluetooth-hid2hci.rules
214
215install -D -m0755 %{SOURCE3} $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/modules/bluez-uinput.modules
216
217install -d -m0755 $RPM_BUILD_ROOT/%{_localstatedir}/lib/bluetooth
218
219mkdir -p $RPM_BUILD_ROOT/%{_libdir}/bluetooth/
220
221install -D -p -m0644 audio/audio.conf ${RPM_BUILD_ROOT}/etc/bluetooth/
222
223%clean
224rm -rf $RPM_BUILD_ROOT
225
226#----------------------------------------------------------------------------
227%post
228/sbin/chkconfig --add bluetooth
229if [ "$1" -ge "1" ]; then
230        /sbin/service bluetooth condrestart >/dev/null 2>&1 || :
231fi
232exit 0
233
234%preun
235if [ "$1" = "0" ]; then
236        /sbin/service bluetooth stop >/dev/null 2>&1 || :
237        /sbin/chkconfig --del bluetooth
238fi
239exit 0
240
241%post libs
242/sbin/ldconfig
243
244%postun libs
245/sbin/ldconfig
246
247#----------------------------------------------------------------------------
248%files
249%defattr(-, root, root)
250%{_bindir}/*
251%{_sbindir}/*
252%{_mandir}/man1/*
253%{_mandir}/man8/*
254%dir %{_sysconfdir}/bluetooth/
255%config(noreplace) %{_sysconfdir}/bluetooth/*
256%config(noreplace) %{_sysconfdir}/sysconfig/*
257%config %{_sysconfdir}/dbus-1/system.d/bluetooth.conf
258%{_sysconfdir}/udev/rules.d/*.rules
259%{_sysconfdir}/rc.d/init.d/*
260%{_libdir}/bluetooth/
261%{_datadir}/dbus-1/system-services/org.bluez.service
262/lib/udev/bluetooth_serial
263/lib/udev/hid2hci
264/lib/udev/rules.d/*.rules
265
266%files libs
267%defattr(-, root, root)
268%{_libdir}/libbluetooth.so.*
269%doc AUTHORS COPYING INSTALL ChangeLog NEWS README trusts.txt
270%doc */*.txt
271
272%files libs-devel
273%defattr(-, root, root)
274%{_libdir}/libbluetooth.so
275%dir %{_includedir}/bluetooth
276%{_includedir}/bluetooth/*
277%{_libdir}/pkgconfig/bluez.pc
278
279%files cups
280%defattr(-, root, root)
281%{_libdir}/cups/backend/bluetooth
282
283%files gstreamer
284%defattr(-, root, root)
285%{_libdir}/gstreamer-*/*.so
286
287%files alsa
288%defattr(-, root, root)
289#%config %{_sysconfdir}/alsa/bluetooth.conf
290%config %{_datadir}/alsa/bluetooth.conf
291%{_libdir}/alsa-lib/*.so
292
293%changelog
294* Thu Jul 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.101-2
295- build with sbc
296  - add BR: sbc-devel
297
298* Sun Jun 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.101-1
299- new upstream release
300
301* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.99-1
302- new upstream release
303
304* Thu Feb 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.98-1
305- new upstream release
306
307* Sun Dec 25 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.97-1
308- new upstream release
309- add BuildRequires: check-devel, readline-devel
310
311* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.96-1
312- new upstream release
313- add BuildRequires: libudev-devel
314
315* Thu Feb 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.89-1
316- new upstream release
317
318* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.87-1
319- new upstream release
320
321* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.84-1
322- new upstream release
323
324* Sun Dec 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.82-1
325- new upstream release
326
327* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.81-1
328- new upstream release
329
330* Tue Nov 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.79-1
331- new upstream release
332- drop Patch2
333
334* Wed Nov 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.77-1
335- new upstream release
336- fix %files (change path of alsa/bluetooth.conf)
337
338* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.69-2
339- rebuild with rpm-4.8.1 for pkg-config file
340
341* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.69-1
342- new upstream release
343
344* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.66-1
345- new upstream release
346
347* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.64-1
348- new upstream release
349- drop Patch1, Patch5, Patch6
350
351* Sun Jul 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.42-2
352- add bluetooth.init again.
353  - on-demand startup on bootup process will fail, because
354    D-BUS service is not started yet.
355
356* Sun Jun 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.42-1
357- new upstream release
358
359* Mon Jun 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.41-2
360- remove bluetooth.init
361  - on-demand start/stop bluetoothd using udev
362  - run hid2hci using udev
363- add missing files to %%files
364
365* Fri Jun 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.41-1
366- new upstream release
367- add udev rule
368- add upstream Patch[2-6]
369
370* Tue May 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.37-1
371- new upstream release
372
373* Fri Oct 24 2008 Seiichirou Babasaki 4.15-1
374- Update to 4.15
375- added # Maintainers:  comments.
376- FedoraCore - LOGS
377-- 4.14-2
378-- Add script to autoload uinput on startup, so the PS3 remote
379   works out-of-the-box
380-- 4.14-1 - Update to 4.14
381-- 4.13-3
382-- Update udev rules (#246840)
383-- 4.13-2
384-- Fix PS3 BD remote input event generation
385-- 4.13-1 - Update to 4.13
386-- 4.12-1 - Update to 4.12
387-- 4.11-1 - Update to 4.11
388-- 4.10-1 - Update to 4.10
389-- 4.9-1 - Update to 4.9
390-- 4.8-1 - Update to 4.8
391-- 4.7-1 - Update to 4.7
392-- 4.6-4
393-- Fix patch application
394-- 4.6-3
395-- Add fuzz
396-- 4.6-2
397-- Fix possible crasher on resume from suspend
398-- 4.6-1 - Update to 4.6
399-- 4.5-4
400-- SDP browse fixes
401-- 4.5-3
402-- Bluez-alsa needs to provide/obsolete bluez-utils-alsa
403-- Use versioned Obsoletes:
404-- 4.5-2
405-- Change main utils package name to 'bluez'; likewise its subpackages
406-- Remove references to obsolete initscripts (hidd,pand,dund)
407-- 4.5-1
408-- Update to 4.5
409-- Fix initscript to actually start bluetoothd by hand
410-- Add chkconfig information to the initscript
411-- 4.4-2
412-- Fix rpmlint problems
413-- Fix input device handling
414-- 4.4-1
415-- Update to 4.4
416-- Update source address, and remove unneeded deps (thanks Marcel)
417-- 4.1-1
418-- Initial build
419- updated specfile
420- VineLinux-4.2 logfile
421-- *Thu Oct 2 2008 Seiichirou Babasaki 3.24-4
422-- update bleuz-gnome, rebuild bluez-utils
423-- Requires: fuse
424-- updated specfile
425-- *Tue Sep 30 2008 Seiichirou Babasaki 3.24-3
426-- trusts.txt update (added audio profile)
427-- updated specfile
428
429#----------------------------------------------------------------------------
430* Fri Sep 26 2008 Seiichirou Babasaki 3.32-2
431- *.conf update
432- updated specfile
433
434* Fri Jun 13 2008 Seiichirou Babasaki 3.32-1
435- Updated 3.32
436- Updated specfile
437- ** LOGS 3.31-2
438- ** Add a .service file, starting up hcid only when used (#446918)
439- ** Fix descriptions in the initscript headers (#433647)
440- ** LOGS 3.30-2
441- ** Add support for Dell HID/HCI switch
442- ** LOGS 3.27-1
443- ** Ship audio.conf (#278831)
444- ** Ship network service
445
446* Wed Jan 26 2008 Seiichirou Babasaki 3.24-2
447- Updated specfile
448-   marge bluez-utils-3.24-conf-vl.patch
449-      << bluez-utils-2.3-conf.patch
450- add trusts.txt(ja)
451- Updated specfile
452
453* Mon Jan 21 2008 Seiichirou Babasaki 3.24-1vl2
454- Updated specfile for (dbus-devel >= 0.90)
455
456* Wed Jan 16 2008 Seiichirou Babasaki 3.24-1vl1
457- Import bluez-utils - Packager: Babasaki
458- Updated specfile for (dbus-devel >= 0.60)
459- Update to 3.24
Note: See TracBrowser for help on using the repository browser.