source: projects/specs/trunk/b/bluez/bluez-vl.spec @ 12347

Revision 12347, 12.4 KB checked in by tomop, 4 years ago (diff)

updated 4 packages

bluez-5.54-1

gthumb-3.8.3-1

ipmitool-1.8.18-1

python-urllib3-1.25.8-1

Line 
1%define _unpackaged_files_terminate_build 1
2
3Summary: Bluetooth utilities
4Summary(ja): Bluetooth ユーティリティ
5Name: bluez
6Version: 5.54
7Release: 1%{?_dist_release}
8Group: Applications/System
9Vendor: Project Vine
10Distribution: Vine Linux
11Packager: daisuke
12
13License: GPLv2+
14URL: http://www.bluez.org/
15
16#----------------------------------------------------------------------------
17
18Source: http://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.xz
19Source1: bluetooth.init.vine
20Source3: bluez-uinput.modules
21
22Source11: trusts.txt
23Source20: main.conf
24
25# from http://www.linuxfromscratch.org/patches/downloads/bluez/
26Patch0: 0001-bluez-5.54-obexd_without_systemd-1.patch
27
28# Patch for Vine
29Patch100: 0002-bluez-5.54-daemon.patch
30Patch101: 0003-bluez-5.54-config-vine.patch
31
32#----------------------------------------------------------------------------
33BuildRoot:      %{_tmppath}/%{name}-%{version}-root
34
35BuildRequires:  flex
36BuildRequires:  bison
37BuildRequires:  dbus-devel
38BuildRequires:  glib2-devel
39BuildRequires:  eudev-libudev-devel
40BuildRequires:  readline-devel
41BuildRequires:  libical-devel
42
43ExcludeArch: s390 s390x
44
45Obsoletes: bluez-pan < 4.0, bluez-sdp < 4.0
46Requires: initscripts, bluez-libs = %{version}
47Requires: dbus >= 0.60
48# Requires: fuse
49## Requires: hwdata >= 0.215
50Requires: hwdata >= 0.146
51# virtual provides "dbus-bluez-pin-helper" ex. bluez-gnome
52Requires: dbus-bluez-pin-helper
53Requires(preun): /sbin/chkconfig, /sbin/service
54Requires(post): /sbin/chkconfig, /sbin/service
55#----------------------------------------------------------------------------
56
57Obsoletes: bluez-utils < 4.5-2
58Provides: bluez-utils = %{version}-%{release}
59Obsoletes: bluez-gstreamer < 5.0
60Obsoletes: bluez-alsa < 5.0
61
62#----------------------------------------------------------------------------
63%description
64Utilities for use in Bluetooth applications:
65        - hcitool
66        - hciattach
67        - hciconfig
68        - bluetoothd
69        - l2ping
70        - start scripts VineLinux (RedHat base)
71        - pcmcia configuration files
72
73 Please, read %{_defaultdocdir}/%{name}-%{version}/trusts.txt
74
75The BLUETOOTH trademarks are owned by Bluetooth SIG, Inc., U.S.A.
76
77%description -l ja
78Bluetooth ユーティリティ (bluez-utils):
79        - hcitool
80        - hciattach
81        - hciconfig
82        - l2ping
83        - 起動スクリプト (Red Hat用をVineLinuxに合わせました)
84        - pcmcia コンフィグレーション ファイル
85※付属の%{_defaultdocdir}/%{name}-%{version}/trusts.txtもご覧下さい。
86
87(BLUETOOTH は Bluetooth SIG, Inc.(USA)のトレードマークです)
88
89#----------------------------------------------------------------------------
90%package libs
91Summary: Libraries for use in Bluetooth applications
92Summary(ja): BlueTooth アプリケーションの使用するライブラリ(BlueZ)
93Group: System Environment/Libraries
94
95%description libs
96Libraries for use in Bluetooth applications.
97
98%description libs -l ja
99Bluetooth アプリケーションのためのライブラリです。
100※BlueZ のユーティリティのためにも必要です
101
102#----------------------------------------------------------------------------
103%package libs-devel
104Summary: Development libraries for Bluetooth applications
105Summary(ja): Bluetooth アプリケーション開発のためのdevelパッケージ
106Group: Development/Libraries
107Requires: bluez-libs = %{version}
108Requires: pkgconfig
109Obsoletes: bluez-sdp-devel < 4.0
110
111%description libs-devel
112bluez-libs-devel contains development libraries and headers for
113use in Bluetooth applications.
114
115%description libs-devel -l ja
116bluez-libs-devel パッケージは Bluetooth アプリケーション開発のための
117ライブラリやヘッダーファイルを提供します。
118
119#----------------------------------------------------------------------------
120%package cups
121Summary: CUPS printer backend for Bluetooth printers
122Summary(ja): Bluetooth 経由の CUPS プリンタシステム用
123Group: System Environment/Daemons
124Obsoletes: bluez-utils-cups < 4.5-2
125Provides: bluez-utils-cups = %{version}-%{release}
126Requires: bluez-libs = %{version}
127Requires: cups
128
129%description cups
130This package contains the CUPS backend
131
132%description cups -l ja
133Bluetooth対応 プリンターを CUPS印刷システムから利用する
134ためのバックエンドです。
135
136#----------------------------------------------------------------------------
137
138%prep
139rm -rf $RPM_BUILD_ROOT
140
141%setup -q
142%patch0 -p1
143%patch100 -p1
144%patch101 -p1
145
146%build
147%configure \
148        --disable-systemd \
149        --enable-library \
150    --enable-cups \
151    --enable-tools \
152    --enable-sixaxis \
153    --enable-nfc \
154        --disable-android
155
156# copy txt
157#cp %{SOURCE11} .
158
159make
160
161#----------------------------------------------------------------------------
162%install
163rm -rf $RPM_BUILD_ROOT
164make install DESTDIR=$RPM_BUILD_ROOT
165
166# Remove autocrap and libtool droppings
167find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
168
169mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bluetooth/
170mkdir -p $RPM_BUILD_ROOT%{_libdir}/bluetooth/
171mkdir -p $RPM_BUILD_ROOT%{_sbindir}
172
173install -D -m0755 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/bluetooth
174ln -s ../libexec/bluetooth/bluetoothd $RPM_BUILD_ROOT%{_sbindir}/bluetoothd
175
176#install -D -m0644 %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/bluetooth/
177install -D -m0644 src/main.conf $RPM_BUILD_ROOT%{_sysconfdir}/bluetooth/
178# rename serial-api.txt
179#mv  doc/serial-api.txt doc/serial-api_doc.txt
180
181install -D -m0755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/modules/bluez-uinput.modules
182
183%clean
184rm -rf $RPM_BUILD_ROOT
185
186#----------------------------------------------------------------------------
187%post
188/sbin/chkconfig --add bluetooth
189if [ "$1" -ge "1" ]; then
190        /sbin/service bluetooth condrestart >/dev/null 2>&1 || :
191fi
192exit 0
193
194%preun
195if [ "$1" = "0" ]; then
196        /sbin/service bluetooth stop >/dev/null 2>&1 || :
197        /sbin/chkconfig --del bluetooth
198fi
199exit 0
200
201%post libs
202/sbin/ldconfig
203
204%postun libs
205/sbin/ldconfig
206
207#----------------------------------------------------------------------------
208%files
209%defattr(-, root, root)
210%license COPYING
211%doc AUTHORS INSTALL ChangeLog NEWS README
212%dir %{_sysconfdir}/bluetooth/
213%config(noreplace) %{_sysconfdir}/bluetooth/*
214%{_sysconfdir}/dbus-1/system.d/bluetooth.conf
215%{_sysconfdir}/rc.d/init.d/bluetooth
216%{_sysconfdir}/sysconfig/modules/bluez-uinput.modules
217%{_bindir}/*
218%{_sbindir}/bluetoothd
219%{_libexecdir}/bluetooth/bluetoothd
220%{_libexecdir}/bluetooth/obexd
221%dir %{_libdir}/bluetooth
222%dir %{_libdir}/bluetooth/plugins
223%{_libdir}/bluetooth/plugins/sixaxis.so
224%{_mandir}/man1/*
225%{_mandir}/man8/*
226/lib/udev/hid2hci
227/lib/udev/rules.d/97-hid2hci.rules
228%dir %{_datadir}/zsh
229%dir %{_datadir}/zsh/site-functions
230%{_datadir}/zsh/site-functions/_bluetoothctl
231
232%files libs
233%defattr(-, root, root)
234%{_libdir}/libbluetooth.so.*
235
236%files libs-devel
237%defattr(-, root, root)
238%{_libdir}/libbluetooth.so
239%dir %{_includedir}/bluetooth
240%{_includedir}/bluetooth/*
241%{_libdir}/pkgconfig/bluez.pc
242
243%files cups
244%defattr(-, root, root)
245%{_libdir}/cups/backend/bluetooth
246
247
248%changelog
249* Sun Mar 22 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.54-1
250- updated to 5.54.
251- updated all patches.
252
253* Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.50-1
254- updated to 5.50.
255
256* Fri Jan 26 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.48-1
257- updated to 5.48.
258
259* Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.35-1
260- update to 5.35
261- remove %%{name}-gstreamer, %%{name}-alsa subpackages
262- add Patch0 (bluez-5.35-obexd_without_systemd-1.patch)
263- add Patch100 (bluez-5.35-daemon.patch)
264- add Patch101 (bluez-5.35-config-vine.patch)
265
266* Sat Jul 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.101-5
267- rebuild with readline-6.3
268
269* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.101-4
270- change BuildRequires: eudev-libudev-devel instead of libudev-devel
271
272* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.101-3
273- rebuild with VineSeed environment
274
275* Thu Jul 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.101-2
276- build with sbc
277  - add BR: sbc-devel
278
279* Sun Jun 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.101-1
280- new upstream release
281
282* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.99-1
283- new upstream release
284
285* Thu Feb 23 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.98-1
286- new upstream release
287
288* Sun Dec 25 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.97-1
289- new upstream release
290- add BuildRequires: check-devel, readline-devel
291
292* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.96-1
293- new upstream release
294- add BuildRequires: libudev-devel
295
296* Thu Feb 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.89-1
297- new upstream release
298
299* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.87-1
300- new upstream release
301
302* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.84-1
303- new upstream release
304
305* Sun Dec 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.82-1
306- new upstream release
307
308* Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.81-1
309- new upstream release
310
311* Tue Nov 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.79-1
312- new upstream release
313- drop Patch2
314
315* Wed Nov 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.77-1
316- new upstream release
317- fix %files (change path of alsa/bluetooth.conf)
318
319* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.69-2
320- rebuild with rpm-4.8.1 for pkg-config file
321
322* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.69-1
323- new upstream release
324
325* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.66-1
326- new upstream release
327
328* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.64-1
329- new upstream release
330- drop Patch1, Patch5, Patch6
331
332* Sun Jul 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.42-2
333- add bluetooth.init again.
334  - on-demand startup on bootup process will fail, because
335    D-BUS service is not started yet.
336
337* Sun Jun 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.42-1
338- new upstream release
339
340* Mon Jun 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.41-2
341- remove bluetooth.init
342  - on-demand start/stop bluetoothd using udev
343  - run hid2hci using udev
344- add missing files to %%files
345
346* Fri Jun 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.41-1
347- new upstream release
348- add udev rule
349- add upstream Patch[2-6]
350
351* Tue May 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.37-1
352- new upstream release
353
354* Fri Oct 24 2008 Seiichirou Babasaki 4.15-1
355- Update to 4.15
356- added # Maintainers:  comments.
357- FedoraCore - LOGS
358-- 4.14-2
359-- Add script to autoload uinput on startup, so the PS3 remote
360   works out-of-the-box
361-- 4.14-1 - Update to 4.14
362-- 4.13-3
363-- Update udev rules (#246840)
364-- 4.13-2
365-- Fix PS3 BD remote input event generation
366-- 4.13-1 - Update to 4.13
367-- 4.12-1 - Update to 4.12
368-- 4.11-1 - Update to 4.11
369-- 4.10-1 - Update to 4.10
370-- 4.9-1 - Update to 4.9
371-- 4.8-1 - Update to 4.8
372-- 4.7-1 - Update to 4.7
373-- 4.6-4
374-- Fix patch application
375-- 4.6-3
376-- Add fuzz
377-- 4.6-2
378-- Fix possible crasher on resume from suspend
379-- 4.6-1 - Update to 4.6
380-- 4.5-4
381-- SDP browse fixes
382-- 4.5-3
383-- Bluez-alsa needs to provide/obsolete bluez-utils-alsa
384-- Use versioned Obsoletes:
385-- 4.5-2
386-- Change main utils package name to 'bluez'; likewise its subpackages
387-- Remove references to obsolete initscripts (hidd,pand,dund)
388-- 4.5-1
389-- Update to 4.5
390-- Fix initscript to actually start bluetoothd by hand
391-- Add chkconfig information to the initscript
392-- 4.4-2
393-- Fix rpmlint problems
394-- Fix input device handling
395-- 4.4-1
396-- Update to 4.4
397-- Update source address, and remove unneeded deps (thanks Marcel)
398-- 4.1-1
399-- Initial build
400- updated specfile
401- VineLinux-4.2 logfile
402-- *Thu Oct 2 2008 Seiichirou Babasaki 3.24-4
403-- update bleuz-gnome, rebuild bluez-utils
404-- Requires: fuse
405-- updated specfile
406-- *Tue Sep 30 2008 Seiichirou Babasaki 3.24-3
407-- trusts.txt update (added audio profile)
408-- updated specfile
409
410#----------------------------------------------------------------------------
411* Fri Sep 26 2008 Seiichirou Babasaki 3.32-2
412- *.conf update
413- updated specfile
414
415* Fri Jun 13 2008 Seiichirou Babasaki 3.32-1
416- Updated 3.32
417- Updated specfile
418- ** LOGS 3.31-2
419- ** Add a .service file, starting up hcid only when used (#446918)
420- ** Fix descriptions in the initscript headers (#433647)
421- ** LOGS 3.30-2
422- ** Add support for Dell HID/HCI switch
423- ** LOGS 3.27-1
424- ** Ship audio.conf (#278831)
425- ** Ship network service
426
427* Sat Jan 26 2008 Seiichirou Babasaki 3.24-2
428- Updated specfile
429-   marge bluez-utils-3.24-conf-vl.patch
430-      << bluez-utils-2.3-conf.patch
431- add trusts.txt(ja)
432- Updated specfile
433
434* Mon Jan 21 2008 Seiichirou Babasaki 3.24-1vl2
435- Updated specfile for (dbus-devel >= 0.90)
436
437* Wed Jan 16 2008 Seiichirou Babasaki 3.24-1vl1
438- Import bluez-utils - Packager: Babasaki
439- Updated specfile for (dbus-devel >= 0.60)
440- Update to 3.24
Note: See TracBrowser for help on using the repository browser.