source: projects/specs/trunk/b/bluez-gnome/bluez-gnome-vl.spec @ 521

Revision 521, 11.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           bluez-gnome
2Version:        1.8
3Release:        3%{?_dist_release}
4Summary:        Bluetooth pairing and control applet
5Summary(ja): Bluetooth ペアリングとコントロールのアプレット
6
7Group:          Applications/System
8License:        GPLv2+
9URL:            http://www.bluez.org/
10Source0:        http://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.gz
11
12Patch0:         bluetooth-sendto-ods-svn.patch
13# http://thread.gmane.org/gmane.linux.bluez.kernel/535
14Patch1:         0001-Fix-PS3-BD-remote-pairing.patch
15#----------------------------------------------------------------------------
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19#----------------------------------------------------------------------------
20BuildRequires: dbus-devel >= 1.0
21BuildRequires: gtk2-devel >= 2.10
22BuildRequires: GConf2-devel, libnotify-devel
23BuildRequires: dbus-glib-devel, perl-XML-Parser, intltool
24BuildRequires: desktop-file-utils, gettext
25BuildRequires: hal-devel
26
27# virtual package
28Provides:       dbus-bluez-pin-helper
29
30Obsoletes:      bluez-pin
31ExcludeArch:    s390 s390x
32
33Requires:       gvfs  >= 0.99.1
34#### Gnome より引用
35# GVFS とはユーザ空間の仮想ファイルシステムであり、SFTP や FTP、DAV、SMB、
36# ObexFTP といった各種プロトコルのバックエンドを持ちます。GVFS は従来の
37# GNOME-VFS に置き換わるものです。
38# ※現在(2008年)のところ GNOME-VFS は廃止する方向で検討されており、GNOME
39# アプリケーションの開発者は今後このフレームワーク(gnome-vfs)を利用しない
40# ようにして下さい。
41
42# Requires:     gvfs-obexftp (fedora)
43Requires:       obex-data-server
44# obex-data-server Requires: openobex-devel
45
46Requires(post): shared-mime-info
47Requires(post): desktop-file-utils
48Requires(postun): shared-mime-info
49Requires(postun): desktop-file-utils
50
51#----------------------------------------------------------------------------
52%description
53The bluez-gnome package contains Bluetooth helper applets and tools for
54the GNOME desktop environment.
55
56%description -l ja
57bluez-gnome パッケージは Bluetooth のヘルパー アプレットです。
58GNOME デスクトップにBlutooth ペアリングのための機能を提供します。
59※訳注 :基本的にアプレットとして使用しますがメニューからも使えます
60
61#----------------------------------------------------------------------------
62%package analyzer
63Summary: Bluetooth protocol analyzer
64Summary(ja): Bluetooth プロトコルアナライザ
65Group: Applications/Engineering
66Requires: %{name} = %{version}-%{release}
67
68%description analyzer
69The bluez-gnome package contains Bluetooth helper applets and tools for
70the GNOME desktop environment.
71
72This package contains the Bluetooth protocol analyzer.
73
74%description analyzer -l ja
75bluez-gnome パッケージには Bluetooth ヘルパーアプレットと
76GNOME デスクトップ環境の為のツールが含まれています。
77
78このパッケージは Bluetooth プロトコルアナライザです。
79
80
81#----------------------------------------------------------------------------
82%prep
83%setup -q
84
85
86%patch0 -p1 -b .ods-svn
87%patch1 -p1 -b .ps3-bd
88
89%build
90%configure --disable-mime-update --disable-desktop-update \
91           --disable-icon-update
92make %{?_smp_mflags}
93
94#----------------------------------------------------------------------------
95%install
96rm -rf $RPM_BUILD_ROOT
97export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
98make install DESTDIR=$RPM_BUILD_ROOT
99
100mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome/
101mv $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/ $RPM_BUILD_ROOT%{_datadir}/gnome/
102
103desktop-file-install --vendor=""                                \
104        --add-category=X-GNOME-NetworkSettings                  \
105        --delete-original                                       \
106        --dir=$RPM_BUILD_ROOT%{_datadir}/applications           \
107        $RPM_BUILD_ROOT%{_datadir}/applications/bluetooth-properties.desktop
108
109desktop-file-install --vendor=""                                \
110        --remove-category=Application                           \
111        --remove-category=Utility                               \
112        --add-category=GTK                                      \
113        --add-category=System                                   \
114        --delete-original                                       \
115        --dir=$RPM_BUILD_ROOT%{_datadir}/applications           \
116        $RPM_BUILD_ROOT%{_datadir}/applications/bluetooth-analyzer.desktop
117
118%find_lang bluetooth-manager
119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123#----------------------------------------------------------------------------
124%post
125update-desktop-database -q
126export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
127gconftool-2 --makefile-install-rule                                     \
128        %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas          \
129        >& /dev/null || :
130update-mime-database %{_datadir}/mime >/dev/null
131
132if [ -x /usr/bin/gtk-update-icon-cache ]; then
133  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
134fi
135
136%pre
137if [ "$1" -gt 1 ]; then
138    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
139    gconftool-2 --makefile-uninstall-rule                               \
140        %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas          \
141        >& /dev/null || :
142fi
143
144%preun
145if [ "$1" -eq 0 ]; then
146    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
147    gconftool-2 --makefile-uninstall-rule                               \
148        %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas          \
149        >& /dev/null || :
150fi
151
152%postun
153update-desktop-database -q
154update-mime-database %{_datadir}/mime >/dev/null
155if [ -x /usr/bin/gtk-update-icon-cache ]; then
156  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
157fi
158
159#----------------------------------------------------------------------------
160%files -f bluetooth-manager.lang
161%defattr(-,root,root,-)
162%{_bindir}/bluetooth-applet
163%{_bindir}/bluetooth-properties
164%{_bindir}/bluetooth-sendto
165%{_bindir}/bluetooth-wizard
166%{_bindir}/bluetooth-browse
167%config %{_sysconfdir}/gconf/schemas/*
168%{_datadir}/gnome/autostart/bluetooth-applet.desktop
169%{_datadir}/applications/bluetooth-properties.desktop
170%{_datadir}/mime/packages/bluetooth-manager.xml
171%{_datadir}/icons/hicolor/*/apps/*
172%{_mandir}/man1/bluetooth-applet.1.gz
173%{_mandir}/man1/bluetooth-properties.1.gz
174%{_mandir}/man1/bluetooth-wizard.1.gz
175%{_mandir}/man1/bluetooth-sendto.1.gz
176%{_mandir}/man1/bluetooth-browse.1.gz
177%doc README COPYING AUTHORS ChangeLog
178
179
180%files analyzer
181%{_datadir}/applications/bluetooth-analyzer.desktop
182%{_bindir}/bluetooth-analyzer
183%{_datadir}/man/man1/bluetooth-analyzer.1.gz
184
185#----------------------------------------------------------------------------
186# Maintainers: babasaki@mindgear.org
187#
188#----------------------------------------------------------------------------
189%changelog
190* Fri Oct 24  2008 Seiichirou Babasaki 1.8-3
191- Update to 1.8 (VineSeed)
192- added "# Maintainers: " comments.
193- changed UTF-8 encode at bluez-gnome.vs.spec
194- FedoraCore - LOGS
195-- 1.8-2
196-- Add patch to make the PS3 BD remote work
197-- 1.8-1
198-- Update to 1.8 and update obex-data-server patch
199-- 1.7-2
200-- Remove the X-GNOME-NetworkSettings category from the
201   preferences' desktop file, it makes the prefs show up in
202   two places in the menus (#465180)
203-- Update to 1.7
204-- Update to 1.6
205-- 1.5-2
206-- Add another patch for Bluetooth sendto support for BlueZ 4.x
207-- Update to 1.5
208-- 1.4-4
209-- Update bluetooth-sendto to the BlueZ 4.x API, and obex-data-server
210   SVN APIs
211-- Tidy up specfile, fix source URL
212-- 1.4-3
213-- Add missing files to the list
214-- 1.4-2
215-- Remove obsolete patch
216-- 1.4-1
217-- 1.3-1
218-- Update to 1.3 (from 0.28)
219- updated specfile
220
221* Fri Jun 13 2008 Seiichirou Babasaki 0.28-1
222- Update to 0.28
223- Updated specfile
224
225* Fri Jun 13 2008 Seiichirou Babasaki 0.26-1
226- Update to 0.26
227- Updated specfile
228- LOGS - 0.24-2
229- Fix crasher when removing the default adapter
230- LOGS - 0.23-2
231- Add dependency on a gvfs with ObexFTP support
232- LOGS - 0.21-2
233- Update the patch to hide the "Class of device" selection widget,
234  avoids a crasher on startup with unstable releases of gnome-session
235- LOGS - 0.18-2
236- Add patch to make the search button work
237- LOGS - 0.17-2
238- Update the patch to remove the class setting
239- LOGS - 0.17-1
240- Update new sendto patch
241- LOGS - 0.16-2
242- Re-add the sendto patch, we don't want the old stuff
243- LOGS - 0.15-3
244- Add requires on obex-data-server for bluetooth-sendto
245- LOGS - 0.15-2
246- Add patch to update the sendto binary
247- LOGS - 0.15-1
248- Add patch to remove the useless hardware type selection
249
250* Wed Jan 16 2008 Seiichirou Babasaki 0.15-1vl1
251- Import bluez-gnome - Packager: Babasaki
252- Updated specfile
253- Update to 0.15
254
255#----------------------------------------------------------------------------
256* Tue Oct 23 2007 Matthias Clasen <mclasen@redhat.com> - 0.14-9
257- Rebuild against new dbus-glib
258
259* Wed Oct 10 2007 - Bastien Nocera <bnocera@redhat.com> - 0.14-8
260- Require gnome-vfs2-obexftp, so that the functionality works
261  as expected (#326231)
262
263* Sat Oct 06 2007 - Bastien Nocera <bnocera@redhat.com> - 0.14-7
264- Provide virtual dbus-bluez-pin-helper for bluez-utils to use
265  (#212421)
266
267* Wed Oct 03 2007 - Bastien Nocera <bnocera@redhat.com> - 0.14-6
268- Fix location of the autostart desktop file (#316101)
269
270* Thu Sep 20 2007 - Bastien Nocera <bnocera@redhat.com> - 0.14-5
271- Don't allow class of the device to be changed if HAL is being
272  used (#244261)
273
274* Thu Sep 20 2007 - Bastien Nocera <bnocera@redhat.com> - 0.14-4
275- Only show and start the bluez-gnome bits in GNOME (#258721)
276
277* Tue Sep 18 2007 - Bastien Nocera <bnocera@redhat.com> - 0.14-3
278- Split out the analyzer so it's not installed by default
279- Don't prefix the properties .desktop with fedora for no reason
280
281* Fri Aug 31 2007 - Bastien Nocera <bnocera@redhat.com> - 0.14-2
282- Remove the obex BR, we're not using it yet
283- Build with HAL support
284
285* Wed Aug 29 2007 - Bastien Nocera <bnocera@redhat.com> - 0.14-1
286- Update to 0.14
287
288* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> - 0.13-3
289- Rebuild for build ID
290
291* Thu Aug  9 2007  Matthias Clasen <mclasen@redhat.com> - 0.13-2
292- Move the analyzer to a better place in the menus
293- Use desktop-file-install for all desktop files
294- Update the license field
295
296* Wed Aug 01 2007 - Bastien Nocera <bnocera@redhat.com> - 0.13-1
297- Update to 0.13
298
299* Tue Jul 31 2007 - Bastien Nocera <bnocera@redhat.com> - 0.12-1
300- Update to 0.12
301
302* Tue Jul 31 2007 - Bastien Nocera <bnocera@redhat.com> - 0.11-1
303- Update to 0.11
304
305* Sun Jul 29 2007 Bastien Nocera <bnocera@redhat.com> - 0.10-1
306- Update to 0.10
307- Add the analyser's desktop file
308
309* Sat Jul 21 2007 David Woodhouse <dwmw2@infradead.org> - 0.9-1
310- Update to 0.9
311
312* Sat Jul 07 2007 Bastien Nocera <bnocera@redhat.com> - 0.8-2
313- Only install and uninstall our own schema file (#247330)
314
315* Thu Jun 14 2007 Bastien Nocera <bnocera@redhat.com> - 0.8-1
316- Update to 0.8
317- Punt outdated patches
318- Add man pages, and translations
319- Add GConf and desktop file updating scriplets
320
321* Wed Jan 24 2007 Matthias Clasen <mclasen@redhat.com> 0.6-2
322- Add X-GNOME-NetworkSettings to desktop file categories
323- Use desktop-file-install
324 
325* Thu Oct 26 2006 David Woodhouse <dwmw2@redhat.com> 0.6-1
326- Update to bluez-gnome 0.6
327
328* Fri Oct  6 2006 David Woodhouse <dwmw2@redhat.com> 0.5-5
329- Allow user to toggle discoverability
330
331* Wed Oct  4 2006 David Woodhouse <dwmw2@redhat.com> 0.5-4
332- Avoid needing executable stack
333
334* Mon Oct  2 2006 David Woodhouse <dwmw2@redhat.com> 0.5-3
335- Provide startup file for KDE too
336
337* Sun Oct  1 2006 David Woodhouse <dwmw2@redhat.com> 0.5-2
338- Fix startup visibility
339
340* Sat Sep 30 2006 David Woodhouse <dwmw2@redhat.com> 0.5-1
341- Initial build
342
Note: See TracBrowser for help on using the repository browser.