source: projects/specs/trunk/b/blueman/blueman-vl.spec @ 10376

Revision 10376, 5.7 KB checked in by Takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1Summary:        Full featured bluetooth manager for GNOME/GTK
2Summary(ja):    GNOME/GTK 用の高機能な Bluetooth マネージャ
3
4Name:           blueman
5Version:        2.0.4
6Release:        1%{?_dist_release}
7License:        GPLv2+
8Group:          Applications/System
9Url:            https://github.com/blueman-project/blueman
10
11Source0:        https://github.com/blueman-project/blueman/releases/download/2.0/%{name}-%{version}.tar.xz
12
13Buildroot:      %{_tmppath}/%{name}-%{version}
14BuildRequires:  desktop-file-utils
15BuildRequires:  perl(XML::Parser)
16BuildRequires:  glib2-devel
17BuildRequires:  gtk2-devel
18BuildRequires:  pygtk2-devel
19BuildRequires:  polkit-devel
20BuildRequires:  intltool
21BuildRequires:  startup-notification-devel
22BuildRequires:  pygobject3-devel
23BuildRequires:  Cython
24BuildRequires:  notify-python
25BuildRequires:  bluez-libs-devel >= 4.37
26BuildRequires:  python-devel
27BuildRequires:  python-pyrex
28BuildRequires:  dbus-python
29Requires:       bluez
30Requires:       obex-data-server
31Requires:       notify-python
32Requires:       pygtk2
33Requires:       dbus-python
34Requires:       pygobject3
35Requires:       Cython
36Requires:       polkit
37Requires(postun,posttrans): glib2
38Requires(post,postun): desktop-file-utils
39Requires(post,postun): gtk2
40
41Provides:       dbus-bluez-pin-helper
42
43Obsoletes:      bluez-gnome < 1.9
44
45Vendor: Project Vine
46Distribution: Vine Linux
47Packager: daisuke
48
49
50%description
51Blueman is designed to provide simple, yet effective means for
52controlling BlueZ API and simplifying bluetooth tasks such as:
53
54* Connecting to 3G/EDGE/GPRS via dial-up
55* Connecting to/Creating bluetooth networks
56* Connecting to input devices
57* Connecting to audio devices
58* Sending/Receiving/Browsing files via OBEX
59* Pairing
60
61Blueman also integrates with Network Manager 0.7, so any Dialup/Network
62 connections will be made available (via HAL) to Network Manager.
63
64%prep
65%setup -q
66
67%build
68%configure --disable-desktop-update --disable-icon-update --disable-schemas-install
69%__make %{?_smp_mflags}
70
71%install
72rm -rf %{buildroot}
73%__make install DESTDIR=${RPM_BUILD_ROOT}
74
75desktop-file-install --vendor="" \
76  --add-category="GNOME;GTK" \
77  --add-category="Settings;HardwareSettings" \
78  --dir %{buildroot}%{_datadir}/applications %{buildroot}%{_datadir}/applications/%{name}-manager.desktop
79
80find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
81find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
82
83rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
84
85%find_lang %{name}
86
87%clean
88rm -rf %{buildroot}
89
90%post
91update-desktop-database %{_datadir}/applications >& /dev/null || :
92touch --no-create %{_datadir}/icons/hicolor
93if [ -x /usr/bin/gtk-update-icon-cache ]; then
94  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
95fi
96 
97%postun
98update-desktop-database %{_datadir}/applications >& /dev/null || :
99touch --no-create %{_datadir}/icons/hicolor
100if [ -x /usr/bin/gtk-update-icon-cache ]; then
101  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
102fi
103glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
104
105%posttrans
106glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
107
108
109%files -f %{name}.lang
110%doc CHANGELOG.md COPYING FAQ README.md
111%defattr(-,root,root)
112%{_sysconfdir}/dbus-1/system.d/org.%{name}*.conf
113%{_sysconfdir}/xdg/autostart/%{name}.desktop
114%{_bindir}/%{name}-*
115%{_datadir}/Thunar/sendto/thunar-sendto-%{name}.desktop
116%{_datadir}/applications/%{name}-adapters.desktop
117%{_datadir}/applications/%{name}-manager.desktop
118%{_datadir}/%{name}/ui/*.ui
119%{_datadir}/dbus-1/services/%{name}-applet.service
120%{_datadir}/dbus-1/system-services/org.%{name}*.service
121%{_datadir}/glib-2.0/schemas/org.%{name}.gschema.xml
122%{_datadir}/icons/hicolor/*/*/*
123%{_datadir}/pixmaps/%{name}
124%{_datadir}/polkit-1/actions/org.%{name}.policy
125%{_mandir}/man1/%{name}*1.*
126%{python_sitelib}/*
127%if %_lib == lib64
128%{python_sitearch}/*
129%endif
130%{_libexecdir}/%{name}-*
131
132
133%changelog
134* Wed Jun 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.4-1
135- new upstream release
136
137* Tue Jan 26 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.3-1
138- new upstream release
139  (including security fix for CVE-2015-8612)
140
141* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.1-2
142- rebuild with bluez-5.36
143
144* Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.1-1
145- new upstream release
146
147* Sun Sep 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0-2
148- remove Requires: polkit-gnome, gnome-python
149- add Requires: polkit
150
151* Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0-1
152- update to 2.0
153- add BuildRequires: polkit-devel, pygobject3-devel, Cython
154- remove BuildRequires: pygobject-devel
155
156* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.23-4
157- rebuild with VineSeed environment
158
159* Sat Oct 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.23-3
160- change Requires: polkit-gnome instead of PolicyKit-gnome
161
162* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.23-2
163- rebuild with python-2.7.2
164
165* Tue Jan 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.23-1
166- new upstream release
167
168* Mon Apr 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.21-4
169- rebuild with rpm-4.8.1
170
171* Sun Feb 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.21-3
172- add BuildRequires: gtk2-devel
173
174* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.21-2
175- rebuilt with python-2.6.4
176
177* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.21-1
178- new upstream release
179
180* Mon Jan 04 2010 Shu KONNO <owa@bg.wakwak.com> 1.10-2
181- added _blueman to %%files (if lib64)
182
183* Tue May 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-1
184- initial build for Vine Linux
185
186* Fri Mar 27 2009 Emmanuel Andry <eandry@mandriva.org> 1.02-4mdv2009.1
187+ Revision: 361574
188- don't explicitely requires notification-daemon
189
190* Mon Mar 02 2009 Emmanuel Andry <eandry@mandriva.org> 1.02-3mdv2009.1
191+ Revision: 347587
192- requires python-blueman
193
194* Mon Mar 02 2009 Emmanuel Andry <eandry@mandriva.org> 1.02-2mdv2009.1
195+ Revision: 347346
196- fix files
197- BR python-dbus
198- fix BR
199- BR python-devel
200- import blueman
201
202
Note: See TracBrowser for help on using the repository browser.