source: projects/specs/trunk/b/bluefish/bluefish-vl.spec @ 8216

Revision 8216, 9.9 KB checked in by tanakanata, 10 years ago (diff)

src update. enable zen-coding

Line 
1Name:           bluefish
2Version:        2.2.4
3Release:        1%{?_dist_release}
4Summary:        GTK2 web development application for experienced users
5Summary(ja):    経験者向け Web 開発用 GTK2 アプリケーション
6Group:          Applications/Editors
7License:        GPLv3+
8URL:            http://bluefish.openoffice.nl/
9# Upstream source contains non-free jsmin.py
10# Source0:      http://www.bennewitz.com/bluefish/stable/source/bluefish-%{version}%{?prerel:-%{prerel}}.tar.bz2
11# To generate clean source, simply rm -rf data/jsmin.py
12# We provide a replacement in Source1.
13Source0:        bluefish-%{version}%{?prerel:-%{prerel}}-clean.tar.bz2
14Source1:        https://raw.github.com/v8/v8/master/tools/jsmin.py
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  desktop-file-utils
17BuildRequires:  enchant-devel >= 1.4.2
18BuildRequires:  gettext
19BuildRequires:  glib2-devel >= 2.24
20%if "%{?_dist_release}" < "vl7"
21BuildRequires:  gtk2-devel >= 2.20
22BuildRequires:  gucharmap-devel >= 2.20
23%else
24BuildRequires:  gtk3-devel >= 3.2
25BuildRequires:  gucharmap-devel >= 2.90
26%endif
27BuildRequires:  intltool
28BuildRequires:  libxml2-devel
29BuildRequires:  python-devel
30# Needed to check man pages
31BuildRequires:  /usr/bin/man
32# For the Advanced Open function
33Requires:       findutils, grep
34Requires:       %{name}-shared-data = %{version}-%{release}
35
36# Automatically upgrade bluefish-unstable
37Obsoletes:      bluefish-unstable < %{version}-%{release}
38Provides:       bluefish-unstable = %{version}-%{release}
39
40# XML Catalog registration
41Requires(post): /usr/bin/xmlcatalog, xml-common
42Requires(postun): /usr/bin/xmlcatalog, xml-common
43
44# Don't "provide" plugin shared objects
45%{?filter_setup:
46%filter_provides_in %{_libdir}/%{name}/.*\.so$
47%filter_setup
48}
49
50# Move to unversioned documentation directories from F-20
51# https://fedoraproject.org/wiki/Changes/UnversionedDocdirs
52%global bluefish_docdir %{?_pkgdocdir}%{!?_pkgdocdir:%{_docdir}/%{name}-%{version}}
53
54%description
55Bluefish is a powerful editor for experienced web designers and programmers.
56Bluefish supports many programming and markup languages, but it focuses on
57editing dynamic and interactive websites.
58
59%package shared-data
60Summary:        Architecture-independent data for %{name}
61Group:          Development/Tools
62BuildArch:      noarch
63# For ownership of %%{_datadir}/mime/packages
64Requires:       shared-mime-info
65# For ownership of %%{_datadir}/icons/hicolor/*/{apps,mimetypes}
66Requires:       hicolor-icon-theme
67
68# Automatically upgrade bluefish-unstable-shared-data
69Obsoletes:      bluefish-unstable-shared-data < %{version}-%{release}
70Provides:       bluefish-unstable-shared-data = %{version}-%{release}
71
72%description shared-data
73Files common to every architecture version of %{name}.
74
75%prep
76%setup -q -n %{name}-%{version}%{?prerel:-%{prerel}}
77
78cp -a %{SOURCE1} data/
79sed -i 's|python2.4|python|g' data/jsmin.py
80
81%build
82%configure      --disable-dependency-tracking \
83                --disable-static \
84                --disable-update-databases \
85                --disable-xml-catalog-update \
86                --docdir=%{bluefish_docdir}
87make %{?_smp_mflags}
88
89%install
90rm -rf %{buildroot}
91mkdir -p %{buildroot}%{_datadir}/applications
92make install DESTDIR=%{buildroot} INSTALL="install -p"
93
94# Make zencoding plugin scripts executable to placate rpmlint
95find %{buildroot}%{_datadir}/bluefish/plugins/zencoding -name '*.py' |
96        xargs awk '/^#!/ { print FILENAME }' |
97        xargs chmod -c +x
98
99%find_lang %{name}
100%find_lang %{name}_plugin_about
101%find_lang %{name}_plugin_charmap
102%find_lang %{name}_plugin_entities
103%find_lang %{name}_plugin_htmlbar
104%find_lang %{name}_plugin_infbrowser
105%find_lang %{name}_plugin_snippets
106%find_lang %{name}_plugin_zencoding
107cat %{name}_plugin_{about,charmap,entities,htmlbar,infbrowser,snippets,zencoding}.lang >> \
108        %{name}.lang
109
110desktop-file-validate \
111        %{buildroot}%{_datadir}/applications/%{name}.desktop
112
113# Manually install docs so that they go into
114# %%{bluefish_docdir} even though we put them in the
115# shared-data subpackage
116install -m 644 -p -t %{buildroot}%{bluefish_docdir}/ \
117        AUTHORS ChangeLog COPYING NEWS README TODO
118
119# Unpackaged files
120rm -f %{buildroot}%{_libdir}/%{name}/*.la
121
122%clean
123rm -rf %{buildroot}
124
125%post
126/usr/bin/update-mime-database %{_datadir}/mime &> /dev/null || :
127/usr/bin/update-desktop-database &> /dev/null || :
128/usr/bin/xmlcatalog --noout --add 'delegateURI' \
129        'http://bluefish.openoffice.nl/ns/bflang/2.0/' \
130        '%{_datadir}/xml/%{name}' \
131        %{_sysconfdir}/xml/catalog &> /dev/null || :
132
133%postun
134/usr/bin/update-mime-database %{_datadir}/mime &> /dev/null || :
135/usr/bin/update-desktop-database &> /dev/null || :
136if [ "$1" = 0 ]; then
137        /usr/bin/xmlcatalog --noout --del \
138                'http://bluefish.openoffice.nl/ns/bflang/2.0/' \
139                %{_sysconfdir}/xml/catalog &> /dev/null || :
140fi
141
142%files
143%defattr(-,root,root,-)
144%{_bindir}/%{name}
145%{_libdir}/%{name}/
146
147%files shared-data -f %{name}.lang
148%defattr(-,root,root,-)
149%doc %{bluefish_docdir}/
150%{_datadir}/%{name}/
151%{_datadir}/applications/%{name}.desktop
152%{_datadir}/mime/packages/%{name}.xml
153%{_datadir}/icons/hicolor/*/mimetypes/application-x-bluefish-project.png
154%{_datadir}/icons/hicolor/*/apps/%{name}.png
155%{_datadir}/icons/hicolor/scalable/mimetypes/bluefish-project.svg
156%{_datadir}/icons/hicolor/scalable/apps/bluefish-icon.svg
157%{_datadir}/pixmaps/application-x-bluefish-project.png
158%{_datadir}/pixmaps/%{name}.png
159%{_datadir}/xml/%{name}/
160%{_mandir}/man1/%{name}.1*
161
162%changelog
163* Thu Jan 23 2014 TANAKA hiroaki <mosaicist@jcom.home.ne.jp> 2.2.4
164- all resources renew from fedora bluefish-2.2.4-3.fc20.src.rpm
165
166* Sun Aug 21 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.3-1
167- new upstream release
168- built without gucharmap (VineSeed)
169- added BR: libxml2-devel
170
171* Tue Oct 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.2-1
172- new upstream release
173
174* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-1
175- new upstream release
176
177* Fri Mar 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1
178- new upstream release
179- updated BR
180
181* Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.7-2
182- added Japanese description
183
184* Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.7-1vl5
185- applied new versioning policy, spec in utf-8
186
187* Tue Nov  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.7-0vl2
188- rebuilt for Vine Linux 4.0
189
190* Tue Nov  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.7-0vl1
191- new upstream release
192
193* Sat Feb 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-0vl3
194- rebuild for VineSeed Plus
195
196* Sat Feb 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-0vl2
197- rebuit for VinePlus/3.0
198- dropped Patch0 (fixed at upstream version)
199
200* Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-0vl1
201- new upstream release
202
203* Tue Sep  6 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl1.1
204- added Patch0 for disable PCRE_UTF8 in highlighting
205
206* Sat Sep  3 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl1
207- new upstream release
208
209* Thu Aug 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl2
210- rebuild for VineSeed Plus
211
212* Thu Aug 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl1
213- new upstream release
214
215* Tue Aug 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl2
216- rebuild for VineSeed Plus
217
218* Tue Aug 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
219- new upstream release
220
221* Mon Jun 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-0vl3
222- rebuild for VineSeed Plus
223
224* Mon Jun 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-0vl2
225- rebuild for VinePlus/3.1
226- added BuildRequires: shared-mime-info
227
228* Sun Jun  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-0vl1
229- new upstream release
230
231* Thu May 26 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0-0vl2
232- rebuild for VineSeed Plus
233- added --disable-update-databases option
234- run update-mime-database on %post
235- added Prereq: shared-mime-info
236
237* Sun Feb  6 2005 Masaki Shinomiya <shino@pos.to> 1.0-0vl1
238- new upstream release, make install, files. desktop, compile ja.po
239
240* Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.13-0vl1
241- new upstream release
242- dropped patch0
243
244* Mon Jul 28 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11-0vl1
245- new upstream release
246
247* Fri Jul 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10-0vl1
248- Rebuild with new toolchains and Gnome2 for VineSeedPlus
249- add makefile.patch to fix Makefile.in
250- modified encodings.default
251
252* Fri Aug 2 2002 Masaki Shinomiya <shino@pos.to>
253- 0.7-0vl1 for VinePllus2.1, 0.7-0vl2 for VinePlus2.5/VineSeedPlus
254- vine.patch, without perl
255
256* Fri Mar  1 2002 Shingo Akagaki <dora@kondara.org>
257- (0.7-8k)
258- fix file attributes
259
260* Thu Feb 21 2002 Shingo Akagaki <dora@kondara.org>
261- (0.7-6k)
262- rebuild against for db3,4
263
264* Thu Feb 07 2002 Motonobu Ichimura <famao@kondara.org>
265- (0.7-4k)
266- add perl,attrpage,internal-preview support
267
268* Thu Feb 07 2002 Motonobu Ichimura <famao@kondara.org>
269- (0.7-2k)
270- add xim patch
271- up to 0.7
272
273* Thu Oct 18 2001 Motonobu Ichimura <famao@kondara.org>
274- (0.6-4k)
275- not egcs, but gcc2.95.3
276
277* Thu Oct 18 2001 Motonobu Ichimura <famao@kondara.org>
278- (0.6-2k)
279- up to 0.6
280- add BuildRequires: egcs ...
281- include .desktop file
282
283* Wed Oct 17 2001 Toru Hoshina <t@kondara.org>
284- (0.4-10k)
285- rebuild against gettext 0.10.40.
286
287* Mon Oct 15 2001 Toru Hoshina <t@kondara.org>
288- (0.4-8k)
289- rebuild against libpng 1.2.0.
290
291* Sat Dec  2 2000 MATSUDA, Daiki <dyky@df-usa.com>
292- (0.4-4k)
293- modified spec file with macros
294
295* Thu Jul 13 2000 AYUHANA Tomonori <l@kondara.org>
296- (0.4-2k)
297- SPEC fixed ( BuildRoot )
298- missing bluefish.desktop!
299
300* Tue Jun 13 2000 haruka kusumi <haruka76@kondara.org>
301  - changed some items for kondara
302
303* Fri May 5 2000   Bo Forslund  <bo.forslund@abc.se>
304  - fine tuning of the spec file
305  - possible to build with all processors on smp machines
306  - an entry for RedHats wmconfig
307
308* Tue Mar 21 2000 CW Zuckschwerdt <zany@triq.net>
309  - complete rewrite of spec file
310  - relocateable on build-time
311  - no privileges required while building
312  - fix for install_location (should really be $(LIBDIR)/bluefish!)
313  - included man, locale and lib into RPM (was seriously broken)
314
315* Thu Jan 13 2000 Chris Lea <chrislea@luciddesigns.com>
316  - Fixed up spec file some. bluefish-0.3.5
317
318* Wed Nov 17 1999 Chris Lea <chrislea@luciddesigns.com>
319  - added spec file. this is my third RPM that I've made a spec
320    file for, so please be merciful if I've screwed something up
Note: See TracBrowser for help on using the repository browser.