source: projects/specs/trunk/b/blender/blender-vl.spec @ 954

Revision 954, 10.0 KB checked in by owa, 14 years ago (diff)

updated blender to 2.49

Line 
1%define blenderlib %{_datadir}/blender
2%define plugins %{_libdir}/blender/plugins
3Summary:       3D modeling, animation, rendering and post-production.
4Summary(ja):   3D モデリング、アニメーション、レンダリング、ポストプロダクション
5Name:           blender
6Version:        2.49
7Release:        1%{?_dist_release}
8Group:          Applications/Multimedia
9License:        GPL
10URL:            http://www.blender.org/
11Source0:        http://download.blender.org/source/blender-%{version}.tar.gz
12Source1:        http://bane.servebeer.com/programming/blender/import-3ds-0.92.py
13Source2:        http://bane.servebeer.com/programming/blender/export-3ds-0.72.py
14Source3:        blender.png
15Source4:        blender.desktop
16Source5:        blender.xml
17
18Patch1: blender-2.49-scons.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  desktop-file-utils
22BuildRequires:  esound-devel
23BuildRequires:  glut-devel
24BuildRequires:  gettext-devel
25BuildRequires:  libjpeg-devel
26BuildRequires:  libogg-devel
27BuildRequires:  libpng-devel
28BuildRequires:  libtiff-devel
29BuildRequires:  libtool
30BuildRequires:  libvorbis-devel
31BuildRequires:  freealut-devel
32BuildRequires:  openssl-devel
33BuildRequires:  python-devel
34BuildRequires:  scons
35BuildRequires:  SDL-devel
36BuildRequires:  zlib-devel
37BuildRequires:  libXi-devel
38BuildRequires:  xorg-x11-proto-devel
39BuildRequires:  mesa-libGL-devel
40BuildRequires:  mesa-libGLU-devel
41BuildRequires:  freetype-devel
42BuildRequires:  OpenEXR-devel
43BuildRequires:  glew-devel
44
45Requires(post): desktop-file-utils
46Requires(post): shared-mime-info
47Requires(postun): desktop-file-utils
48Requires(postun): shared-mime-info
49
50
51%description
52Blender is an integrated suite of tools enabling the creation of a broad
53range of 3D content. It offers full functionality for modelling, rendering,
54animation, post-production, creation and playback of interactive 3D content
55with the singular benefits of cross-platform operability.
56
57Aimed at media professionals and artists, Blender can be used to create 3D
58visualizations, stills as well as broadcast quality video, while the
59incorporation of a real-time 3D engine allows for the creation of 3D
60interactive content for stand-alone playback.
61
62%description -l ja
63Blender は、幅広い 3D コンテンツの製作を可能にする統合ソフトウェアです。
64Blender は、モデリング、レンダリング、アニメーション、ポストプロダクション、
65インタラクティブな 3D コンテンツの製作と再生といった全機能を、複数の OS への
66対応という他には類のない利点と共に提供しています。
67
68Blender は、メディアの専門家や達人もターゲットにしているので、3D の視覚化や、
69良質なテレビ放送映像や静止画像の作成にも使用できます。さらに、リアルタイム
703D エンジンを統合したことにより、スタンドアロン再生用のインタラクティブな
713D コンテンツの製作も可能です。
72
73%prep
74%setup -q -n %{name}-%{version}
75#%patch1 -p1 -b .scons
76
77%build
78cat > user-config.py <<EOF
79WITH_BF_OPENAL = 'false'
80#BF_OPENAL = '%{_prefix}'
81#BF_OPENAL_INC = '%{_includedir}/AL'
82#BF_OPENAL_LIB = '%{_libdir}'
83WITH_BF_FFMPEG = 'false'
84BF_PYTHON = '%{_prefix}'
85BF_PYTHON_INC = '%{_includedir}/python%{pyver}'
86BF_PYTHON_LIB = 'python%{pyver}'
87BF_OPENEXR_INC = '%{_includedir}/OpenEXR'
88BF_GETTEXT = '%{_prefix}'
89BF_GETTEXT_INC = '%{_includedir}'
90BF_GETTEXT_LIB = 'gettextlib'
91BF_BUILDDIR = './builddir'
92BF_INSTALLDIR='./installdir'
93EOF
94
95## don't use parallel build
96#scons -i -k %{?_smp_mflags} BF_QUIET=0
97scons BF_QUIET=0
98
99install -d release/plugins/include
100install -m 644 source/blender/blenpluginapi/*.h release/plugins/include
101chmod +x release/plugins/bmake
102make -C release/plugins/
103
104
105%install
106rm -rf ${RPM_BUILD_ROOT}
107
108mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
109install -D -m 755 ./builddir/bin/blender ${RPM_BUILD_ROOT}/%{_bindir}/blender
110install -D -m 755 ./builddir/bin/blenderplayer ${RPM_BUILD_ROOT}/%{_bindir}/blenderplayer
111
112mkdir -p ${RPM_BUILD_ROOT}/%{_datadir}
113pushd bin/.blender/locale
114rm -rf $(find -name '.svn' -print)
115popd
116cp -a bin/.blender/locale ${RPM_BUILD_ROOT}/%{_datadir}
117install -p -D -m0644 %{SOURCE3} ${RPM_BUILD_ROOT}%{_datadir}/pixmaps/blender.png
118install -p -D -m0644 %{SOURCE5} ${RPM_BUILD_ROOT}%{_datadir}/mime/packages/blender.xml
119
120mkdir -p ${RPM_BUILD_ROOT}%{blenderlib}/scripts/
121install -p -D -m0644 release/scripts/*.py ${RPM_BUILD_ROOT}%{blenderlib}/scripts/
122install -m 644 release/VERSION ${RPM_BUILD_ROOT}/%{blenderlib}
123install -m 644 bin/.blender/.Blanguages ${RPM_BUILD_ROOT}/%{blenderlib}
124install -m 644 bin/.blender/.bfont.ttf ${RPM_BUILD_ROOT}/%{blenderlib}
125install -p -D -m0644 %{SOURCE1} ${RPM_BUILD_ROOT}%{blenderlib}/scripts/import-3ds-0.7.py
126install -p -D -m0644 %{SOURCE2} ${RPM_BUILD_ROOT}%{blenderlib}/scripts/export-3ds-0.71.py
127
128install -d ${RPM_BUILD_ROOT}/%{plugins}/sequence
129install -d ${RPM_BUILD_ROOT}/%{plugins}/texture
130install -m 644 release/plugins/sequence/*.so ${RPM_BUILD_ROOT}/%{plugins}/sequence
131install -m 655 release/plugins/texture/*.so ${RPM_BUILD_ROOT}/%{plugins}/texture
132
133desktop-file-install --vendor "" --dir ${RPM_BUILD_ROOT}%{_datadir}/applications %{SOURCE4}
134
135%find_lang %name
136
137
138%clean
139rm -rf ${RPM_BUILD_ROOT}
140
141
142%post
143update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
144update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
145
146
147%postun
148update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
149update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
150
151
152%files -f %name.lang
153%defattr(-,root,root,-)
154%doc COPYING README doc/python-dev-guide.txt doc/GPL-license.txt doc/bf-members.txt
155%{_bindir}/*
156%{_libdir}/blender/
157%{blenderlib}/
158%{_datadir}/applications/blender.desktop
159%{_datadir}/pixmaps/*.png
160%{_datadir}/mime/packages/blender.xml
161
162
163%changelog
164* Wed May 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.49-1
165- updated blender to 2.49
166- applied new versioning policy, and spec in utf-8
167- built without smp option
168- disable OpenAL, FFMPEG at user-config.py
169- added BR: libXi-devel xorg-x11-proto-devel mesa-libGL-devel mesa-libGLU-devel
170- added BR: freetype-devel OpenEXR-devel glew-devel
171
172* Mon Jan 02 2006 IKEDA Katsumi <ikeda@webmasters.gr.jp> 2.40-0vl2
173- new upstream release.
174
175* Sat Oct 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.35-0vl1
176- initial build for Vine Linux
177
178* Mon Nov 15 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 2.35-1
179- 2.35.
180
181* Thu Nov 11 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 2.34-0.fdr.3
182- Mime-type corrections for FC3.
183- Dropped redundent BR XFree86-devel.
184
185* Thu Aug 05 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.34-0.fdr.2
186- blender.applications file.
187- blender.xml file.
188- post/postun update-mime-database.
189
190* Thu Aug 05 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.34-0.fdr.1
191- Updated to 2.34.
192
193* Thu Aug 05 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.33-0.fdr.2.a
194- Include 3ds import/export scripts.
195- Added mime info.
196- Added mime icon (from yattacier theme).
197
198* Wed Aug 04 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.33-0.fdr.1.a
199- 2.33a.
200- Now building with scons.
201
202* Tue Feb 10 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.32-0.fdr.2
203- Now including scripts.
204
205* Thu Feb 05 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.32-0.fdr.1
206- Updated to 2.32.
207
208* Sun Jan 11 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.31-0.fdr.3.a
209- --enable-openal.
210- --disable-rpath.
211- remove --enable-international.
212- modify .desktop to execute with -w.
213
214* Thu Dec 04 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.31-0.fdr.2.a
215- Updated to 2.31a.
216
217* Sun Nov 30 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.31-0.fdr.1
218- Updated to 2.31.
219- enable-international.
220
221* Tue Nov 18 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.30-0.fdr.1
222- Updated to 2.30.
223
224* Fri Oct 10 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28-0.fdr.5.c
225- Updated to 2.28c.
226
227* Tue Oct 07 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28-0.fdr.4.a
228- Removed BuildReq smpeg-devel
229
230* Mon Sep 15 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28-0.fdr.3.a
231- Moved 'a' out of version according to naming guidelines.
232
233* Fri Sep 12 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28a-0.fdr.2
234- changed file permission on tarball.
235- dropped redundant messages about aclocal, etc.
236- configure --disable-shared.
237- automake --foreign.
238- added doc/python-dev-guide.txt doc/GPL-license.txt doc/bf-members.txt to %%doc.
239
240* Wed Sep 10 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28a-0.fdr.1
241- Updated to 2.28a.
242
243* Wed Aug 13 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28-0.fdr.2
244- New Icon.
245
246* Thu Jul 24 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28-0.fdr.1
247- Updated to 2.28.
248- BuildReq libvorbis-devel.
249- BuildReq smpeg-devel.
250- BuildReq esound-devel.
251- BuildReq libogg-devel.
252- BuildReq vorbis-tools.
253- BuildReq openal-devel
254- BuildReq libtool
255
256* Mon May 26 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.27-0.fdr.2
257- Removed post/postun ldconfig.
258- Added autoconf workaround.
259
260* Mon May 19 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.27-0.fdr.1
261- Updated to 2.27.
262- Removed devel package.
263
264* Wed Apr 09 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.26-0.fdr.9
265- Corrected devel Group.
266
267* Tue Apr 01 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.26-0.fdr.8
268- Added desktop-file-utils to BuildRequires.
269- Changed category to X-Fedora-Extra.
270
271* Mon Mar 31 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.26-0.fdr.7
272- Added Missing BuildRequires.
273
274* Sun Mar 30 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.26-0.fdr.6
275- Cleaned up BuildRequires.
276- Added Epoch:0.
277
278* Sat Mar 22 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 2.26-0.fdr.5
279- Spec file cleanup.
280
281* Sat Mar 08 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 2.26-1.fdr.4
282- Spec file cleanup.
283
284* Wed Feb 26 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 2.26-1.fedora.3
285- Spec file cleanup.
286
287* Thu Feb 20 2003 Warren Togami
288- Add BuildRequires python-devel
289
290* Wed Feb 19 2003 Phillip Compton
291- Initial RPM release.
Note: See TracBrowser for help on using the repository browser.