source: projects/specs/trunk/b/bleachbit/bleachbit-vl.spec @ 5175

Revision 5175, 6.2 KB checked in by kudoh, 13 years ago (diff)

bleachbit-vl.spec

Line 
1%define _prefix /usr
2
3Name:                   bleachbit
4Version:                0.9.1
5Release:                1%{?_dist_release}
6Summary:                Tool for remove unnecessary files, free space, and maintain privacy
7Summary(ja):            不要ファイルの削除、スペースの解放、プライバシーの保全のためのツール
8Group:                  Applications/System
9License:                GPLv3
10URL:                    http://bleachbit.sourceforge.net/
11Source0:                %{name}-%{version}.tar.bz2
12Patch0:                 no_update.patch
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildArch:      noarch
16BuildRequires:  python-devel
17BuildRequires:  desktop-file-utils
18BuildRequires:  gettext
19
20Requires:      gnome-python
21Requires:       python
22Requires:       python-simplejson
23Requires:       pygtk2 >= 2.6
24Requires:      usermode
25
26%description
27Delete traces of your activities and other junk files to free disk
28space and maintain privacy.  BleachBit identifies and erases
29broken menu entries, cache, cookies, localizations, recent document
30lists, and temporary files in Firefox, OpenOffice.org, Bash, and 50
31other applications.
32
33%description -l ja
34あなたの活動の形跡及びその他不要なファイルを
35ディスクスペース確保とプライバシー保護のために削除します。
36BleachBit は壊れたメニューエントリ・キャッシュ・クッキー・
37ローカライゼーション・最近使用したドキュメントのリスト・
38Firefox・OpenOffice.org・bash、その他50のアプリケーションの
39一時ファイルを検出し、削除します。
40
41%prep
42%setup -q
43%patch0 -p1
44
45%build
46make -C po local
47%{__python} setup.py build
48
49cp %{name}.desktop %{name}-root.desktop
50sed -i -e 's/Name=BleachBit$/Name=BleachBit as Administrator/g' %{name}-root.desktop
51
52cat > bleachbit.pam <<EOF
53#%PAM-1.0
54auth            include         config-util
55account         include         config-util
56session         include         config-util
57EOF
58
59cat > bleachbit.console <<EOF
60USER=root
61PROGRAM=/usr/bin/bleachbit
62SESSION=true
63EOF
64
65# remove Windows-specific cleaners
66grep -l os=.windows. cleaners/*xml | xargs rm -f
67# remove Windows-specific modules
68rm -f bleachbit/Windows.py
69
70%install
71rm -rf $RPM_BUILD_ROOT
72
73make install DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix}
74
75desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
76
77sed -i -e 's/Exec=bleachbit$/Exec=bleachbit-root/g' %{name}-root.desktop
78
79desktop-file-install \
80        --dir=%{buildroot}/%{_datadir}/applications/ \
81        --vendor="" %{name}-root.desktop
82
83# consolehelper and userhelper
84ln -s consolehelper %{buildroot}/%{_bindir}/%{name}-root
85mkdir -p %{buildroot}/%{_sbindir}
86ln -s ../..%{_datadir}/%{name}/GUI.py %{buildroot}/%{_sbindir}/%{name}-root
87mkdir -p %{buildroot}%{_sysconfdir}/pam.d
88install -m 644 %{name}.pam %{buildroot}%{_sysconfdir}/pam.d/%{name}-root
89mkdir -p %{buildroot}%{_sysconfdir}/security/console.apps
90install -m 644 %{name}.console %{buildroot}%{_sysconfdir}/security/console.apps/%{name}-root
91
92make -C po install DESTDIR=$RPM_BUILD_ROOT
93
94%find_lang %{name}
95
96%__rm %{buildroot}%{_datadir}/%{name}/*.py[co]
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%post
102update-desktop-database &> /dev/null ||:
103
104%postun
105update-desktop-database &> /dev/null ||:
106
107%files -f %{name}.lang
108%defattr(-,root,root)
109%doc COPYING
110%config(noreplace) %{_sysconfdir}/pam.d/%{name}-root
111%config(noreplace) %{_sysconfdir}/security/console.apps/%{name}-root
112%{_bindir}/%{name}-root
113%{_sbindir}/%{name}-root
114%{_bindir}/%{name}
115%dir %{_datadir}/%{name}
116%{_datadir}/%{name}/*
117%{_datadir}/pixmaps/*.png
118%{_datadir}/applications/*.desktop
119
120%changelog
121* Wed Nov 23 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.1-1
122- new upstream release
123
124* Sat Sep 03 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.0-1
125- new upstream release
126
127* Tue Jun 21 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.8-1
128- new upstream release
129
130* Wed Feb 16 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.7-1
131- new upstream release
132
133* Mon Jan 17 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.6-1
134- new upstream release
135
136* Sun Jan 2 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.5-1
137- new upstream release
138- added Requires: python-simplejson
139
140* Sat Dec 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.4-1
141- new upstream release
142
143* Mon Dec 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.3-1
144- new upstream release
145
146* Tue Nov 16 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.2-1
147- new upstream release
148
149* Wed Oct 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
150- new upstream release
151
152* Sat Jun 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.0-1
153- new upstream release
154
155* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.4-1
156- new upstream release
157- fixed Japanese description
158
159* Sun Feb 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.3-1
160- new upstream release
161
162* Sat Feb 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
163- rebuilt with python-2.6.4
164
165* Tue Dec 1 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
166- new upstream release
167
168* Tue Nov 10 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
169- new upstream release
170
171* Fri Oct 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
172- new upstream release
173- added Patch0 from Debian to disable update check
174
175* Sun Oct 4 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.5-1
176- new upstream release
177
178* Thu Sep 24 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.4-2
179- added BuildRequires: gettext
180- added Requires: gnome-python
181- changed Requires: pygtk2 >= 2.6
182- changed description/ -l ja
183- deleted Windows-specific cleaners and modules
184- changed program path in root
185
186* Thu Sep 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.4-1
187- new upstream release
188
189* Thu Sep 3 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.3-1
190- new upstream release
191
192* Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
193- new upstream release
194
195* Tue Aug 4 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.0-1
196- new upstream release
197
198* Fri Jul 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.4-1
199- new upstream release
200
201* Thu Jul 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.3-1
202- new upstream release
203
204* Tue Jun 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
205- new upstream release
206
207* Fri Jun 12 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.1-1
208- new upstream release
209
210* Sun Jun 7 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
211- new upstream release
212
213* Fri May 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
214- initial build for VineSeed
215
Note: See TracBrowser for help on using the repository browser.