source: projects/specs/trunk/b/bleachbit/bleachbit-vl.spec @ 2208

Revision 2208, 5.5 KB checked in by kudoh, 13 years ago (diff)
Line 
1%define _prefix /usr
2
3Name:                   bleachbit
4Version:                0.8.2
5Release:                1%{?_dist_release}
6Summary:                Tool for remove unnecessary files, free space, and maintain privacy
7Summary(ja):            不要ファイルの削除、スペースの解放、プライバシーの保全のためのツール
8Group:                  Applications/System
9License:                GPLv3
10URL:                    http://bleachbit.sourceforge.net/
11Source0:                %{name}-%{version}.tar.bz2
12Patch0:                 no_update.patch
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildArch:      noarch
16BuildRequires:  python-devel
17BuildRequires:  desktop-file-utils
18BuildRequires:  gettext
19
20Requires:       gnome-python
21Requires:       python
22Requires:       pygtk2 >= 2.6
23Requires:       usermode
24
25%description
26Delete traces of your activities and other junk files to free disk
27space and maintain privacy.  BleachBit identifies and erases
28broken menu entries, cache, cookies, localizations, recent document
29lists, and temporary files in Firefox, OpenOffice.org, Bash, and 50
30other applications.
31
32%description -l ja
33あなたの活動の形跡及びその他不要なファイルを
34ディスクスペース確保とプライバシー保護のために削除します。
35BleachBit は壊れたメニューエントリ・キャッシュ・クッキー・
36ローカライゼーション・最近使用したドキュメントのリスト・
37Firefox・OpenOffice.org・bash、その他50のアプリケーションの
38一時ファイルを検出し、削除します。
39
40%prep
41%setup -q
42%patch0 -p1
43
44%build
45make -C po local
46%{__python} setup.py build
47
48cp %{name}.desktop %{name}-root.desktop
49sed -i -e 's/Name=BleachBit$/Name=BleachBit as Administrator/g' %{name}-root.desktop
50
51cat > bleachbit.pam <<EOF
52#%PAM-1.0
53auth            include         config-util
54account         include         config-util
55session         include         config-util
56EOF
57
58cat > bleachbit.console <<EOF
59USER=root
60PROGRAM=/usr/bin/bleachbit
61SESSION=true
62EOF
63
64# remove Windows-specific cleaners
65grep -l os=.windows. cleaners/*xml | xargs rm -f
66# remove Windows-specific modules
67rm -f bleachbit/Windows.py
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
72make install DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix}
73
74desktop-file-validate %{buildroot}/%{_datadir}/applications/%{name}.desktop
75
76sed -i -e 's/Exec=bleachbit$/Exec=bleachbit-root/g' %{name}-root.desktop
77
78desktop-file-install \
79        --dir=%{buildroot}/%{_datadir}/applications/ \
80        --vendor="" %{name}-root.desktop
81
82# consolehelper and userhelper
83ln -s consolehelper %{buildroot}/%{_bindir}/%{name}-root
84mkdir -p %{buildroot}/%{_sbindir}
85ln -s ../..%{_datadir}/%{name}/GUI.py %{buildroot}/%{_sbindir}/%{name}-root
86mkdir -p %{buildroot}%{_sysconfdir}/pam.d
87install -m 644 %{name}.pam %{buildroot}%{_sysconfdir}/pam.d/%{name}-root
88mkdir -p %{buildroot}%{_sysconfdir}/security/console.apps
89install -m 644 %{name}.console %{buildroot}%{_sysconfdir}/security/console.apps/%{name}-root
90
91make -C po install DESTDIR=$RPM_BUILD_ROOT
92
93%find_lang %{name}
94
95%__rm %{buildroot}%{_datadir}/%{name}/*.py[co]
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%post
101update-desktop-database &> /dev/null ||:
102
103%postun
104update-desktop-database &> /dev/null ||:
105
106%files -f %{name}.lang
107%defattr(-,root,root)
108%doc COPYING
109%config(noreplace) %{_sysconfdir}/pam.d/%{name}-root
110%config(noreplace) %{_sysconfdir}/security/console.apps/%{name}-root
111%{_bindir}/%{name}-root
112%{_sbindir}/%{name}-root
113%{_bindir}/%{name}
114%dir %{_datadir}/%{name}
115%{_datadir}/%{name}/*
116%{_datadir}/pixmaps/*.png
117%{_datadir}/applications/*.desktop
118
119%changelog
120* Tue Nov 16 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.2-1
121- new upstream release
122
123* Wed Oct 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
124- new upstream release
125
126* Sat Jun 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.0-1
127- new upstream release
128
129* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.4-1
130- new upstream release
131- fixed Japanese description
132
133* Sun Feb 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.3-1
134- new upstream release
135
136* Sat Feb 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
137- rebuilt with python-2.6.4
138
139* Tue Dec 1 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
140- new upstream release
141
142* Tue Nov 10 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
143- new upstream release
144
145* Fri Oct 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
146- new upstream release
147- added Patch0 from Debian to disable update check
148
149* Sun Oct 4 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.5-1
150- new upstream release
151
152* Thu Sep 24 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.4-2
153- added BuildRequires: gettext
154- added Requires: gnome-python
155- changed Requires: pygtk2 >= 2.6
156- changed description/ -l ja
157- deleted Windows-specific cleaners and modules
158- changed program path in root
159
160* Thu Sep 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.4-1
161- new upstream release
162
163* Thu Sep 3 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.3-1
164- new upstream release
165
166* Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
167- new upstream release
168
169* Tue Aug 4 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.0-1
170- new upstream release
171
172* Fri Jul 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.4-1
173- new upstream release
174
175* Thu Jul 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.3-1
176- new upstream release
177
178* Tue Jun 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
179- new upstream release
180
181* Fri Jun 12 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.1-1
182- new upstream release
183
184* Sun Jun 7 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
185- new upstream release
186
187* Fri May 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
188- initial build for VineSeed
189
Note: See TracBrowser for help on using the repository browser.