source: projects/specs/trunk/b/bind/bind-vl.spec @ 12483

Revision 12483, 25.0 KB checked in by tomop, 4 years ago (diff)

updated 4 packages

bind-9.11.22-1

bison-3.7.1-1

golang-1.15.1-1

php74-7.4.10-1

Line 
1%bcond_with systemd
2
3%bcond_with python
4%define python_executable %{__python}
5
6%define _localstatedir /var
7%define _unpackaged_files_terminate_build 1
8
9%define sname bind
10%define pname bind
11# example: 9.9.13.P1
12%define pversion 9.11.22
13# example: 9.9.13-P1
14%define sversion 9.11.22
15%define bind_epoch 1
16# fixed <BTS:VineLinux:1139>
17%define old_bind_version 1:9.9.2p2-1vl7
18
19%define bind_uid  25
20%define bind_gid  25
21
22%bcond_with readline
23
24Summary: A DNS (Domain Name System) server.
25Summary(ja): DNS (Domain Name System) サーバ
26Name: %{pname}
27Epoch: %{bind_epoch}
28Version: %{pversion}
29Release: 1%{?_dist_release}%{?with_systemd:.systemd}
30Group: servers
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: daisuke
34
35License: ISC and BSD and Public Domain
36URL: http://www.isc.org/bind.html
37Source: https://downloads.isc.org/isc/bind9/%{sversion}/bind-%{sversion}.tar.gz
38Source1: bind-manpages.tar.bz2
39Source2: named.sysconfig
40Source3: named.init
41Source4: named.logrotate
42Source5: keygen.c
43Source100: named.service
44Source101: named-setup-rndc.service
45Source102: named.sysconfig.systemd
46Source103: bind.tmpfiles.d
47Source104: named.conf
48
49Patch1: bind-9.11.5-rndckey.patch
50
51BuildRoot: %{_tmppath}/%{name}-%{version}-root
52%if %{with python}
53BuildRequires: python
54BuildRequires: python-rpm-macros
55BuildRequires: python-ply
56%endif
57BuildRequires: openssl-devel glibc-devel libtool
58BuildRequires: libxml2-devel
59BuildRequires: libcap-devel
60%if %{with readline}
61BuildRequires: readline-devel
62%endif
63Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
64Requires(pre): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
65Requires(pre): shadow-utils
66Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
67Requires(post): coreutils
68%if %{with systemd}
69%{?systemd_requires}
70%else
71Requires(post): chkconfig
72Requires(preun): chkconfig
73%endif
74Conflicts: bind9 <= 9.2.1-0vl5, bind-current
75Obsoletes: bind9 <= 9.2.1-0vl5
76Obsoletes: bind-current < 1:9.9.4-1
77
78%description
79BIND (Berkeley Internet Name Domain) is an implementation of the DNS
80(Domain Name System) protocols. BIND includes a DNS server (named),
81which resolves host names to IP addresses, and a resolver library
82(routines for applications to use when interfacing with DNS).  A DNS
83server allows clients to name resources or objects and share the
84information with other network machines.  The named DNS server can be
85used on workstations as a caching name server, but is generally only
86needed on one machine for an entire network.  Note that the
87configuration files for making BIND act as a simple caching nameserver
88are included in the caching-nameserver package. 
89
90Install the bind package if you need a DNS server for your network.  If
91you want bind to act a caching name server, you will also need to install
92the caching-nameserver package.
93
94
95%package libs
96Summary: Libraries used by various DNS packages
97Summary(ja): さまざまな DNS パッケージで使用されるライブラリ
98Group: system
99Obsoletes: bind-current-libs <= %{old_bind_version}
100
101%description libs
102Contains libraries used by both the bind server package as well as the utils packages.
103
104
105%package utils
106Summary: Utilities for querying DNS name servers.
107Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
108Group: admin-tools
109Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
110Conflicts: bind9-utils <= 9.2.1-0vl5
111Conflicts: bind-current-utils
112Obsoletes: bind9-utils <= 9.2.1-0vl5
113Obsoletes: bind-current-utils <= %{old_bind_version}
114
115%description utils
116Bind-utils contains a collection of utilities for querying DNS (Domain
117Name Service) name servers to find out information about Internet hosts.
118These tools will provide you with the IP addresses for given host names,
119as well as other information about registered domains and network
120addresses.
121
122You should install bind-utils if you need to get information from DNS name
123servers.
124
125
126%package devel
127Summary: Include files and libraries needed for bind DNS development.
128Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
129Group: programming
130Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
131Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
132Conflicts: bind9-devel <= 9.2.1-0vl5
133Conflicts: bind-current-devel
134Obsoletes: bind9-devel <= 9.2.1-0vl5
135Obsoletes: bind-current-devel <= %{old_bind_version}
136
137%description devel
138The bind-devel package contains all the include files and the
139library required for DNS (Domain Name Service) development for
140BIND versions 9.x.x.
141
142You should install bind-devel if you want to develop bind DNS
143applications. If you install bind-devel, you'll also need to install
144bind.
145#'
146
147
148%prep
149%setup -n bind-%{sversion} -q
150%patch1 -p1 -b .key
151perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
152
153%build
154libtoolize --copy --force
155aclocal
156autoconf
157%configure \
158  --with-libtool \
159  --with-openssl=/usr \
160%if %{without readline}
161    --without-readline \
162%endif
163  --disable-openssl-version-ceck \
164  --enable-threads \
165  --enable-ipv6 \
166  --with-pic \
167  --with-dlz-dlopen \
168%if %{with python}
169  --with-python=%{python_executable} \
170%else
171  --with-python=no \
172%endif
173  --enable-filter-aaaa \
174  --enable-fixed-rrset
175make %{?_smp_mflags}
176
177%install
178rm -rf %{buildroot}
179mkdir -p %{buildroot}%{_sysconfdir}/{logrotate.d,sysconfig}
180mkdir -p %{buildroot}/usr/{bin,lib,sbin,include}
181mkdir -p %{buildroot}/var/named/data
182mkdir -p %{buildroot}%{_mandir}/{man1,man5,man8}
183mkdir -p %{buildroot}/var/run/named
184
185make DESTDIR=%{buildroot} install
186install -c -m 640 bin/rndc/rndc.conf %{buildroot}/etc
187install -c -m 644 %SOURCE4 %{buildroot}%{_sysconfdir}/logrotate.d/named
188touch %{buildroot}%{_sysconfdir}/rndc.key
189gcc %{optflags} -o %{buildroot}/usr/sbin/dns-keygen %{SOURCE5}
190cd %{buildroot}%{_mandir}
191tar xjf %{SOURCE1}
192# newer version is contained in source
193rm -f man5/named.conf.5.gz
194
195install -m 644 %{SOURCE104} %{buildroot}%{_sysconfdir}/named.conf
196
197%if %{with systemd}
198# Systemd unit files
199mkdir -p %{buildroot}%{_unitdir}
200install -m 644 %{SOURCE100} %{buildroot}%{_unitdir}
201install -m 644 %{SOURCE101} %{buildroot}%{_unitdir}
202install -m 644 %{SOURCE102} %{buildroot}%{_sysconfdir}/sysconfig/named
203mkdir -p %{buildroot}%{_tmpfilesdir}
204install -m 644 %{SOURCE103} %{buildroot}%{_tmpfilesdir}/named.conf
205%else
206mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
207install -c -m 755 %SOURCE3 %{buildroot}%{_sysconfdir}/rc.d/init.d/named
208cp %{SOURCE2} %{buildroot}%{_sysconfdir}/sysconfig/named
209%endif
210
211chmod +x %{buildroot}%{_libdir}/*.so.*
212
213rm -f %{buildroot}%{_libdir}/*.la
214
215%clean
216rm -rf %{buildroot} ${RPM_BUILD_DIR}/%{name}-%{version}
217
218
219%pre
220if [ "$1" -eq 1 ]; then
221  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
222  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
223fi;
224:;
225
226%post
227/sbin/ldconfig
228if [ "$1" -eq 1 ]; then
229  if [ ! -e /etc/rndc.key ]; then
230    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
231  fi
232  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
233  # rndc.key has to have correct perms and ownership, CVE-2007-6283
234  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
235  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
236
237  # Check DNSSEC settings if this is a fresh install
238  if [ -r /etc/sysconfig/dnssec ]; then
239    . /etc/sysconfig/dnssec
240    [ -x /usr/sbin/dnssec-configure ] && \
241      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
242        /dev/null 2>&1
243  fi;
244fi
245%if %{with systemd}
246%systemd_post named.service
247%else
248if [ "$1" -eq 1 ]; then
249  /sbin/chkconfig --add named
250fi
251%endif
252:;
253
254%preun
255%if %{with systemd}
256# Package removal, not upgrade
257%systemd_preun named.service
258%else
259if [ "$1" -eq 0 -o -x /sbin/systemctl ]; then
260   /sbin/service named stop >/dev/null 2>&1 || :
261   /sbin/chkconfig --del named ||:
262fi
263%endif
264exit 0
265
266%postun
267/sbin/ldconfig
268%if %{with systemd}
269# Package upgrade, not uninstall
270%systemd_postun_with_restart named.service
271%else
272if [ "$1" -ge 1 ]; then
273        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
274fi
275%endif
276exit 0
277
278%triggerpostun -- bind < 8.2.2_P5-15
279/sbin/chkconfig --add named
280/sbin/ldconfig
281
282%triggerpostun -- bind-current < 1:9.9.4-1
283/sbin/chkconfig --add named
284/sbin/ldconfig
285
286%post libs -p /sbin/ldconfig
287
288%postun libs -p /sbin/ldconfig
289
290
291%files
292%defattr(-,root,root)
293%license COPYRIGHT
294%doc CHANGES README*
295%doc doc/arm doc/misc
296%config(noreplace) %{_sysconfdir}/named.conf
297%config(noreplace) %{_sysconfdir}/logrotate.d/named
298%if %{with systemd}
299%{_unitdir}/named.service
300%{_unitdir}/named-setup-rndc.service
301%{_tmpfilesdir}/named.conf
302%else
303%config %{_sysconfdir}/rc.d/init.d/named
304%attr(-,named,named) %dir %{_var}/run/named
305%endif
306%config(noreplace) %{_sysconfdir}/sysconfig/named
307%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
308%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
309%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
310
311%attr(-,named,named) %dir %{_var}/named
312%attr(-,named,named) %dir %{_var}/named/data
313
314%{_sbindir}/dnssec*
315%{_sbindir}/lwresd
316%{_sbindir}/named
317%{_sbindir}/named-check*
318%{_sbindir}/named-compilezone
319%{_sbindir}/rndc*
320%{_sbindir}/dns-keygen
321%{_bindir}/arpaname
322%{_sbindir}/ddns-confgen
323%{_sbindir}/genrandom
324%{_sbindir}/isc-hmac-fixup
325%{_sbindir}/named-journalprint
326%{_sbindir}/nsec3hash
327%{_sbindir}/tsig-keygen
328
329%if %{with python}
330%{python_sitelib}/*
331%endif
332
333%{_mandir}/man1/arpaname.1*
334%{_mandir}/man5/resolv.conf.5*
335%{_mandir}/man5/named.conf.5*
336%{_mandir}/man5/rndc.conf.5*
337%{_mandir}/man8/rndc.8*
338%{_mandir}/man8/named.8*
339%{_mandir}/man8/lwresd.8*
340%{_mandir}/man8/dnssec*.8*
341%{_mandir}/man8/named-checkconf.8*
342%{_mandir}/man8/named-checkzone.8*
343%{_mandir}/man8/named-compilezone.8*
344%{_mandir}/man8/rndc-confgen.8*
345%{_mandir}/man8/ddns-confgen.8*
346%{_mandir}/man8/genrandom.8*
347%{_mandir}/man8/isc-hmac-fixup.8*
348%{_mandir}/man8/named-journalprint.8*
349%{_mandir}/man8/nsec3hash.8*
350%{_mandir}/man8/tsig-keygen.8*
351
352%files libs
353%defattr(-,root,root)
354%{_libdir}/*.so.*
355
356%files utils
357%defattr(-,root,root)
358%{_bindir}/delv
359%{_bindir}/dig
360%{_bindir}/host
361%{_bindir}/mdig
362%{_bindir}/named-rrchecker
363%{_bindir}/nslookup
364%{_bindir}/nsupdate
365%{_mandir}/man1/delv.1*
366%{_mandir}/man1/dig.1*
367%{_mandir}/man1/host.1*
368%{_mandir}/man1/mdig.1*
369%{_mandir}/man1/named-rrchecker.1*
370%{_mandir}/man1/nslookup.1*
371%{_mandir}/man1/nsupdate.1*
372%{_mandir}/man5/resolver.5*
373%{_mandir}/man8/nslookup.8*
374
375%files devel
376%defattr(-,root,root)
377%{_libdir}/*.so
378%{_libdir}/*.a
379%{_includedir}/*
380%{_mandir}/man3/*
381%{_mandir}/man1/bind9-config.1*
382%{_mandir}/man1/isc-config.sh.1*
383%{_bindir}/bind9-config
384%{_bindir}/isc-config.sh
385
386%changelog
387* Thu Sep 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.22-1
388- updated to 9.11.22.
389
390* Fri Jul 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.20-2
391- added systemd support (disabled as default).
392
393* Thu Jul 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.20-1
394- updated to 9.11.20.
395
396* Sat Nov 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.12-1
397- updated to 9.11.12.
398
399* Wed Oct 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.11-1
400- updated to 9.11.11.
401
402* Sun Dec 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.5-1
403- updated to 9.11.5 (new ESV).
404- updated Patch1.
405
406* Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.9.13.P1-1
407- updated to 9.9.13.P1.
408- updated Patch1.
409
410* Thu Apr 13 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 9.9.9.P8-1
411- update to 9.9.9.P8
412
413* Sun Feb 19 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 9.9.9.P6-1
414- new upstream release.
415
416* Thu Nov 03 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 9.9.9.P4-1
417- new upstream release.
418
419* Mon Aug 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.9.9.P2-1
420- new upstream release.
421
422* Mon Mar 14 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P4-1
423- new upstream release with secrity fix (CVE-2016-1285,1286)
424- built with openssl 1.0.2g
425
426* Wed Jan 20 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P3-1
427- new upstream release with secrity fix (CVE-2015-4620) 
428
429* Thu Jul  9 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P1-1
430- new upstream release with secrity fix (CVE-2015-4620)
431
432* Mon Mar 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-2
433- rebuilt without readline to avoid GPL infection
434
435* Fri Feb 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-1
436- new upstream release with secrity fix (CVE-2015-1349)
437- added BR: readline-devel
438
439* Fri Feb  6 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P1-3
440- new upstream release with secrity fix (CVE-2014-8500) 
441- used "3" as release number because of being newer than Vine Linux/6 updates
442
443* Tue Oct 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.4-1
444- update to 9.9.4(ESV)
445
446* Thu Mar 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.2p2-1
447- update to 9.9.2-P2
448- remove .la
449- remove Conflicts/Obsoletes from libs subpackage.
450- add configure options
451  --enable-ipv6 --with-pic --enable-filter-aaaa --enable-fixed-rrset
452
453* Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.8.4p1-1
454- new upstream release.
455- added an option "--with-dlz-dlopen".
456
457* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.8.0p2-2
458- Obosoletes: bind.* < 1:9.6.ESV.R1
459 - fixed <BTS:VineLinux:1139>
460
461* Sun May 29 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p2-1
462- new upstream release with security fix (CVE-2011-1910)
463
464* Tue May 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.8.0p1-2
465- add BuildRequires: libxml2-devel, libcap-devel
466
467* Mon May  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
468- new upstream release with security fix (CVE-2011-1907)
469- fix changelog typo
470
471* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
472- Obosoletes: bind.* < 1:9.6.ESV.R1
473
474* Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
475- update to 9.8.0
476- remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
477
478* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
479- rebuild with openssl-1.0.0c
480
481* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
482- fix Req: in bind package
483
484* Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
485- change package name bind -> bind-current
486- add epoch 1
487- new upstream release
488
489* Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
490- new upstream release
491
492* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
493- rebuilt with gcc-4.4.3-3 on ppc
494
495* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
496- rebuilt with new toolchains (for VineSeed)
497- s/BuildPrereq/BuildRequires/
498
499* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
500- add man1/isc-config.sh.1 into devel file list
501
502* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
503- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
504
505* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
506- new upstream release with security fix (CVE-2009-4022)
507
508* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
509- new upstream release with security fix
510
511* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
512- new upstream release
513- clean up %%post/%%pre scriptlet
514  - create named user and group in %%pre
515  - don't remove named user/group in %%preun
516  - use rndc-confgen to create rndc.key
517
518* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
519- new upstream release
520- drop patch0 and patch14, merged in upstream
521
522* Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
523- new upstream release with security fix
524
525* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
526- new upstream release with security fix
527- new versioning policy
528
529* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
530- new upstream release with security fix
531
532* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
533- new upstream release
534- build with new openssl/toolchain
535
536* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
537- new upstream release with security fix
538
539* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
540- new upstream release
541
542* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
543- add Prereq sed
544
545* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
546- new upstream release for security fix (CVE-2006-4095,4096)
547
548* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
549- separate -libs package
550- remove old named.conf.5.gz
551  - newer version is contained in source
552
553* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
554- add bsdcompat patch (Patch4)
555- add fix_h_errno patch from FC
556  - h_errno not being accessed / set correctly in libbind
557
558* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
559- new upstream release
560
561* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
562- added PreReq to bind-utils (see: [VineSeed:09555])
563
564* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
565- new upstream release
566
567* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
568- fix /etc/init.d/named to use rndc
569
570* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
571- rebuild to remove unneeded dependancy
572
573* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
574- new upstream release
575
576* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
577- new upstream release
578
579* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
580- fix dependancies.
581
582* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
583- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
584- change package name to bind for VineSeed.
585- use more macros.
586
587* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
588- fixed some macros
589- add conflicts: to bind-* in bind9-devel and bind9-utils
590- add provides: bind = %%{version}
591
592* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
593- use %%configure macros
594
595* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
596- fixed inconsistent dependency
597
598* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
599- updated to 9.2.2rc1
600
601* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
602- updated to bind9(9.2.1), test packages ;)
603        -- based on Rawhide's bind-9.2.0-8
604        -- changed name bind9
605        -- added Conflicts: bind
606
607* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
608- release 8.3.1 includes security fixes
609
610* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
611- Upgraded to current stable release 8.3.0
612
613* Mon Oct  8 2001 <zn@mbf.nifty.com>
614- 8.2.5-0vl0: Upgraded to new upstream version.
615
616* Thu May 24 2001 <sagami@vinelinux.org>
617- 8.2.4-0vl1: eliminate CVS related files from %%doc
618
619* Thu May 17 2001 <sagami@vinelinux.org>
620- 8.2.4-0vl0
621
622* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
623- 8.2.3-1vl2
624- built on VineSeed
625
626* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
627- add doc/old
628- build for Vine 2.1
629
630* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
631- 8.2.3, fixes several security problems
632
633* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
634- static libraries may be used in shared objects. Build with -fPIC on ia64
635
636* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
637- 8.2.2-P7 (fixes Bug #20546)
638
639* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
640- condrestart fixes
641
642* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
643- change the init script to take condrestart, not cond-restart
644- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
645  the %pre and %post scripts
646
647* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
648- Don't prereq /etc/init.d
649
650* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
651- move initscript back
652
653* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
654- automatic rebuild
655
656* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
657- add "exit 0" for uninstall case
658
659* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
660- add prereq init.d and cleanup install section
661
662* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
663- fix the init script
664
665* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
666- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
667
668* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
669- Fix up the initscript (Bug #13033)
670- Fix build with current glibc (Bug #12755)
671- /etc/rc.d/init.d -> /etc/init.d
672- use %%{_mandir} rather than /usr/share/man
673
674* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
675- fix conflict with man-pages
676- remove compatibilty chkconfig links
677- initscript munging
678
679* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
680- modify logrotate setup to use PID file
681- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
682- actually bump the release this time
683
684* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
685- FHS compliance
686
687* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
688- clean up restart patch
689
690* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
691- provide /var/named (fix for bugs #9847, #10205)
692- preserve args when restarted via ndc(8) (bug #10227)
693- make resolv.conf(5) a link to resolver(5) (bug #10245)
694- fix SYSTYPE bug in all makefiles
695- move creation of named user from %%post into %%pre
696
697* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
698- Fix TTL (patch from ISC, Bug #9820)
699
700* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
701- fix typo in spec (it's %post, without a leading blank) introduced in -6
702- change SYSTYPE to linux
703
704* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
705- pick a standard < 100 uid/gid for named
706
707* Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
708- Pass named a '-u named' parameter by default, and add/remove user.
709
710* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
711- fix host mx bug (Bug #9021)
712
713* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
714- rebuild to fix dependencies
715- man pages are compressed
716
717* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
718- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
719
720* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
721- Fix up location of named-bootconf.pl and make it executable
722  (Bug #8028)
723- bind-devel requires bind
724
725* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
726- update to 8.2.2-P5
727
728* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
729- update to 8.2.2-P3
730
731* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
732- add patch to stop a cache only server from complaining about lame servers
733  on every request.
734
735* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
736- use real stop and start in named.init for restart, not ndc restart, it has
737  problems when named has changed during a package update... (# 4890)
738
739* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
740- chkconfig --del in %preun, not %postun
741
742* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
743- initscript munging
744
745* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
746- fix installed chkconfig links to match init file
747
748* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
749- conflict with new (in man-1.24) man pages (#3876,#3877).
750
751* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
752- fix named.logrotate (wrong %SOURCE)
753
754* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
755- update to 8.2.1.
756- add named.logrotate (#3571).
757- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
758- vet file list.
759
760* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
761- don't run by default
762
763* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
764- nslookup fixes (#2463).
765- missing files (#3152).
766
767* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
768- nslookup patched:
769  to count numRecords properly
770  to fix subsequent calls to ls -d
771  to parse "view" and "finger" commands properly
772  the view hack updated for bind-8 (using sed)
773
774* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
775- add ISC patch
776- add quick hack to make host not crash
777- add more docs
778
779* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
780- add probing information in the init file to keep linuxconf happy
781- dont strip libbind
782
783* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
784- auto rebuild in the new build environment (release 3)
785
786* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
787- removed 'done' output at named shutdown.
788
789* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
790- version 8.2
791
792* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
793- patch to use the __FDS_BITS macro
794- build for glibc 2.1
795
796* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
797- change named.restart to /usr/sbin/ndc restart
798
799* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
800- install man pages correctly.
801- change K10named to K45named.
802
803* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
804- don't start if /etc/named.conf doesn't exist.
805
806* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
807- autmagically create /etc/named.conf from /etc/named.boot in %post
808- remove echo in %post
809
810* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
811- merge in 5.1 mods
812
813* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
814- Several essential modifications to build and install correctly.
815- Modified 'ndc' to avoid deprecated use of '-'
816
817* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
818- Used buildroot
819- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
820  on Redhat 5.0 instead of <nlist.h>
821
Note: See TracBrowser for help on using the repository browser.