source: projects/specs/trunk/b/bind-current/bind-current-vl.spec @ 7258

Revision 7258, 20.8 KB checked in by tomop, 11 years ago (diff)

bind-current-9.8.4p1-1

Line 
1%define _localstatedir /var
2
3%define sname bind
4%define pname bind-current
5%define pversion 9.8.4p1
6%define sversion 9.8.4-P1
7%define bind_epoch 1
8# fixed <BTS:VineLinux:1139>
9%define old_bind_version 1:9.6.ESV.R1
10
11%define bind_uid  25
12%define bind_gid  25
13
14Summary: A DNS (Domain Name System) server.
15Summary(ja): DNS (Domain Name System) サーバ
16Name: %{pname}
17Version: %{pversion}
18Release: 1%{?_dist_release}
19Epoch: %{bind_epoch}
20License: distributable
21Group: System Environment/Daemons
22Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{sname}-%{sversion}.tar.gz
23Source1: bind-manpages.tar.bz2
24Source2: named.sysconfig
25Source3: named.init
26Source4: named.logrotate
27Source5: keygen.c
28URL: http://www.isc.org/bind.html
29Patch1: bind-9.3.3rc2-rndckey.patch
30
31Buildroot: %{_tmppath}/%{name}-%{version}-root
32BuildRequires: openssl-devel glibc-devel libtool
33BuildRequires: libxml2-devel
34BuildRequires: libcap-devel
35Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
36Requires(pre): shadow-utils
37Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
38Requires(post): coreutils, chkconfig
39Requires(preun): initscripts, chkconfig
40#Requires(triggerpostun): chkconfig
41Conflicts: bind9 <= 9.2.1-0vl5, bind < %{bind_epoch}:%{version}-%{release}
42Obsoletes: bind9 <= 9.2.1-0vl5, bind < %{old_bind_version}
43
44Vendor: Project Vine
45Distribution: Vine Linux
46Packager: daisuke
47
48%description
49BIND (Berkeley Internet Name Domain) is an implementation of the DNS
50(Domain Name System) protocols. BIND includes a DNS server (named),
51which resolves host names to IP addresses, and a resolver library
52(routines for applications to use when interfacing with DNS).  A DNS
53server allows clients to name resources or objects and share the
54information with other network machines.  The named DNS server can be
55used on workstations as a caching name server, but is generally only
56needed on one machine for an entire network.  Note that the
57configuration files for making BIND act as a simple caching nameserver
58are included in the caching-nameserver package. 
59
60Install the bind package if you need a DNS server for your network.  If
61you want bind to act a caching name server, you will also need to install
62the caching-nameserver package.
63
64
65%package libs
66Summary: Libraries used by various DNS packages
67Group: System Environment/Libraries
68Conflicts: bind9-libs <= 9.2.1-0vl5
69Conflicts: bind-libs < %{bind_epoch}:%{version}-%{release}
70Obsoletes: bind9-libs <= 9.2.1-0vl5
71Obsoletes: bind-libs < %{old_bind_version}
72
73%description libs
74Contains libraries used by both the bind server package as well as the utils packages.
75
76
77%package utils
78Summary: Utilities for querying DNS name servers.
79Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
80Group: Applications/System
81Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
82Conflicts: bind9-utils <= 9.2.1-0vl5
83Conflicts: bind-utils < %{bind_epoch}:%{version}-%{release}
84Obsoletes: bind9-utils <= 9.2.1-0vl5
85Obsoletes: bind-utils < %{old_bind_version}
86
87%description utils
88Bind-utils contains a collection of utilities for querying DNS (Domain
89Name Service) name servers to find out information about Internet hosts.
90These tools will provide you with the IP addresses for given host names,
91as well as other information about registered domains and network
92addresses.
93
94You should install bind-utils if you need to get information from DNS name
95servers.
96
97
98%package devel
99Summary: Include files and libraries needed for bind DNS development.
100Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
101Group: Development/Libraries
102Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
103Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
104Conflicts: bind9-devel <= 9.2.1-0vl5
105Conflicts: bind-devel < %{bind_epoch}:%{version}-%{release}
106Obsoletes: bind9-devel <= 9.2.1-0vl5
107Obsoletes: bind-devel < %{old_bind_version}
108
109%description devel
110The bind-devel package contains all the include files and the
111library required for DNS (Domain Name Service) development for
112BIND versions 9.x.x.
113
114You should install bind-devel if you want to develop bind DNS
115applications. If you install bind-devel, you'll also need to install
116bind.
117#'
118
119%prep
120%setup -n bind-%{sversion} -q
121%patch1 -p1 -b .key
122perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
123
124%build
125libtoolize --copy --force
126aclocal
127autoconf
128%configure --with-libtool --with-openssl=/usr --enable-threads --with-dlz-dlopen
129make %{?_smp_mflags}
130
131%install
132rm -rf $RPM_BUILD_ROOT
133mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
134mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
135mkdir -p ${RPM_BUILD_ROOT}/var/named
136mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
137mkdir -p ${RPM_BUILD_ROOT}/var/run/named
138
139make DESTDIR=$RPM_BUILD_ROOT install
140install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
141install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
142install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
143install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
144touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
145gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
146cd $RPM_BUILD_ROOT%{_mandir}
147tar xjf %{SOURCE1}
148# newer version is contained in source
149rm -f man5/named.conf.5.gz
150mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
151cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
152
153chmod +x %{buildroot}%{_libdir}/*.so.*
154
155%pre
156if [ "$1" -eq 1 ]; then
157  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
158  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
159fi;
160:;
161
162%post
163/sbin/ldconfig
164/sbin/chkconfig --add named
165if [ "$1" -eq 1 ]; then
166  if [ ! -e /etc/rndc.key ]; then
167    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
168  fi
169  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
170  # rndc.key has to have correct perms and ownership, CVE-2007-6283
171  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
172  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
173
174  # Check DNSSEC settings if this is a fresh install
175  if [ -r /etc/sysconfig/dnssec ]; then
176    . /etc/sysconfig/dnssec
177    [ -x /usr/sbin/dnssec-configure ] && \
178      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
179        /dev/null 2>&1
180  fi;
181fi
182:;
183
184%preun
185if [ "$1" -eq 0 ]; then
186   /sbin/service named stop >/dev/null 2>&1 || :
187   /sbin/chkconfig --del named ||:
188fi
189exit 0
190
191
192%postun
193if [ "$1" -ge 1 ]; then
194        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
195fi
196/sbin/ldconfig
197
198%triggerpostun -- bind < 8.2.2_P5-15
199/sbin/chkconfig --add named
200/sbin/ldconfig
201
202%clean
203rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
204
205
206%post libs
207/sbin/ldconfig
208
209%postun libs
210/sbin/ldconfig
211
212
213%files
214%defattr(-,root,root)
215%doc CHANGES README
216%doc doc/arm doc/draft doc/rfc doc/misc
217%config(noreplace) %{_sysconfdir}/logrotate.d/named
218%config %{_sysconfdir}/rc.d/init.d/named
219%config(noreplace) %{_sysconfdir}/sysconfig/named
220%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
221%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
222%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
223
224%{_sbindir}/dnssec*
225%{_sbindir}/lwresd
226%{_sbindir}/named
227%{_sbindir}/named-bootconf
228%{_sbindir}/named-check*
229%{_sbindir}/named-compilezone
230%{_sbindir}/rndc*
231%{_sbindir}/dns-keygen
232%{_sbindir}/arpaname
233%{_sbindir}/ddns-confgen
234%{_sbindir}/genrandom
235%{_sbindir}/isc-hmac-fixup
236%{_sbindir}/named-journalprint
237%{_sbindir}/nsec3hash
238
239%{_mandir}/man1/arpaname.1*
240%{_mandir}/man5/resolv.conf.5*
241%{_mandir}/man5/named.conf.5*
242%{_mandir}/man5/rndc.conf.5*
243%{_mandir}/man8/rndc.8*
244%{_mandir}/man8/named.8*
245%{_mandir}/man8/lwresd.8*
246%{_mandir}/man8/dnssec*.8*
247%{_mandir}/man8/named-checkconf.8*
248%{_mandir}/man8/named-checkzone.8*
249%{_mandir}/man8/named-compilezone.8*
250%{_mandir}/man8/rndc-confgen.8*
251%{_mandir}/man8/ddns-confgen.8*
252%{_mandir}/man8/genrandom.8*
253%{_mandir}/man8/isc-hmac-fixup.8*
254%{_mandir}/man8/named-journalprint.8*
255%{_mandir}/man8/nsec3hash.8*
256
257%attr(-,named,named) %dir %{_var}/named
258%attr(-,named,named) %dir %{_var}/run/named
259     
260
261%files libs
262%defattr(-,root,root)
263%{_libdir}/*.so.*
264
265%files utils
266%defattr(-,root,root)
267%{_bindir}/dig
268%{_bindir}/host
269%{_bindir}/nslookup
270%{_bindir}/nsupdate
271%{_mandir}/man1/host.1*
272%{_mandir}/man1/nsupdate.1*
273%{_mandir}/man1/dig.1*
274%{_mandir}/man5/resolver.5*
275%{_mandir}/man1/nslookup.1*
276%{_mandir}/man8/nslookup.8*
277
278
279%files devel
280%defattr(-,root,root)
281%{_libdir}/*.so
282%{_libdir}/*.la
283%{_libdir}/*.a
284%{_includedir}/*
285%{_mandir}/man3/*
286%{_mandir}/man1/isc-config.sh.1*
287%{_bindir}/isc-config.sh
288
289%changelog
290* Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.8.4p1-1
291- new upstream release.
292- added an option "--with-dlz-dlopen".
293
294* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.8.0p2-2
295- Obosoletes: bind.* < 1:9.6.ESV.R1
296 - fixed <BTS:VineLinux:1139>
297
298* Sun May 29 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p2-1
299- new upstream release with security fix (CVE-2011-1910)
300
301* Tue May 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.8.0p1-2
302- add BuildRequires: libxml2-devel, libcap-devel
303
304* Mon May  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
305- new upstream release with security fix (CVE-2011-1907)
306- fix changelog typo
307
308* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
309- Obosoletes: bind.* < 1:9.6.ESV.R1
310
311* Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
312- update to 9.8.0
313- remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
314
315* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
316- rebuild with openssl-1.0.0c
317
318* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
319- fix Req: in bind package
320
321* Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
322- change package name bind -> bind-current
323- add epoch 1
324- new upstream release
325
326* Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
327- new upstream release
328
329* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
330- rebuilt with gcc-4.4.3-3 on ppc
331
332* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
333- rebuilt with new toolchains (for VineSeed)
334- s/BuildPrereq/BuildRequires/
335
336* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
337- add man1/isc-config.sh.1 into devel file list
338
339* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
340- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
341
342* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
343- new upstream release with security fix (CVE-2009-4022)
344
345* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
346- new upstream release with security fix
347
348* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
349- new upstream release
350- clean up %%post/%%pre scriptlet
351  - create named user and group in %%pre
352  - don't remove named user/group in %%preun
353  - use rndc-confgen to create rndc.key
354
355* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
356- new upstream release
357- drop patch0 and patch14, merged in upstream
358
359* Sat Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
360- new upstream release with security fix
361
362* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
363- new upstream release with security fix
364- new versioning policy
365
366* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
367- new upstream release with security fix
368
369* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
370- new upstream release
371- build with new openssl/toolchain
372
373* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
374- new upstream release with security fix
375
376* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
377- new upstream release
378
379* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
380- add Prereq sed
381
382* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
383- new upstream release for security fix (CVE-2006-4095,4096)
384
385* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
386- separate -libs package
387- remove old named.conf.5.gz
388  - newer version is contained in source
389
390* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
391- add bsdcompat patch (Patch4)
392- add fix_h_errno patch from FC
393  - h_errno not being accessed / set correctly in libbind
394
395* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
396- new upstream release
397
398* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
399- added PreReq to bind-utils (see: [VineSeed:09555])
400
401* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
402- new upstream release
403
404* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
405- fix /etc/init.d/named to use rndc
406
407* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
408- rebuild to remove unneeded dependancy
409
410* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
411- new upstream release
412
413* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
414- new upstream release
415
416* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
417- fix dependancies.
418
419* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
420- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
421- change package name to bind for VineSeed.
422- use more macros.
423
424* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
425- fixed some macros
426- add conflicts: to bind-* in bind9-devel and bind9-utils
427- add provides: bind = %%{version}
428
429* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
430- use %%configure macros
431
432* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
433- fixed inconsistent dependency
434
435* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
436- updated to 9.2.2rc1
437
438* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
439- updated to bind9(9.2.1), test packages ;)
440        -- based on Rawhide's bind-9.2.0-8
441        -- changed name bind9
442        -- added Conflicts: bind
443
444* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
445- release 8.3.1 includes security fixes
446
447* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
448- Upgraded to current stable release 8.3.0
449
450* Mon Oct  8 2001 <zn@mbf.nifty.com>
451- 8.2.5-0vl0: Upgraded to new upstream version.
452
453* Thu May 24 2001 <sagami@vinelinux.org>
454- 8.2.4-0vl1: eliminate CVS related files from %%doc
455
456* Thu May 17 2001 <sagami@vinelinux.org>
457- 8.2.4-0vl0
458
459* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
460- 8.2.3-1vl2
461- built on VineSeed
462
463* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
464- add doc/old
465- build for Vine 2.1
466
467* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
468- 8.2.3, fixes several security problems
469
470* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
471- static libraries may be used in shared objects. Build with -fPIC on ia64
472
473* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
474- 8.2.2-P7 (fixes Bug #20546)
475
476* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
477- condrestart fixes
478
479* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
480- change the init script to take condrestart, not cond-restart
481- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
482  the %pre and %post scripts
483
484* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
485- Don't prereq /etc/init.d
486
487* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
488- move initscript back
489
490* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
491- automatic rebuild
492
493* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
494- add "exit 0" for uninstall case
495
496* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
497- add prereq init.d and cleanup install section
498
499* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
500- fix the init script
501
502* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
503- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
504
505* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
506- Fix up the initscript (Bug #13033)
507- Fix build with current glibc (Bug #12755)
508- /etc/rc.d/init.d -> /etc/init.d
509- use %%{_mandir} rather than /usr/share/man
510
511* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
512- fix conflict with man-pages
513- remove compatibilty chkconfig links
514- initscript munging
515
516* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
517- modify logrotate setup to use PID file
518- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
519- actually bump the release this time
520
521* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
522- FHS compliance
523
524* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
525- clean up restart patch
526
527* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
528- provide /var/named (fix for bugs #9847, #10205)
529- preserve args when restarted via ndc(8) (bug #10227)
530- make resolv.conf(5) a link to resolver(5) (bug #10245)
531- fix SYSTYPE bug in all makefiles
532- move creation of named user from %%post into %%pre
533
534* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
535- Fix TTL (patch from ISC, Bug #9820)
536
537* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
538- fix typo in spec (it's %post, without a leading blank) introduced in -6
539- change SYSTYPE to linux
540
541* Sat Feb 11 2000 Bill Nottingham <notting@redhat.com>
542- pick a standard < 100 uid/gid for named
543
544* Thu Feb 04 2000 Elliot Lee <sopwith@redhat.com>
545- Pass named a '-u named' parameter by default, and add/remove user.
546
547* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
548- fix host mx bug (Bug #9021)
549
550* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
551- rebuild to fix dependencies
552- man pages are compressed
553
554* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
555- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
556
557* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
558- Fix up location of named-bootconf.pl and make it executable
559  (Bug #8028)
560- bind-devel requires bind
561
562* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
563- update to 8.2.2-P5
564
565* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
566- update to 8.2.2-P3
567
568* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
569- add patch to stop a cache only server from complaining about lame servers
570  on every request.
571
572* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
573- use real stop and start in named.init for restart, not ndc restart, it has
574  problems when named has changed during a package update... (# 4890)
575
576* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
577- chkconfig --del in %preun, not %postun
578
579* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
580- initscript munging
581
582* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
583- fix installed chkconfig links to match init file
584
585* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
586- conflict with new (in man-1.24) man pages (#3876,#3877).
587
588* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
589- fix named.logrotate (wrong %SOURCE)
590
591* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
592- update to 8.2.1.
593- add named.logrotate (#3571).
594- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
595- vet file list.
596
597* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
598- don't run by default
599
600* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
601- nslookup fixes (#2463).
602- missing files (#3152).
603
604* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
605- nslookup patched:
606  to count numRecords properly
607  to fix subsequent calls to ls -d
608  to parse "view" and "finger" commands properly
609  the view hack updated for bind-8 (using sed)
610
611* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
612- add ISC patch
613- add quick hack to make host not crash
614- add more docs
615
616* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
617- add probing information in the init file to keep linuxconf happy
618- dont strip libbind
619
620* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
621- auto rebuild in the new build environment (release 3)
622
623* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
624- removed 'done' output at named shutdown.
625
626* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
627- version 8.2
628
629* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
630- patch to use the __FDS_BITS macro
631- build for glibc 2.1
632
633* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
634- change named.restart to /usr/sbin/ndc restart
635
636* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
637- install man pages correctly.
638- change K10named to K45named.
639
640* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
641- don't start if /etc/named.conf doesn't exist.
642
643* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
644- autmagically create /etc/named.conf from /etc/named.boot in %post
645- remove echo in %post
646
647* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
648- merge in 5.1 mods
649
650* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
651- Several essential modifications to build and install correctly.
652- Modified 'ndc' to avoid deprecated use of '-'
653
654* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
655- Used buildroot
656- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
657  on Redhat 5.0 instead of <nlist.h>
658
Note: See TracBrowser for help on using the repository browser.